restored cmake 2.4 compatibility
This commit is contained in:
parent
f81aa1b997
commit
e904bc0f13
@ -1,10 +1,10 @@
|
||||
From afe99001ee31f4cf827fc6aee0b2088bd4e7b85b Mon Sep 17 00:00:00 2001
|
||||
From da14b3bc703ec3ec2b8332e2d9452d9526f3c1af Mon Sep 17 00:00:00 2001
|
||||
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
|
||||
Date: Sat, 5 Apr 2008 10:55:02 +0200
|
||||
Subject: [PATCH 1/6] make -> cmake transition
|
||||
|
||||
---
|
||||
CMakeLists.txt | 275 +++++++++++++++++++++++++++
|
||||
CMakeLists.txt | 279 +++++++++++++++++++++++++++
|
||||
cmake/try-attr.cc | 3 +
|
||||
cmake/va-list-is-array.c | 9 +
|
||||
examples/CMakeLists.txt | 57 ++++++
|
||||
@ -62,7 +62,7 @@ Subject: [PATCH 1/6] make -> cmake transition
|
||||
version.h.cmake | 5 +
|
||||
xmlrpc-c-config | 108 +++++++++++
|
||||
xmlrpc_config.h.cmake | 105 ++++++++++
|
||||
58 files changed, 1469 insertions(+), 0 deletions(-)
|
||||
58 files changed, 1473 insertions(+), 0 deletions(-)
|
||||
create mode 100644 CMakeLists.txt
|
||||
create mode 100644 cmake/try-attr.cc
|
||||
create mode 100644 cmake/va-list-is-array.c
|
||||
@ -124,17 +124,21 @@ Subject: [PATCH 1/6] make -> cmake transition
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
new file mode 100644
|
||||
index 0000000..f64b143
|
||||
index 0000000..3b8ad6a
|
||||
--- /dev/null
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -0,0 +1,275 @@
|
||||
@@ -0,0 +1,279 @@
|
||||
+## -*- cmake -*-
|
||||
+project(xmlrpc-c)
|
||||
+include(FindPkgConfig)
|
||||
+include(CheckIncludeFile)
|
||||
+include(CheckFunctionExists)
|
||||
+
|
||||
+cmake_minimum_required(VERSION 2.6)
|
||||
+cmake_minimum_required(VERSION 2.4)
|
||||
+
|
||||
+if(COMMAND cmake_policy)
|
||||
+ cmake_policy(SET CMP0003 NEW)
|
||||
+endif()
|
||||
+
|
||||
+
|
||||
+set(XMLRPC_C_VERSION_MAJOR "1" CACHE STRING "Version (major) of xmlrpc-c")
|
||||
|
Loading…
Reference in New Issue
Block a user