* Fri May 15 2009 Eric Sandeen <sandeen@redhat.com> 3.0.1-3
- Fix and re-enable readline
This commit is contained in:
parent
88976ab108
commit
7aab75c830
55
xfsprogs-3.0.1-readline.patch
Normal file
55
xfsprogs-3.0.1-readline.patch
Normal file
@ -0,0 +1,55 @@
|
|||||||
|
[PATCH] xfsprogs: fix readline/editline for xfs_io and xfs_quota
|
||||||
|
|
||||||
|
It looks like libxcmd wasn't ever being built with -DENABLE_READLINE
|
||||||
|
even when it was asked for by configure --enable-readline=yes
|
||||||
|
so xfs_io & xfs_quota didn't get the functionality.
|
||||||
|
|
||||||
|
This seems to fix it up for me (fixes editline too while we're
|
||||||
|
at it).
|
||||||
|
|
||||||
|
Signed-off-by: Eric Sandeen <sandeen@sandeen.net>
|
||||||
|
---
|
||||||
|
|
||||||
|
|
||||||
|
Index: xfsprogs-3.0.1/libxcmd/Makefile
|
||||||
|
===================================================================
|
||||||
|
--- xfsprogs-3.0.1.orig/libxcmd/Makefile
|
||||||
|
+++ xfsprogs-3.0.1/libxcmd/Makefile
|
||||||
|
@@ -20,6 +20,14 @@ ifeq ($(HAVE_GETMNTINFO),yes)
|
||||||
|
LCFLAGS += -DHAVE_GETMNTINFO
|
||||||
|
endif
|
||||||
|
|
||||||
|
+ifeq ($(ENABLE_READLINE),yes)
|
||||||
|
+LCFLAGS += -DENABLE_READLINE
|
||||||
|
+endif
|
||||||
|
+
|
||||||
|
+ifeq ($(ENABLE_EDITLINE),yes)
|
||||||
|
+LCFLAGS += -DENABLE_EDITLINE
|
||||||
|
+endif
|
||||||
|
+
|
||||||
|
default: $(LTLIBRARY)
|
||||||
|
|
||||||
|
include $(BUILDRULES)
|
||||||
|
|
||||||
|
Index: xfsprogs-3.0.1/growfs/Makefile
|
||||||
|
===================================================================
|
||||||
|
--- xfsprogs-3.0.1.orig/growfs/Makefile
|
||||||
|
+++ xfsprogs-3.0.1/growfs/Makefile
|
||||||
|
@@ -10,6 +10,14 @@ LTCOMMAND = xfs_growfs
|
||||||
|
CFILES = xfs_growfs.c
|
||||||
|
|
||||||
|
LLDLIBS = $(LIBXFS) $(LIBXCMD) $(LIBUUID) $(LIBRT) $(LIBPTHREAD)
|
||||||
|
+ifeq ($(ENABLE_READLINE),yes)
|
||||||
|
+LLDLIBS += $(LIBREADLINE) $(LIBTERMCAP)
|
||||||
|
+endif
|
||||||
|
+
|
||||||
|
+ifeq ($(ENABLE_EDITLINE),yes)
|
||||||
|
+LLDLIBS += $(LIBEDITLINE) $(LIBTERMCAP)
|
||||||
|
+endif
|
||||||
|
+
|
||||||
|
LTDEPENDENCIES = $(LIBXFS) $(LIBXCMD)
|
||||||
|
LLDFLAGS = -static
|
||||||
|
LSRCFILES = xfs_info.sh
|
||||||
|
|
||||||
|
|
||||||
|
|
@ -1,7 +1,7 @@
|
|||||||
Summary: Utilities for managing the XFS filesystem
|
Summary: Utilities for managing the XFS filesystem
|
||||||
Name: xfsprogs
|
Name: xfsprogs
|
||||||
Version: 3.0.1
|
Version: 3.0.1
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
# Licensing based on generic "GNU GENERAL PUBLIC LICENSE"
|
# Licensing based on generic "GNU GENERAL PUBLIC LICENSE"
|
||||||
# in source, with no mention of version.
|
# in source, with no mention of version.
|
||||||
# doc/COPYING file specifies what is GPL and what is LGPL
|
# doc/COPYING file specifies what is GPL and what is LGPL
|
||||||
@ -18,6 +18,8 @@ Provides: xfs-cmds
|
|||||||
Obsoletes: xfs-cmds <= %{version}
|
Obsoletes: xfs-cmds <= %{version}
|
||||||
Conflicts: xfsdump < 3.0.1
|
Conflicts: xfsdump < 3.0.1
|
||||||
|
|
||||||
|
Patch0: xfsprogs-3.0.1-readline.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
A set of commands to use the XFS filesystem, including mkfs.xfs.
|
A set of commands to use the XFS filesystem, including mkfs.xfs.
|
||||||
|
|
||||||
@ -61,6 +63,8 @@ in building or running the xfstests QA suite.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export tagname=CC DEBUG=-DNDEBUG
|
export tagname=CC DEBUG=-DNDEBUG
|
||||||
# xfsprogs abuses libexecdir
|
# xfsprogs abuses libexecdir
|
||||||
@ -68,7 +72,8 @@ export tagname=CC DEBUG=-DNDEBUG
|
|||||||
--sbindir=/sbin \
|
--sbindir=/sbin \
|
||||||
--libdir=/%{_lib} \
|
--libdir=/%{_lib} \
|
||||||
--libexecdir=%{_libdir} \
|
--libexecdir=%{_libdir} \
|
||||||
--bindir=%{_sbindir}
|
--bindir=%{_sbindir} \
|
||||||
|
--enable-readline=yes
|
||||||
|
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
@ -185,6 +190,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_includedir}/xfs/xfs_types.h
|
%{_includedir}/xfs/xfs_types.h
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 15 2009 Eric Sandeen <sandeen@redhat.com> 3.0.1-3
|
||||||
|
- Fix and re-enable readline
|
||||||
|
|
||||||
* Tue May 05 2009 Eric Sandeen <sandeen@redhat.com> 3.0.1-2
|
* Tue May 05 2009 Eric Sandeen <sandeen@redhat.com> 3.0.1-2
|
||||||
- Conflict with xfsdump < 3.0.1 since files moved between them
|
- Conflict with xfsdump < 3.0.1 since files moved between them
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user