7aab75c830
- Fix and re-enable readline
56 lines
1.4 KiB
Diff
56 lines
1.4 KiB
Diff
[PATCH] xfsprogs: fix readline/editline for xfs_io and xfs_quota
|
|
|
|
It looks like libxcmd wasn't ever being built with -DENABLE_READLINE
|
|
even when it was asked for by configure --enable-readline=yes
|
|
so xfs_io & xfs_quota didn't get the functionality.
|
|
|
|
This seems to fix it up for me (fixes editline too while we're
|
|
at it).
|
|
|
|
Signed-off-by: Eric Sandeen <sandeen@sandeen.net>
|
|
---
|
|
|
|
|
|
Index: xfsprogs-3.0.1/libxcmd/Makefile
|
|
===================================================================
|
|
--- xfsprogs-3.0.1.orig/libxcmd/Makefile
|
|
+++ xfsprogs-3.0.1/libxcmd/Makefile
|
|
@@ -20,6 +20,14 @@ ifeq ($(HAVE_GETMNTINFO),yes)
|
|
LCFLAGS += -DHAVE_GETMNTINFO
|
|
endif
|
|
|
|
+ifeq ($(ENABLE_READLINE),yes)
|
|
+LCFLAGS += -DENABLE_READLINE
|
|
+endif
|
|
+
|
|
+ifeq ($(ENABLE_EDITLINE),yes)
|
|
+LCFLAGS += -DENABLE_EDITLINE
|
|
+endif
|
|
+
|
|
default: $(LTLIBRARY)
|
|
|
|
include $(BUILDRULES)
|
|
|
|
Index: xfsprogs-3.0.1/growfs/Makefile
|
|
===================================================================
|
|
--- xfsprogs-3.0.1.orig/growfs/Makefile
|
|
+++ xfsprogs-3.0.1/growfs/Makefile
|
|
@@ -10,6 +10,14 @@ LTCOMMAND = xfs_growfs
|
|
CFILES = xfs_growfs.c
|
|
|
|
LLDLIBS = $(LIBXFS) $(LIBXCMD) $(LIBUUID) $(LIBRT) $(LIBPTHREAD)
|
|
+ifeq ($(ENABLE_READLINE),yes)
|
|
+LLDLIBS += $(LIBREADLINE) $(LIBTERMCAP)
|
|
+endif
|
|
+
|
|
+ifeq ($(ENABLE_EDITLINE),yes)
|
|
+LLDLIBS += $(LIBEDITLINE) $(LIBTERMCAP)
|
|
+endif
|
|
+
|
|
LTDEPENDENCIES = $(LIBXFS) $(LIBXCMD)
|
|
LLDFLAGS = -static
|
|
LSRCFILES = xfs_info.sh
|
|
|
|
|
|
|