Update to upstream version 4.4
- Rebase patches - Remove obsolete groovy patch
This commit is contained in:
parent
de40555fc4
commit
b690c4900c
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@ xbean-3.7.tar.xz
|
||||
/xbean-4.1-source-release.zip
|
||||
/xbean-4.2-source-release.zip
|
||||
/xbean-4.3-source-release.zip
|
||||
/xbean-4.4-source-release.zip
|
||||
|
@ -1,85 +1,16 @@
|
||||
From e62e47e891b9f14c612b0176d735b2a66b0217dc Mon Sep 17 00:00:00 2001
|
||||
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
||||
Date: Fri, 21 Nov 2014 09:39:00 +0100
|
||||
Subject: [PATCH 1/4] Unshade ASM
|
||||
From aaf9dad09a9a26c5de3c2910d910b24a258b0b1d Mon Sep 17 00:00:00 2001
|
||||
From: Michael Simacek <msimacek@redhat.com>
|
||||
Date: Tue, 1 Dec 2015 12:36:21 +0100
|
||||
Subject: [PATCH 1/3] Unshade ASM
|
||||
|
||||
---
|
||||
pom.xml | 23 ------------
|
||||
xbean-finder/pom.xml | 5 ---
|
||||
.../org/apache/xbean/finder/AbstractFinder.java | 31 ++++++++--------
|
||||
.../org/apache/xbean/finder/AnnotationFinder.java | 43 +++++++++++-----------
|
||||
xbean-reflect/pom.xml | 13 -------
|
||||
.../xbean/recipe/AsmParameterNameLoader.java | 6 ++-
|
||||
.../org/apache/xbean/recipe/ReflectionUtil.java | 8 +---
|
||||
.../xbean/recipe/XbeanAsmParameterNameLoader.java | 18 +++++----
|
||||
8 files changed, 53 insertions(+), 94 deletions(-)
|
||||
.../xbean/recipe/XbeanAsmParameterNameLoader.java | 16 ++++----
|
||||
3 files changed, 46 insertions(+), 44 deletions(-)
|
||||
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
index dd4d7ee..0c17645 100644
|
||||
--- a/pom.xml
|
||||
+++ b/pom.xml
|
||||
@@ -217,26 +217,6 @@
|
||||
<artifactId>xbean-telnet</artifactId>
|
||||
<version>${project.version}</version>
|
||||
</dependency>
|
||||
- <dependency>
|
||||
- <groupId>org.apache.xbean</groupId>
|
||||
- <artifactId>xbean-asm-shaded</artifactId>
|
||||
- <version>${project.version}</version>
|
||||
- </dependency>
|
||||
- <dependency>
|
||||
- <groupId>org.apache.xbean</groupId>
|
||||
- <artifactId>xbean-asm5-shaded</artifactId>
|
||||
- <version>${project.version}</version>
|
||||
- </dependency>
|
||||
- <dependency>
|
||||
- <groupId>org.apache.xbean</groupId>
|
||||
- <artifactId>xbean-asm-util</artifactId>
|
||||
- <version>${project.version}</version>
|
||||
- </dependency>
|
||||
- <dependency>
|
||||
- <groupId>org.apache.xbean</groupId>
|
||||
- <artifactId>xbean-finder-shaded</artifactId>
|
||||
- <version>${project.version}</version>
|
||||
- </dependency>
|
||||
|
||||
<!-- external dependencies -->
|
||||
|
||||
@@ -412,7 +392,6 @@
|
||||
<module>xbean-classloader</module>
|
||||
<module>xbean-classpath</module>
|
||||
<module>xbean-bundleutils</module>
|
||||
- <module>xbean-asm-util</module>
|
||||
<module>xbean-finder</module>
|
||||
<module>xbean-naming</module>
|
||||
<module>xbean-reflect</module>
|
||||
@@ -420,8 +399,6 @@
|
||||
<module>xbean-spring</module>
|
||||
<module>xbean-telnet</module>
|
||||
<module>maven-xbean-plugin</module>
|
||||
- <module>xbean-asm5-shaded</module>
|
||||
- <module>xbean-finder-shaded</module>
|
||||
</modules>
|
||||
|
||||
<reporting>
|
||||
diff --git a/xbean-finder/pom.xml b/xbean-finder/pom.xml
|
||||
index 6048ac3..4f20b5f 100644
|
||||
--- a/xbean-finder/pom.xml
|
||||
+++ b/xbean-finder/pom.xml
|
||||
@@ -58,11 +58,6 @@
|
||||
<version>4.3.1</version>
|
||||
<scope>provided</scope>
|
||||
</dependency>
|
||||
- <dependency>
|
||||
- <groupId>org.apache.xbean</groupId>
|
||||
- <artifactId>xbean-asm-util</artifactId>
|
||||
- <version>${project.version}</version>
|
||||
- </dependency>
|
||||
</dependencies>
|
||||
<build>
|
||||
<plugins>
|
||||
diff --git a/xbean-finder/src/main/java/org/apache/xbean/finder/AbstractFinder.java b/xbean-finder/src/main/java/org/apache/xbean/finder/AbstractFinder.java
|
||||
index 8beb72b..3639bee 100644
|
||||
index 6bf1f3c..fab8b88 100644
|
||||
--- a/xbean-finder/src/main/java/org/apache/xbean/finder/AbstractFinder.java
|
||||
+++ b/xbean-finder/src/main/java/org/apache/xbean/finder/AbstractFinder.java
|
||||
@@ -34,10 +34,10 @@ import java.util.HashMap;
|
||||
@ -159,7 +90,7 @@ index 8beb72b..3639bee 100644
|
||||
}
|
||||
|
||||
diff --git a/xbean-finder/src/main/java/org/apache/xbean/finder/AnnotationFinder.java b/xbean-finder/src/main/java/org/apache/xbean/finder/AnnotationFinder.java
|
||||
index ea96d78..48b2262 100644
|
||||
index 7d68cd9..6454aa1 100644
|
||||
--- a/xbean-finder/src/main/java/org/apache/xbean/finder/AnnotationFinder.java
|
||||
+++ b/xbean-finder/src/main/java/org/apache/xbean/finder/AnnotationFinder.java
|
||||
@@ -20,13 +20,13 @@
|
||||
@ -177,7 +108,7 @@ index ea96d78..48b2262 100644
|
||||
import org.objectweb.asm.FieldVisitor;
|
||||
import org.objectweb.asm.MethodVisitor;
|
||||
import org.objectweb.asm.Opcodes;
|
||||
@@ -1755,13 +1755,15 @@ public class AnnotationFinder implements IAnnotationFinder {
|
||||
@@ -1790,13 +1790,15 @@ public class AnnotationFinder implements IAnnotationFinder {
|
||||
initAnnotationInfos(annotationInfo.getName()).add(info);
|
||||
}
|
||||
|
||||
@ -194,7 +125,7 @@ index ea96d78..48b2262 100644
|
||||
this.info = info;
|
||||
}
|
||||
|
||||
@@ -1809,7 +1811,7 @@ public class AnnotationFinder implements IAnnotationFinder {
|
||||
@@ -1844,7 +1846,7 @@ public class AnnotationFinder implements IAnnotationFinder {
|
||||
AnnotationInfo annotationInfo = new AnnotationInfo(desc);
|
||||
info.getAnnotations().add(annotationInfo);
|
||||
index(annotationInfo, info);
|
||||
@ -203,7 +134,7 @@ index ea96d78..48b2262 100644
|
||||
}
|
||||
|
||||
@Override
|
||||
@@ -1817,32 +1819,31 @@ public class AnnotationFinder implements IAnnotationFinder {
|
||||
@@ -1852,32 +1854,31 @@ public class AnnotationFinder implements IAnnotationFinder {
|
||||
ClassInfo classInfo = ((ClassInfo) info);
|
||||
FieldInfo fieldInfo = new FieldInfo(classInfo, name, desc);
|
||||
classInfo.getFields().add(fieldInfo);
|
||||
@ -252,144 +183,46 @@ index ea96d78..48b2262 100644
|
||||
}
|
||||
|
||||
public static class GenericAwareInfoBuildingVisitor extends SignatureVisitor {
|
||||
@@ -2007,4 +2008,4 @@ public class AnnotationFinder implements IAnnotationFinder {
|
||||
@@ -2042,4 +2043,4 @@ public class AnnotationFinder implements IAnnotationFinder {
|
||||
|
||||
}
|
||||
|
||||
-}
|
||||
\ No newline at end of file
|
||||
+}
|
||||
diff --git a/xbean-reflect/pom.xml b/xbean-reflect/pom.xml
|
||||
index e9e51c7..0b80389 100644
|
||||
--- a/xbean-reflect/pom.xml
|
||||
+++ b/xbean-reflect/pom.xml
|
||||
@@ -47,19 +47,6 @@
|
||||
<optional>true</optional>
|
||||
</dependency>
|
||||
<dependency>
|
||||
- <groupId>org.apache.xbean</groupId>
|
||||
- <artifactId>xbean-asm-util</artifactId>
|
||||
- <scope>provided</scope>
|
||||
- <optional>true</optional>
|
||||
- </dependency>
|
||||
- <dependency>
|
||||
- <groupId>org.apache.xbean</groupId>
|
||||
- <artifactId>xbean-asm5-shaded</artifactId>
|
||||
- <version>${project.version}</version>
|
||||
- <scope>provided</scope>
|
||||
- <optional>true</optional>
|
||||
- </dependency>
|
||||
- <dependency>
|
||||
<groupId>log4j</groupId>
|
||||
<artifactId>log4j</artifactId>
|
||||
<version>1.2.12</version>
|
||||
diff --git a/xbean-reflect/src/main/java/org/apache/xbean/recipe/AsmParameterNameLoader.java b/xbean-reflect/src/main/java/org/apache/xbean/recipe/AsmParameterNameLoader.java
|
||||
index 6859cad..f513b77 100644
|
||||
--- a/xbean-reflect/src/main/java/org/apache/xbean/recipe/AsmParameterNameLoader.java
|
||||
+++ b/xbean-reflect/src/main/java/org/apache/xbean/recipe/AsmParameterNameLoader.java
|
||||
@@ -17,8 +17,8 @@
|
||||
*/
|
||||
package org.apache.xbean.recipe;
|
||||
|
||||
-import org.apache.xbean.asm5.original.commons.EmptyVisitor;
|
||||
import org.objectweb.asm.ClassReader;
|
||||
+import org.objectweb.asm.ClassVisitor;
|
||||
import org.objectweb.asm.Label;
|
||||
import org.objectweb.asm.MethodVisitor;
|
||||
import org.objectweb.asm.Opcodes;
|
||||
@@ -211,7 +211,7 @@ public class AsmParameterNameLoader implements ParameterNameLoader {
|
||||
}
|
||||
}
|
||||
|
||||
- private static class AllParameterNamesDiscoveringVisitor extends EmptyVisitor {
|
||||
+ private static class AllParameterNamesDiscoveringVisitor extends ClassVisitor {
|
||||
private final Map<Constructor,List<String>> constructorParameters = new HashMap<Constructor,List<String>>();
|
||||
private final Map<Method,List<String>> methodParameters = new HashMap<Method,List<String>>();
|
||||
private final Map<String,Exception> exceptions = new HashMap<String,Exception>();
|
||||
@@ -220,6 +220,7 @@ public class AsmParameterNameLoader implements ParameterNameLoader {
|
||||
private final Map<String,Constructor> constructorMap = new HashMap<String,Constructor>();
|
||||
|
||||
public AllParameterNamesDiscoveringVisitor(Class type, String methodName) {
|
||||
+ super(Opcodes.ASM5);
|
||||
this.methodName = methodName;
|
||||
|
||||
List<Method> methods = new ArrayList<Method>(Arrays.asList(type.getMethods()));
|
||||
@@ -232,6 +233,7 @@ public class AsmParameterNameLoader implements ParameterNameLoader {
|
||||
}
|
||||
|
||||
public AllParameterNamesDiscoveringVisitor(Class type) {
|
||||
+ super(Opcodes.ASM5);
|
||||
this.methodName = "<init>";
|
||||
|
||||
List<Constructor> constructors = new ArrayList<Constructor>(Arrays.asList(type.getConstructors()));
|
||||
diff --git a/xbean-reflect/src/main/java/org/apache/xbean/recipe/ReflectionUtil.java b/xbean-reflect/src/main/java/org/apache/xbean/recipe/ReflectionUtil.java
|
||||
index 84ded16..39dfd58 100644
|
||||
--- a/xbean-reflect/src/main/java/org/apache/xbean/recipe/ReflectionUtil.java
|
||||
+++ b/xbean-reflect/src/main/java/org/apache/xbean/recipe/ReflectionUtil.java
|
||||
@@ -41,13 +41,7 @@ public final class ReflectionUtil {
|
||||
private static ParameterNameLoader parameterNamesLoader;
|
||||
|
||||
static {
|
||||
- if (isClassAvailable("org.apache.xbean.asm5.ClassReader")) {
|
||||
- parameterNamesLoader = new XbeanAsmParameterNameLoader();
|
||||
- } else if (isClassAvailable("org.objectweb.asm.ClassReader")) {
|
||||
- parameterNamesLoader = new AsmParameterNameLoader();
|
||||
- } else if (isClassAvailable("org.apache.xbean.asm.ClassReader") || isClassAvailable("org.apache.xbean.asm4.ClassReader")) {
|
||||
- throw new RuntimeException("Your xbean-asm-shade is too old, please upgrade to xbean-asm5-shade");
|
||||
- }
|
||||
+ parameterNamesLoader = new XbeanAsmParameterNameLoader();
|
||||
}
|
||||
|
||||
private ReflectionUtil() {
|
||||
diff --git a/xbean-reflect/src/main/java/org/apache/xbean/recipe/XbeanAsmParameterNameLoader.java b/xbean-reflect/src/main/java/org/apache/xbean/recipe/XbeanAsmParameterNameLoader.java
|
||||
index 4a89c44..6242dd3 100644
|
||||
index dea2f2a..dbbfb51 100644
|
||||
--- a/xbean-reflect/src/main/java/org/apache/xbean/recipe/XbeanAsmParameterNameLoader.java
|
||||
+++ b/xbean-reflect/src/main/java/org/apache/xbean/recipe/XbeanAsmParameterNameLoader.java
|
||||
@@ -17,12 +17,12 @@
|
||||
@@ -17,13 +17,6 @@
|
||||
*/
|
||||
package org.apache.xbean.recipe;
|
||||
|
||||
-import org.apache.xbean.asm5.shade.commons.EmptyVisitor;
|
||||
-import org.apache.xbean.asm5.ClassReader;
|
||||
-import org.apache.xbean.asm5.ClassVisitor;
|
||||
-import org.apache.xbean.asm5.Label;
|
||||
-import org.apache.xbean.asm5.MethodVisitor;
|
||||
-import org.apache.xbean.asm5.Opcodes;
|
||||
-import org.apache.xbean.asm5.Type;
|
||||
-
|
||||
import java.io.IOException;
|
||||
import java.io.InputStream;
|
||||
import java.lang.reflect.Constructor;
|
||||
@@ -37,6 +30,13 @@ import java.util.List;
|
||||
import java.util.Map;
|
||||
import java.util.WeakHashMap;
|
||||
|
||||
+import org.objectweb.asm.ClassReader;
|
||||
+import org.objectweb.asm.ClassVisitor;
|
||||
+import org.objectweb.asm.Label;
|
||||
+import org.objectweb.asm.MethodVisitor;
|
||||
+import org.objectweb.asm.Opcodes;
|
||||
+import org.objectweb.asm.Type;
|
||||
|
||||
import java.io.IOException;
|
||||
import java.io.InputStream;
|
||||
@@ -211,7 +211,7 @@ public class XbeanAsmParameterNameLoader implements ParameterNameLoader {
|
||||
}
|
||||
}
|
||||
|
||||
- private static class AllParameterNamesDiscoveringVisitor extends EmptyVisitor {
|
||||
+ private static class AllParameterNamesDiscoveringVisitor extends ClassVisitor {
|
||||
private final Map<Constructor,List<String>> constructorParameters = new HashMap<Constructor,List<String>>();
|
||||
private final Map<Method,List<String>> methodParameters = new HashMap<Method,List<String>>();
|
||||
private final Map<String,Exception> exceptions = new HashMap<String,Exception>();
|
||||
@@ -220,6 +220,7 @@ public class XbeanAsmParameterNameLoader implements ParameterNameLoader {
|
||||
private final Map<String,Constructor> constructorMap = new HashMap<String,Constructor>();
|
||||
|
||||
public AllParameterNamesDiscoveringVisitor(Class type, String methodName) {
|
||||
+ super(Opcodes.ASM5);
|
||||
this.methodName = methodName;
|
||||
|
||||
List<Method> methods = new ArrayList<Method>(Arrays.asList(type.getMethods()));
|
||||
@@ -232,6 +233,7 @@ public class XbeanAsmParameterNameLoader implements ParameterNameLoader {
|
||||
}
|
||||
|
||||
public AllParameterNamesDiscoveringVisitor(Class type) {
|
||||
+ super(Opcodes.ASM5);
|
||||
this.methodName = "<init>";
|
||||
|
||||
List<Constructor> constructors = new ArrayList<Constructor>(Arrays.asList(type.getConstructors()));
|
||||
@@ -312,4 +314,4 @@ public class XbeanAsmParameterNameLoader implements ParameterNameLoader {
|
||||
+
|
||||
/**
|
||||
* Implementation of ParameterNameLoader that uses ASM to read the parameter names from the local variable table in the
|
||||
* class byte code.
|
||||
@@ -314,4 +314,4 @@ public class XbeanAsmParameterNameLoader implements ParameterNameLoader {
|
||||
return null;
|
||||
}
|
||||
}
|
||||
@ -397,5 +230,5 @@ index 4a89c44..6242dd3 100644
|
||||
\ No newline at end of file
|
||||
+}
|
||||
--
|
||||
2.1.0
|
||||
2.5.0
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
From 82b34a42835d82896c88bf3d3c7ea5f44fb76c39 Mon Sep 17 00:00:00 2001
|
||||
From 8c7cc1ab013f80fb71ab4bda77d922bc75ead514 Mon Sep 17 00:00:00 2001
|
||||
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
||||
Date: Fri, 21 Nov 2014 10:05:05 +0100
|
||||
Subject: [PATCH 2/4] Port to Eclipse Luna OSGi
|
||||
Subject: [PATCH 2/3] Port to Eclipse Luna OSGi
|
||||
|
||||
---
|
||||
xbean-bundleutils/pom.xml | 8 +-------
|
||||
@ -9,7 +9,7 @@ Subject: [PATCH 2/4] Port to Eclipse Luna OSGi
|
||||
2 files changed, 11 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/xbean-bundleutils/pom.xml b/xbean-bundleutils/pom.xml
|
||||
index 015f97d..6dcad55 100644
|
||||
index acda42f..8a45319 100644
|
||||
--- a/xbean-bundleutils/pom.xml
|
||||
+++ b/xbean-bundleutils/pom.xml
|
||||
@@ -35,15 +35,9 @@
|
||||
@ -30,7 +30,7 @@ index 015f97d..6dcad55 100644
|
||||
</dependency>
|
||||
</dependencies>
|
||||
diff --git a/xbean-bundleutils/src/main/java/org/apache/xbean/osgi/bundle/util/DelegatingBundleContext.java b/xbean-bundleutils/src/main/java/org/apache/xbean/osgi/bundle/util/DelegatingBundleContext.java
|
||||
index f4e876d..ea353ef 100644
|
||||
index 58a392b..cc8d081 100644
|
||||
--- a/xbean-bundleutils/src/main/java/org/apache/xbean/osgi/bundle/util/DelegatingBundleContext.java
|
||||
+++ b/xbean-bundleutils/src/main/java/org/apache/xbean/osgi/bundle/util/DelegatingBundleContext.java
|
||||
@@ -31,7 +31,9 @@ import org.osgi.framework.BundleListener;
|
||||
@ -58,5 +58,5 @@ index f4e876d..ea353ef 100644
|
||||
|
||||
}
|
||||
--
|
||||
2.1.0
|
||||
2.5.0
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
From a0749b244a47ca9433df9070767b13c2118244dd Mon Sep 17 00:00:00 2001
|
||||
From 838dfd967213ac90a3124a57a414bc209fe25d68 Mon Sep 17 00:00:00 2001
|
||||
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
||||
Date: Fri, 21 Nov 2014 10:51:38 +0100
|
||||
Subject: [PATCH 3/4] Port to QDox 2.0
|
||||
Subject: [PATCH 3/3] Port to QDox 2.0
|
||||
|
||||
---
|
||||
pom.xml | 2 +-
|
||||
@ -10,10 +10,10 @@ Subject: [PATCH 3/4] Port to QDox 2.0
|
||||
3 files changed, 163 insertions(+), 127 deletions(-)
|
||||
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
index 0c17645..36bb2da 100644
|
||||
index b031527..836389b 100644
|
||||
--- a/pom.xml
|
||||
+++ b/pom.xml
|
||||
@@ -277,7 +277,7 @@
|
||||
@@ -297,7 +297,7 @@
|
||||
<dependency>
|
||||
<groupId>com.thoughtworks.qdox</groupId>
|
||||
<artifactId>qdox</artifactId>
|
||||
@ -651,5 +651,5 @@ index 94bd7a1..ae55819 100644
|
||||
for (Enumeration entries = jarFile.entries(); entries.hasMoreElements(); ) {
|
||||
JarEntry entry = (JarEntry) entries.nextElement();
|
||||
--
|
||||
2.1.0
|
||||
2.5.0
|
||||
|
||||
|
@ -1,65 +0,0 @@
|
||||
From 7103c99bd97f40d5282c1701b30e23fea11d8a60 Mon Sep 17 00:00:00 2001
|
||||
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
||||
Date: Fri, 21 Nov 2014 11:43:56 +0100
|
||||
Subject: [PATCH 4/4] Port to Groovy 2.3.7
|
||||
|
||||
---
|
||||
pom.xml | 4 ++--
|
||||
xbean-telnet/pom.xml | 2 +-
|
||||
xbean-telnet/src/main/java/org/apache/xbean/command/GroovySh.java | 4 +++-
|
||||
3 files changed, 6 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
index 36bb2da..e483eb0 100644
|
||||
--- a/pom.xml
|
||||
+++ b/pom.xml
|
||||
@@ -245,9 +245,9 @@
|
||||
</dependency>
|
||||
|
||||
<dependency>
|
||||
- <groupId>groovy</groupId>
|
||||
+ <groupId>org.codehaus.groovy</groupId>
|
||||
<artifactId>groovy</artifactId>
|
||||
- <version>1.0-jsr-03</version>
|
||||
+ <version>2.3.7</version>
|
||||
</dependency>
|
||||
|
||||
<dependency>
|
||||
diff --git a/xbean-telnet/pom.xml b/xbean-telnet/pom.xml
|
||||
index 1f26170..f6db40e 100644
|
||||
--- a/xbean-telnet/pom.xml
|
||||
+++ b/xbean-telnet/pom.xml
|
||||
@@ -36,7 +36,7 @@
|
||||
<dependencies>
|
||||
|
||||
<dependency>
|
||||
- <groupId>groovy</groupId>
|
||||
+ <groupId>org.codehaus.groovy</groupId>
|
||||
<artifactId>groovy</artifactId>
|
||||
</dependency>
|
||||
|
||||
diff --git a/xbean-telnet/src/main/java/org/apache/xbean/command/GroovySh.java b/xbean-telnet/src/main/java/org/apache/xbean/command/GroovySh.java
|
||||
index 2ccb8eb..b7208fe 100755
|
||||
--- a/xbean-telnet/src/main/java/org/apache/xbean/command/GroovySh.java
|
||||
+++ b/xbean-telnet/src/main/java/org/apache/xbean/command/GroovySh.java
|
||||
@@ -17,6 +17,8 @@
|
||||
package org.apache.xbean.command;
|
||||
|
||||
import groovy.lang.GroovyShell;
|
||||
+import groovy.lang.GroovySystem;
|
||||
+
|
||||
import org.codehaus.groovy.runtime.InvokerHelper;
|
||||
|
||||
import java.io.BufferedReader;
|
||||
@@ -33,7 +35,7 @@ public class GroovySh implements Command {
|
||||
public int main(String[] args, InputStream in, PrintStream out) {
|
||||
GroovyShell shell = new GroovyShell();
|
||||
BufferedReader reader = new BufferedReader(new InputStreamReader(in));
|
||||
- String version = InvokerHelper.getVersion();
|
||||
+ String version = GroovySystem.getVersion();
|
||||
out.println("Lets get Groovy!");
|
||||
out.println("================");
|
||||
out.println("Version: " + version + " JVM: " + System.getProperty("java.vm.version"));
|
||||
--
|
||||
2.1.0
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
1266a774e63353d0474daaeef1e62320 xbean-4.3-source-release.zip
|
||||
62903a79e3f959df8bcf6594c63c5116 xbean-4.4-source-release.zip
|
||||
|
16
xbean.spec
16
xbean.spec
@ -6,7 +6,7 @@
|
||||
%endif
|
||||
|
||||
Name: xbean
|
||||
Version: 4.3
|
||||
Version: 4.4
|
||||
Release: 1%{?dist}
|
||||
Summary: Java plugin based web server
|
||||
License: ASL 2.0
|
||||
@ -20,7 +20,6 @@ Patch0: 0001-Unshade-ASM.patch
|
||||
# Compatibility with Eclipse Luna (rhbz#1087461)
|
||||
Patch1: 0002-Port-to-Eclipse-Luna-OSGi.patch
|
||||
Patch2: 0003-Port-to-QDox-2.0.patch
|
||||
Patch3: 0004-Port-to-Groovy-2.3.7.patch
|
||||
|
||||
BuildRequires: java-devel
|
||||
BuildRequires: apache-commons-beanutils
|
||||
@ -121,11 +120,17 @@ rm src/site/site.xml
|
||||
%patch1 -p1
|
||||
%endif
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
%pom_remove_parent
|
||||
%pom_remove_dep mx4j:mx4j
|
||||
|
||||
%pom_remove_dep -r :xbean-asm-util
|
||||
%pom_remove_dep -r :xbean-asm5-shaded
|
||||
%pom_remove_dep -r :xbean-finder-shaded
|
||||
%pom_disable_module xbean-asm-util
|
||||
%pom_disable_module xbean-asm5-shaded
|
||||
%pom_disable_module xbean-finder-shaded
|
||||
|
||||
# Prevent modules depending on springframework from building.
|
||||
%if %{without spring}
|
||||
%pom_remove_dep org.springframework:
|
||||
@ -188,6 +193,11 @@ sed -i "s|</Private-Package>|</Private-Package-->|" xbean-blueprint/pom.xml
|
||||
%doc LICENSE NOTICE
|
||||
|
||||
%changelog
|
||||
* Tue Nov 24 2015 Michael Simacek <msimacek@redhat.com> - 4.4-1
|
||||
- Update to upstream version 4.4
|
||||
- Rebase patches
|
||||
- Remove obsolete groovy patch
|
||||
|
||||
* Mon Jul 13 2015 Mikolaj Izdebski <mizdebsk@redhat.com> - 4.3-1
|
||||
- Update to upstream version 4.3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user