Update to latest upstream version
- Build with maven 3 - Packaging & guidelines fixes
This commit is contained in:
parent
566be54101
commit
abc71dded7
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
xbean-3.7.tar.xz
|
||||
/xbean-3.8.tar.xz
|
||||
|
@ -1,6 +1,7 @@
|
||||
diff -Naur xbean-3.7/pom.xml xbean-3.7-work/pom.xml
|
||||
--- xbean-3.7/pom.xml 2010-05-14 10:21:23.000000000 -0400
|
||||
+++ xbean-3.7-work/pom.xml 2011-05-28 07:55:22.461631687 -0400
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
index cfabbe5..b699aff 100644
|
||||
--- a/pom.xml
|
||||
+++ b/pom.xml
|
||||
@@ -24,12 +24,6 @@
|
||||
|
||||
<modelVersion>4.0.0</modelVersion>
|
||||
@ -50,27 +51,6 @@ diff -Naur xbean-3.7/pom.xml xbean-3.7-work/pom.xml
|
||||
</dependency>
|
||||
</dependencies>
|
||||
</dependencyManagement>
|
||||
@@ -327,13 +303,13 @@
|
||||
<artifactId>maven-bundle-plugin</artifactId>
|
||||
<version>2.0.0</version>
|
||||
<extensions>true</extensions>
|
||||
- <configuration>
|
||||
- <instructions>
|
||||
- <Bundle-DocURL>${project.url}</Bundle-DocURL>
|
||||
- <Export-Package>org.apache.xbean.*;version=${pom.version}</Export-Package>
|
||||
- <Private-Package />
|
||||
- </instructions>
|
||||
- </configuration>
|
||||
+ <configuration>
|
||||
+- <instructions>
|
||||
+- <Bundle-DocURL>${project.url}</Bundle-DocURL>
|
||||
+- <Export-Package>org.apache.xbean.*;version=${pom.version}</Export-Package>
|
||||
+- <Private-Package />
|
||||
+- </instructions>
|
||||
+- </configuration>
|
||||
</plugin>
|
||||
</plugins>
|
||||
</pluginManagement>
|
||||
@@ -343,22 +319,22 @@
|
||||
<groupId>org.apache.felix</groupId>
|
||||
<artifactId>maven-bundle-plugin</artifactId>
|
||||
@ -101,27 +81,28 @@ diff -Naur xbean-3.7/pom.xml xbean-3.7-work/pom.xml
|
||||
</modules>
|
||||
|
||||
<reporting>
|
||||
@@ -422,4 +398,4 @@
|
||||
@@ -424,4 +400,4 @@
|
||||
</plugins>
|
||||
</reporting>
|
||||
|
||||
-</project>
|
||||
\ No newline at end of file
|
||||
+</project>
|
||||
diff -Naur xbean-3.7/xbean-reflect/pom.xml xbean-3.7-work/xbean-reflect/pom.xml
|
||||
--- xbean-3.7/xbean-reflect/pom.xml 2010-05-14 10:21:23.000000000 -0400
|
||||
+++ xbean-3.7-work/xbean-reflect/pom.xml 2011-05-28 07:53:16.040651498 -0400
|
||||
diff --git a/xbean-reflect/pom.xml b/xbean-reflect/pom.xml
|
||||
index b2a76b2..3985b46 100644
|
||||
--- a/xbean-reflect/pom.xml
|
||||
+++ b/xbean-reflect/pom.xml
|
||||
@@ -47,13 +47,6 @@
|
||||
<optional>true</optional>
|
||||
</dependency>
|
||||
<dependency>
|
||||
- <groupId>org.apache.xbean</groupId>
|
||||
- <artifactId>xbean-asm-shaded</artifactId>
|
||||
- <version>3.7</version>
|
||||
- <scope>provided</scope>
|
||||
- <optional>true</optional>
|
||||
- </dependency>
|
||||
- <dependency>
|
||||
<groupId>log4j</groupId>
|
||||
<artifactId>log4j</artifactId>
|
||||
<version>1.2.12</version>
|
||||
<optional>true</optional>
|
||||
</dependency>
|
||||
<dependency>
|
||||
- <groupId>org.apache.xbean</groupId>
|
||||
- <artifactId>xbean-asm-shaded</artifactId>
|
||||
- <version>3.8</version>
|
||||
- <scope>provided</scope>
|
||||
- <optional>true</optional>
|
||||
- </dependency>
|
||||
- <dependency>
|
||||
<groupId>log4j</groupId>
|
||||
<artifactId>log4j</artifactId>
|
||||
<version>1.2.12</version>
|
2
sources
2
sources
@ -1 +1 @@
|
||||
987f14094e03d803e948d6c09ad8a2d4 xbean-3.7.tar.xz
|
||||
ad5e6370facd5c186db4db570d0be1df xbean-3.8.tar.xz
|
||||
|
36
xbean.spec
36
xbean.spec
@ -1,8 +1,8 @@
|
||||
Name: xbean
|
||||
Version: 3.7
|
||||
Version: 3.8
|
||||
BuildArch: noarch
|
||||
|
||||
Release: 7%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: Java plugin based web server
|
||||
|
||||
Group: Development/Libraries
|
||||
@ -11,8 +11,8 @@ URL: http://geronimo.apache.org/xbean/
|
||||
|
||||
# unfortunately no source/binary releases are being made lately, just
|
||||
# tags in repos and binary releases in maven repositories
|
||||
# svn export http://svn.apache.org/repos/asf/geronimo/xbean/tags/xbean-3.7
|
||||
# tar caf xbean-3.7.tar.xz xbean-3.7
|
||||
# svn export http://svn.apache.org/repos/asf/geronimo/xbean/tags/xbean-3.8
|
||||
# tar caf xbean-3.8.tar.xz xbean-3.8
|
||||
Source0: xbean-%{version}.tar.xz
|
||||
Source1: xbean.depmap
|
||||
|
||||
@ -27,16 +27,20 @@ BuildRequires: ant
|
||||
BuildRequires: qdox
|
||||
BuildRequires: slf4j
|
||||
BuildRequires: felix-osgi-core >= 1.4.0
|
||||
BuildRequires: maven
|
||||
BuildRequires: maven-plugin-bundle
|
||||
BuildRequires: maven-antrun-plugin
|
||||
BuildRequires: maven-compiler-plugin
|
||||
BuildRequires: maven-dependency-plugin
|
||||
BuildRequires: maven-idea-plugin
|
||||
BuildRequires: maven-install-plugin
|
||||
BuildRequires: maven-javadoc-plugin
|
||||
BuildRequires: maven-resources-plugin
|
||||
BuildRequires: maven-surefire-maven-plugin
|
||||
BuildRequires: maven-surefire-provider-junit4
|
||||
BuildRequires: maven-site-plugin
|
||||
BuildRequires: maven-shade-plugin
|
||||
BuildRequires: eclipse-rcp
|
||||
|
||||
Requires: java
|
||||
Requires: objectweb-asm
|
||||
@ -75,10 +79,9 @@ sed -i 's/org.apache.xbean.asm/org.objectweb.asm/' \
|
||||
xbean-reflect/src/main/java/org/apache/xbean/recipe/XbeanAsmParameterNameLoader.java
|
||||
|
||||
%build
|
||||
export MAVEN_REPO_LOCAL=$(pwd)/.m2/repository
|
||||
mvn-jpp -e \
|
||||
-Dmaven.repo.local=$MAVEN_REPO_LOCAL \
|
||||
-Dmaven2.jpp.depmap.file="%{SOURCE1}" \
|
||||
mvn-rpmbuild -e \
|
||||
-Dmaven.local.depmap.file="%{SOURCE1}" \
|
||||
-Dmaven.test.skip=true \
|
||||
install javadoc:aggregate
|
||||
|
||||
|
||||
@ -93,7 +96,7 @@ for sub in bundleutils finder reflect naming classpath; do
|
||||
install -Dpm 644 %{name}-${sub}/pom.xml $RPM_BUILD_ROOT/%{_mavenpomdir}/JPP.%{name}-%{name}-${sub}.pom
|
||||
|
||||
# maven depmap
|
||||
%add_to_maven_depmap org.apache.xbean %{name}-${sub} %{version} JPP/%{name} %{name}-${sub}
|
||||
%add_maven_depmap JPP.%{name}-%{name}-${sub}.pom %{name}/%{name}-${sub}.jar
|
||||
done
|
||||
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}
|
||||
@ -101,32 +104,29 @@ cp -pr target/site/apidocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}
|
||||
|
||||
# parent pom
|
||||
install -pm 644 pom.xml $RPM_BUILD_ROOT/%{_mavenpomdir}/JPP.%{name}-main.pom
|
||||
%add_to_maven_depmap org.apache.xbean %{name} %{version} JPP/%{name} main
|
||||
%add_maven_depmap JPP.%{name}-main.pom
|
||||
|
||||
%pre javadoc
|
||||
# workaround for rpm bug, can be removed in F-17
|
||||
[ $1 -gt 1 ] && [ -L %{_javadocdir}/%{name} ] && \
|
||||
rm -rf $(readlink -f %{_javadocdir}/%{name}) %{_javadocdir}/%{name} || :
|
||||
|
||||
%post
|
||||
%update_maven_depmap
|
||||
|
||||
%postun
|
||||
%update_maven_depmap
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc LICENSE NOTICE
|
||||
%{_mavenpomdir}/*.pom
|
||||
%{_mavendepmapfragdir}/%{name}
|
||||
%{_javadir}/%{name}
|
||||
|
||||
%files javadoc
|
||||
%defattr(-,root,root,-)
|
||||
%doc LICENSE
|
||||
%{_javadocdir}/%{name}
|
||||
|
||||
%changelog
|
||||
* Tue Dec 6 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 3.8-1
|
||||
- Update to latest upstream version
|
||||
- Build with maven 3
|
||||
- Packaging & guidelines fixes
|
||||
|
||||
* Sat May 28 2011 Marek Goldmann <mgoldman@redhat.com> - 3.7-7
|
||||
- Added xbean-finder and xbean-bundleutils submodules
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user