Convert patch to POM macros
This commit is contained in:
parent
351792020a
commit
6b26146e79
114
pom-3.8.patch
114
pom-3.8.patch
@ -1,114 +0,0 @@
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
index cfabbe5..b3f0a12 100644
|
||||
--- a/pom.xml
|
||||
+++ b/pom.xml
|
||||
@@ -24,12 +24,6 @@
|
||||
|
||||
<modelVersion>4.0.0</modelVersion>
|
||||
|
||||
- <parent>
|
||||
- <groupId>org.apache.geronimo.genesis</groupId>
|
||||
- <artifactId>genesis-java5-flava</artifactId>
|
||||
- <version>2.0</version>
|
||||
- </parent>
|
||||
-
|
||||
<groupId>org.apache.xbean</groupId>
|
||||
<artifactId>xbean</artifactId>
|
||||
<name>Apache XBean</name>
|
||||
@@ -259,39 +253,15 @@
|
||||
</dependency>
|
||||
|
||||
<dependency>
|
||||
- <groupId>mx4j</groupId>
|
||||
- <artifactId>mx4j</artifactId>
|
||||
- <version>3.0.1</version>
|
||||
- </dependency>
|
||||
-
|
||||
- <dependency>
|
||||
- <groupId>org.springframework</groupId>
|
||||
- <artifactId>spring-beans</artifactId>
|
||||
- <version>2.5.6</version>
|
||||
- </dependency>
|
||||
-
|
||||
- <dependency>
|
||||
- <groupId>org.springframework</groupId>
|
||||
- <artifactId>spring-context</artifactId>
|
||||
- <version>2.5.6</version>
|
||||
- </dependency>
|
||||
-
|
||||
- <dependency>
|
||||
- <groupId>org.springframework</groupId>
|
||||
- <artifactId>spring-web</artifactId>
|
||||
- <version>2.5.6</version>
|
||||
- </dependency>
|
||||
-
|
||||
- <dependency>
|
||||
<groupId>com.thoughtworks.qdox</groupId>
|
||||
<artifactId>qdox</artifactId>
|
||||
<version>1.6.3</version>
|
||||
</dependency>
|
||||
-
|
||||
+
|
||||
<dependency>
|
||||
<groupId>org.slf4j</groupId>
|
||||
<artifactId>slf4j-api</artifactId>
|
||||
- <version>1.5.11</version>
|
||||
+ <version>1.5.11</version>
|
||||
</dependency>
|
||||
</dependencies>
|
||||
</dependencyManagement>
|
||||
@@ -343,22 +313,22 @@
|
||||
<groupId>org.apache.felix</groupId>
|
||||
<artifactId>maven-bundle-plugin</artifactId>
|
||||
</plugin>
|
||||
+ <plugin>
|
||||
+ <artifactId>maven-compiler-plugin</artifactId>
|
||||
+ <configuration>
|
||||
+ <source>1.5</source>
|
||||
+ <target>1.5</target>
|
||||
+ </configuration>
|
||||
+ </plugin>
|
||||
</plugins>
|
||||
</build>
|
||||
|
||||
<modules>
|
||||
- <module>xbean-classloader</module>
|
||||
<module>xbean-classpath</module>
|
||||
<module>xbean-bundleutils</module>
|
||||
<module>xbean-finder</module>
|
||||
<module>xbean-naming</module>
|
||||
<module>xbean-reflect</module>
|
||||
- <module>xbean-blueprint</module>
|
||||
- <module>xbean-spring</module>
|
||||
- <module>xbean-telnet</module>
|
||||
- <module>maven-xbean-plugin</module>
|
||||
- <module>xbean-asm-shaded</module>
|
||||
- <module>xbean-finder-shaded</module>
|
||||
</modules>
|
||||
|
||||
<reporting>
|
||||
@@ -424,4 +394,4 @@
|
||||
</plugins>
|
||||
</reporting>
|
||||
|
||||
-</project>
|
||||
\ No newline at end of file
|
||||
+</project>
|
||||
diff --git a/xbean-reflect/pom.xml b/xbean-reflect/pom.xml
|
||||
index b2a76b2..3985b46 100644
|
||||
--- a/xbean-reflect/pom.xml
|
||||
+++ b/xbean-reflect/pom.xml
|
||||
@@ -47,13 +47,6 @@
|
||||
<optional>true</optional>
|
||||
</dependency>
|
||||
<dependency>
|
||||
- <groupId>org.apache.xbean</groupId>
|
||||
- <artifactId>xbean-asm-shaded</artifactId>
|
||||
- <version>3.8</version>
|
||||
- <scope>provided</scope>
|
||||
- <optional>true</optional>
|
||||
- </dependency>
|
||||
- <dependency>
|
||||
<groupId>log4j</groupId>
|
||||
<artifactId>log4j</artifactId>
|
||||
<version>1.2.12</version>
|
27
xbean.spec
27
xbean.spec
@ -16,8 +16,6 @@ URL: http://geronimo.apache.org/xbean/
|
||||
Source0: xbean-%{version}.tar.xz
|
||||
Source1: xbean.depmap
|
||||
|
||||
Patch0: pom-%{version}.patch
|
||||
|
||||
BuildRequires: java-devel
|
||||
BuildRequires: apache-commons-beanutils
|
||||
BuildRequires: apache-commons-logging
|
||||
@ -70,11 +68,28 @@ Requires: jpackage-utils
|
||||
# build failing on this due to doxia-sitetools problems
|
||||
rm src/site/site.xml
|
||||
|
||||
# removes dependency on springframework and prevents building of
|
||||
# modules depending on it. If other modules are required,
|
||||
# springframework will have to be brought in first
|
||||
%patch0 -p1
|
||||
%pom_xpath_remove "pom:parent"
|
||||
%pom_remove_dep org.springframework:
|
||||
%pom_remove_dep mx4j:mx4j
|
||||
%pom_remove_dep :xbean-asm-shaded xbean-reflect
|
||||
|
||||
# Prevent modules depending on springframework from building.
|
||||
%pom_disable_module xbean-asm-shaded
|
||||
%pom_disable_module xbean-blueprint
|
||||
%pom_disable_module xbean-classloader
|
||||
%pom_disable_module xbean-finder-shaded
|
||||
%pom_disable_module xbean-spring
|
||||
%pom_disable_module xbean-telnet
|
||||
%pom_disable_module maven-xbean-plugin
|
||||
|
||||
%pom_xpath_inject "pom:build/pom:plugins" "
|
||||
<plugin>
|
||||
<artifactId>maven-compiler-plugin</artifactId>
|
||||
<configuration>
|
||||
<source>1.5</source>
|
||||
<target>1.5</target>
|
||||
</configuration>
|
||||
</plugin>"
|
||||
|
||||
# Fix dependency on xbean-asm-shaded to original objectweb-asm
|
||||
sed -i 's/org.apache.xbean.asm/org.objectweb.asm/' \
|
||||
|
Loading…
Reference in New Issue
Block a user