Update to 2.36.5

Related: #2061996
This commit is contained in:
Michael Catanzaro 2022-07-28 12:30:59 -05:00
parent 53f904f769
commit ad58495496
4 changed files with 9 additions and 60 deletions

2
.gitignore vendored
View File

@ -97,3 +97,5 @@
/webkitgtk-2.36.3.tar.xz.asc /webkitgtk-2.36.3.tar.xz.asc
/webkitgtk-2.36.4.tar.xz /webkitgtk-2.36.4.tar.xz
/webkitgtk-2.36.4.tar.xz.asc /webkitgtk-2.36.4.tar.xz.asc
/webkitgtk-2.36.5.tar.xz
/webkitgtk-2.36.5.tar.xz.asc

View File

@ -1,54 +0,0 @@
From f20bac21ea37991c1a1110e78846897a406932f0 Mon Sep 17 00:00:00 2001
From: Michael Catanzaro <mcatanzaro@redhat.com>
Date: Tue, 5 Jul 2022 08:23:12 -0500
Subject: [PATCH] Revert "Merge r295034 - WebKitTestRunner shouldn't link
object files of JavaScriptCore and WebCore"
This reverts commit 7916fda00b347ff263fbfe72c065032d1d9b523c.
---
Source/JavaScriptCore/CMakeLists.txt | 12 +++++++++---
Tools/WebKitTestRunner/CMakeLists.txt | 1 -
Tools/WebKitTestRunner/PlatformGTK.cmake | 4 ++++
Tools/WebKitTestRunner/PlatformWin.cmake | 4 ++++
4 files changed, 17 insertions(+), 4 deletions(-)
diff --git a/Source/JavaScriptCore/CMakeLists.txt b/Source/JavaScriptCore/CMakeLists.txt
index 95a1300ce1b3..238208eb1137 100644
--- a/Source/JavaScriptCore/CMakeLists.txt
+++ b/Source/JavaScriptCore/CMakeLists.txt
@@ -456,7 +456,7 @@ if (MSVC AND NOT ENABLE_C_LOOP)
COMMAND ${MASM_EXECUTABLE} ${LLINT_MASM_FLAGS} ${JavaScriptCore_DERIVED_SOURCES_DIR}/LowLevelInterpreterWin.obj ${JavaScriptCore_DERIVED_SOURCES_DIR}/LowLevelInterpreterWin.asm
VERBATIM)
list(APPEND JavaScriptCore_SOURCES ${JavaScriptCore_DERIVED_SOURCES_DIR}/LowLevelInterpreterWin.obj)
- add_library(LowLevelInterpreterLib STATIC llint/LowLevelInterpreter.cpp)
+ add_library(LowLevelInterpreterLib OBJECT llint/LowLevelInterpreter.cpp)
else ()
# As there's poor toolchain support for using `.file` directives in
# inline asm (i.e. there's no way to avoid clashes with the `.file`
@@ -465,7 +465,7 @@ else ()
# an object file. We only need to do this for LowLevelInterpreter.cpp
# and cmake doesn't allow us to introduce a compiler wrapper for a
# single source file, so we need to create a separate target for it.
- add_library(LowLevelInterpreterLib STATIC llint/LowLevelInterpreter.cpp
+ add_library(LowLevelInterpreterLib OBJECT llint/LowLevelInterpreter.cpp
${JavaScriptCore_DERIVED_SOURCES_DIR}/${LLIntOutput})
endif ()
@@ -1496,7 +1496,13 @@ if (CMAKE_COMPILER_IS_GNUCXX AND GCC_OFFLINEASM_SOURCE_MAP)
COMPILE_OPTIONS "-fno-lto")
endif ()
-list(APPEND JavaScriptCore_PRIVATE_LIBRARIES LowLevelInterpreterLib)
+# When building JavaScriptCore as an object library, we need to make sure the
+# lowlevelinterpreter lib objects get propogated.
+if (${JavaScriptCore_LIBRARY_TYPE} STREQUAL "OBJECT")
+ list(APPEND JavaScriptCore_PRIVATE_LIBRARIES $<TARGET_OBJECTS:LowLevelInterpreterLib>)
+else ()
+ list(APPEND JavaScriptCore_SOURCES $<TARGET_OBJECTS:LowLevelInterpreterLib>)
+endif ()
WEBKIT_COMPUTE_SOURCES(JavaScriptCore)
list(APPEND JavaScriptCore_SOURCES
--
2.36.1

View File

@ -1,2 +1,2 @@
SHA512 (webkitgtk-2.36.4.tar.xz) = c5365c682ba4e8e6ad891638b5a82e74e38fa0867ce6c8e4e08a9dc15b862a6d3edc096a049e0711306972d6162d79fe90a0e76d8b395001798005e4488467f2 SHA512 (webkitgtk-2.36.5.tar.xz) = 71be328aae93f1454d74371c3a614aab15190d2abc7dd7d7a003004c2f35a19d610d2613e64292f21e472d5112cba865ef019fecc2b4066eb87368c6d363b545
SHA512 (webkitgtk-2.36.4.tar.xz.asc) = 7cea7d124c6de8b89f58aad46565cfb1a0ca51156d3643e88c6c5a97a27a7a0c819015491824aadb4c4b95930728fc3e2212bfc9260e0b303ed8878f9defb2db SHA512 (webkitgtk-2.36.5.tar.xz.asc) = 7566fdfa20b31c2462f715a250fe0e9792ec6156a2373aa5710198661bc1ca51c8fbb48ee51019bca7c37e9a59949661a9ad8c6c3c22e71dd20b22929c836de3

View File

@ -16,7 +16,7 @@
%bcond_without docs %bcond_without docs
Name: webkit2gtk3 Name: webkit2gtk3
Version: 2.36.4 Version: 2.36.5
Release: 1%{?dist} Release: 1%{?dist}
Summary: GTK Web content engine library Summary: GTK Web content engine library
@ -35,9 +35,6 @@ Source2: webkitgtk-keys.gpg
Patch0: aarch64-page-size.patch Patch0: aarch64-page-size.patch
%endif %endif
# https://bugs.webkit.org/show_bug.cgi?id=242340
Patch1: fix-build.patch
BuildRequires: bison BuildRequires: bison
BuildRequires: bubblewrap BuildRequires: bubblewrap
BuildRequires: cmake BuildRequires: cmake
@ -323,6 +320,10 @@ export NINJA_STATUS="[%f/%t][%e] "
%endif %endif
%changelog %changelog
* Thu Jul 28 2022 Michael Catanzaro <mcatanzaro@redhat.com> - 2.36.5-1
- Update to 2.36.5
Related: #2061996
* Tue Jul 05 2022 Michael Catanzaro <mcatanzaro@redhat.com> - 2.36.4-1 * Tue Jul 05 2022 Michael Catanzaro <mcatanzaro@redhat.com> - 2.36.4-1
- Update to 2.36.4 - Update to 2.36.4
Related: #2061996 Related: #2061996