parent
127d76a193
commit
53f904f769
2
.gitignore
vendored
2
.gitignore
vendored
@ -95,3 +95,5 @@
|
||||
/webkitgtk-2.36.2.tar.xz.asc
|
||||
/webkitgtk-2.36.3.tar.xz
|
||||
/webkitgtk-2.36.3.tar.xz.asc
|
||||
/webkitgtk-2.36.4.tar.xz
|
||||
/webkitgtk-2.36.4.tar.xz.asc
|
||||
|
54
fix-build.patch
Normal file
54
fix-build.patch
Normal file
@ -0,0 +1,54 @@
|
||||
From f20bac21ea37991c1a1110e78846897a406932f0 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Catanzaro <mcatanzaro@redhat.com>
|
||||
Date: Tue, 5 Jul 2022 08:23:12 -0500
|
||||
Subject: [PATCH] Revert "Merge r295034 - WebKitTestRunner shouldn't link
|
||||
object files of JavaScriptCore and WebCore"
|
||||
|
||||
This reverts commit 7916fda00b347ff263fbfe72c065032d1d9b523c.
|
||||
---
|
||||
Source/JavaScriptCore/CMakeLists.txt | 12 +++++++++---
|
||||
Tools/WebKitTestRunner/CMakeLists.txt | 1 -
|
||||
Tools/WebKitTestRunner/PlatformGTK.cmake | 4 ++++
|
||||
Tools/WebKitTestRunner/PlatformWin.cmake | 4 ++++
|
||||
4 files changed, 17 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/Source/JavaScriptCore/CMakeLists.txt b/Source/JavaScriptCore/CMakeLists.txt
|
||||
index 95a1300ce1b3..238208eb1137 100644
|
||||
--- a/Source/JavaScriptCore/CMakeLists.txt
|
||||
+++ b/Source/JavaScriptCore/CMakeLists.txt
|
||||
@@ -456,7 +456,7 @@ if (MSVC AND NOT ENABLE_C_LOOP)
|
||||
COMMAND ${MASM_EXECUTABLE} ${LLINT_MASM_FLAGS} ${JavaScriptCore_DERIVED_SOURCES_DIR}/LowLevelInterpreterWin.obj ${JavaScriptCore_DERIVED_SOURCES_DIR}/LowLevelInterpreterWin.asm
|
||||
VERBATIM)
|
||||
list(APPEND JavaScriptCore_SOURCES ${JavaScriptCore_DERIVED_SOURCES_DIR}/LowLevelInterpreterWin.obj)
|
||||
- add_library(LowLevelInterpreterLib STATIC llint/LowLevelInterpreter.cpp)
|
||||
+ add_library(LowLevelInterpreterLib OBJECT llint/LowLevelInterpreter.cpp)
|
||||
else ()
|
||||
# As there's poor toolchain support for using `.file` directives in
|
||||
# inline asm (i.e. there's no way to avoid clashes with the `.file`
|
||||
@@ -465,7 +465,7 @@ else ()
|
||||
# an object file. We only need to do this for LowLevelInterpreter.cpp
|
||||
# and cmake doesn't allow us to introduce a compiler wrapper for a
|
||||
# single source file, so we need to create a separate target for it.
|
||||
- add_library(LowLevelInterpreterLib STATIC llint/LowLevelInterpreter.cpp
|
||||
+ add_library(LowLevelInterpreterLib OBJECT llint/LowLevelInterpreter.cpp
|
||||
${JavaScriptCore_DERIVED_SOURCES_DIR}/${LLIntOutput})
|
||||
endif ()
|
||||
|
||||
@@ -1496,7 +1496,13 @@ if (CMAKE_COMPILER_IS_GNUCXX AND GCC_OFFLINEASM_SOURCE_MAP)
|
||||
COMPILE_OPTIONS "-fno-lto")
|
||||
endif ()
|
||||
|
||||
-list(APPEND JavaScriptCore_PRIVATE_LIBRARIES LowLevelInterpreterLib)
|
||||
+# When building JavaScriptCore as an object library, we need to make sure the
|
||||
+# lowlevelinterpreter lib objects get propogated.
|
||||
+if (${JavaScriptCore_LIBRARY_TYPE} STREQUAL "OBJECT")
|
||||
+ list(APPEND JavaScriptCore_PRIVATE_LIBRARIES $<TARGET_OBJECTS:LowLevelInterpreterLib>)
|
||||
+else ()
|
||||
+ list(APPEND JavaScriptCore_SOURCES $<TARGET_OBJECTS:LowLevelInterpreterLib>)
|
||||
+endif ()
|
||||
|
||||
WEBKIT_COMPUTE_SOURCES(JavaScriptCore)
|
||||
list(APPEND JavaScriptCore_SOURCES
|
||||
--
|
||||
2.36.1
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (webkitgtk-2.36.3.tar.xz) = dfd02e22a58d0080d9bf6c7dd2a710bb9d8698ff8a4226653629294b74cc981a3e35d4d93eed5ebad35c81b339ec8b96755ad0b36c0238da151b359e07bcb692
|
||||
SHA512 (webkitgtk-2.36.3.tar.xz.asc) = c11823ac9d54bedeb4f6e9a944570fd1a8ab24c9de67f8c6b6a6c598e3ff1dc39f4f05949b571b320c0819e9e02511444fd2a770c19f3fdf6125bd20f0348616
|
||||
SHA512 (webkitgtk-2.36.4.tar.xz) = c5365c682ba4e8e6ad891638b5a82e74e38fa0867ce6c8e4e08a9dc15b862a6d3edc096a049e0711306972d6162d79fe90a0e76d8b395001798005e4488467f2
|
||||
SHA512 (webkitgtk-2.36.4.tar.xz.asc) = 7cea7d124c6de8b89f58aad46565cfb1a0ca51156d3643e88c6c5a97a27a7a0c819015491824aadb4c4b95930728fc3e2212bfc9260e0b303ed8878f9defb2db
|
||||
|
@ -16,7 +16,7 @@
|
||||
%bcond_without docs
|
||||
|
||||
Name: webkit2gtk3
|
||||
Version: 2.36.3
|
||||
Version: 2.36.4
|
||||
Release: 1%{?dist}
|
||||
Summary: GTK Web content engine library
|
||||
|
||||
@ -35,6 +35,9 @@ Source2: webkitgtk-keys.gpg
|
||||
Patch0: aarch64-page-size.patch
|
||||
%endif
|
||||
|
||||
# https://bugs.webkit.org/show_bug.cgi?id=242340
|
||||
Patch1: fix-build.patch
|
||||
|
||||
BuildRequires: bison
|
||||
BuildRequires: bubblewrap
|
||||
BuildRequires: cmake
|
||||
@ -320,6 +323,10 @@ export NINJA_STATUS="[%f/%t][%e] "
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Jul 05 2022 Michael Catanzaro <mcatanzaro@redhat.com> - 2.36.4-1
|
||||
- Update to 2.36.4
|
||||
Related: #2061996
|
||||
|
||||
* Thu Jun 02 2022 Michael Catanzaro <mcatanzaro@redhat.com> - 2.36.3-1
|
||||
- Update to 2.36.3
|
||||
- Related: #2061996
|
||||
|
Loading…
Reference in New Issue
Block a user