import vulkan-validation-layers-1.1.126.0-3.el8
This commit is contained in:
parent
d811863186
commit
31dd2ec3ec
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/Vulkan-ValidationLayers-sdk-1.1.82.0.tar.gz
|
||||
SOURCES/Vulkan-ValidationLayers-sdk-1.1.126.0.tar.gz
|
||||
|
@ -1 +1 @@
|
||||
29c69f3c334102dfe05f3216deb6fdca06b0f4af SOURCES/Vulkan-ValidationLayers-sdk-1.1.82.0.tar.gz
|
||||
3c697791a750e61d8ded6d6c0f4634a41a9fd16f SOURCES/Vulkan-ValidationLayers-sdk-1.1.126.0.tar.gz
|
||||
|
@ -1,12 +1,12 @@
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -300,7 +300,7 @@
|
||||
add_library(VkLayer_utils STATIC ${VALIDATION_LAYER_UTILS_SOURCES})
|
||||
target_compile_definitions(VkLayer_utils PUBLIC _CRT_SECURE_NO_WARNINGS)
|
||||
else()
|
||||
- add_library(VkLayer_utils STATIC ${VALIDATION_LAYER_UTILS_SOURCES})
|
||||
+ add_library(VkLayer_utils SHARED ${VALIDATION_LAYER_UTILS_SOURCES})
|
||||
endif()
|
||||
install(TARGETS VkLayer_utils DESTINATION ${CMAKE_INSTALL_LIBDIR})
|
||||
set_target_properties(VkLayer_utils PROPERTIES LINKER_LANGUAGE CXX)
|
||||
|
||||
diff -up Vulkan-ValidationLayers-sdk-1.1.92.0/CMakeLists.txt.dma Vulkan-ValidationLayers-sdk-1.1.92.0/CMakeLists.txt
|
||||
--- Vulkan-ValidationLayers-sdk-1.1.92.0/CMakeLists.txt.dma 2019-02-13 09:20:44.590959278 +1000
|
||||
+++ Vulkan-ValidationLayers-sdk-1.1.92.0/CMakeLists.txt 2019-02-13 09:21:29.178151673 +1000
|
||||
@@ -294,7 +294,7 @@ set_target_properties(generate_helper_fi
|
||||
# files directly in layers.
|
||||
|
||||
add_library(VkLayer_utils
|
||||
- STATIC
|
||||
+ SHARED
|
||||
layers/vk_layer_config.cpp
|
||||
layers/vk_layer_extension_utils.cpp
|
||||
layers/vk_layer_utils.cpp
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: vulkan-validation-layers
|
||||
Version: 1.1.82.0
|
||||
Release: 1%{?dist}
|
||||
Version: 1.1.126.0
|
||||
Release: 3%{?dist}
|
||||
Summary: Vulkan validation layers
|
||||
|
||||
License: ASL 2.0
|
||||
@ -24,6 +24,7 @@ BuildRequires: pkgconfig(x11)
|
||||
BuildRequires: pkgconfig(xrandr)
|
||||
BuildRequires: pkgconfig(xcb)
|
||||
|
||||
Requires: spirv-tools-libs >= 2019.4-1.20191109
|
||||
%description
|
||||
Vulkan validation layers
|
||||
|
||||
@ -47,7 +48,8 @@ developing applications that use %{name}.
|
||||
|
||||
%cmake3 -GNinja \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DGLSLANG_INSTALL_DIR=%{_bindir} \
|
||||
-DGLSLANG_INSTALL_DIR=%{_prefix} \
|
||||
-DBUILD_LAYER_SUPPORT_FILES:BOOL=ON \
|
||||
-DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}/vulkan/ .
|
||||
%ninja_build
|
||||
|
||||
@ -60,7 +62,7 @@ developing applications that use %{name}.
|
||||
|
||||
|
||||
%files
|
||||
%license LICENSE.txt COPYRIGHT.txt
|
||||
%license LICENSE.txt
|
||||
%doc README.md CONTRIBUTING.md
|
||||
%{_datadir}/vulkan/explicit_layer.d/*.json
|
||||
%{_libdir}/libVkLayer_*.so
|
||||
@ -69,6 +71,21 @@ developing applications that use %{name}.
|
||||
%{_includedir}/vulkan/
|
||||
|
||||
%changelog
|
||||
* Sat Dec 07 2019 Dave Airlie <airlied@redhat.com> - 1.1.126.0-3
|
||||
- Update for 8.2.0
|
||||
|
||||
* Fri Nov 29 2019 Dave Airlie <airlied@redhat.com> - 1.1.126.0-2
|
||||
- Add explicit spirv toos libs requires
|
||||
|
||||
* Wed Nov 13 2019 Dave Airlie <airlied@redhat.com> - 1.1.126.0-1
|
||||
- Update validation layers to 1.1.126.0
|
||||
|
||||
* Wed Jul 31 2019 Dave Airlie <airlied@redhat.com> - 1.1.114.0-1
|
||||
- Update validation layers to 1.1.114.0
|
||||
|
||||
* Wed Mar 06 2019 Dave Airlie <airlied@redhat.com> - 1.1.101.0-1
|
||||
- Update valdiation layers to 1.1.101.0
|
||||
|
||||
* Tue Aug 07 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.1.82.0-1
|
||||
- Update to 1.1.82.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user