import vulkan-validation-layers-1.1.82.0-1.el8
This commit is contained in:
commit
d811863186
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/Vulkan-ValidationLayers-sdk-1.1.82.0.tar.gz
|
1
.vulkan-validation-layers.metadata
Normal file
1
.vulkan-validation-layers.metadata
Normal file
@ -0,0 +1 @@
|
||||
29c69f3c334102dfe05f3216deb6fdca06b0f4af SOURCES/Vulkan-ValidationLayers-sdk-1.1.82.0.tar.gz
|
12
SOURCES/fix_shared.patch
Normal file
12
SOURCES/fix_shared.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -300,7 +300,7 @@
|
||||
add_library(VkLayer_utils STATIC ${VALIDATION_LAYER_UTILS_SOURCES})
|
||||
target_compile_definitions(VkLayer_utils PUBLIC _CRT_SECURE_NO_WARNINGS)
|
||||
else()
|
||||
- add_library(VkLayer_utils STATIC ${VALIDATION_LAYER_UTILS_SOURCES})
|
||||
+ add_library(VkLayer_utils SHARED ${VALIDATION_LAYER_UTILS_SOURCES})
|
||||
endif()
|
||||
install(TARGETS VkLayer_utils DESTINATION ${CMAKE_INSTALL_LIBDIR})
|
||||
set_target_properties(VkLayer_utils PROPERTIES LINKER_LANGUAGE CXX)
|
||||
|
85
SPECS/vulkan-validation-layers.spec
Normal file
85
SPECS/vulkan-validation-layers.spec
Normal file
@ -0,0 +1,85 @@
|
||||
Name: vulkan-validation-layers
|
||||
Version: 1.1.82.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Vulkan validation layers
|
||||
|
||||
License: ASL 2.0
|
||||
URL: https://github.com/KhronosGroup/Vulkan-ValidationLayers
|
||||
Source0: %url/archive/sdk-%{version}.tar.gz#/Vulkan-ValidationLayers-sdk-%{version}.tar.gz
|
||||
Patch0: fix_shared.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: cmake3
|
||||
BuildRequires: glslang-devel
|
||||
BuildRequires: ninja-build
|
||||
BuildRequires: python%{python3_pkgversion}-devel
|
||||
BuildRequires: spirv-tools-devel
|
||||
BuildRequires: vulkan-loader-devel
|
||||
BuildRequires: pkgconfig(wayland-client)
|
||||
BuildRequires: pkgconfig(wayland-cursor)
|
||||
BuildRequires: pkgconfig(wayland-server)
|
||||
BuildRequires: pkgconfig(wayland-egl)
|
||||
BuildRequires: pkgconfig(x11)
|
||||
BuildRequires: pkgconfig(xrandr)
|
||||
BuildRequires: pkgconfig(xcb)
|
||||
|
||||
%description
|
||||
Vulkan validation layers
|
||||
|
||||
%package devel
|
||||
Summary: Development files for %{name}
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
Requires: vulkan-headers
|
||||
|
||||
%description devel
|
||||
The %{name}-devel package contains libraries and header files for
|
||||
developing applications that use %{name}.
|
||||
|
||||
%prep
|
||||
%autosetup -p1 -n Vulkan-ValidationLayers-sdk-%{version}
|
||||
|
||||
|
||||
%build
|
||||
# Decrease debuginfo verbosity to reduce memory consumption even more
|
||||
%global optflags %(echo %{optflags} | sed 's/-g /-g1 /')
|
||||
|
||||
|
||||
%cmake3 -GNinja \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DGLSLANG_INSTALL_DIR=%{_bindir} \
|
||||
-DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}/vulkan/ .
|
||||
%ninja_build
|
||||
|
||||
|
||||
%install
|
||||
%ninja_install
|
||||
|
||||
|
||||
%ldconfig_scriptlets
|
||||
|
||||
|
||||
%files
|
||||
%license LICENSE.txt COPYRIGHT.txt
|
||||
%doc README.md CONTRIBUTING.md
|
||||
%{_datadir}/vulkan/explicit_layer.d/*.json
|
||||
%{_libdir}/libVkLayer_*.so
|
||||
|
||||
%files devel
|
||||
%{_includedir}/vulkan/
|
||||
|
||||
%changelog
|
||||
* Tue Aug 07 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.1.82.0-1
|
||||
- Update to 1.1.82.0
|
||||
|
||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.77.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Tue Jun 26 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.1.77.0-3
|
||||
- Workaround i686 build issue
|
||||
|
||||
* Tue Jun 26 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.1.77.0-2
|
||||
- Exclude i686 due to 'virtual memory exhausted' FTBFS
|
||||
|
||||
* Sat Jun 23 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.1.77.0-1
|
||||
- Initial package
|
Loading…
Reference in New Issue
Block a user