vulkan-loader/fix-vulkan-loader.patch
DistroBaker 75ac50c9dd Merged update from upstream sources
This is an automated DistroBaker update from upstream sources.
If you do not know what this is about or would like to opt out,
contact the OSCI team.

Source: https://src.fedoraproject.org/rpms/vulkan-loader.git#3c6c19718bcbde9abaf66f71971325d23c34321a
2021-01-29 05:01:19 +00:00

38 lines
1.3 KiB
Diff

From 66a23ac8c566299343668f094de50798a5f4a0e4 Mon Sep 17 00:00:00 2001
From: Michel Zou <xantares09@hotmail.com>
Date: Wed, 16 Dec 2020 15:03:23 +0100
Subject: [PATCH] Rename LIB_SUFFIX to VULKAN_LIB_SUFFIX
Closes #527
---
loader/CMakeLists.txt | 2 +-
loader/vulkan.pc.in | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/loader/CMakeLists.txt b/loader/CMakeLists.txt
index 659511855..ba9f460f1 100644
--- a/loader/CMakeLists.txt
+++ b/loader/CMakeLists.txt
@@ -327,7 +327,7 @@ if(PKG_CONFIG_FOUND)
set(PRIVATE_LIBS "${PRIVATE_LIBS} -l${LIB}")
endforeach()
if(WIN32)
- set(LIB_SUFFIX "-1")
+ set(VULKAN_LIB_SUFFIX "-1")
endif ()
configure_file("vulkan.pc.in" "vulkan.pc" @ONLY)
install(FILES "${CMAKE_CURRENT_BINARY_DIR}/vulkan.pc" DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig")
diff --git a/loader/vulkan.pc.in b/loader/vulkan.pc.in
index fc17cb1f3..44049ee34 100644
--- a/loader/vulkan.pc.in
+++ b/loader/vulkan.pc.in
@@ -6,7 +6,7 @@ includedir=@CMAKE_INSTALL_FULL_INCLUDEDIR@
Name: @CMAKE_PROJECT_NAME@
Description: Vulkan Loader
Version: @VK_API_VERSION@
-Libs: -L${libdir} -lvulkan@LIB_SUFFIX@
+Libs: -L${libdir} -lvulkan@VULKAN_LIB_SUFFIX@
Libs.private: @PRIVATE_LIBS@
Cflags: -I${includedir}