Merged update from upstream sources

This is an automated DistroBaker update from upstream sources.
If you do not know what this is about or would like to opt out,
contact the OSCI team.

Source: https://src.fedoraproject.org/rpms/vulkan-loader.git#3c6c19718bcbde9abaf66f71971325d23c34321a
This commit is contained in:
DistroBaker 2021-01-29 05:01:19 +00:00
parent 08c3f376a7
commit 75ac50c9dd
3 changed files with 71 additions and 2 deletions

26
fix-vulkan-1.patch Normal file
View File

@ -0,0 +1,26 @@
From 7a313093b5c4af964d50a5a64e73d7df6152ea3f Mon Sep 17 00:00:00 2001
From: Michel Zou <xantares09@hotmail.com>
Date: Thu, 26 Nov 2020 22:12:58 +0100
Subject: [PATCH] cmake: remove mingw lib prefix
we want the dll to be named vulkan-1.dll and not libvulkan-1.dll
as it is the default on mingw (for drop-in replacement)
---
loader/CMakeLists.txt | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/loader/CMakeLists.txt b/loader/CMakeLists.txt
index 7cc5fd71e..659511855 100644
--- a/loader/CMakeLists.txt
+++ b/loader/CMakeLists.txt
@@ -224,7 +224,9 @@ if(WIN32)
PROPERTIES LINK_FLAGS_DEBUG
"/ignore:4098"
OUTPUT_NAME
- vulkan-1)
+ vulkan-1
+ PREFIX
+ "")
target_link_libraries(vulkan Vulkan::Headers)
if(ENABLE_WIN10_ONECORE)

37
fix-vulkan-loader.patch Normal file
View File

@ -0,0 +1,37 @@
From 66a23ac8c566299343668f094de50798a5f4a0e4 Mon Sep 17 00:00:00 2001
From: Michel Zou <xantares09@hotmail.com>
Date: Wed, 16 Dec 2020 15:03:23 +0100
Subject: [PATCH] Rename LIB_SUFFIX to VULKAN_LIB_SUFFIX
Closes #527
---
loader/CMakeLists.txt | 2 +-
loader/vulkan.pc.in | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/loader/CMakeLists.txt b/loader/CMakeLists.txt
index 659511855..ba9f460f1 100644
--- a/loader/CMakeLists.txt
+++ b/loader/CMakeLists.txt
@@ -327,7 +327,7 @@ if(PKG_CONFIG_FOUND)
set(PRIVATE_LIBS "${PRIVATE_LIBS} -l${LIB}")
endforeach()
if(WIN32)
- set(LIB_SUFFIX "-1")
+ set(VULKAN_LIB_SUFFIX "-1")
endif ()
configure_file("vulkan.pc.in" "vulkan.pc" @ONLY)
install(FILES "${CMAKE_CURRENT_BINARY_DIR}/vulkan.pc" DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig")
diff --git a/loader/vulkan.pc.in b/loader/vulkan.pc.in
index fc17cb1f3..44049ee34 100644
--- a/loader/vulkan.pc.in
+++ b/loader/vulkan.pc.in
@@ -6,7 +6,7 @@ includedir=@CMAKE_INSTALL_FULL_INCLUDEDIR@
Name: @CMAKE_PROJECT_NAME@
Description: Vulkan Loader
Version: @VK_API_VERSION@
-Libs: -L${libdir} -lvulkan@LIB_SUFFIX@
+Libs: -L${libdir} -lvulkan@VULKAN_LIB_SUFFIX@
Libs.private: @PRIVATE_LIBS@
Cflags: -I${includedir}

View File

@ -1,12 +1,15 @@
Name: vulkan-loader
Version: 1.2.162.0
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Vulkan ICD desktop loader
License: ASL 2.0
URL: https://github.com/KhronosGroup/Vulkan-Loader
Source0: %url/archive/sdk-%{version}.tar.gz#/Vulkan-Loader-sdk-%{version}.tar.gz
# vulkan loader fix from github
Patch1: fix-vulkan-loader.patch
BuildRequires: gcc
BuildRequires: gcc-c++
BuildRequires: cmake3
@ -52,7 +55,7 @@ developing applications that use %{name}.
%prep
%autosetup -n Vulkan-Loader-sdk-%{version}
%autosetup -p1 -n Vulkan-Loader-sdk-%{version}
%build
@ -91,6 +94,9 @@ mkdir -p %{buildroot}%{_sysconfdir}/vulkan/{explicit,implicit}_layer.d/ \
%changelog
* Fri Jan 29 2021 Dave Airlie <airlied@redhat.com> - 1.2.162.0-2
- Fix regression with vulkan loader upstream
* Fri Jan 29 2021 Dave Airlie <airlied@redhat.com> - 1.2.162.0-1
- Update to 1.2.162.0 loader