import vorbis-tools-1.4.0-28.el8

This commit is contained in:
CentOS Sources 2021-03-04 14:10:55 +00:00 committed by Andrew Lukoshko
commit c19ab3a48e
10 changed files with 73001 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/vorbis-tools-1.4.0.tar.gz

1
.vorbis-tools.metadata Normal file
View File

@ -0,0 +1 @@
fc6a820bdb5ad6fcac074721fab5c3f96eaf6562 SOURCES/vorbis-tools-1.4.0.tar.gz

View File

@ -0,0 +1,84 @@
From 32c4958c4d113562f879ce76664fe785f93bba7c Mon Sep 17 00:00:00 2001
From: Kamil Dudka <kdudka@redhat.com>
Date: Thu, 19 Feb 2015 15:32:24 +0100
Subject: [PATCH] oggenc: validate count of channels in the header
... in order to prevent a division by zero (CVE-2014-9638) and integer
overflow (CVE-2014-9639).
Bug: https://trac.xiph.org/ticket/2136
Bug: https://trac.xiph.org/ticket/2137
---
oggenc/audio.c | 19 +++++++++++++++++--
1 file changed, 17 insertions(+), 2 deletions(-)
diff --git a/oggenc/audio.c b/oggenc/audio.c
index 22bbed4..1cbb214 100644
--- a/oggenc/audio.c
+++ b/oggenc/audio.c
@@ -13,6 +13,7 @@
#include <config.h>
#endif
+#include <limits.h>
#include <stdlib.h>
#include <stdio.h>
#include <string.h>
@@ -251,6 +252,7 @@ int aiff_open(FILE *in, oe_enc_opt *opt, unsigned char *buf, int buflen)
aiff_fmt format;
aifffile *aiff = malloc(sizeof(aifffile));
int i;
+ long channels;
if(buf[11]=='C')
aifc=1;
@@ -277,11 +279,17 @@ int aiff_open(FILE *in, oe_enc_opt *opt, unsigned char *buf, int buflen)
return 0;
}
- format.channels = READ_U16_BE(buffer);
+ format.channels = channels = READ_U16_BE(buffer);
format.totalframes = READ_U32_BE(buffer+2);
format.samplesize = READ_U16_BE(buffer+6);
format.rate = (int)read_IEEE80(buffer+8);
+ if(channels <= 0L || SHRT_MAX < channels)
+ {
+ fprintf(stderr, _("Warning: Unsupported count of channels in AIFF header\n"));
+ return 0;
+ }
+
aiff->bigendian = 1;
if(aifc)
@@ -412,6 +420,7 @@ int wav_open(FILE *in, oe_enc_opt *opt, unsigned char *oldbuf, int buflen)
wav_fmt format;
wavfile *wav = malloc(sizeof(wavfile));
int i;
+ long channels;
/* Ok. At this point, we know we have a WAV file. Now we have to detect
* whether we support the subtype, and we have to find the actual data
@@ -449,12 +458,18 @@ int wav_open(FILE *in, oe_enc_opt *opt, unsigned char *oldbuf, int buflen)
}
format.format = READ_U16_LE(buf);
- format.channels = READ_U16_LE(buf+2);
+ format.channels = channels = READ_U16_LE(buf+2);
format.samplerate = READ_U32_LE(buf+4);
format.bytespersec = READ_U32_LE(buf+8);
format.align = READ_U16_LE(buf+12);
format.samplesize = READ_U16_LE(buf+14);
+ if(channels <= 0L || SHRT_MAX < channels)
+ {
+ fprintf(stderr, _("Warning: Unsupported count of channels in WAV header\n"));
+ return 0;
+ }
+
if(format.format == -2) /* WAVE_FORMAT_EXTENSIBLE */
{
if(len<40)
--
2.1.0

View File

@ -0,0 +1,43 @@
From 16d10a1c957425a49cf74332b99cf3d39e80cc09 Mon Sep 17 00:00:00 2001
From: Mark Harris <mark.hsj@gmail.com>
Date: Sun, 30 Aug 2015 05:54:46 -0700
Subject: [PATCH] oggenc: Fix large alloca on bad AIFF input
Fixes #2212
Signed-off-by: Kamil Dudka <kdudka@redhat.com>
---
oggenc/audio.c | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/oggenc/audio.c b/oggenc/audio.c
index 1cbb214..547e826 100644
--- a/oggenc/audio.c
+++ b/oggenc/audio.c
@@ -246,8 +246,8 @@ static int aiff_permute_matrix[6][6] =
int aiff_open(FILE *in, oe_enc_opt *opt, unsigned char *buf, int buflen)
{
int aifc; /* AIFC or AIFF? */
- unsigned int len;
- unsigned char *buffer;
+ unsigned int len, readlen;
+ unsigned char buffer[22];
unsigned char buf2[8];
aiff_fmt format;
aifffile *aiff = malloc(sizeof(aifffile));
@@ -271,9 +271,9 @@ int aiff_open(FILE *in, oe_enc_opt *opt, unsigned char *buf, int buflen)
return 0; /* Weird common chunk */
}
- buffer = alloca(len);
-
- if(fread(buffer,1,len,in) < len)
+ readlen = len < sizeof(buffer) ? len : sizeof(buffer);
+ if(fread(buffer,1,readlen,in) < readlen ||
+ (len > readlen && !seek_forward(in, len-readlen)))
{
fprintf(stderr, _("Warning: Unexpected EOF in reading AIFF header\n"));
return 0;
--
2.4.6

View File

@ -0,0 +1,26 @@
From 1fbd20941836aa4df17d0f6b44fef4d655ff5fc2 Mon Sep 17 00:00:00 2001
From: Kamil Dudka <kdudka@redhat.com>
Date: Tue, 3 Sep 2013 12:28:32 +0200
Subject: [PATCH] vcut: fix an off-by-one error in submit_headers_to_stream()
Bug: https://bugzilla.redhat.com/1003607
---
vcut/vcut.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/vcut/vcut.c b/vcut/vcut.c
index d7ba699..17426b9 100644
--- a/vcut/vcut.c
+++ b/vcut/vcut.c
@@ -178,7 +178,7 @@ static int submit_headers_to_stream(vcut_state *s)
for(i=0;i<4;i++)
{
ogg_packet p;
- if(i < 4) /* a header packet */
+ if(i < 3) /* a header packet */
{
p.bytes = vs->headers[i].length;
p.packet = vs->headers[i].packet;
--
1.7.1

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,31 @@
From c0a0dbfa58bf13cbd2a637288bf93619a7007673 Mon Sep 17 00:00:00 2001
From: Kamil Dudka <kdudka@redhat.com>
Date: Mon, 26 Jan 2015 12:33:19 +0100
Subject: [PATCH] oggenc: do not use stack variable out of its scope of
validity
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Reported-by: Thomas Köller
Bug: https://bugzilla.redhat.com/1185558
---
oggenc/oggenc.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/oggenc/oggenc.c b/oggenc/oggenc.c
index ea105b2..759a3ee 100644
--- a/oggenc/oggenc.c
+++ b/oggenc/oggenc.c
@@ -239,7 +239,7 @@ int main(int argc, char **argv)
if(opt.rawmode)
{
- input_format raw_format = {NULL, 0, raw_open, wav_close, "raw",
+ static input_format raw_format = {NULL, 0, raw_open, wav_close, "raw",
N_("RAW file reader")};
enc_opts.rate=opt.raw_samplerate;
--
2.1.0

View File

@ -0,0 +1,27 @@
From 43120cc36c08dcfba0c9ff22354da2f3029c3f70 Mon Sep 17 00:00:00 2001
From: Kamil Dudka <kdudka@redhat.com>
Date: Mon, 17 Dec 2012 12:50:36 +0100
Subject: [PATCH] vorbiscomment.1: fix URL to format documentation
Reported By: Samuel Sieb
Bug: https://bugzilla.redhat.com/887540
---
vorbiscomment/vorbiscomment.1 | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/vorbiscomment/vorbiscomment.1 b/vorbiscomment/vorbiscomment.1
index a47bb12..0108e78 100644
--- a/vorbiscomment/vorbiscomment.1
+++ b/vorbiscomment/vorbiscomment.1
@@ -87,7 +87,7 @@ To add a set of comments from the standard input:
.SH TAG FORMAT
-See http://xiph.org/ogg/vorbis/doc/v-comment.html for documentation on the Ogg Vorbis tag format, including a suggested list of canonical tag names.
+See http://xiph.org/vorbis/doc/v-comment.html for documentation on the Ogg Vorbis tag format, including a suggested list of canonical tag names.
.SH AUTHORS
--
1.7.1

View File

@ -0,0 +1,217 @@
From b3a6187e1843e55c47b6e55d11e01399ab3894a0 Mon Sep 17 00:00:00 2001
From: Kamil Dudka <kdudka@redhat.com>
Date: Tue, 28 May 2013 13:44:02 +0200
Subject: [PATCH 1/6] Remove the --quiet (-q) option from vorbiscomment.1 man page.
---
vorbiscomment/vorbiscomment.1 | 4 +---
1 files changed, 1 insertions(+), 3 deletions(-)
diff --git a/vorbiscomment/vorbiscomment.1 b/vorbiscomment/vorbiscomment.1
index 0108e78..2bceb83 100644
--- a/vorbiscomment/vorbiscomment.1
+++ b/vorbiscomment/vorbiscomment.1
@@ -39,13 +39,11 @@ Reads, modifies, and appends Ogg Vorbis audio file metadata tags.
.IP "-a, --append"
Append comments.
.IP "-c file, --commentfile file"
-Take comments from a file. The file is the same format as is output by the the -l option or given to the -t option: one element per line in 'tag=value' format. If the file is /dev/null and -w was passed, the existing comments will be removed.
+Take comments from a file. The file is the same format as is output by the -l option or given to the -t option: one element per line in 'tag=value' format. If the file is /dev/null and -w was passed, the existing comments will be removed.
.IP "-h, --help"
Show command help.
.IP "-l, --list"
List the comments in the Ogg Vorbis file.
-.IP "-q, --quiet"
-Quiet mode. No messages are displayed.
.IP "-t 'name=value', --tag 'name=value'"
Specify a new tag on the command line. Each tag is given as a single string. The part before the '=' is treated as the tag name and the part after as the value.
.IP "-w, --write"
--
1.7.1
From 78ade241f35c6e4119e40ad879748a6d6a1a1821 Mon Sep 17 00:00:00 2001
From: Kamil Dudka <kdudka@redhat.com>
Date: Tue, 28 May 2013 13:46:31 +0200
Subject: [PATCH 2/6] Mention the -V option in ogginfo.1 man page.
---
ogginfo/ogginfo.1 | 2 ++
1 files changed, 2 insertions(+), 0 deletions(-)
diff --git a/ogginfo/ogginfo.1 b/ogginfo/ogginfo.1
index 126da20..bde5490 100644
--- a/ogginfo/ogginfo.1
+++ b/ogginfo/ogginfo.1
@@ -49,6 +49,8 @@ Quiet mode. This may be specified multiple times. Doing so once will remove
the detailed informative messages, twice will remove warnings as well.
.IP -v
Verbose mode. At the current time, this does not do anything.
+.IP -V
+Output version information and exit.
.SH AUTHORS
.br
--
1.7.1
From fa810af21f475cf073891088d40bbaf952fd1e28 Mon Sep 17 00:00:00 2001
From: Kamil Dudka <kdudka@redhat.com>
Date: Tue, 28 May 2013 13:48:06 +0200
Subject: [PATCH 3/6] Fix typos in oggdec.1 man page.
---
oggdec/oggdec.1 | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/oggdec/oggdec.1 b/oggdec/oggdec.1
index fb12b18..1035cb6 100644
--- a/oggdec/oggdec.1
+++ b/oggdec/oggdec.1
@@ -6,7 +6,7 @@ oggdec - simple decoder, Ogg Vorbis file to PCM audio file (Wave or RAW).
.SH "SYNOPSIS"
.B oggdec
[
-.B -Qhv
+.B -QhV
] [
.B -b bits_per_sample
] [
@@ -48,7 +48,7 @@ Print help message.
Display version information.
.IP "-b n, --bits=n"
Bits per sample. Valid values are 8 or 16.
-.IP "-e n, --endian=n"
+.IP "-e n, --endianness=n"
Set endianness for 16-bit output. 0 (default) is little-endian (Intel byte order). 1 is big-endian (sane byte order).
.IP "-R, --raw"
Output in raw format. If not specified, writes Wave file (RIFF headers).
--
1.7.1
From 8c8d416cc17cb07dac72ad71d3ef0cc5e09c3bd3 Mon Sep 17 00:00:00 2001
From: Kamil Dudka <kdudka@redhat.com>
Date: Tue, 28 May 2013 14:00:07 +0200
Subject: [PATCH 4/6] Document the --scale option of oggenc.
---
oggenc/man/oggenc.1 | 5 +++++
oggenc/oggenc.c | 1 +
2 files changed, 6 insertions(+), 0 deletions(-)
diff --git a/oggenc/man/oggenc.1 b/oggenc/man/oggenc.1
index 411e2a9..633e5ec 100755
--- a/oggenc/man/oggenc.1
+++ b/oggenc/man/oggenc.1
@@ -47,6 +47,9 @@ oggenc \- encode audio into the Ogg Vorbis format
.B --downmix
]
[
+.B --scale
+]
+[
.B -s
.I serial
]
@@ -164,6 +167,8 @@ useful for downsampling for lower-bitrate encoding.
.IP "--downmix"
Downmix input from stereo to mono (has no effect on non-stereo streams). Useful
for lower-bitrate encoding.
+.IP "--scale"
+Input scaling factor (helps with clipping inputs).
.IP "--advanced-encode-option optionname=value"
Sets an advanced option. See the Advanced Options section for details.
.IP "-s, --serial"
diff --git a/oggenc/oggenc.c b/oggenc/oggenc.c
index 9c3e9cd..ea105b2 100644
--- a/oggenc/oggenc.c
+++ b/oggenc/oggenc.c
@@ -513,6 +513,7 @@ static void usage(void)
" --resample n Resample input data to sampling rate n (Hz)\n"
" --downmix Downmix stereo to mono. Only allowed on stereo\n"
" input.\n"
+ " --scale Input scaling factor (helps with clipping inputs).\n"
" -s, --serial Specify a serial number for the stream. If encoding\n"
" multiple files, this will be incremented for each\n"
" stream after the first.\n"));
--
1.7.1
From 3dcdecdcb520150b53a7e3e7d346e23a49f4018a Mon Sep 17 00:00:00 2001
From: Kamil Dudka <kdudka@redhat.com>
Date: Tue, 28 May 2013 14:05:22 +0200
Subject: [PATCH 5/6] Document --remote and -delay in ogg123.1 man page.
---
ogg123/ogg123.1 | 6 ++++++
1 files changed, 6 insertions(+), 0 deletions(-)
diff --git a/ogg123/ogg123.1 b/ogg123/ogg123.1
index 160a876..935cab6 100644
--- a/ogg123/ogg123.1
+++ b/ogg123/ogg123.1
@@ -73,6 +73,10 @@ Specify output file for file devices. The filename "-" writes to standard
out. If the file already exists,
.B ogg123
will overwrite it.
+.IP "-l s, --delay s"
+Set termination timeout in milliseconds. ogg123 will skip to the next song on
+SIGINT (Ctrl-C), and will terminate if two SIGINTs are received within the
+specified timeout 's'. (default 500)
.IP "-h, --help"
Show command help.
.IP "-k n, --skip n"
@@ -106,6 +110,8 @@ times slower than normal speed. May be with -x for interesting fractional
speeds.
.IP "-r, --repeat"
Repeat playlist indefinitely.
+.IP "-R, --remote"
+Use remote control interface.
.IP "-z, --shuffle"
Play files in pseudo-random order.
.IP "-Z, --random"
--
1.7.1
From ecd9cd8d881fadbb24bc948980bb6125f7b2c710 Mon Sep 17 00:00:00 2001
From: Kamil Dudka <kdudka@redhat.com>
Date: Tue, 28 May 2013 14:14:32 +0200
Subject: [PATCH 6/6] Document the --config (-c) option of ogg123.
---
ogg123/cmdline_options.c | 1 +
ogg123/ogg123.1 | 2 ++
2 files changed, 3 insertions(+), 0 deletions(-)
diff --git a/ogg123/cmdline_options.c b/ogg123/cmdline_options.c
index d663cc6..8abf4c5 100644
--- a/ogg123/cmdline_options.c
+++ b/ogg123/cmdline_options.c
@@ -373,6 +373,7 @@ void cmdline_usage (void)
printf ("\n");
printf (_("Miscellaneous options\n"));
+ printf (_(" -c c, --config c Config options from command-line.\n"));
printf (_(" -l s, --delay s Set termination timeout in milliseconds. ogg123\n"
" will skip to the next song on SIGINT (Ctrl-C),\n"
" and will terminate if two SIGINTs are received\n"
diff --git a/ogg123/ogg123.1 b/ogg123/ogg123.1
index 935cab6..1b419f7 100644
--- a/ogg123/ogg123.1
+++ b/ogg123/ogg123.1
@@ -73,6 +73,8 @@ Specify output file for file devices. The filename "-" writes to standard
out. If the file already exists,
.B ogg123
will overwrite it.
+.IP "-c c, --config c"
+Config options from command-line.
.IP "-l s, --delay s"
Set termination timeout in milliseconds. ogg123 will skip to the next song on
SIGINT (Ctrl-C), and will terminate if two SIGINTs are received within the
--
1.7.1

364
SPECS/vorbis-tools.spec Normal file
View File

@ -0,0 +1,364 @@
Summary: The Vorbis General Audio Compression Codec tools
Name: vorbis-tools
Version: 1.4.0
Release: 28%{?dist}
Epoch: 1
Group: Applications/Multimedia
License: GPLv2
URL: http://www.xiph.org/
Source: http://downloads.xiph.org/releases/vorbis/%{name}-%{version}.tar.gz
Patch0: vorbis-tools-1.4.0-bz887540.patch
# http://thread.gmane.org/gmane.comp.multimedia.ogg.vorbis.devel/5729
Patch1: vorbis-tools-1.4.0-man-page.patch
# http://thread.gmane.org/gmane.comp.multimedia.ogg.vorbis.devel/5738
Patch2: vorbis-tools-1.4.0-bz1003607.patch
# update po files from translationproject.org (#1116650)
Patch3: vorbis-tools-1.4.0-bz1116650.patch
# do not use stack variable out of its scope of validity (#1185558)
Patch4: vorbis-tools-1.4.0-bz1185558.patch
# validate count of channels in the header (CVE-2014-9638 and CVE-2014-9639)
Patch5: vorbis-tools-1.4.0-CVE-2014-9638-CVE-2014-9639.patch
# oggenc: fix large alloca on bad AIFF input (CVE-2015-6749)
Patch6: vorbis-tools-1.4.0-CVE-2015-6749.patch
BuildRequires: flac-devel
BuildRequires: gettext
BuildRequires: gcc
BuildRequires: libao-devel
BuildRequires: libcurl-devel
BuildRequires: libvorbis-devel
BuildRequires: speex-devel
Obsoletes: vorbis < %{epoch}:%{version}-%{release}
Provides: vorbis = %{epoch}:%{version}-%{release}
%description
Ogg Vorbis is a fully open, non-proprietary, patent- and royalty-free,
general-purpose compressed audio format for audio and music at fixed
and variable bitrates from 16 to 128 kbps/channel.
The vorbis package contains an encoder, a decoder, a playback tool, and a
comment editor.
%prep
%setup -q
%patch0 -p1
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%build
# fix FTBFS if "-Werror=format-security" flag is used (#1025257)
export CFLAGS="$RPM_OPT_FLAGS -Wno-error=format-security"
# uncomment this when debugging
#CFLAGS="$CFLAGS -O0"
%configure
make %{?_smp_mflags}
make %{?_smp_mflags} update-gmo -C po
%install
make DESTDIR=$RPM_BUILD_ROOT install
rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}*
%find_lang %{name}
%files -f %{name}.lang
%doc AUTHORS COPYING README ogg123/ogg123rc-example
%{_bindir}/*
%{_mandir}/man1/*
%changelog
* Mon Feb 19 2018 Kamil Dudka <kdudka@redhat.com> - 1:1.4.0-28
- add explicit BR for the gcc compiler
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1:1.4.0-27
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1:1.4.0-26
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1:1.4.0-25
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1:1.4.0-24
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1:1.4.0-23
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Mon Aug 31 2015 Kamil Dudka <kdudka@redhat.com> - 1:1.4.0-22
- oggenc: fix large alloca on bad AIFF input (CVE-2015-6749)
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.4.0-21
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Sat Feb 21 2015 Till Maas <opensource@till.name> - 1:1.4.0-20
- Rebuilt for Fedora 23 Change
https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
* Thu Feb 19 2015 Kamil Dudka <kdudka@redhat.com> - 1:1.4.0-19
- validate count of channels in the header (CVE-2014-9638 and CVE-2014-9639)
* Mon Jan 26 2015 Kamil Dudka <kdudka@redhat.com> - 1:1.4.0-18
- do not use stack variable out of its scope of validity (#1185558)
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.4.0-17
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Mon Jul 07 2014 Kamil Dudka <kdudka@redhat.com> - 1:1.4.0-16
- translate the newly added .po files into .gmo files during build (#1116650)
* Mon Jul 07 2014 Kamil Dudka <kdudka@redhat.com> - 1:1.4.0-15
- update po files from translationproject.org (#1116650)
* Tue Jun 10 2014 Kamil Dudka <kdudka@redhat.com> - 1:1.4.0-14
- fix FTBFS if "-Werror=format-security" flag is used (#1025257)
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.4.0-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Tue Sep 03 2013 Kamil Dudka <kdudka@redhat.com> - 1:1.4.0-12
- fix an off-by-one error in the vcut utility (#1003607)
* Fri Aug 09 2013 Kamil Dudka <kdudka@redhat.com> - 1:1.4.0-11
- fix various man page issues
* Mon Aug 05 2013 Hans de Goede <hdegoede@redhat.com> - 1:1.4.0-10
- Fix FTBFS caused by unversioned docdir change (#992862)
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.4.0-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.4.0-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Mon Dec 17 2012 Kamil Dudka <kdudka@redhat.com> - 1:1.4.0-7
- fix URL to format documentation in vorbiscomment.1 man page (#887540)
* Tue Aug 28 2012 Kamil Dudka <kdudka@redhat.com> - 1:1.4.0-6
- fix specfile issues reported by the fedora-review script
* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.4.0-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.4.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.4.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Thu Sep 02 2010 Kamil Dudka <kdudka@redhat.com> - 1:1.4.0-2
- rebuilt against libao-1.0.0 (#618171)
* Fri Mar 26 2010 Kamil Dudka <kdudka@redhat.com> - 1:1.4.0-1
- new upstream release
* Wed Nov 25 2009 Kamil Dudka <kdudka@redhat.com> - 1:1.2.0-7
- fix source URL
* Tue Oct 06 2009 Kamil Dudka <kdudka@redhat.com> - 1:1.2.0-6
- upstream patch fixing crash of oggenc --resample (#526653)
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.2.0-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.2.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
* Tue Oct 21 2008 Zdenek Prikryl <zprikryl@redhat.com> - 1:1.2.0-3
- fixed seting flags for stderr (#467064)
* Sat May 31 2008 Hans de Goede <j.w.r.degoede@hhs.n> - 1:1.2.0-2
- Stop calling autoconf, this was no longer necessarry and in current
rawhide breaks us from building (because aclocal.m4 does not match
the new autoconf version)
- Drop our last 2 patches, they were modifying configure, but since we called
autoconf after that in effect they were not doing anything, review has
confirmed that they indeed are no longer needed)
- Drop using system libtool hack, this is dangerous when the libtool used
to generate ./configure and the one used differ
- Remove various antique checks (for example check if RPM_BUILD_ROOT == /)
- Drop unnecessary explicit library Requires
- Cleanup BuildRequires
* Tue Mar 11 2008 Jindrich Novy <jnovy@redhat.com> - 1:1.2.0-1
- update to 1.2.0
- remove libcurl and oggdec patches, applied upstream
- drop unneeded autoconf BR
- fix BuildRoot
* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1:1.1.1.svn20070412-6
- Autorebuild for GCC 4.3
* Thu Nov 15 2007 Hans de Goede <j.w.r.degoede@hhs.n> - 1:1.1.1.svn20070412-5
- Minor specfile cleanups for merge review (bz 226532)
* Thu Oct 04 2007 Todd Zullinger <tmz@pobox.com> - 1:1.1.1.svn20070412-4
- Upstream patch to fix oggdec writing silent wav files (#244757)
* Thu Aug 23 2007 Adam Jackson <ajax@redhat.com> - 1:1.1.1.svn20070412-3
- Rebuild for build ID
* Wed May 16 2007 Christopher Aillon <caillon@redhat.com> 1:1.1.1.svn20070412-2.fc7
- Bring back support for http URLs which was broken with the previous update
See https://bugzilla.redhat.com/240351
* Thu Apr 12 2007 - Bastien Nocera <bnocera@redhat.com> - 1.1.1.svn20070412-1.fc7
- Upgrade to a current SVN snapshot of vorbis-tools to get our FLAC support
back, after the recent libFLAC upgrade (#229124)
- Remove obsolete UTF8 and Curl mute patches
* Wed Feb 14 2007 Karsten Hopp <karsten@redhat.com> 1.1.1-5
- rebuild with libFLAC.so.8, link with libogg instead of libOggFLAC
* Wed Nov 1 2006 Matthias Clasen <mclasen@redhat.com> - 1:1.1.1-4
- Rebuild against new curl
- Don't use CURLOPT_MUTE
* Sun Oct 29 2006 Matthias Clasen <mclasen@redhat.com> - 1:1.1.1-3
- Fix charset conversion (#98816)
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1:1.1.1-2
- rebuild
- Add missing br libtool
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1:1.1.1-1.2.1
- bump again for double-long bug on ppc(64)
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1:1.1.1-1.2
- rebuilt for new gcc4.1 snapshot and glibc changes
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
- rebuilt
* Wed Nov 09 2005 John (J5) Palmieri <johnp@redhat.com> 1:1.1.1-1
- Update to version 1.1.1
* Tue Mar 29 2005 John (J5) Palmieri <johnp@redhat.com> 1:1.0.1-6
- rebuild for flac 1.1.2
* Wed Mar 02 2005 John (J5) Palmieri <johnp@redhat.com> 1:1.0.1-5
- rebuild with gcc 4.0
* Wed Jul 28 2004 Colin Walters <walters@redhat.com>
- rebuild
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Fri Dec 12 2003 Bill Nottingham <notting@redhat.com> 1:1.0.1-1
- update to 1.0.1
* Tue Oct 21 2003 Bill Nottingham <notting@redhat.com> 1.0-7
- rebuild (#107673)
* Fri Sep 5 2003 Bill Nottingham <notting@redhat.com> 1.0-6
- fix curl detection so ogg123 gets built (#103831)
* Thu Aug 7 2003 Elliot Lee <sopwith@redhat.com> 1.0-5
- Fix link errors
* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Tue Jun 3 2003 Jeff Johnson <jbj@redhat.com>
- add explicit epoch's where needed.
* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
- rebuilt
* Wed Dec 11 2002 Tim Powers <timp@redhat.com> 1:1.0-2
- rebuild on all arches
* Thu Jul 18 2002 Bill Nottingham <notting@redhat.com>
- one-dot-oh
* Tue Jul 16 2002 Elliot Lee <sopwith@redhat.com>
- Add builddep on curl-devel
* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
- automated rebuild
* Thu May 23 2002 Tim Powers <timp@redhat.com>
- automated rebuild
* Tue Feb 26 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.0rc3-3
- s/Copyright/License/
- Add curl-devel as a build dependency
* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
- automated rebuild
* Tue Jan 1 2002 Bill Nottingham <notting@redhat.com>
- update to 1.0rc3
* Mon Aug 13 2001 Bill Nottingham <notting@redhat.com>
- update to 1.0rc2
* Fri Jul 20 2001 Bill Nottingham <notting@redhat.com>
- split libao, libvorbis out
* Tue Jul 10 2001 Bill Nottingham <notting@redhat.com>
- own %%{_libdir}/ao
- I love libtool
* Tue Jun 26 2001 Florian La Roche <Florian.LaRoche@redhat.de>
- add links from library major version numbers in rpms
* Tue Jun 19 2001 Bill Nottingham <notting@redhat.com>
- update to rc1
* Fri May 4 2001 Oliver Paukstadt <oliver.paukstadt@millenux.com>
- fixed perl line in spec file to set optims correctly
* Tue Mar 20 2001 Bill Nottingham <notting@redhat.com>
- fix alpha/ia64, again
- use optflags, not -O20 -ffast-math (especially on alpha...)
* Mon Feb 26 2001 Bill Nottingham <notting@redhat.com>
- fix license tag
* Mon Feb 26 2001 Bill Nottingham <notting@redhat.com>
- beta4
* Fri Feb 9 2001 Bill Nottingham <notting@redhat.com>
- fix alpha/ia64
* Thu Feb 8 2001 Bill Nottingham <notting@redhat.com>
- update CVS in prep for beta4
* Wed Feb 07 2001 Philipp Knirsch <pknirsch@redhat.de>
- Fixed bugzilla bug #25391. ogg123 now usses the OSS driver by default if
none was specified.
* Tue Jan 9 2001 Bill Nottingham <notting@redhat.com>
- update CVS, grab aRts backend for libao
* Wed Dec 27 2000 Bill Nottingham <notting@redhat.com>
- update CVS
* Fri Dec 01 2000 Bill Nottingham <notting@redhat.com>
- rebuild because of broken fileutils
* Mon Nov 13 2000 Bill Nottingham <notting@redhat.com>
- hack up specfile some, merge some packages
* Sat Oct 21 2000 Jack Moffitt <jack@icecast.org>
- initial spec file created