virt-what/SOURCES/0017-maintainer-Add-rules-f...

52 lines
1.5 KiB
Diff

From b6161b67b0bd542169e13cdfa0488a0266e3ae7a Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Thu, 3 Oct 2019 10:13:43 +0100
Subject: [PATCH 17/25] maintainer: Add rules for maintainers.
Adds:
make maintainer-check-extra-dist
make maintainer-commit
make maintainer-tag
---
Makefile.am | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)
diff --git a/Makefile.am b/Makefile.am
index 1cb73b7..5435132 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -41,3 +41,30 @@ virt-what.txt: virt-what.pod
pod2text $? > $@
endif
+
+#----------------------------------------------------------------------
+# Maintainers only!
+
+# Check no files are missing from EXTRA_DIST rules, and that all
+# generated files have been included in the tarball. (Note you must
+# have done 'make dist')
+maintainer-check-extra-dist:
+ @zcat $(PACKAGE_NAME)-$(VERSION).tar.gz | tar tf - | sort | \
+ sed 's,^$(PACKAGE_NAME)-$(VERSION)/,,' > tarfiles
+ @git ls-files | \
+ sort > gitfiles
+ @comm -13 tarfiles gitfiles > comm-out
+ @echo Checking for differences between EXTRA_DIST and git ...
+ @cat comm-out
+ @[ ! -s comm-out ]
+ @rm tarfiles gitfiles comm-out
+ @echo PASS: EXTRA_DIST tests
+
+# Commit everything in the current directory and set the commit
+# message to the current version number.
+maintainer-commit:
+ git commit -a -m "Version $(VERSION)."
+
+# Tag HEAD with the current version.
+maintainer-tag:
+ git tag -a v$(VERSION) -m "Version $(VERSION)." -f
--
2.18.4