import virt-what-1.21-2.el9.2
This commit is contained in:
commit
da65569806
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/virt-what-1.21.tar.gz
|
1
.virt-what.metadata
Normal file
1
.virt-what.metadata
Normal file
@ -0,0 +1 @@
|
||||
572bdc052b8d6864c0f79b391cfe4b48a230008d SOURCES/virt-what-1.21.tar.gz
|
267
SOURCES/0001-Add-support-for-VMware-ESXi-on-ARM.patch
Normal file
267
SOURCES/0001-Add-support-for-VMware-ESXi-on-ARM.patch
Normal file
@ -0,0 +1,267 @@
|
||||
From 09094be5f2afa21bb5b8221580303f125fd90d0c Mon Sep 17 00:00:00 2001
|
||||
From: Razvan Corneliu <razvan.vilt@linux360.ro>
|
||||
Date: Mon, 10 May 2021 21:02:27 +0100
|
||||
Subject: [PATCH] Add support for VMware ESXi on ARM
|
||||
|
||||
Virt-what doesn't recognize VMware VMs for AARCH64/ARM (with licensing
|
||||
implications in ESXi Fling for ARM and Fusion v.Next for ARM). I've
|
||||
created and attached a patch that adds both support for recognizing
|
||||
ESXi and the automated tests for it.
|
||||
---
|
||||
configure.ac | 2 +
|
||||
tests/esx-arm/Makefile.am | 30 ++++++++++
|
||||
tests/esx-arm/proc/cpuinfo | 18 ++++++
|
||||
.../proc/device-tree/hypervisor/compatible | 1 +
|
||||
.../esx-arm/proc/device-tree/hypervisor/name | 1 +
|
||||
tests/esx-arm/proc/self/status | 55 +++++++++++++++++++
|
||||
tests/esx-arm/sbin/dmidecode | 2 +
|
||||
tests/esx-arm/sbin/uname | 2 +
|
||||
tests/esx-arm/sbin/virt-what-cpuid-helper | 2 +
|
||||
tests/esx-arm/test.sh | 32 +++++++++++
|
||||
virt-what.in | 4 ++
|
||||
11 files changed, 149 insertions(+)
|
||||
create mode 100644 tests/esx-arm/Makefile.am
|
||||
create mode 100644 tests/esx-arm/proc/cpuinfo
|
||||
create mode 100644 tests/esx-arm/proc/device-tree/hypervisor/compatible
|
||||
create mode 100644 tests/esx-arm/proc/device-tree/hypervisor/name
|
||||
create mode 100644 tests/esx-arm/proc/self/status
|
||||
create mode 100755 tests/esx-arm/sbin/dmidecode
|
||||
create mode 100755 tests/esx-arm/sbin/uname
|
||||
create mode 100755 tests/esx-arm/sbin/virt-what-cpuid-helper
|
||||
create mode 100755 tests/esx-arm/test.sh
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index bce03a1..9d0a423 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -41,6 +41,7 @@ tests="\
|
||||
baremetal \
|
||||
bhyve \
|
||||
docker \
|
||||
+ esx-arm \
|
||||
esx4.1 \
|
||||
hyperv \
|
||||
kvm \
|
||||
@@ -85,6 +86,7 @@ AC_CONFIG_FILES([Makefile
|
||||
tests/baremetal/Makefile
|
||||
tests/bhyve/Makefile
|
||||
tests/docker/Makefile
|
||||
+ tests/esx-arm/Makefile
|
||||
tests/esx4.1/Makefile
|
||||
tests/hyperv/Makefile
|
||||
tests/kvm/Makefile
|
||||
diff --git a/tests/esx-arm/Makefile.am b/tests/esx-arm/Makefile.am
|
||||
new file mode 100644
|
||||
index 0000000..b87ec83
|
||||
--- /dev/null
|
||||
+++ b/tests/esx-arm/Makefile.am
|
||||
@@ -0,0 +1,30 @@
|
||||
+# Makefile for virt-what
|
||||
+# Copyright (C) 2008-2011 Red Hat Inc.
|
||||
+#
|
||||
+# This program is free software; you can redistribute it and/or modify
|
||||
+# it under the terms of the GNU General Public License as published by
|
||||
+# the Free Software Foundation; either version 2 of the License, or
|
||||
+# (at your option) any later version.
|
||||
+#
|
||||
+# This program is distributed in the hope that it will be useful,
|
||||
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
+# GNU General Public License for more details.
|
||||
+#
|
||||
+# You should have received a copy of the GNU General Public License
|
||||
+# along with this program; if not, write to the Free Software
|
||||
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
|
||||
+
|
||||
+CLEANFILES = *~
|
||||
+
|
||||
+TESTS = test.sh
|
||||
+
|
||||
+EXTRA_DIST = \
|
||||
+ test.sh \
|
||||
+ proc/cpuinfo \
|
||||
+ proc/device-tree/hypervisor/compatible \
|
||||
+ proc/device-tree/hypervisor/name \
|
||||
+ proc/self/status \
|
||||
+ sbin/dmidecode \
|
||||
+ sbin/uname \
|
||||
+ sbin/virt-what-cpuid-helper
|
||||
diff --git a/tests/esx-arm/proc/cpuinfo b/tests/esx-arm/proc/cpuinfo
|
||||
new file mode 100644
|
||||
index 0000000..246b574
|
||||
--- /dev/null
|
||||
+++ b/tests/esx-arm/proc/cpuinfo
|
||||
@@ -0,0 +1,18 @@
|
||||
+processor : 0
|
||||
+BogoMIPS : 108.00
|
||||
+Features : fp asimd evtstrm crc32 cpuid
|
||||
+CPU implementer : 0x41
|
||||
+CPU architecture: 8
|
||||
+CPU variant : 0x0
|
||||
+CPU part : 0xd08
|
||||
+CPU revision : 3
|
||||
+
|
||||
+processor : 1
|
||||
+BogoMIPS : 108.00
|
||||
+Features : fp asimd evtstrm crc32 cpuid
|
||||
+CPU implementer : 0x41
|
||||
+CPU architecture: 8
|
||||
+CPU variant : 0x0
|
||||
+CPU part : 0xd08
|
||||
+CPU revision : 3
|
||||
+
|
||||
diff --git a/tests/esx-arm/proc/device-tree/hypervisor/compatible b/tests/esx-arm/proc/device-tree/hypervisor/compatible
|
||||
new file mode 100644
|
||||
index 0000000..0554874
|
||||
--- /dev/null
|
||||
+++ b/tests/esx-arm/proc/device-tree/hypervisor/compatible
|
||||
@@ -0,0 +1 @@
|
||||
+vmware
|
||||
diff --git a/tests/esx-arm/proc/device-tree/hypervisor/name b/tests/esx-arm/proc/device-tree/hypervisor/name
|
||||
new file mode 100644
|
||||
index 0000000..d508e44
|
||||
--- /dev/null
|
||||
+++ b/tests/esx-arm/proc/device-tree/hypervisor/name
|
||||
@@ -0,0 +1 @@
|
||||
+hypervisor
|
||||
diff --git a/tests/esx-arm/proc/self/status b/tests/esx-arm/proc/self/status
|
||||
new file mode 100644
|
||||
index 0000000..13dd246
|
||||
--- /dev/null
|
||||
+++ b/tests/esx-arm/proc/self/status
|
||||
@@ -0,0 +1,55 @@
|
||||
+Name: cat
|
||||
+Umask: 0022
|
||||
+State: R (running)
|
||||
+Tgid: 292937
|
||||
+Ngid: 0
|
||||
+Pid: 292937
|
||||
+PPid: 10956
|
||||
+TracerPid: 0
|
||||
+Uid: 0 0 0 0
|
||||
+Gid: 0 0 0 0
|
||||
+FDSize: 256
|
||||
+Groups: 0
|
||||
+NStgid: 292937
|
||||
+NSpid: 292937
|
||||
+NSpgid: 292937
|
||||
+NSsid: 10956
|
||||
+VmPeak: 6400 kB
|
||||
+VmSize: 6400 kB
|
||||
+VmLck: 0 kB
|
||||
+VmPin: 0 kB
|
||||
+VmHWM: 960 kB
|
||||
+VmRSS: 960 kB
|
||||
+RssAnon: 448 kB
|
||||
+RssFile: 512 kB
|
||||
+RssShmem: 0 kB
|
||||
+VmData: 640 kB
|
||||
+VmStk: 192 kB
|
||||
+VmExe: 64 kB
|
||||
+VmLib: 1600 kB
|
||||
+VmPTE: 384 kB
|
||||
+VmSwap: 0 kB
|
||||
+HugetlbPages: 0 kB
|
||||
+CoreDumping: 0
|
||||
+THP_enabled: 1
|
||||
+Threads: 1
|
||||
+SigQ: 2/3947
|
||||
+SigPnd: 0000000000000000
|
||||
+ShdPnd: 0000000000000000
|
||||
+SigBlk: 0000000000000000
|
||||
+SigIgn: 0000000000000000
|
||||
+SigCgt: 0000000000000000
|
||||
+CapInh: 0000000000000000
|
||||
+CapPrm: 0000003fffffffff
|
||||
+CapEff: 0000003fffffffff
|
||||
+CapBnd: 0000003fffffffff
|
||||
+CapAmb: 0000000000000000
|
||||
+NoNewPrivs: 0
|
||||
+Seccomp: 0
|
||||
+Speculation_Store_Bypass: vulnerable
|
||||
+Cpus_allowed: 3
|
||||
+Cpus_allowed_list: 0-1
|
||||
+Mems_allowed: 01
|
||||
+Mems_allowed_list: 0
|
||||
+voluntary_ctxt_switches: 1
|
||||
+nonvoluntary_ctxt_switches: 0
|
||||
diff --git a/tests/esx-arm/sbin/dmidecode b/tests/esx-arm/sbin/dmidecode
|
||||
new file mode 100755
|
||||
index 0000000..e53c12f
|
||||
--- /dev/null
|
||||
+++ b/tests/esx-arm/sbin/dmidecode
|
||||
@@ -0,0 +1,2 @@
|
||||
+#!/bin/sh -
|
||||
+exit 1
|
||||
diff --git a/tests/esx-arm/sbin/uname b/tests/esx-arm/sbin/uname
|
||||
new file mode 100755
|
||||
index 0000000..bd33a2d
|
||||
--- /dev/null
|
||||
+++ b/tests/esx-arm/sbin/uname
|
||||
@@ -0,0 +1,2 @@
|
||||
+#!/bin/sh -
|
||||
+echo aarch64
|
||||
diff --git a/tests/esx-arm/sbin/virt-what-cpuid-helper b/tests/esx-arm/sbin/virt-what-cpuid-helper
|
||||
new file mode 100755
|
||||
index 0000000..77a6692
|
||||
--- /dev/null
|
||||
+++ b/tests/esx-arm/sbin/virt-what-cpuid-helper
|
||||
@@ -0,0 +1,2 @@
|
||||
+#!/bin/sh -
|
||||
+# nothing
|
||||
diff --git a/tests/esx-arm/test.sh b/tests/esx-arm/test.sh
|
||||
new file mode 100755
|
||||
index 0000000..344afef
|
||||
--- /dev/null
|
||||
+++ b/tests/esx-arm/test.sh
|
||||
@@ -0,0 +1,32 @@
|
||||
+# Test for ESXi on ARM
|
||||
+# Copyright (C) 2008-2011 Red Hat Inc.
|
||||
+#
|
||||
+# This program is free software; you can redistribute it and/or modify
|
||||
+# it under the terms of the GNU General Public License as published by
|
||||
+# the Free Software Foundation; either version 2 of the License, or
|
||||
+# (at your option) any later version.
|
||||
+#
|
||||
+# This program is distributed in the hope that it will be useful,
|
||||
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
+# GNU General Public License for more details.
|
||||
+#
|
||||
+# You should have received a copy of the GNU General Public License
|
||||
+# along with this program; if not, write to the Free Software
|
||||
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
|
||||
+
|
||||
+output="$(PATH=../..:$PATH virt-what --test-root=. 2>&1)"
|
||||
+expected="vmware"
|
||||
+
|
||||
+if [ "$output" != "$expected" ]; then
|
||||
+ echo "$0: test failed because output did not match expected"
|
||||
+ echo "Expected output was:"
|
||||
+ echo "----------------------------------------"
|
||||
+ echo "$expected"
|
||||
+ echo "----------------------------------------"
|
||||
+ echo "But the actual output of the program was:"
|
||||
+ echo "----------------------------------------"
|
||||
+ echo "$output"
|
||||
+ echo "----------------------------------------"
|
||||
+ exit 1
|
||||
+fi
|
||||
diff --git a/virt-what.in b/virt-what.in
|
||||
index d52171c..b7d266b 100644
|
||||
--- a/virt-what.in
|
||||
+++ b/virt-what.in
|
||||
@@ -264,6 +264,10 @@ elif [ "$arch" = "arm" ] || [ "$arch" = "aarch64" ]; then
|
||||
echo xen
|
||||
skip_qemu_kvm=true
|
||||
skip_lkvm=true
|
||||
+ elif [ -d "${root}/proc/device-tree/hypervisor" ] &&
|
||||
+ grep -q "vmware" "${root}/proc/device-tree/hypervisor/compatible"; then
|
||||
+ echo vmware
|
||||
+ skip_lkvm=true
|
||||
fi
|
||||
elif [ "$arch" = "ia64" ]; then
|
||||
if [ -d "${root}/sys/bus/xen" -a ! -d "${root}/sys/bus/xen-backend" ]; then
|
||||
--
|
||||
2.32.0
|
||||
|
268
SPECS/virt-what.spec
Normal file
268
SPECS/virt-what.spec
Normal file
@ -0,0 +1,268 @@
|
||||
Name: virt-what
|
||||
Version: 1.21
|
||||
Release: 2%{?dist}.2
|
||||
Summary: Detect if we are running in a virtual machine
|
||||
License: GPLv2+
|
||||
|
||||
URL: http://people.redhat.com/~rjones/virt-what/
|
||||
Source0: http://people.redhat.com/~rjones/virt-what/files/%%{name}-%%{version}.tar.gz
|
||||
|
||||
# Support for VMware on aarch64 (RHBZ#1959174).
|
||||
Patch1: 0001-Add-support-for-VMware-ESXi-on-ARM.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: git
|
||||
BuildRequires: autoconf, automake, libtool
|
||||
|
||||
# This is provided by the build root, but we make it explicit
|
||||
# anyway in case this was dropped from the build root in future.
|
||||
BuildRequires: gcc
|
||||
BuildRequires: /usr/bin/pod2man
|
||||
|
||||
# Required at build time in order to do 'make check' (for getopt).
|
||||
BuildRequires: util-linux
|
||||
|
||||
# virt-what script uses dmidecode and getopt (from util-linux).
|
||||
# RPM cannot detect this so make the dependencies explicit here.
|
||||
%ifarch aarch64 %{ix86} x86_64
|
||||
Requires: dmidecode
|
||||
%endif
|
||||
Requires: util-linux
|
||||
|
||||
# Runs the 'which' program to find the helper.
|
||||
Requires: which
|
||||
|
||||
|
||||
%description
|
||||
virt-what is a shell script which can be used to detect if the program
|
||||
is running in a virtual machine.
|
||||
|
||||
The program prints out a list of "facts" about the virtual machine,
|
||||
derived from heuristics. One fact is printed per line.
|
||||
|
||||
If nothing is printed and the script exits with code 0 (no error),
|
||||
then it can mean either that the program is running on bare-metal or
|
||||
the program is running inside a type of virtual machine which we don't
|
||||
know about or can't detect.
|
||||
|
||||
Current types of virtualization detected:
|
||||
|
||||
- aws Amazon Web Services
|
||||
- bhyve FreeBSD hypervisor
|
||||
- docker Docker container
|
||||
- hyperv Microsoft Hyper-V
|
||||
- ibm_power-kvm
|
||||
IBM POWER KVM
|
||||
- ibm_power-lpar_shared
|
||||
- ibm_power-lpar_dedicated
|
||||
IBM POWER LPAR (hardware partition)
|
||||
- ibm_systemz-*
|
||||
IBM SystemZ Direct / LPAR / z/VM / KVM
|
||||
- ldoms Oracle VM Server for SPARC Logical Domains
|
||||
- linux_vserver
|
||||
Linux VServer container
|
||||
- lxc Linux LXC container
|
||||
- kvm Linux Kernel Virtual Machine (KVM)
|
||||
- lkvm LKVM / kvmtool
|
||||
- nutanix_ahv Nutanix Acropolis Hypervisor (AHV)
|
||||
- openvz OpenVZ or Virtuozzo
|
||||
- ovirt oVirt node
|
||||
- parallels Parallels Virtual Platform
|
||||
- powervm_lx86 IBM PowerVM Lx86 Linux/x86 emulator
|
||||
- qemu QEMU (unaccelerated)
|
||||
- rhev Red Hat Enterprise Virtualization
|
||||
- uml User-Mode Linux (UML)
|
||||
- virtage Hitachi Virtualization Manager (HVM) Virtage LPAR
|
||||
- virtualbox VirtualBox
|
||||
- virtualpc Microsoft VirtualPC
|
||||
- vmm vmm OpenBSD hypervisor
|
||||
- vmware VMware
|
||||
- xen Xen
|
||||
- xen-dom0 Xen dom0 (privileged domain)
|
||||
- xen-domU Xen domU (paravirtualized guest domain)
|
||||
- xen-hvm Xen guest fully virtualized (HVM)
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup -S git
|
||||
|
||||
# Always rebuild upstream autotools files.
|
||||
autoreconf -i
|
||||
|
||||
|
||||
%build
|
||||
%configure
|
||||
make
|
||||
|
||||
|
||||
%install
|
||||
%make_install
|
||||
|
||||
|
||||
%check
|
||||
if ! make check ; then
|
||||
cat test-suite.log
|
||||
exit 1
|
||||
fi
|
||||
|
||||
%files
|
||||
%doc README COPYING
|
||||
%{_sbindir}/virt-what
|
||||
%{_libexecdir}/virt-what-cpuid-helper
|
||||
%{_mandir}/man1/*.1*
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Aug 10 2021 Mohan Boddu <mboddu@redhat.com> - 1.21-2.2
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Fri Jun 18 2021 Richard W.M. Jones <rjones@redhat.com> - 1.21-1.el9.2
|
||||
- Support for VMware on aarch64
|
||||
resolves: rhbz#1959174
|
||||
|
||||
* Wed Jun 2 2021 Richard W.M. Jones <rjones@redhat.com> - 1.21-1.el9.1
|
||||
- Add gating tests for RHEL 9
|
||||
|
||||
* Mon Apr 19 2021 Richard W.M. Jones <rjones@redhat.com> - 1.21-1
|
||||
- New upstream version 1.21.
|
||||
|
||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 1.20-6
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.20-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.20-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Tue Jul 14 2020 Tom Stellard <tstellar@redhat.com> - 1.20-3
|
||||
- Use make macros
|
||||
- https://fedoraproject.org/wiki/Changes/UseMakeBuildInstallMacro
|
||||
|
||||
* Fri Jan 31 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.20-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Thu Oct 3 2019 Richard W.M. Jones <rjones@redhat.com> - 1.20-1
|
||||
- New upstream version 1.20.
|
||||
|
||||
* Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.19-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.19-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Wed Oct 31 2018 Richard W.M. Jones <rjones@redhat.com> - 1.19-1
|
||||
- New upstream version 1.19.
|
||||
- Fixes support for AWS.
|
||||
- Remove patches which are now upstream.
|
||||
|
||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.18-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.18-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Tue Oct 17 2017 Richard W.M. Jones <rjones@redhat.com> - 1.18-4
|
||||
- Include upstream patches since 1.18 was released.
|
||||
- dmidecode is also available on aarch64.
|
||||
|
||||
* Mon Jul 31 2017 Richard W.M. Jones <rjones@redhat.com> - 1.18-1
|
||||
- New upstream version 1.18.
|
||||
- Update RPM description section with complete list of supported guests.
|
||||
- If ‘make check’ fails, dump ‘test-suite.log’.
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.15-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.15-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Tue Jun 14 2016 Richard W.M. Jones <rjones@redhat.com> - 1.15-4
|
||||
- Require 'which' program.
|
||||
|
||||
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.15-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Tue Apr 21 2015 Richard W.M. Jones <rjones@redhat.com> - 1.15-1
|
||||
- New upstream version 1.15.
|
||||
- Remove patches, now upstream.
|
||||
|
||||
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.13-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.13-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Mon Oct 28 2013 Richard W.M. Jones <rjones@redhat.com> - 1.13-3
|
||||
- Suppress warning message on Amazon EC2:
|
||||
"grep: /proc/xen/capabilities: No such file or directory"
|
||||
|
||||
* Wed Sep 11 2013 Richard W.M. Jones <rjones@redhat.com> - 1.13-2
|
||||
- Include two upstream patches for detecting Xen and Linux VServer better
|
||||
(RHBZ#973663).
|
||||
- Modernize the spec file.
|
||||
|
||||
* Mon Jul 29 2013 Richard W.M. Jones <rjones@redhat.com> - 1.13-1
|
||||
- New upstream version 1.13.
|
||||
|
||||
* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.12-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.12-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Sat Mar 17 2012 Richard W.M. Jones <rjones@redhat.com> - 1.12-1
|
||||
- New upstream version 1.12.
|
||||
|
||||
* Wed Feb 29 2012 Richard W.M. Jones <rjones@redhat.com> - 1.11-3
|
||||
- Remove ExclusiveArch, but don't require dmidecode except on
|
||||
i?86 and x86-64 (RHBZ#791370).
|
||||
|
||||
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.11-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Fri May 27 2011 Richard W.M. Jones <rjones@redhat.com> - 1.11-1
|
||||
- New upstream version 1.11.
|
||||
|
||||
* Wed May 25 2011 Richard W.M. Jones <rjones@redhat.com> - 1.10-1
|
||||
- New upstream version 1.10.
|
||||
|
||||
* Tue Mar 8 2011 Richard W.M. Jones <rjones@redhat.com> - 1.9-1
|
||||
- New upstream version 1.9.
|
||||
|
||||
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Mon Jan 31 2011 Richard W.M. Jones <rjones@redhat.com> - 1.8-1
|
||||
- New upstream version 1.8.
|
||||
|
||||
* Thu Jan 20 2011 Richard W.M. Jones <rjones@redhat.com> - 1.7-1
|
||||
- New upstream version 1.7.
|
||||
|
||||
* Wed Jan 19 2011 Richard W.M. Jones <rjones@redhat.com> - 1.6-2
|
||||
- New upstream version 1.6.
|
||||
- BuildRequires 'getopt' from util-linux-ng.
|
||||
|
||||
* Tue Jan 18 2011 Richard W.M. Jones <rjones@redhat.com> - 1.5-1
|
||||
- New upstream version 1.5.
|
||||
- Add 'make check' section.
|
||||
|
||||
* Tue Jan 18 2011 Richard W.M. Jones <rjones@redhat.com> - 1.4-1
|
||||
- New upstream version 1.4.
|
||||
- More hypervisor types detected.
|
||||
|
||||
* Thu Oct 28 2010 Richard W.M. Jones <rjones@redhat.com> - 1.3-4
|
||||
- Move configure into build (not prep).
|
||||
|
||||
* Thu Oct 28 2010 Richard W.M. Jones <rjones@redhat.com> - 1.3-3
|
||||
- Initial import into Fedora.
|
||||
|
||||
* Tue Oct 19 2010 Richard W.M. Jones <rjones@redhat.com> - 1.3-2
|
||||
- Make changes suggested by reviewer (RHBZ#644259).
|
||||
|
||||
* Tue Oct 19 2010 Richard W.M. Jones <rjones@redhat.com> - 1.3-1
|
||||
- Initial release.
|
Loading…
Reference in New Issue
Block a user