virt-manager-4.1.0-1

Update to version 4.1.0
This commit is contained in:
Cole Robinson 2022-08-04 15:57:30 -04:00
parent 324f3eed4d
commit d4094e151e
3 changed files with 7 additions and 43 deletions

View File

@ -1,39 +0,0 @@
From 90e13549b4f2dd74b3343a3a28c30f31c20032d5 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
Date: Tue, 2 Aug 2022 16:39:36 +0200
Subject: [PATCH] Fix build with setuptools 61+
+ ./setup.py configure --default-hvs qemu,xen,lxc
error: Multiple top-level packages discovered in a flat-layout: ['po', 'ui', 'man', 'data', 'virtinst', 'virtManager'].
To avoid accidental inclusion of unwanted files or directories,
setuptools will not proceed with this build.
If you are trying to create a single distribution with multiple packages
on purpose, you should not rely on automatic discovery.
Instead, consider the following options:
1. set up custom discovery (`find` directive with `include` or `exclude`)
2. use a `src-layout`
3. explicitly set `py_modules` or `packages` with a list of names
To find more information, look for "package discovery" on setuptools docs.
Downstream bug report: https://bugzilla.redhat.com/2113754
---
setup.py | 3 +++
1 file changed, 3 insertions(+)
diff --git a/setup.py b/setup.py
index 6a546606..b45d315a 100755
--- a/setup.py
+++ b/setup.py
@@ -530,6 +530,9 @@ setuptools.setup(
glob.glob("virtinst/install/*.py")),
],
+ # stop setuptools 61+ thinking we want to include everything automatically
+ py_modules=[],
+
cmdclass={
'build': my_build,
'build_i18n': my_build_i18n,
--
2.37.1

View File

@ -1 +1 @@
SHA512 (virt-manager-4.0.0.tar.gz) = 115dc3feb499bb2f1f6df537bffe150d23b9b568fe8047d43577a138ff9b9180b10259dde3476136cdc85750576da1104e81a8c2f5761b4f2a89852467761f81
SHA512 (virt-manager-4.1.0.tar.gz) = 725cb5bcbaebaafae417f95deffb4243ccdad769668cba6e1235f4607e2b29dbd099d2a9a3885981158f53ea854dd71cc29ed9d7557b2791161c13d34f2ef883

View File

@ -7,8 +7,8 @@
# End local config
Name: virt-manager
Version: 4.0.0
Release: 3%{?dist}
Version: 4.1.0
Release: 1%{?dist}
%global verrel %{version}-%{release}
Summary: Desktop tool for managing virtual machines via libvirt
@ -16,7 +16,7 @@ License: GPLv2+
BuildArch: noarch
URL: https://virt-manager.org/
Source0: https://virt-manager.org/download/sources/%{name}/%{name}-%{version}.tar.gz
Patch: 0001-Fix-build-with-setuptools-61.patch
Requires: virt-manager-common = %{verrel}
Requires: python3-gobject >= 3.31.3
@ -163,6 +163,9 @@ machine).
%changelog
* Thu Aug 04 2022 Cole Robinson <crobinso@redhat.com> - 4.1.0-1
- Update to version 4.1.0
* Wed Aug 3 2022 Daniel. P. Berrange <berrange@redhat.com> - 4.0.0-3
- Fix compat with setuptools >= 61 (rhbz#2113754)