Fix compat with setuptools >= 61

Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
This commit is contained in:
Daniel P. Berrangé 2022-08-03 10:36:58 +01:00
parent fae04c2d70
commit 324f3eed4d
2 changed files with 44 additions and 2 deletions

View File

@ -0,0 +1,39 @@
From 90e13549b4f2dd74b3343a3a28c30f31c20032d5 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
Date: Tue, 2 Aug 2022 16:39:36 +0200
Subject: [PATCH] Fix build with setuptools 61+
+ ./setup.py configure --default-hvs qemu,xen,lxc
error: Multiple top-level packages discovered in a flat-layout: ['po', 'ui', 'man', 'data', 'virtinst', 'virtManager'].
To avoid accidental inclusion of unwanted files or directories,
setuptools will not proceed with this build.
If you are trying to create a single distribution with multiple packages
on purpose, you should not rely on automatic discovery.
Instead, consider the following options:
1. set up custom discovery (`find` directive with `include` or `exclude`)
2. use a `src-layout`
3. explicitly set `py_modules` or `packages` with a list of names
To find more information, look for "package discovery" on setuptools docs.
Downstream bug report: https://bugzilla.redhat.com/2113754
---
setup.py | 3 +++
1 file changed, 3 insertions(+)
diff --git a/setup.py b/setup.py
index 6a546606..b45d315a 100755
--- a/setup.py
+++ b/setup.py
@@ -530,6 +530,9 @@ setuptools.setup(
glob.glob("virtinst/install/*.py")),
],
+ # stop setuptools 61+ thinking we want to include everything automatically
+ py_modules=[],
+
cmdclass={
'build': my_build,
'build_i18n': my_build_i18n,
--
2.37.1

View File

@ -8,7 +8,7 @@
Name: virt-manager
Version: 4.0.0
Release: 2%{?dist}
Release: 3%{?dist}
%global verrel %{version}-%{release}
Summary: Desktop tool for managing virtual machines via libvirt
@ -16,7 +16,7 @@ License: GPLv2+
BuildArch: noarch
URL: https://virt-manager.org/
Source0: https://virt-manager.org/download/sources/%{name}/%{name}-%{version}.tar.gz
Patch: 0001-Fix-build-with-setuptools-61.patch
Requires: virt-manager-common = %{verrel}
Requires: python3-gobject >= 3.31.3
@ -163,6 +163,9 @@ machine).
%changelog
* Wed Aug 3 2022 Daniel. P. Berrange <berrange@redhat.com> - 4.0.0-3
- Fix compat with setuptools >= 61 (rhbz#2113754)
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild