- Update to 0.6.92 release
This commit is contained in:
parent
0f757d95b2
commit
4dcc5fc5d7
@ -1 +1 @@
|
||||
tracker-0.6.91.tar.bz2
|
||||
tracker-0.6.92.tar.bz2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
6eb81eed996e603c7d117b7d38970da2 tracker-0.6.91.tar.bz2
|
||||
df843d3ef338baf6c91e252db3273533 tracker-0.6.92.tar.bz2
|
||||
|
@ -1,22 +0,0 @@
|
||||
--- configure.ac 2009-03-13 10:55:58.000000000 -0400
|
||||
+++ configure.ac.new 2009-03-13 13:28:43.370976746 -0400
|
||||
@@ -654,7 +654,7 @@
|
||||
fi
|
||||
|
||||
if test -z "$deskbar_applet_dir"; then
|
||||
- deskbar_applet_dir="\$(exec_prefix)/lib/deskbar-applet/handlers"
|
||||
+ deskbar_applet_dir="\$(libdir)/deskbar-applet/handlers"
|
||||
fi
|
||||
fi
|
||||
|
||||
@@ -665,8 +665,8 @@
|
||||
deskbar_applet_dir="$with_deskbar_applet_dir"
|
||||
fi
|
||||
|
||||
- if test -z "$module_dir"; then
|
||||
- deskbar_applet_dir="\$(exec_prefix)/lib/deskbar-applet/modules-2.20-compatible"
|
||||
+ if test -z "$deskbar_applet_dir"; then
|
||||
+ deskbar_applet_dir="\$(libdir)/deskbar-applet/modules-2.20-compatible"
|
||||
fi
|
||||
fi
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- configure.ac 2009-03-13 10:55:58.000000000 -0400
|
||||
+++ configure.ac.new 2009-03-13 12:30:30.625852667 -0400
|
||||
@@ -110,7 +110,7 @@
|
||||
@@ -132,7 +132,7 @@
|
||||
GTK_REQUIRED=2.8.0
|
||||
GLADE_REQUIRED=2.5
|
||||
QDBM_REQUIRED=1.8
|
||||
@ -9,7 +9,7 @@
|
||||
LIBXML2_REQUIRED=0.6
|
||||
LIBNOTIFY_REQUIRED=0.4.3
|
||||
HAL_REQUIRED=0.5
|
||||
@@ -159,7 +159,7 @@
|
||||
@@ -181,7 +181,7 @@
|
||||
AC_SUBST(PANGO_LIBS)
|
||||
|
||||
# Check for GMime
|
||||
@ -429,190 +429,3 @@ Index: src/tracker-indexer/modules/evolution-common.c
|
||||
- return g_strdup (start_encoding);
|
||||
- }
|
||||
-}
|
||||
Index: src/tracker-indexer/modules/evolution-imap-db.c
|
||||
===================================================================
|
||||
--- src/tracker-indexer/modules/evolution-imap-db.c (revision 2802)
|
||||
+++ src/tracker-indexer/modules/evolution-imap-db.c (working copy)
|
||||
@@ -360,7 +360,7 @@
|
||||
if (result == SQLITE_ROW) {
|
||||
const gchar *folder;
|
||||
|
||||
- folder = sqlite3_column_text (stmt, 0);
|
||||
+ folder = (gchar *) sqlite3_column_text (stmt, 0);
|
||||
|
||||
if (folder[0] != '.') {
|
||||
self->folders = g_list_prepend (self->folders, g_strdup (folder));
|
||||
@@ -420,7 +420,7 @@
|
||||
static gboolean
|
||||
get_attachment_info (const gchar *mime_file,
|
||||
gchar **name,
|
||||
- GMimePartEncodingType *encoding)
|
||||
+ GMimeContentEncoding *encoding)
|
||||
{
|
||||
GMimeContentType *mime;
|
||||
gchar *tmp, *mime_content;
|
||||
@@ -431,7 +431,7 @@
|
||||
}
|
||||
|
||||
if (encoding) {
|
||||
- *encoding = GMIME_PART_ENCODING_DEFAULT;
|
||||
+ *encoding = GMIME_CONTENT_ENCODING_DEFAULT;
|
||||
}
|
||||
|
||||
if (!g_file_get_contents (mime_file, &tmp, NULL, NULL)) {
|
||||
@@ -478,7 +478,7 @@
|
||||
*name = g_strdup (g_mime_content_type_get_parameter (mime, "name"));
|
||||
}
|
||||
|
||||
- g_mime_content_type_destroy (mime);
|
||||
+ g_object_unref (mime);
|
||||
}
|
||||
|
||||
if (name && !*name) {
|
||||
@@ -500,17 +500,17 @@
|
||||
gchar *encoding_str = g_strndup (pos_encoding, pos_end_encoding - pos_encoding);
|
||||
|
||||
if (strcmp (encoding_str, "7bit") == 0) {
|
||||
- *encoding = GMIME_PART_ENCODING_7BIT;
|
||||
+ *encoding = GMIME_CONTENT_ENCODING_7BIT;
|
||||
} else if (strcmp (encoding_str, "8bit") == 0) {
|
||||
- *encoding = GMIME_PART_ENCODING_7BIT;
|
||||
+ *encoding = GMIME_CONTENT_ENCODING_7BIT;
|
||||
} else if (strcmp (encoding_str, "binary") == 0) {
|
||||
- *encoding = GMIME_PART_ENCODING_BINARY;
|
||||
+ *encoding = GMIME_CONTENT_ENCODING_BINARY;
|
||||
} else if (strcmp (encoding_str, "base64") == 0) {
|
||||
- *encoding = GMIME_PART_ENCODING_BASE64;
|
||||
+ *encoding = GMIME_CONTENT_ENCODING_BASE64;
|
||||
} else if (strcmp (encoding_str, "quoted-printable") == 0) {
|
||||
- *encoding = GMIME_PART_ENCODING_QUOTEDPRINTABLE;
|
||||
+ *encoding = GMIME_CONTENT_ENCODING_QUOTEDPRINTABLE;
|
||||
} else if (strcmp (encoding_str, "x-uuencode") == 0) {
|
||||
- *encoding = GMIME_PART_ENCODING_UUENCODE;
|
||||
+ *encoding = GMIME_CONTENT_ENCODING_UUENCODE;
|
||||
}
|
||||
|
||||
g_free (encoding_str);
|
||||
@@ -586,14 +586,17 @@
|
||||
}
|
||||
|
||||
static void
|
||||
-extract_message_text (GMimeObject *object,
|
||||
+extract_message_text (GMimeObject *parent,
|
||||
+ GMimeObject *object,
|
||||
gpointer user_data)
|
||||
{
|
||||
GString *body = (GString *) user_data;
|
||||
- GMimePartEncodingType part_encoding;
|
||||
+ GMimeContentEncoding part_encoding;
|
||||
GMimePart *part;
|
||||
- const gchar *content, *disposition, *filename;
|
||||
- gchar *encoding, *part_body;
|
||||
+ GMimeStream *stream;
|
||||
+ GMimeDataWrapper *data;
|
||||
+ const gchar *disposition, *filename, *encoding;
|
||||
+ gchar *part_body, buffer[1024];
|
||||
gsize len;
|
||||
|
||||
if (GMIME_IS_MESSAGE_PART (object)) {
|
||||
@@ -602,7 +605,7 @@
|
||||
message = g_mime_message_part_get_message (GMIME_MESSAGE_PART (object));
|
||||
|
||||
if (message) {
|
||||
- g_mime_message_foreach_part (message, extract_message_text, user_data);
|
||||
+ g_mime_message_foreach (message, extract_message_text, user_data);
|
||||
g_object_unref (message);
|
||||
}
|
||||
|
||||
@@ -614,12 +617,12 @@
|
||||
|
||||
part = GMIME_PART (object);
|
||||
filename = g_mime_part_get_filename (part);
|
||||
- disposition = g_mime_part_get_content_disposition (part);
|
||||
- part_encoding = g_mime_part_get_encoding (part);
|
||||
+ disposition = g_mime_object_get_disposition (GMIME_OBJECT (part));
|
||||
+ part_encoding = g_mime_part_get_content_encoding (part);
|
||||
|
||||
- if (part_encoding == GMIME_PART_ENCODING_BINARY ||
|
||||
- part_encoding == GMIME_PART_ENCODING_BASE64 ||
|
||||
- part_encoding == GMIME_PART_ENCODING_UUENCODE) {
|
||||
+ if (part_encoding == GMIME_CONTENT_ENCODING_BINARY ||
|
||||
+ part_encoding == GMIME_CONTENT_ENCODING_BASE64 ||
|
||||
+ part_encoding == GMIME_CONTENT_ENCODING_UUENCODE) {
|
||||
return;
|
||||
}
|
||||
|
||||
@@ -634,34 +637,34 @@
|
||||
return;
|
||||
}
|
||||
|
||||
- content = g_mime_part_get_content (GMIME_PART (object), &len);
|
||||
+ data = g_mime_part_get_content_object (GMIME_PART (object));
|
||||
|
||||
- if (!content) {
|
||||
- return;
|
||||
- }
|
||||
+ if (!data)
|
||||
+ return;
|
||||
|
||||
- if (g_utf8_validate (content, len, NULL)) {
|
||||
- g_string_append_len (body, content, (gssize) len);
|
||||
- return;
|
||||
- }
|
||||
+ stream = g_mime_data_wrapper_get_stream (data);
|
||||
|
||||
- encoding = evolution_common_get_object_encoding (object);
|
||||
+ if (!stream) {
|
||||
+ g_object_unref (data);
|
||||
+ return;
|
||||
+ }
|
||||
|
||||
- if (!encoding) {
|
||||
- /* FIXME: This will break for non-utf8 text without
|
||||
- * the proper content type set
|
||||
- */
|
||||
- g_string_append_len (body, content, (gssize) len);
|
||||
- } else {
|
||||
- part_body = g_convert (content, (gssize) len, "utf8", encoding, NULL, NULL, NULL);
|
||||
+ encoding = g_mime_object_get_content_disposition_parameter (GMIME_OBJECT (part), "charset");
|
||||
|
||||
- if (part_body) {
|
||||
- g_string_append (body, part_body);
|
||||
- g_free (part_body);
|
||||
+ while (!g_mime_stream_eos (stream)) {
|
||||
+ len = g_mime_stream_read (stream, buffer, 1024);
|
||||
+ if (len > 0 && g_utf8_validate (buffer, len, NULL)) {
|
||||
+ if (!encoding)
|
||||
+ g_string_append_len (body, buffer, (gssize) len);
|
||||
+ else {
|
||||
+ part_body = g_convert (buffer, (gssize) len, "utf8", encoding, NULL, NULL, NULL);
|
||||
+ g_string_append (body, part_body);
|
||||
+ g_free (part_body);
|
||||
+ }
|
||||
}
|
||||
+ }
|
||||
|
||||
- g_free (encoding);
|
||||
- }
|
||||
+ g_object_unref (stream);
|
||||
}
|
||||
|
||||
static gchar *
|
||||
@@ -706,7 +709,7 @@
|
||||
|
||||
if (message) {
|
||||
body = g_string_new (NULL);
|
||||
- g_mime_message_foreach_part (message, extract_message_text, body);
|
||||
+ g_mime_message_foreach (message, extract_message_text, body);
|
||||
g_object_unref (message);
|
||||
}
|
||||
|
||||
@@ -799,7 +802,7 @@
|
||||
TrackerModuleMetadata *metadata;
|
||||
GMimeStream *stream;
|
||||
GMimeDataWrapper *wrapper;
|
||||
- GMimePartEncodingType encoding;
|
||||
+ GMimeContentEncoding encoding;
|
||||
gchar *path, *name;
|
||||
|
||||
if (!get_attachment_info (mime_file, &name, &encoding)) {
|
||||
|
13
tracker.spec
13
tracker.spec
@ -1,6 +1,6 @@
|
||||
Summary: An object database, tag/metadata database, search tool and indexer
|
||||
Name: tracker
|
||||
Version: 0.6.91
|
||||
Version: 0.6.92
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: Applications/System
|
||||
@ -8,13 +8,13 @@ URL: http://projects.gnome.org/tracker/
|
||||
Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.6/%{name}-%{version}.tar.bz2
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=564640
|
||||
Patch0: tracker-gmime-2.4.patch
|
||||
Patch1: tracker-deskbar_dir.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: gmime-devel, poppler-glib-devel, evolution-devel
|
||||
BuildRequires: gnome-desktop-devel, gamin-devel, libnotify-devel
|
||||
BuildRequires: totem-pl-parser-devel, libgsf-devel, gstreamer-devel
|
||||
BuildRequires: gstreamer-plugins-base-devel
|
||||
BuildRequires: libjpeg-devel, libexif-devel, exempi-devel, raptor-devel
|
||||
BuildRequires: libiptcdata-devel
|
||||
BuildRequires: desktop-file-utils, intltool, gettext, deskbar-applet
|
||||
BuildRequires: sqlite-devel, qdbm-devel, pygtk2-devel, libtiff-devel
|
||||
BuildRequires: autoconf, automake, libtool
|
||||
@ -57,7 +57,6 @@ GNOME libraries
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p0
|
||||
%patch1 -p0
|
||||
autoreconf -f -i
|
||||
|
||||
%define deskbar_applet_ver %(pkg-config --modversion deskbar-applet)
|
||||
@ -69,6 +68,8 @@ autoreconf -f -i
|
||||
%define deskbar_type handler
|
||||
%endif
|
||||
|
||||
%define evo_plugins_dir %(pkg-config evolution-plugin --variable=plugindir)
|
||||
|
||||
%build
|
||||
%configure --disable-static --enable-deskbar-applet=%{deskbar_type} \
|
||||
--enable-external-qdbm
|
||||
@ -92,6 +93,7 @@ desktop-file-install --delete-original \
|
||||
%{buildroot}%{_datadir}/applications/%{name}-search-tool.desktop
|
||||
|
||||
rm -rf %{buildroot}%{_libdir}/*.la
|
||||
rm -rf %{buildroot}/%{evo_plugins_dir}/*.la
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
@ -126,6 +128,8 @@ fi
|
||||
%{_datadir}/dbus-1/services/org.freedesktop.Tracker.*
|
||||
%{_libdir}/*.so.*
|
||||
%{_libdir}/tracker/
|
||||
%{evo_plugins_dir}/liborg-freedesktop-Tracker-evolution-plugin.so
|
||||
%{evo_plugins_dir}/org-freedesktop-Tracker-evolution-plugin.eplug
|
||||
%{_mandir}/*/tracker*.gz
|
||||
%{_sysconfdir}/xdg/autostart/trackerd.desktop
|
||||
%{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
|
||||
@ -150,6 +154,9 @@ fi
|
||||
%{_sysconfdir}/xdg/autostart/tracker-applet.desktop
|
||||
|
||||
%changelog
|
||||
* Fri Mar 28 2009 Deji Akingunola <dakingun@gmail.com> - 0.6.92-1
|
||||
- Update to 0.6.92 release
|
||||
|
||||
* Fri Mar 13 2009 Deji Akingunola <dakingun@gmail.com> - 0.6.91-1
|
||||
- Update to 0.6.91 release
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user