- Update to 0.6.91 release
This commit is contained in:
parent
f30ccb631c
commit
0f757d95b2
@ -1 +1 @@
|
||||
tracker-0.6.90.tar.bz2
|
||||
tracker-0.6.91.tar.bz2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
5b4a85a67e3305e00a1e71f8d340e179 tracker-0.6.90.tar.bz2
|
||||
6eb81eed996e603c7d117b7d38970da2 tracker-0.6.91.tar.bz2
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- tracker-0.6.6/python/deskbar-handler/tracker-module.py.fix-deskbar 2008-01-14 23:04:47.000000000 -0500
|
||||
+++ tracker-0.6.6/python/deskbar-handler/tracker-module.py 2009-02-12 19:21:37.538647319 -0500
|
||||
@@ -11,7 +11,7 @@
|
||||
import os.path
|
||||
import deskbar
|
||||
import deskbar.core.Utils
|
||||
-import deskbar.core.gnomedesktop
|
||||
+import gnomedesktop
|
||||
import deskbar.interfaces.Module
|
||||
import deskbar.interfaces.Match
|
||||
import deskbar.interfaces.Action
|
22
tracker-deskbar_dir.patch
Normal file
22
tracker-deskbar_dir.patch
Normal file
@ -0,0 +1,22 @@
|
||||
--- configure.ac 2009-03-13 10:55:58.000000000 -0400
|
||||
+++ configure.ac.new 2009-03-13 13:28:43.370976746 -0400
|
||||
@@ -654,7 +654,7 @@
|
||||
fi
|
||||
|
||||
if test -z "$deskbar_applet_dir"; then
|
||||
- deskbar_applet_dir="\$(exec_prefix)/lib/deskbar-applet/handlers"
|
||||
+ deskbar_applet_dir="\$(libdir)/deskbar-applet/handlers"
|
||||
fi
|
||||
fi
|
||||
|
||||
@@ -665,8 +665,8 @@
|
||||
deskbar_applet_dir="$with_deskbar_applet_dir"
|
||||
fi
|
||||
|
||||
- if test -z "$module_dir"; then
|
||||
- deskbar_applet_dir="\$(exec_prefix)/lib/deskbar-applet/modules-2.20-compatible"
|
||||
+ if test -z "$deskbar_applet_dir"; then
|
||||
+ deskbar_applet_dir="\$(libdir)/deskbar-applet/modules-2.20-compatible"
|
||||
fi
|
||||
fi
|
||||
|
@ -1,15 +1,15 @@
|
||||
--- configure.ac 2009-02-09 12:15:00.000000000 -0500
|
||||
+++ configure.ac.new 2009-02-09 21:35:08.000000000 -0500
|
||||
@@ -108,7 +108,7 @@
|
||||
GLIB_REQUIRED=2.16.0
|
||||
PANGO_REQUIRED=1.0.0
|
||||
--- configure.ac 2009-03-13 10:55:58.000000000 -0400
|
||||
+++ configure.ac.new 2009-03-13 12:30:30.625852667 -0400
|
||||
@@ -110,7 +110,7 @@
|
||||
GTK_REQUIRED=2.8.0
|
||||
GLADE_REQUIRED=2.5
|
||||
QDBM_REQUIRED=1.8
|
||||
-GMIME_REQUIRED=2.1.0
|
||||
+GMIME_REQUIRED=2.4.0
|
||||
LIBXML2_REQUIRED=0.6
|
||||
LIBNOTIFY_REQUIRED=0.4.3
|
||||
HAL_REQUIRED=0.5
|
||||
GDKPIXBUF_REQUIRED=2.12.0
|
||||
@@ -153,7 +153,7 @@
|
||||
@@ -159,7 +159,7 @@
|
||||
AC_SUBST(PANGO_LIBS)
|
||||
|
||||
# Check for GMime
|
||||
|
23
tracker.spec
23
tracker.spec
@ -1,15 +1,14 @@
|
||||
Summary: An object database, tag/metadata database, search tool and indexer
|
||||
Name: tracker
|
||||
Version: 0.6.90
|
||||
Release: 4%{?dist}
|
||||
Version: 0.6.91
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: Applications/System
|
||||
URL: http://projects.gnome.org/tracker/
|
||||
Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.6/%{name}-%{version}.tar.bz2
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=564640
|
||||
Patch0: tracker-gmime-2.4.patch
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=571573
|
||||
Patch1: tracker-0.6.6-fix-deskbar.patch
|
||||
Patch1: tracker-deskbar_dir.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: gmime-devel, poppler-glib-devel, evolution-devel
|
||||
BuildRequires: gnome-desktop-devel, gamin-devel, libnotify-devel
|
||||
@ -58,7 +57,7 @@ GNOME libraries
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p0
|
||||
%patch1 -p1 -b .fix-deskbar
|
||||
%patch1 -p0
|
||||
autoreconf -f -i
|
||||
|
||||
%define deskbar_applet_ver %(pkg-config --modversion deskbar-applet)
|
||||
@ -84,8 +83,8 @@ rm -rf %{buildroot}
|
||||
make DESTDIR=%{buildroot} install
|
||||
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d
|
||||
echo "%{_libdir}/tracker" \
|
||||
> %{buildroot}%{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
|
||||
echo "%{_libdir}/tracker" \
|
||||
> %{buildroot}%{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
|
||||
|
||||
desktop-file-install --delete-original \
|
||||
--vendor="fedora" \
|
||||
@ -151,14 +150,8 @@ fi
|
||||
%{_sysconfdir}/xdg/autostart/tracker-applet.desktop
|
||||
|
||||
%changelog
|
||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.90-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Thu Feb 19 2009 Deji Akingunola <dakingun@gmail.com> - 0.6.90-3
|
||||
- Add %libdir/tracker to linker path to solve RH #486479
|
||||
|
||||
* Thu Feb 12 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.90-2
|
||||
- Fix incorrect import in Tracker's deskbar module
|
||||
* Fri Mar 13 2009 Deji Akingunola <dakingun@gmail.com> - 0.6.91-1
|
||||
- Update to 0.6.91 release
|
||||
|
||||
* Mon Feb 09 2009 Deji Akingunola <dakingun@gmail.com> - 0.6.90-1
|
||||
- New release, with tons of changes
|
||||
|
Loading…
Reference in New Issue
Block a user