Cleanup spec file conditionals
Fix FTBFS (BZ#1424149)
This commit is contained in:
parent
e0be87cfbb
commit
f722580cfb
26615
torque-4.2.10-fix-bad-crypto-check.patch
Normal file
26615
torque-4.2.10-fix-bad-crypto-check.patch
Normal file
File diff suppressed because it is too large
Load Diff
29
torque-4.2.10-remove-unused-header.patch
Normal file
29
torque-4.2.10-remove-unused-header.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
From fb7c21c16423cecdbd8ac2429118305c26b82bb4 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Justin Bronder <jsbronder@gmail.com>
|
||||||
|
Date: Sat, 1 Jun 2013 11:37:27 -0400
|
||||||
|
Subject: [PATCH] Libnet: remove unused header
|
||||||
|
|
||||||
|
Do not include <rpc/rpc.h> as it is unused. While this is normally
|
||||||
|
harmless, glibc is dropping support for rpc as of 2.14 [1] and ipv6 is
|
||||||
|
only supported in ti-rpc.
|
||||||
|
|
||||||
|
This fixes building on distros that have not manually patched rpc
|
||||||
|
support back into glibc.
|
||||||
|
|
||||||
|
1. http://sourceware.org/bugzilla/show_bug.cgi?id=12949
|
||||||
|
---
|
||||||
|
src/lib/Libnet/net_client.c | 1 -
|
||||||
|
1 file changed, 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/lib/Libnet/net_client.c b/src/lib/Libnet/net_client.c
|
||||||
|
index d8e51312f8..04c3ba0d78 100644
|
||||||
|
--- a/src/lib/Libnet/net_client.c
|
||||||
|
+++ b/src/lib/Libnet/net_client.c
|
||||||
|
@@ -80,7 +80,6 @@
|
||||||
|
|
||||||
|
#include <sys/types.h>
|
||||||
|
#include <sys/socket.h>
|
||||||
|
-#include <rpc/rpc.h>
|
||||||
|
#include <netinet/in.h>
|
||||||
|
#include <stdio.h>
|
||||||
|
#include <errno.h>
|
27
torque.spec
27
torque.spec
@ -71,7 +71,7 @@
|
|||||||
|
|
||||||
Name: torque
|
Name: torque
|
||||||
Version: 4.2.10
|
Version: 4.2.10
|
||||||
Release: 15%{?dist}
|
Release: 16%{?dist}
|
||||||
Summary: Tera-scale Open-source Resource and QUEue manager
|
Summary: Tera-scale Open-source Resource and QUEue manager
|
||||||
Source0: http://www.adaptivecomputing.com/download/%{name}/%{name}-%{version}.tar.gz
|
Source0: http://www.adaptivecomputing.com/download/%{name}/%{name}-%{version}.tar.gz
|
||||||
Source2: xpbs.desktop
|
Source2: xpbs.desktop
|
||||||
@ -94,6 +94,10 @@ Source24: mom.layout
|
|||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=713996
|
# https://bugzilla.redhat.com/show_bug.cgi?id=713996
|
||||||
Patch1: torque-munge-size.patch
|
Patch1: torque-munge-size.patch
|
||||||
Patch2: torque-%{version}-port-args.patch
|
Patch2: torque-%{version}-port-args.patch
|
||||||
|
# Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1424149
|
||||||
|
Patch3: torque-%{version}-fix-bad-crypto-check.patch
|
||||||
|
# From https://github.com/adaptivecomputing/torque/pull/148
|
||||||
|
Patch4: torque-%{version}-remove-unused-header.patch
|
||||||
|
|
||||||
License: OpenPBS and TORQUEv1.1
|
License: OpenPBS and TORQUEv1.1
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -126,23 +130,23 @@ BuildRequires: systemd
|
|||||||
%if 0%{?doxydoc}
|
%if 0%{?doxydoc}
|
||||||
BuildRequires: graphviz
|
BuildRequires: graphviz
|
||||||
BuildRequires: doxygen
|
BuildRequires: doxygen
|
||||||
%if "%{?rhel}" == "5"
|
%if 0%{?rhel} == 5
|
||||||
BuildRequires: graphviz-gd
|
BuildRequires: graphviz-gd
|
||||||
%endif
|
%endif
|
||||||
%if %{?fedora}%{!?fedora:0} >= 24
|
%if 0%{?fedora} >= 24 || 0%{?rhel} > 7
|
||||||
BuildRequires: texlive-tabu
|
BuildRequires: texlive-tabu
|
||||||
%endif
|
%endif
|
||||||
%if %{?fedora}%{!?fedora:0} >= 9 || %{?rhel}%{!?rhel:0} >= 7
|
%if 0%{?fedora} >= 9 || 0%{?rhel} >= 7
|
||||||
BuildRequires: tex(latex)
|
BuildRequires: tex(latex)
|
||||||
BuildRequires: tex-xtab
|
BuildRequires: tex-xtab
|
||||||
BuildRequires: tex-sectsty
|
BuildRequires: tex-sectsty
|
||||||
BuildRequires: tex-tocloft
|
BuildRequires: tex-tocloft
|
||||||
BuildRequires: tex-multirow
|
BuildRequires: tex-multirow
|
||||||
%if %{?fedora}%{!?fedora:0}
|
%if 0%{?fedora} || 0%{?rhel} > 7
|
||||||
BuildRequires: tex-adjustbox
|
BuildRequires: tex-adjustbox
|
||||||
%endif
|
%endif
|
||||||
%else
|
%else
|
||||||
%if %{?rhel}%{!?rhel:0} >= 6
|
%if 0%{?rhel} >= 6
|
||||||
BuildRequires: tex(latex)
|
BuildRequires: tex(latex)
|
||||||
%else
|
%else
|
||||||
BuildRequires: tetex-latex
|
BuildRequires: tetex-latex
|
||||||
@ -367,6 +371,8 @@ DRMAA is "Distributed Resource Management Application API"
|
|||||||
%setup -q -n torque-%{version}
|
%setup -q -n torque-%{version}
|
||||||
%patch1 -p 1
|
%patch1 -p 1
|
||||||
%patch2 -p 1
|
%patch2 -p 1
|
||||||
|
%patch3 -p 0
|
||||||
|
%patch4 -p 1
|
||||||
sed -i '/LATEX_BATCHMODE/d' src/drmaa/Doxyfile.in
|
sed -i '/LATEX_BATCHMODE/d' src/drmaa/Doxyfile.in
|
||||||
install -pm 644 %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} \
|
install -pm 644 %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} \
|
||||||
%{SOURCE6} %{SOURCE8} .
|
%{SOURCE6} %{SOURCE8} .
|
||||||
@ -374,7 +380,8 @@ install -pm 644 %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} \
|
|||||||
chmod 644 torque.setup
|
chmod 644 torque.setup
|
||||||
|
|
||||||
%build
|
%build
|
||||||
CFLAGS="%{optflags} -DUSE_INTERP_RESULT -DUSE_INTERP_ERRORLINE"
|
# -fpermissive added to downgrade numerous 'invalid conversion' errors to warnings
|
||||||
|
CFLAGS="%{optflags} -DUSE_INTERP_RESULT -DUSE_INTERP_ERRORLINE -fpermissive"
|
||||||
%configure --includedir=%{_includedir}/torque \
|
%configure --includedir=%{_includedir}/torque \
|
||||||
--with-server-home=%{torquehomedir} --with-pam=/%{_lib}/security \
|
--with-server-home=%{torquehomedir} --with-pam=/%{_lib}/security \
|
||||||
--with-sendmail=%{_sbindir}/sendmail --disable-static \
|
--with-sendmail=%{_sbindir}/sendmail --disable-static \
|
||||||
@ -865,7 +872,7 @@ fi
|
|||||||
%{_mandir}/man3/compat.h.3.*
|
%{_mandir}/man3/compat.h.3.*
|
||||||
%{_mandir}/man3/drmaa.3.*
|
%{_mandir}/man3/drmaa.3.*
|
||||||
%{_mandir}/man3/drmaa.h.3.*
|
%{_mandir}/man3/drmaa.h.3.*
|
||||||
%if 0%{?rhel}%{?fedora} >= 6
|
%if 0%{?rhel} >= 6 || 0%{?fedora} >= 6
|
||||||
%{_mandir}/man3/drmaa_attr_names_s.3.*
|
%{_mandir}/man3/drmaa_attr_names_s.3.*
|
||||||
%{_mandir}/man3/drmaa_attr_values_s.3.*
|
%{_mandir}/man3/drmaa_attr_values_s.3.*
|
||||||
%{_mandir}/man3/drmaa_attrib.3.*
|
%{_mandir}/man3/drmaa_attrib.3.*
|
||||||
@ -889,6 +896,10 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 11 2018 Merlin Mathesius <mmathesi@redhat.com> - 4.2.10-16
|
||||||
|
- Cleanup spec file conditionals
|
||||||
|
- Fix FTBFS (BZ#1424149)
|
||||||
|
|
||||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.10-15
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.10-15
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user