update to 2.1.3
This commit is contained in:
parent
c37fc01d2b
commit
cc85700ced
@ -1 +1 @@
|
|||||||
torque-2.1.2.tar.gz
|
torque-2.1.3.tar.gz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
f1b37efb5d4770a0105c66294a05d140 torque-2.1.2.tar.gz
|
0b7217fa2512c8df2e4d4616d0fef29b torque-2.1.3.tar.gz
|
||||||
|
@ -1,63 +0,0 @@
|
|||||||
Index: src/server/node_manager.c
|
|
||||||
===================================================================
|
|
||||||
RCS file: /usr/local/nfs/src/cvs_repository/torque/src/server/node_manager.c,v
|
|
||||||
retrieving revision 1.64
|
|
||||||
retrieving revision 1.66
|
|
||||||
diff -r1.64 -r1.66
|
|
||||||
736,738c736
|
|
||||||
< if ((pjob == NULL) ||
|
|
||||||
< ((pjob->ji_qs.ji_substate != JOB_SUBSTATE_SUSPEND) &&
|
|
||||||
< (pjob->ji_qs.ji_substate != JOB_SUBSTATE_RUNNING)))
|
|
||||||
---
|
|
||||||
> if (pjob == NULL)
|
|
||||||
740c738
|
|
||||||
< /* job is reported by mom but server has no record of job on node */
|
|
||||||
---
|
|
||||||
> /* job is reported by mom but server has no record of job */
|
|
||||||
742c740
|
|
||||||
< sprintf(log_buffer,"stray job %s found on %s (substate=%d)",
|
|
||||||
---
|
|
||||||
> sprintf(log_buffer,"stray job %s found on %s",
|
|
||||||
744,745c742
|
|
||||||
< np->nd_name,
|
|
||||||
< (pjob != NULL) ? pjob->ji_qs.ji_substate : -1);
|
|
||||||
---
|
|
||||||
> np->nd_name);
|
|
||||||
749,755d745
|
|
||||||
< if ((preq = alloc_br(PBS_BATCH_DeleteJob)) == NULL)
|
|
||||||
< {
|
|
||||||
< log_err(-1,id,"unable to allocate DeleteJob request - big trouble!");
|
|
||||||
<
|
|
||||||
< break;
|
|
||||||
< }
|
|
||||||
<
|
|
||||||
762c752,772
|
|
||||||
< strcpy(preq->rq_ind.rq_delete.rq_objname,jobidstr);
|
|
||||||
---
|
|
||||||
> if (conn >= 0)
|
|
||||||
> {
|
|
||||||
> if ((preq = alloc_br(PBS_BATCH_DeleteJob)) == NULL)
|
|
||||||
> {
|
|
||||||
> log_err(-1,id,"unable to allocate DeleteJob request - big trouble!");
|
|
||||||
>
|
|
||||||
> svr_disconnect(conn);
|
|
||||||
> }
|
|
||||||
> else
|
|
||||||
> {
|
|
||||||
> strcpy(preq->rq_ind.rq_delete.rq_objname,jobidstr);
|
|
||||||
>
|
|
||||||
> if (issue_Drequest(conn,preq,release_req,0) != 0)
|
|
||||||
> {
|
|
||||||
> /* release_req will free preq and close connection if successful */
|
|
||||||
> free_br(preq);
|
|
||||||
>
|
|
||||||
> svr_disconnect(conn);
|
|
||||||
> }
|
|
||||||
> }
|
|
||||||
> }
|
|
||||||
764,766c774
|
|
||||||
< issue_Drequest(conn,preq,release_req,0);
|
|
||||||
<
|
|
||||||
< /* release_req will free preq and close connection */
|
|
||||||
---
|
|
||||||
> DIS_rpp_reset();
|
|
@ -1,12 +0,0 @@
|
|||||||
--- torque-2.1.0p0-snap.200604171430/src/scheduler.cc/pbs_sched.c.orig 2006-04-06 23:56:37.000000000 +0200
|
|
||||||
+++ torque-2.1.0p0-snap.200604171430/src/scheduler.cc/pbs_sched.c 2006-04-20 16:52:38.000000000 +0200
|
|
||||||
@@ -992,7 +992,7 @@
|
|
||||||
|
|
||||||
(void)sprintf(log_buffer, "%ld\n", (long)pid);
|
|
||||||
|
|
||||||
- if (write(lockfds, log_buffer, strlen(log_buffer)+1) != strlen(log_buffer))
|
|
||||||
+ if (write(lockfds, log_buffer, strlen(log_buffer)+1) != strlen(log_buffer)+1)
|
|
||||||
{
|
|
||||||
perror("writing to lockfile");
|
|
||||||
|
|
||||||
|
|
@ -1,13 +0,0 @@
|
|||||||
diff -pruN torque-2.1.2_orig/src/pam/pam_pbssimpleauth.c torque-2.1.2/src/pam/pam_pbssimpleauth.c
|
|
||||||
--- torque-2.1.2_orig/src/pam/pam_pbssimpleauth.c 2006-07-12 08:25:23.000000000 -0700
|
|
||||||
+++ torque-2.1.2/src/pam/pam_pbssimpleauth.c 2006-08-02 22:22:27.000000000 -0700
|
|
||||||
@@ -94,8 +94,7 @@ int pam_sm_authenticate(pam_handle_t *pa
|
|
||||||
return PAM_SERVICE_ERR;
|
|
||||||
}
|
|
||||||
|
|
||||||
- if (_pam_getpwnam_r(username, &pwd, &ubuf, &ubuflen, &user_pwd) != 0)
|
|
||||||
- user_pwd = NULL;
|
|
||||||
+ user_pwd = getpwnam(username);
|
|
||||||
|
|
||||||
/* no early returns from this point on because we need to free ubuf */
|
|
||||||
|
|
11
torque.spec
11
torque.spec
@ -1,9 +1,9 @@
|
|||||||
|
|
||||||
# comment out snap if building a real release
|
# comment out snap if building a real release
|
||||||
%define name torque
|
%define name torque
|
||||||
%define version 2.1.2
|
%define version 2.1.3
|
||||||
#%%define snap 200604251602
|
#%%define snap 200604251602
|
||||||
%define release 3
|
%define release 1
|
||||||
|
|
||||||
# The following options are supported:
|
# The following options are supported:
|
||||||
# --with server_name=hostname
|
# --with server_name=hostname
|
||||||
@ -92,7 +92,6 @@ Source4: xpbs.png
|
|||||||
Source5: xpbsmon.png
|
Source5: xpbsmon.png
|
||||||
Source6: README-localhost
|
Source6: README-localhost
|
||||||
Patch1: torque-2.1.0-remove-rpath.path
|
Patch1: torque-2.1.0-remove-rpath.path
|
||||||
Patch2: torque-2.1.2-pam-getpwnam.patch
|
|
||||||
License: Freely redistributable (See PBS_License.txt)
|
License: Freely redistributable (See PBS_License.txt)
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
URL: http://www.clusterresources.com/products/torque/
|
URL: http://www.clusterresources.com/products/torque/
|
||||||
@ -122,7 +121,6 @@ This package holds just a few shared files and directories.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n torque-%{version}%{?snap:-snap.%snap}
|
%setup -q -n torque-%{version}%{?snap:-snap.%snap}
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
|
||||||
|
|
||||||
%__install -pm 644 %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} .
|
%__install -pm 644 %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} .
|
||||||
|
|
||||||
@ -389,7 +387,7 @@ necessary for developing programs which will use %{name}.
|
|||||||
%{_bindir}/pbs-config
|
%{_bindir}/pbs-config
|
||||||
|
|
||||||
%package pam
|
%package pam
|
||||||
Summary: PAM module for PBS MOM nodes.
|
Summary: PAM module for TORQUE MOM nodes
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
|
|
||||||
%description pam
|
%description pam
|
||||||
@ -403,6 +401,9 @@ A simple PAM module to authorize users on PBS MOM nodes with a running job.
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Oct 12 2006 Garrick Staples <garrick@usc.edu> 2.1.3-1
|
||||||
|
- bump to 2.1.3
|
||||||
|
|
||||||
* Sun Aug 27 2006 Garrick Staples <garrick@usc.edu> 2.1.2-3
|
* Sun Aug 27 2006 Garrick Staples <garrick@usc.edu> 2.1.2-3
|
||||||
- FC6 mass rebuild
|
- FC6 mass rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user