import torque-4.2.10-17.el8

This commit is contained in:
CentOS Sources 2019-05-07 06:03:43 -04:00 committed by Andrew Lukoshko
commit c28a3da6bd
16 changed files with 28199 additions and 0 deletions

3
.gitignore vendored Normal file
View File

@ -0,0 +1,3 @@
SOURCES/torque-4.2.10.tar.gz
SOURCES/xpbs.png
SOURCES/xpbsmon.png

3
.torque.metadata Normal file
View File

@ -0,0 +1,3 @@
02819f2d0ed764ebe73ef4094027598326011f3c SOURCES/torque-4.2.10.tar.gz
b8c9209803cf2513620aa1c645135d798092ea08 SOURCES/xpbs.png
1cfd43ed4bd9be416764e016d6cea202c3021f35 SOURCES/xpbsmon.png

84
SOURCES/README.Fedora Normal file
View File

@ -0,0 +1,84 @@
This README describes how to get the most basic working
torque service on a single host.
To setup a basic single-node localhost-only batch system, install the
torque-server, torque-mom, and torque-scheduler packages, and do something like
this:
0) If torque is built with munge support then this
must be enabled first on all nodes. The munge
package should allready be installed.
Create a munge key with
/usr/sbin/create-munge-key
Copy resulting key /etc/munge/munge.key to
all torque nodes in your cluster including
pbs_server, pbs_mom and client (qstat,qsub) nodes.
1) Get your full hostname with
# /bin/hostname --long
e.g myhost.example.org
2) Edit /etc/torque/server_name
to contain the single line
myhost.example.org
3) Edit /etc/torque/mom/config
to contain the single line
$pbsserver myhost.example.org
4) Create a torque serverdb file.
# /usr/sbin/pbs_server -D -t create
Warning this will remove any existing serverdb
file located at /var/lib/torque/server_priv/serverdb
You will have to Ctrl^C the pbs_server command, it will
only take a moment to create this file.
5) Start the pbs_server and configure it.
service pbs_server start
# qmgr -c "s s scheduling=true"
# qmgr -c "c q batch queue_type=execution"
# qmgr -c "s q batch started=true"
# qmgr -c "s q batch enabled=true"
# qmgr -c "s q batch resources_default.nodes=1"
# qmgr -c "s q batch resources_default.walltime=3600"
# qmgr -c "s s default_queue=batch"
6) Add one batch worker to your pbs_server.
# qmgr -c "c n myhost.example.org"
7) Start the pbs_mom and pbs_sched deamons.
# service pbs_mom start
# service pbs_sched start
8) Use chkconfig to start the services at boot time.
# /sbin/chkconfig pbs_mom on
# /sbin/chkconfig pbs_server on
# /sbin/chkconfig pbs_sched on
# /sbin/chkconfig munge on
9) Submit a test job.
As a user not as root run the following
$ qsub <<EOF
hostname
echo "Hi I am a batch job running in torque"
EOF
10 ) Monitor the state of that job with qstat.
In case of problems first of all look in /var/log/torque

2
SOURCES/config Normal file
View File

@ -0,0 +1,2 @@
# Configuration for pbs_mom.
$pbsserver localhost

1
SOURCES/mom.layout Normal file
View File

@ -0,0 +1 @@
nodes=0

11
SOURCES/pbs_mom.service Normal file
View File

@ -0,0 +1,11 @@
[Unit]
Description=pbs-mom
After=syslog.target network.target trqauthd.service
[Service]
Type=forking
ExecStart=/usr/sbin/pbs_mom
PIDFile=/var/lib/torque/mom_priv/mom.lock
[Install]
WantedBy=multi-user.target

11
SOURCES/pbs_sched.service Normal file
View File

@ -0,0 +1,11 @@
[Unit]
Description=pbs-sched
After=syslog.target network.target trqauthd.service
[Service]
Type=forking
ExecStart=/usr/sbin/pbs_sched
PIDFile=/var/lib/torque/sched_priv/sched.lock
[Install]
WantedBy=multi-user.target

View File

@ -0,0 +1,11 @@
[Unit]
Description=pbs-server
After=syslog.target network.target trqauthd.service
[Service]
Type=forking
ExecStart=/usr/sbin/pbs_server
PIDFile=/var/lib/torque/server_priv/server.lock
[Install]
WantedBy=multi-user.target

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,61 @@
--- a/contrib/init.d/pbs_mom.in 2015-03-19 20:24:58.000000000 -0700
+++ b/contrib/init.d/pbs_mom.in 2016-02-20 18:46:26.058196405 -0800
@@ -13,11 +13,21 @@
SBIN_PATH=@sbindir@
PBS_DAEMON="$SBIN_PATH/pbs_mom"
PBS_HOME=@PBS_HOME@
+# this should be the integer port value
+PBS_PORT=""
if [ -f /etc/sysconfig/pbs_mom ];then
. /etc/sysconfig/pbs_mom
fi
+if [ -z "$PBS_PORT" ]; then
+ momctl_port_arg=""
+ pbs_mom_port_arg=""
+else
+ momctl_port_arg="$PBS_PORT"
+ pbs_mom_port_arg="-M $PBS_PORT"
+fi
+
if [ -z "$previous" ];then
# being run manually, don't disturb jobs
args="$args -p"
@@ -41,7 +51,7 @@
fi
retval=1
while kill -0 $pid 2>/dev/null;do
- $SBIN_PATH/momctl -s
+ $SBIN_PATH/momctl -s $momctl_port_arg
retval=$?
sleep 1
done
@@ -58,7 +68,7 @@
[ $RET -eq 0 ] && echo -n "pbs_mom already running" && success && echo && exit 0
# ulimit -c unlimited # Uncomment this to preserve core files
- daemon $PBS_DAEMON $args -d $PBS_HOME
+ daemon $PBS_DAEMON $args $pbs_mom_port_arg -d $PBS_HOME
RET=$?
touch /var/lock/subsys/pbs_mom
echo
--- a/contrib/init.d/pbs_sched.in 2016-02-20 18:48:08.593799420 -0800
+++ b/contrib/init.d/pbs_sched.in 2016-02-20 18:48:54.455727300 -0800
@@ -11,6 +11,7 @@
PBS_DAEMON=@sbindir@/pbs_sched
PBS_HOME=@PBS_HOME@
export PBS_DAEMON PBS_HOME
+PBS_ARGS=""
if [ -f /etc/sysconfig/pbs_sched ];then
. /etc/sysconfig/pbs_sched
@@ -24,7 +25,7 @@
RET=$?
[ $RET -eq 0 ] && echo -n "pbs_sched already running" && success && echo && exit 0
- daemon $PBS_DAEMON -d $PBS_HOME
+ daemon $PBS_DAEMON -d $PBS_HOME $PBS_ARGS
RET=$?
[ $RET -eq 0 ] && touch /var/lock/subsys/pbs_sched
echo

View File

@ -0,0 +1,29 @@
From fb7c21c16423cecdbd8ac2429118305c26b82bb4 Mon Sep 17 00:00:00 2001
From: Justin Bronder <jsbronder@gmail.com>
Date: Sat, 1 Jun 2013 11:37:27 -0400
Subject: [PATCH] Libnet: remove unused header
Do not include <rpc/rpc.h> as it is unused. While this is normally
harmless, glibc is dropping support for rpc as of 2.14 [1] and ipv6 is
only supported in ti-rpc.
This fixes building on distros that have not manually patched rpc
support back into glibc.
1. http://sourceware.org/bugzilla/show_bug.cgi?id=12949
---
src/lib/Libnet/net_client.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/src/lib/Libnet/net_client.c b/src/lib/Libnet/net_client.c
index d8e51312f8..04c3ba0d78 100644
--- a/src/lib/Libnet/net_client.c
+++ b/src/lib/Libnet/net_client.c
@@ -80,7 +80,6 @@
#include <sys/types.h>
#include <sys/socket.h>
-#include <rpc/rpc.h>
#include <netinet/in.h>
#include <stdio.h>
#include <errno.h>

View File

@ -0,0 +1,25 @@
From 12a8d7dde1d07aed670f0dd50b317b256daaa991 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ha=C3=AFkel=20Gu=C3=A9mar?= <hguemar@fedoraproject.org>
Date: Sun, 12 Jan 2014 11:42:32 +0100
Subject: [PATCH] munge size fix
---
src/include/libpbs.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/include/libpbs.h b/src/include/libpbs.h
index 6d32c8b..06b1bec 100644
--- a/src/include/libpbs.h
+++ b/src/include/libpbs.h
@@ -121,7 +121,7 @@
#define EOF -1
#endif
-#define MUNGE_SIZE 256 /* I do not know what the proper size of this should be. My
+#define MUNGE_SIZE 1024 /* I do not know what the proper size of this should be. My
testing with munge shows it creates a string of 128 bytes */
--
1.8.4.2

10
SOURCES/trqauthd.service Normal file
View File

@ -0,0 +1,10 @@
[Unit]
Description=trqauthd
After=syslog.target network.target
[Service]
Type=forking
ExecStart=/usr/sbin/trqauthd
[Install]
WantedBy=multi-user.target

11
SOURCES/xpbs.desktop Normal file
View File

@ -0,0 +1,11 @@
[Desktop Entry]
Encoding=UTF-8
Name=xPBS
GenericName=PBS/TORQUE client
Comment=View job status and submit jobs
Exec=xpbs
Icon=xpbs.png
Terminal=false
Type=Application
Categories=Education;Science;ComputerScience;ParallelComputing;
Version=1.0

11
SOURCES/xpbsmon.desktop Normal file
View File

@ -0,0 +1,11 @@
[Desktop Entry]
Encoding=UTF-8
Name=xPBSMon
GenericName=PBS/TORQUE cluster monitor
Comment=View node status
Exec=xpbsmon
Icon=xpbsmon.png
Terminal=false
Type=Application
Categories=Education;Science;ComputerScience;ParallelComputing;
Version=1.0

1311
SPECS/torque.spec Normal file

File diff suppressed because it is too large Load Diff