update to 6.1.3
This commit is contained in:
parent
d827aa5e9b
commit
bb3c39dfd8
1
.gitignore
vendored
1
.gitignore
vendored
@ -12,3 +12,4 @@
|
||||
/torque-4.2.6.1.tar.gz
|
||||
/torque-4.2.8.tar.gz
|
||||
/torque-4.2.10.tar.gz
|
||||
/torque-6.1.3.tar.xz
|
||||
|
3
sources
3
sources
@ -1,2 +1 @@
|
||||
3dd4348f54ba236ee7c208cc6b97f674 torque-4.2.8.tar.gz
|
||||
541f58ab46166e86d7a468500be3fa4d torque-4.2.10.tar.gz
|
||||
SHA512 (torque-6.1.3.tar.xz) = 9cace317a6331c8a043a11115161cd9a852623ce0ccbc6d745fcc16963a8fe63ed8e4c2d0922a9bd950a2aa6273246340ea32488c88d2e9e476067c3429f1b85
|
||||
|
33
torque-6.1.3-bool-fix.patch
Normal file
33
torque-6.1.3-bool-fix.patch
Normal file
@ -0,0 +1,33 @@
|
||||
diff -up torque/src/drmaa/src/compat.h.bool-fix torque/src/drmaa/src/compat.h
|
||||
--- torque/src/drmaa/src/compat.h.bool-fix 2021-01-28 17:59:06.149190046 -0500
|
||||
+++ torque/src/drmaa/src/compat.h 2021-01-28 17:59:16.941243507 -0500
|
||||
@@ -51,6 +51,7 @@ int asprintf(char **strp, const char *fm
|
||||
int vasprintf(char **strp, const char *fmt, va_list ap);
|
||||
#endif
|
||||
|
||||
+/*
|
||||
#ifndef HAVE_STDBOOL_H
|
||||
# ifndef bool
|
||||
# define bool int
|
||||
@@ -62,6 +63,7 @@ int vasprintf(char **strp, const char *f
|
||||
# define false 0
|
||||
# endif
|
||||
#endif
|
||||
+*/
|
||||
|
||||
#ifdef __cplusplus
|
||||
}
|
||||
diff -up torque/src/include/pbs_ifl.h.bool-fix torque/src/include/pbs_ifl.h
|
||||
--- torque/src/include/pbs_ifl.h.bool-fix 2021-01-28 16:14:24.000000000 -0500
|
||||
+++ torque/src/include/pbs_ifl.h 2021-01-28 17:50:17.068569045 -0500
|
||||
@@ -87,6 +87,10 @@
|
||||
#define _PBS_IFL_DEF
|
||||
#include <sys/socket.h>
|
||||
|
||||
+#ifdef __cplusplus
|
||||
+#include <stdbool.h>
|
||||
+#endif /* __cplusplus */
|
||||
+
|
||||
/* Attribute Names used by user commands */
|
||||
|
||||
#define ATTR_a "Execution_Time"
|
46
torque-6.1.3-port-args.patch
Normal file
46
torque-6.1.3-port-args.patch
Normal file
@ -0,0 +1,46 @@
|
||||
diff -up torque/contrib/init.d/pbs_mom.in.port-args torque/contrib/init.d/pbs_mom.in
|
||||
--- torque/contrib/init.d/pbs_mom.in.port-args 2021-01-28 16:29:53.554947436 -0500
|
||||
+++ torque/contrib/init.d/pbs_mom.in 2021-01-28 16:33:43.410074859 -0500
|
||||
@@ -25,6 +25,8 @@ SBIN_PATH=@sbindir@
|
||||
PBS_DAEMON="$SBIN_PATH/pbs_mom"
|
||||
PBS_HOME=@PBS_HOME@
|
||||
PBS_ARGS=""
|
||||
+# this should be the integer port value
|
||||
+PBS_PORT=""
|
||||
|
||||
SUBSYS_LOCK="/var/lock/subsys/pbs_mom"
|
||||
|
||||
@@ -32,6 +34,14 @@ if [ -f /etc/sysconfig/pbs_mom ];then
|
||||
. /etc/sysconfig/pbs_mom
|
||||
fi
|
||||
|
||||
+if [ -z "$PBS_PORT" ]; then
|
||||
+ momctl_port_arg=""
|
||||
+ pbs_mom_port_arg=""
|
||||
+else
|
||||
+ momctl_port_arg="$PBS_PORT"
|
||||
+ pbs_mom_port_arg="-M $PBS_PORT"
|
||||
+fi
|
||||
+
|
||||
MOM_LOCK="$PBS_HOME/mom_priv/mom.lock"
|
||||
|
||||
if [ -z "$previous" ];then
|
||||
@@ -84,7 +94,7 @@ kill_pbs_mom() {
|
||||
retval=1
|
||||
for i in {1..5}; do
|
||||
kill -0 $pid &>/dev/null || return 0
|
||||
- $SBIN_PATH/momctl -s && return $?
|
||||
+ $SBIN_PATH/momctl -s $momctl_port_arg && return $?
|
||||
sleep 1
|
||||
done
|
||||
return $retval
|
||||
@@ -110,7 +120,7 @@ case "$1" in
|
||||
fi
|
||||
|
||||
# ulimit -c unlimited # Uncomment this to preserve core files
|
||||
- daemon $PBS_DAEMON $args -d $PBS_HOME $PBS_ARGS
|
||||
+ daemon $PBS_DAEMON $args $pbs_mom_port_arg -d $PBS_HOME $PBS_ARGS
|
||||
RET=$?
|
||||
touch $SUBSYS_LOCK
|
||||
echo
|
||||
diff -up torque/contrib/init.d/pbs_sched.in.port-args torque/contrib/init.d/pbs_sched.in
|
318
torque-6.1.3-system-jsoncpp.patch
Normal file
318
torque-6.1.3-system-jsoncpp.patch
Normal file
@ -0,0 +1,318 @@
|
||||
diff -up torque/configure.ac.system-jsoncpp torque/configure.ac
|
||||
--- torque/configure.ac.system-jsoncpp 2021-01-28 17:33:44.008649547 -0500
|
||||
+++ torque/configure.ac 2021-01-28 17:37:26.446751483 -0500
|
||||
@@ -1311,6 +1311,13 @@ if test "x$HWLOC_CFLAGS" != "xnone"; the
|
||||
fi
|
||||
|
||||
|
||||
+PKG_CHECK_MODULES([JSONCPP], [jsoncpp],
|
||||
+ [ CFLAGS="$CFLAGS $JSONCPP_CFLAGS"; CPPFLAGS="$CPPFLAGS $JSONCPP_CFLAGS"; ],
|
||||
+ [ AC_MSG_ERROR([$JSONCPP_PKG_ERRORS])])
|
||||
+
|
||||
+LIBS="$LIBS $JSONCPP_LIBS";
|
||||
+
|
||||
+
|
||||
dnl enable pbs_mom to use the cpuset API from libcpuset
|
||||
dnl only makes sense with cpusets enabled
|
||||
AC_ARG_ENABLE(libcpuset, [ --enable-libcpuset Allows pbs_mom to use the cpuset API from libcpuset])
|
||||
diff -up torque/src/include/machine.hpp.system-jsoncpp torque/src/include/machine.hpp
|
||||
--- torque/src/include/machine.hpp.system-jsoncpp 2021-01-28 17:15:46.295362401 -0500
|
||||
+++ torque/src/include/machine.hpp 2021-01-28 17:15:58.310420979 -0500
|
||||
@@ -14,7 +14,7 @@
|
||||
#include "pbs_job.h"
|
||||
#include "req.hpp"
|
||||
#include "allocation.hpp"
|
||||
-#include "json/json.h"
|
||||
+#include <json/json.h>
|
||||
extern const int ALL_TASKS;
|
||||
|
||||
|
||||
diff -up torque/src/include/Makefile.am.system-jsoncpp torque/src/include/Makefile.am
|
||||
--- torque/src/include/Makefile.am.system-jsoncpp 2021-01-28 17:15:10.067185774 -0500
|
||||
+++ torque/src/include/Makefile.am 2021-01-28 17:15:22.285245341 -0500
|
||||
@@ -27,8 +27,8 @@ noinst_HEADERS = acct.h array.h assertio
|
||||
job_usage_info.hpp machine.hpp req.hpp complete_req.hpp trq_cgroups.h \
|
||||
job_recovery.h allocation.hpp attr_req_info.hpp acl_special.hpp restricted_host.hpp \
|
||||
pbs_helper.h mail_throttler.hpp lib_ifl.h runjob_help.hpp pmix_tracker.hpp \
|
||||
- pmix_operation.hpp job_host_data.hpp policy_values.h plugin_internal.h json/json.h \
|
||||
- json/json-forwards.h authorized_hosts.hpp numa_constants.h
|
||||
+ pmix_operation.hpp job_host_data.hpp policy_values.h plugin_internal.h \
|
||||
+ authorized_hosts.hpp numa_constants.h
|
||||
|
||||
BUILT_SOURCES = site_job_attr_def.h site_job_attr_enum.h \
|
||||
site_qmgr_node_print.h site_qmgr_que_print.h \
|
||||
diff -up torque/src/include/pbs_job.h.system-jsoncpp torque/src/include/pbs_job.h
|
||||
--- torque/src/include/pbs_job.h.system-jsoncpp 2021-01-28 17:16:09.054473361 -0500
|
||||
+++ torque/src/include/pbs_job.h 2021-01-28 17:18:26.715144482 -0500
|
||||
@@ -104,7 +104,7 @@
|
||||
#include "tcp.h" /* tcp_chan */
|
||||
#include "net_connect.h"
|
||||
#include "job_host_data.hpp"
|
||||
-#include "json/json.h"
|
||||
+#include <json/json.h>
|
||||
|
||||
|
||||
#define SAVEJOB_BUF_SIZE 8192
|
||||
diff -up torque/src/lib/Libutils/Makefile.am.system-jsoncpp torque/src/lib/Libutils/Makefile.am
|
||||
--- torque/src/lib/Libutils/Makefile.am.system-jsoncpp 2021-01-28 17:19:31.650461068 -0500
|
||||
+++ torque/src/lib/Libutils/Makefile.am 2021-01-28 17:19:42.934516083 -0500
|
||||
@@ -10,6 +10,6 @@ noinst_LIBRARIES = libutils.a
|
||||
libutils_a_SOURCES = u_groups.c u_tree.c u_mu.c u_MXML.c u_xml.c u_threadpool.c u_lock_ctl.c \
|
||||
u_mom_hierarchy.c u_hash_map_structs.c u_users.c u_constants.c u_mutex_mgr.cpp \
|
||||
u_misc.c u_putenv.c u_wrapper.c u_timer.cpp machine.cpp numa_chip.cpp \
|
||||
- numa_core.cpp numa_pci_device.cpp numa_socket.cpp allocation.cpp jsoncpp.cpp \
|
||||
+ numa_core.cpp numa_pci_device.cpp numa_socket.cpp allocation.cpp \
|
||||
authorized_hosts.cpp numa_constants.cpp
|
||||
|
||||
diff -up torque/src/resmom/catch_child.c.system-jsoncpp torque/src/resmom/catch_child.c
|
||||
--- torque/src/resmom/catch_child.c.system-jsoncpp 2021-01-28 17:20:20.852700949 -0500
|
||||
+++ torque/src/resmom/catch_child.c 2021-01-28 17:20:32.701758691 -0500
|
||||
@@ -51,7 +51,7 @@
|
||||
#include "pbs_cpuset.h"
|
||||
#endif
|
||||
#include "mom_config.h"
|
||||
-#include "json/json.h"
|
||||
+#include <json/json.h>
|
||||
|
||||
#define DIS_REPLY_READ_RETRY 10
|
||||
|
||||
diff -up torque/src/resmom/mom_server.c.system-jsoncpp torque/src/resmom/mom_server.c
|
||||
--- torque/src/resmom/mom_server.c.system-jsoncpp 2021-01-28 17:20:47.497830825 -0500
|
||||
+++ torque/src/resmom/mom_server.c 2021-01-28 17:21:04.386913166 -0500
|
||||
@@ -251,7 +251,7 @@
|
||||
#include "machine.hpp"
|
||||
#endif
|
||||
#ifdef USE_RESOURCE_PLUGIN
|
||||
-#include "json/json.h"
|
||||
+#include <json/json.h>
|
||||
#include "trq_plugin_api.h"
|
||||
#include "plugin_internal.h"
|
||||
#endif
|
||||
diff -up torque/src/resmom/parse_config.c.system-jsoncpp torque/src/resmom/parse_config.c
|
||||
--- torque/src/resmom/parse_config.c.system-jsoncpp 2021-01-28 17:21:14.600962963 -0500
|
||||
+++ torque/src/resmom/parse_config.c 2021-01-28 17:21:26.865022756 -0500
|
||||
@@ -99,7 +99,7 @@
|
||||
#include "mom_func.h"
|
||||
#include "authorized_hosts.hpp"
|
||||
#include "csv.h"
|
||||
-#include "json/json.h"
|
||||
+#include <json/json.h>
|
||||
#include "req.hpp"
|
||||
|
||||
void encode_used(job *pjob, int perm, Json::Value *, tlist_head *phead);
|
||||
diff -up torque/src/resmom/prolog.c.system-jsoncpp torque/src/resmom/prolog.c
|
||||
--- torque/src/resmom/prolog.c.system-jsoncpp 2021-01-28 17:21:37.352073884 -0500
|
||||
+++ torque/src/resmom/prolog.c 2021-01-28 17:21:49.191131604 -0500
|
||||
@@ -108,7 +108,7 @@
|
||||
#include "net_connect.h"
|
||||
#include "utils.h"
|
||||
#include "mom_config.h"
|
||||
-#include "json/json.h"
|
||||
+#include <json/json.h>
|
||||
|
||||
|
||||
const int PELOG_DOESNT_EXIST = -1;
|
||||
diff -up torque/src/resmom/requests.c.system-jsoncpp torque/src/resmom/requests.c
|
||||
--- torque/src/resmom/requests.c.system-jsoncpp 2021-01-28 17:22:05.545211337 -0500
|
||||
+++ torque/src/resmom/requests.c 2021-01-28 17:22:16.108262836 -0500
|
||||
@@ -123,7 +123,7 @@
|
||||
#include "power_state.hpp"
|
||||
#ifdef USE_RESOURCE_PLUGIN
|
||||
#include "plugin_internal.h"
|
||||
-#include "json/json.h"
|
||||
+#include <json/json.h>
|
||||
#endif
|
||||
|
||||
#ifdef _CRAY
|
||||
diff -up torque/src/server/job.cpp.system-jsoncpp torque/src/server/job.cpp
|
||||
--- torque/src/server/job.cpp.system-jsoncpp 2021-01-28 17:22:46.476410893 -0500
|
||||
+++ torque/src/server/job.cpp 2021-01-28 17:22:57.246463402 -0500
|
||||
@@ -1,7 +1,7 @@
|
||||
#include <pbs_config.h>
|
||||
#include "pbs_job.h"
|
||||
#include "log.h"
|
||||
-#include "json/json.h"
|
||||
+#include <json/json.h>
|
||||
|
||||
|
||||
/**
|
||||
diff -up torque/src/server/node_manager.c.system-jsoncpp torque/src/server/node_manager.c
|
||||
--- torque/src/server/node_manager.c.system-jsoncpp 2021-01-28 17:24:40.798968223 -0500
|
||||
+++ torque/src/server/node_manager.c 2021-01-28 17:24:52.041023032 -0500
|
||||
@@ -140,7 +140,7 @@
|
||||
#endif
|
||||
#include "runjob_help.hpp"
|
||||
#include "plugin_internal.h"
|
||||
-#include "json/json.h"
|
||||
+#include <json/json.h>
|
||||
#include "authorized_hosts.hpp"
|
||||
|
||||
#define IS_VALID_STR(STR) (((STR) != NULL) && ((STR)[0] != '\0'))
|
||||
diff -up torque/src/server/pbsnode.cpp.system-jsoncpp torque/src/server/pbsnode.cpp
|
||||
--- torque/src/server/pbsnode.cpp.system-jsoncpp 2021-01-28 17:22:27.386317821 -0500
|
||||
+++ torque/src/server/pbsnode.cpp 2021-01-28 17:22:38.162370359 -0500
|
||||
@@ -9,7 +9,7 @@
|
||||
#include "../lib/Libnet/lib_net.h" /* pbs_getaddrinfo */
|
||||
#include "alps_constants.h"
|
||||
#include "policy_values.h"
|
||||
-#include "json/json.h"
|
||||
+#include <json/json.h>
|
||||
#include "plugin_internal.h"
|
||||
|
||||
#define MSG_LEN_LONG 160
|
||||
diff -up torque/src/test/catch_child/scaffolding.c.system-jsoncpp torque/src/test/catch_child/scaffolding.c
|
||||
--- torque/src/test/catch_child/scaffolding.c.system-jsoncpp 2021-01-28 17:25:02.101072079 -0500
|
||||
+++ torque/src/test/catch_child/scaffolding.c 2021-01-28 17:25:14.307131588 -0500
|
||||
@@ -20,7 +20,7 @@
|
||||
#include "mom_func.h"
|
||||
#include "mom_job_cleanup.h"
|
||||
#include "complete_req.hpp"
|
||||
-#include "json/json.h"
|
||||
+#include <json/json.h>
|
||||
|
||||
int server_down;
|
||||
int called_open_socket = 0;
|
||||
diff -up torque/src/test/job/test_uut.c.system-jsoncpp torque/src/test/job/test_uut.c
|
||||
--- torque/src/test/job/test_uut.c.system-jsoncpp 2021-01-28 17:25:24.008178885 -0500
|
||||
+++ torque/src/test/job/test_uut.c 2021-01-28 17:25:33.824226742 -0500
|
||||
@@ -5,7 +5,7 @@
|
||||
|
||||
#include "pbs_error.h"
|
||||
#include "pbs_job.h"
|
||||
-#include "json/json.h"
|
||||
+#include <json/json.h>
|
||||
#include <check.h>
|
||||
|
||||
extern attribute_def job_attr_def[];
|
||||
diff -up torque/src/test/machine/scaffolding.c.system-jsoncpp torque/src/test/machine/scaffolding.c
|
||||
--- torque/src/test/machine/scaffolding.c.system-jsoncpp 2021-01-28 17:26:18.917446590 -0500
|
||||
+++ torque/src/test/machine/scaffolding.c 2021-01-28 17:26:28.467493151 -0500
|
||||
@@ -6,7 +6,7 @@
|
||||
#include "pbs_error.h"
|
||||
#include "allocation.hpp"
|
||||
#include "complete_req.hpp"
|
||||
-#include "json/json.h"
|
||||
+#include <json/json.h>
|
||||
#include "numa_constants.h"
|
||||
|
||||
int num_for_host;
|
||||
diff -up torque/src/test/machine/test_uut.c.system-jsoncpp torque/src/test/machine/test_uut.c
|
||||
--- torque/src/test/machine/test_uut.c.system-jsoncpp 2021-01-28 17:26:37.960539433 -0500
|
||||
+++ torque/src/test/machine/test_uut.c 2021-01-28 17:26:48.545591403 -0500
|
||||
@@ -9,7 +9,7 @@
|
||||
#include "pbs_job.h"
|
||||
#include "complete_req.hpp"
|
||||
#include "pbs_config.h"
|
||||
-#include "json/json.h"
|
||||
+#include <json/json.h>
|
||||
|
||||
extern int hardware_style;
|
||||
|
||||
diff -up torque/src/test/node_manager/scaffolding.c.system-jsoncpp torque/src/test/node_manager/scaffolding.c
|
||||
--- torque/src/test/node_manager/scaffolding.c.system-jsoncpp 2021-01-28 17:25:45.583284073 -0500
|
||||
+++ torque/src/test/node_manager/scaffolding.c 2021-01-28 17:25:57.028339872 -0500
|
||||
@@ -21,7 +21,7 @@
|
||||
#include "id_map.hpp"
|
||||
#include "machine.hpp"
|
||||
#include "complete_req.hpp"
|
||||
-#include "json/json.h"
|
||||
+#include <json/json.h>
|
||||
#include "authorized_hosts.hpp"
|
||||
|
||||
|
||||
diff -up torque/src/test/node_manager/test_uut.c.system-jsoncpp torque/src/test/node_manager/test_uut.c
|
||||
--- torque/src/test/node_manager/test_uut.c.system-jsoncpp 2021-01-28 17:26:59.731646817 -0500
|
||||
+++ torque/src/test/node_manager/test_uut.c 2021-01-28 17:27:08.815691817 -0500
|
||||
@@ -12,7 +12,7 @@
|
||||
#include "test_uut.h"
|
||||
#include "pbs_error.h"
|
||||
#include "server.h"
|
||||
-#include "json/json.h"
|
||||
+#include <json/json.h>
|
||||
#include "complete_req.hpp"
|
||||
#include "pbs_nodes.h"
|
||||
|
||||
diff -up torque/src/test/numa_chip/scaffolding.c.system-jsoncpp torque/src/test/numa_chip/scaffolding.c
|
||||
--- torque/src/test/numa_chip/scaffolding.c.system-jsoncpp 2021-01-28 17:27:17.770736185 -0500
|
||||
+++ torque/src/test/numa_chip/scaffolding.c 2021-01-28 17:27:25.892776426 -0500
|
||||
@@ -4,7 +4,7 @@
|
||||
#include "log.h"
|
||||
#include "pbs_error.h"
|
||||
#include "machine.hpp"
|
||||
-#include "json/json.h"
|
||||
+#include <json/json.h>
|
||||
#include "numa_constants.h"
|
||||
|
||||
const char *use_cores = "usecores";
|
||||
diff -up torque/src/test/numa_chip/test_uut.c.system-jsoncpp torque/src/test/numa_chip/test_uut.c
|
||||
--- torque/src/test/numa_chip/test_uut.c.system-jsoncpp 2021-01-28 17:27:33.612814672 -0500
|
||||
+++ torque/src/test/numa_chip/test_uut.c 2021-01-28 17:27:41.267852594 -0500
|
||||
@@ -6,7 +6,7 @@
|
||||
#include "hwloc.h"
|
||||
#include "pbs_error.h"
|
||||
#include <sstream>
|
||||
-#include "json/json.h"
|
||||
+#include <json/json.h>
|
||||
|
||||
extern int recorded;
|
||||
|
||||
diff -up torque/src/test/numa_socket/scaffolding.c.system-jsoncpp torque/src/test/numa_socket/scaffolding.c
|
||||
--- torque/src/test/numa_socket/scaffolding.c.system-jsoncpp 2021-01-28 17:27:51.494903256 -0500
|
||||
+++ torque/src/test/numa_socket/scaffolding.c 2021-01-28 17:28:01.090950793 -0500
|
||||
@@ -6,7 +6,7 @@
|
||||
#include "pbs_error.h"
|
||||
#include "req.hpp"
|
||||
#include "allocation.hpp"
|
||||
-#include "json/json.h"
|
||||
+#include <json/json.h>
|
||||
|
||||
int hardware_style;
|
||||
float tasks;
|
||||
diff -up torque/src/test/numa_socket/test_uut.c.system-jsoncpp torque/src/test/numa_socket/test_uut.c
|
||||
--- torque/src/test/numa_socket/test_uut.c.system-jsoncpp 2021-01-28 17:28:13.915014321 -0500
|
||||
+++ torque/src/test/numa_socket/test_uut.c 2021-01-28 17:28:22.609057389 -0500
|
||||
@@ -8,7 +8,7 @@
|
||||
#include "pbs_error.h"
|
||||
#include "allocation.hpp"
|
||||
#include "req.hpp"
|
||||
-#include "json/json.h"
|
||||
+#include <json/json.h>
|
||||
|
||||
extern float tasks;
|
||||
extern int placed;
|
||||
diff -up torque/src/test/parse_config/scaffolding.c.system-jsoncpp torque/src/test/parse_config/scaffolding.c
|
||||
--- torque/src/test/parse_config/scaffolding.c.system-jsoncpp 2021-01-28 17:29:00.388244539 -0500
|
||||
+++ torque/src/test/parse_config/scaffolding.c 2021-01-28 17:29:10.473294499 -0500
|
||||
@@ -7,7 +7,7 @@
|
||||
#include "pbs_job.h"
|
||||
#include "u_tree.h"
|
||||
#include "log.h"
|
||||
-#include "json/json.h"
|
||||
+#include <json/json.h>
|
||||
#include "authorized_hosts.hpp"
|
||||
|
||||
#define LOG_BUF_SIZE 16384
|
||||
diff -up torque/src/test/parse_config/test_uut.c.system-jsoncpp torque/src/test/parse_config/test_uut.c
|
||||
--- torque/src/test/parse_config/test_uut.c.system-jsoncpp 2021-01-28 17:28:40.823147618 -0500
|
||||
+++ torque/src/test/parse_config/test_uut.c 2021-01-28 17:28:51.173198890 -0500
|
||||
@@ -5,7 +5,7 @@
|
||||
|
||||
#include "pbs_job.h"
|
||||
#include "mom_func.h"
|
||||
-#include "json/json.h"
|
||||
+#include <json/json.h>
|
||||
|
||||
extern int encode_used_ctr;
|
||||
extern int encode_flagged_attrs_ctr;
|
||||
diff -up torque/src/test/prolog/scaffolding.c.system-jsoncpp torque/src/test/prolog/scaffolding.c
|
||||
--- torque/src/test/prolog/scaffolding.c.system-jsoncpp 2021-01-28 17:29:18.930336393 -0500
|
||||
+++ torque/src/test/prolog/scaffolding.c 2021-01-28 17:29:28.645384519 -0500
|
||||
@@ -13,7 +13,7 @@
|
||||
#include "libpbs.h" /* job_file */
|
||||
#include "mom_config.h"
|
||||
#include "mom_mach.h"
|
||||
-#include "json/json.h"
|
||||
+#include <json/json.h>
|
||||
|
||||
#define MAXLINE 1024
|
||||
|
87
torque.spec
87
torque.spec
@ -73,10 +73,16 @@
|
||||
%global server_nameflags --with-default-server=%{server_name}
|
||||
|
||||
Name: torque
|
||||
Version: 4.2.10
|
||||
Release: 30%{?dist}
|
||||
Version: 6.1.3
|
||||
Release: 1%{?dist}
|
||||
Summary: Tera-scale Open-source Resource and QUEue manager
|
||||
Source0: http://www.adaptivecomputing.com/download/%{name}/%{name}-%{version}.tar.gz
|
||||
# Source0: http://www.adaptivecomputing.com/download/%%{name}/%%{name}-%%{version}.tar.gz
|
||||
# git clone https://github.com/adaptivecomputing/torque.git
|
||||
# cd torque
|
||||
# git checkout 6.1.3
|
||||
# cd ..
|
||||
# tar cvfJ torque-6.1.3.tar.xz torque/
|
||||
Source0: %{name}-%{version}.tar.xz
|
||||
Source2: xpbs.desktop
|
||||
Source3: xpbsmon.desktop
|
||||
Source4: xpbs.png
|
||||
@ -98,11 +104,14 @@ Source100: pbs-config
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=713996
|
||||
Patch1: torque-munge-size.patch
|
||||
Patch2: torque-%{version}-port-args.patch
|
||||
Patch2: torque-6.1.3-port-args.patch
|
||||
# Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1424149
|
||||
Patch3: torque-%{version}-fix-bad-crypto-check.patch
|
||||
# From https://github.com/adaptivecomputing/torque/pull/148
|
||||
Patch4: torque-%{version}-remove-unused-header.patch
|
||||
# Patch3: torque-4.2.10-fix-bad-crypto-check.patch
|
||||
# Use system jsoncpp
|
||||
Patch4: torque-6.1.3-system-jsoncpp.patch
|
||||
# Include stdbool.h to build pbs-drmaa
|
||||
Patch5: torque-6.1.3-bool-fix.patch
|
||||
|
||||
|
||||
License: OpenPBS and TORQUEv1.1
|
||||
URL: http://www.adaptivecomputing.com/products/open-source/torque/
|
||||
@ -118,6 +127,9 @@ BuildRequires: openssl-devel
|
||||
BuildRequires: hwloc-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: munge-devel
|
||||
BuildRequires: autoconf, automake, libtool
|
||||
BuildRequires: jsoncpp-devel
|
||||
|
||||
%if %{use_tcl}
|
||||
BuildRequires: tcl-devel
|
||||
%endif
|
||||
@ -376,16 +388,17 @@ DRMAA is "Distributed Resource Management Application API"
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n torque-%{version}
|
||||
%patch1 -p 1
|
||||
%patch2 -p 1
|
||||
%patch3 -p 0
|
||||
%patch4 -p 1
|
||||
%setup -q -n torque
|
||||
%patch1 -p 1 -b .munge-size
|
||||
%patch2 -p 1 -b .port-args
|
||||
# %%patch3 -p 0 -b .fix-bad-crypto-check
|
||||
%patch4 -p1 -b .system-jsoncpp
|
||||
%patch5 -p1 -b .bool-fix
|
||||
rm -rf src/lib/Libutils/jsoncpp.cpp src/include/json
|
||||
sed -i '/LATEX_BATCHMODE/d' src/drmaa/Doxyfile.in
|
||||
install -pm 644 %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} \
|
||||
%{SOURCE6} %{SOURCE8} .
|
||||
# rm x bit on some documentation.
|
||||
chmod 644 torque.setup
|
||||
autoreconf -ifv
|
||||
|
||||
%build
|
||||
# -fpermissive added to downgrade numerous 'invalid conversion' errors to warnings
|
||||
@ -411,6 +424,15 @@ done
|
||||
%install
|
||||
make DESTDIR=%{buildroot} INSTALL="install -p" install
|
||||
|
||||
%if %{doxydoc}
|
||||
# spit and bailing wire.
|
||||
# make the drmaa docs and install the manpages.
|
||||
pushd src/drmaa
|
||||
doxygen
|
||||
install -p doc/man/man3/*.3 %{buildroot}%{_mandir}/man3/
|
||||
popd
|
||||
%endif
|
||||
|
||||
# remove files we don't need
|
||||
rm -f %{buildroot}%{_libdir}/*.la
|
||||
rm -f %{buildroot}%{_libdir}/*/buildindex
|
||||
@ -502,18 +524,6 @@ ln -s %{_var}/log/torque/server_logs .
|
||||
popd
|
||||
|
||||
|
||||
# Move drmaa man pages to correct place
|
||||
# and delete the three copies of the same documentation.
|
||||
|
||||
%if 0%{?doxydoc}
|
||||
rm -f %{buildroot}%{_defaultdocdir}/torque-drmaa/man/man3/*_src_drmaa_src_.3
|
||||
mv %{buildroot}%{_defaultdocdir}/torque-drmaa/man/man3/* %{buildroot}%{_mandir}/man3/.
|
||||
rm -rf %{buildroot}%{_defaultdocdir}/torque-drmaa/html/*
|
||||
rm -rf %{buildroot}%{_defaultdocdir}/torque-drmaa/latex/*
|
||||
# Include drmaa.pdf later from the src tree.
|
||||
rm %{buildroot}%{_defaultdocdir}/torque-drmaa/drmaa.pdf
|
||||
%endif
|
||||
|
||||
#Remove man page for binary that is not included.
|
||||
rm %{buildroot}%{_mandir}/man1/basl2c.1
|
||||
|
||||
@ -524,6 +534,15 @@ chmod 755 `find %{buildroot}/var/lib/torque -type d`
|
||||
mv %{buildroot}%{_bindir}/pbs-config %{buildroot}%{_bindir}/pbs-config-%{uname_m_arch}
|
||||
install -m0755 -p %{SOURCE100} %{buildroot}%{_bindir}/pbs-config
|
||||
|
||||
# We do not need a ld.so.conf.d file to point to %%{_libdir}
|
||||
rm -rf %{buildroot}%{_sysconfdir}/ld.so.conf.d
|
||||
|
||||
# We also do not need profile.d files to put /usr/bin and /usr/sbin in the path
|
||||
rm -rf %{buildroot}%{_sysconfdir}/profile.d
|
||||
|
||||
# It also installs a ton of binary stuff under /usr/share/doc/torque-drmaa that is not useful
|
||||
rm -rf %{buildroot}%{_datadir}/doc/torque-drmaa
|
||||
|
||||
%post
|
||||
# fix mistake in previous release
|
||||
sed -i '/pbs_mon/D' /etc/services
|
||||
@ -737,7 +756,7 @@ fi
|
||||
%files docs
|
||||
%doc doc/admin_guide.ps
|
||||
%if 0%{?doxydoc}
|
||||
%doc src/drmaa/drmaa.pdf
|
||||
# %%doc src/drmaa/doc/drmaa.pdf
|
||||
%endif
|
||||
|
||||
%if %{build_gui}
|
||||
@ -868,21 +887,14 @@ fi
|
||||
%{_mandir}/man3/compat.h.3.*
|
||||
%{_mandir}/man3/drmaa.3.*
|
||||
%{_mandir}/man3/drmaa.h.3.*
|
||||
%{_mandir}/man3/drmaa_attr_names_s.3.*
|
||||
%{_mandir}/man3/drmaa_attr_values_s.3.*
|
||||
%{_mandir}/man3/drmaa_attrib.3.*
|
||||
%{_mandir}/man3/drmaa_attrib_info_s.3.*
|
||||
%{_mandir}/man3/drmaa_submission_context_s.3.*
|
||||
%{_mandir}/man3/drmaa_job_ids_s.3.*
|
||||
%{_mandir}/man3/drmaa_def_attr_s.3.*
|
||||
%{_mandir}/man3/pbs_attrib.3.*
|
||||
%{_mandir}/man3/drmaa_viter.3.*
|
||||
%{_mandir}/man3/drmaa_job_iter_s.3.*
|
||||
%{_mandir}/man3/drmaa_job_s.3.*
|
||||
%{_mandir}/man3/drmaa_job_template_s.3.*
|
||||
%{_mandir}/man3/drmaa_jobt.3.*
|
||||
%{_mandir}/man3/drmaa_session.3.*
|
||||
%{_mandir}/man3/drmaa_session_s.3.*
|
||||
%{_mandir}/man3/drmaa_viter.3.*
|
||||
%{_mandir}/man3/pbs_attrib.3.*
|
||||
%{_mandir}/man3/error.h.3.*
|
||||
%{_mandir}/man3/jobs.3.*
|
||||
%{_mandir}/man3/jobs.h.3.*
|
||||
@ -890,6 +902,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Jan 29 2021 Tom Callaway <spot@fedoraproject.org> - 6.1.3-1
|
||||
- update to 6.1.3
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.10-30
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user