Big update to 2.5.7-1, drop torque-buffer-overrun-2.3.13.patch,
change license from OpenPBS to OpenPBS and TORQUEv1.1
This commit is contained in:
parent
fc87943b30
commit
6b1b8e65d1
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
|||||||
torque-2.3.10.tar.gz
|
torque-2.3.10.tar.gz
|
||||||
/torque-2.3.12.tar.gz
|
/torque-2.3.12.tar.gz
|
||||||
/torque-2.3.13.tar.gz
|
/torque-2.3.13.tar.gz
|
||||||
|
/torque-2.5.7.tar.gz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
d59ae7f27d622c4ecd3a5b07686266f2 torque-2.3.13.tar.gz
|
aa033adc22df8ab333e5014dd93754b6 torque-2.5.7.tar.gz
|
||||||
|
@ -1,122 +0,0 @@
|
|||||||
diff -uNr torque-2.3.13.ORIG/src/lib/Libnet/get_hostaddr.c torque-2.3.13/src/lib/Libnet/get_hostaddr.c
|
|
||||||
--- torque-2.3.13.ORIG/src/lib/Libnet/get_hostaddr.c 2011-06-08 16:21:35.185913002 +0200
|
|
||||||
+++ torque-2.3.13/src/lib/Libnet/get_hostaddr.c 2011-06-08 16:30:06.784913002 +0200
|
|
||||||
@@ -143,7 +143,8 @@
|
|
||||||
|
|
||||||
if (hp == NULL)
|
|
||||||
{
|
|
||||||
- sprintf(log_buffer,"cannot resolve IP address for host '%s' herror=%d: %s",
|
|
||||||
+ snprintf(log_buffer, sizeof(log_buffer),
|
|
||||||
+ "cannot resolve IP address for host '%s' herror=%d: %s",
|
|
||||||
hostname,
|
|
||||||
h_errno,
|
|
||||||
hstrerror(h_errno));
|
|
||||||
diff -uNr torque-2.3.13.ORIG/src/server/req_quejob.c torque-2.3.13/src/server/req_quejob.c
|
|
||||||
--- torque-2.3.13.ORIG/src/server/req_quejob.c 2011-06-08 16:21:35.244913002 +0200
|
|
||||||
+++ torque-2.3.13/src/server/req_quejob.c 2011-06-08 16:29:05.238913002 +0200
|
|
||||||
@@ -930,17 +930,20 @@
|
|
||||||
{
|
|
||||||
if (errno == 0)
|
|
||||||
{
|
|
||||||
- sprintf(log_buffer, "job %s in unexpected state '%s'",
|
|
||||||
- pj->ji_qs.ji_jobid,
|
|
||||||
- PJobSubState[pj->ji_qs.ji_substate]);
|
|
||||||
+ snprintf(log_buffer, sizeof(log_buffer),
|
|
||||||
+ "job %s in unexpected state '%s'",
|
|
||||||
+ pj->ji_qs.ji_jobid,
|
|
||||||
+ PJobSubState[pj->ji_qs.ji_substate]);
|
|
||||||
+
|
|
||||||
}
|
|
||||||
else
|
|
||||||
{
|
|
||||||
- sprintf(log_buffer, "job %s in unexpected state '%s' (errno=%d - %s)",
|
|
||||||
- pj->ji_qs.ji_jobid,
|
|
||||||
- PJobSubState[pj->ji_qs.ji_substate],
|
|
||||||
- errno,
|
|
||||||
- strerror(errno));
|
|
||||||
+ snprintf(log_buffer, sizeof(log_buffer),
|
|
||||||
+ "job %s in unexpected state '%s' (errno=%d - %s)",
|
|
||||||
+ pj->ji_qs.ji_jobid,
|
|
||||||
+ PJobSubState[pj->ji_qs.ji_substate],
|
|
||||||
+ errno,
|
|
||||||
+ strerror(errno));
|
|
||||||
}
|
|
||||||
|
|
||||||
log_err(errno, id, log_buffer);
|
|
||||||
@@ -1141,9 +1144,10 @@
|
|
||||||
|
|
||||||
if (LOGLEVEL >= 6)
|
|
||||||
{
|
|
||||||
- sprintf(log_buffer, "successfully moved file '%s' for job '%s'",
|
|
||||||
- namebuf,
|
|
||||||
- preq->rq_ind.rq_jobfile.rq_jobid);
|
|
||||||
+ snprintf(log_buffer, sizeof(log_buffer),
|
|
||||||
+ "successfully moved file '%s' for job '%s'",
|
|
||||||
+ namebuf,
|
|
||||||
+ preq->rq_ind.rq_jobfile.rq_jobid);
|
|
||||||
|
|
||||||
log_record(
|
|
||||||
PBSEVENT_JOB,
|
|
||||||
@@ -1251,9 +1255,11 @@
|
|
||||||
{
|
|
||||||
char tmpLine[1024];
|
|
||||||
|
|
||||||
- sprintf(tmpLine, "cannot save job - errno=%d - %s",
|
|
||||||
- errno,
|
|
||||||
- strerror(errno));
|
|
||||||
+ snprintf(tmpLine, sizeof(tmpLine),
|
|
||||||
+ "cannot save job - errno=%d - %s",
|
|
||||||
+ errno,
|
|
||||||
+ strerror(errno));
|
|
||||||
+
|
|
||||||
|
|
||||||
log_err(errno, "req_rdytocommit", tmpLine);
|
|
||||||
|
|
||||||
@@ -1277,9 +1283,11 @@
|
|
||||||
{
|
|
||||||
/* reply failed, purge the job and close the connection */
|
|
||||||
|
|
||||||
- sprintf(log_buffer, "cannot report jobid - errno=%d - %s",
|
|
||||||
- errno,
|
|
||||||
- strerror(errno));
|
|
||||||
+ snprintf(log_buffer, sizeof(log_buffer),
|
|
||||||
+ "cannot report jobid - errno=%d - %s",
|
|
||||||
+ errno,
|
|
||||||
+ strerror(errno));
|
|
||||||
+
|
|
||||||
|
|
||||||
log_err(errno, "req_rdytocommit", log_buffer);
|
|
||||||
|
|
||||||
@@ -1557,11 +1565,13 @@
|
|
||||||
|
|
||||||
/* need to format message first, before request goes away */
|
|
||||||
|
|
||||||
- sprintf(log_buffer, msg_jobnew,
|
|
||||||
- preq->rq_user, preq->rq_host,
|
|
||||||
- pj->ji_wattr[(int)JOB_ATR_job_owner].at_val.at_str,
|
|
||||||
- pj->ji_wattr[(int)JOB_ATR_jobname].at_val.at_str,
|
|
||||||
- pj->ji_qhdr->qu_qs.qu_name);
|
|
||||||
+ snprintf(log_buffer, sizeof(log_buffer),
|
|
||||||
+ msg_jobnew,
|
|
||||||
+ preq->rq_user, preq->rq_host,
|
|
||||||
+ pj->ji_wattr[JOB_ATR_job_owner].at_val.at_str,
|
|
||||||
+ pj->ji_wattr[JOB_ATR_jobname].at_val.at_str,
|
|
||||||
+ pj->ji_qhdr->qu_qs.qu_name);
|
|
||||||
+
|
|
||||||
|
|
||||||
/* acknowledge the request with the job id */
|
|
||||||
|
|
||||||
@@ -1591,8 +1601,11 @@
|
|
||||||
{
|
|
||||||
if (LOGLEVEL >= 7)
|
|
||||||
{
|
|
||||||
- sprintf(log_buffer, "Trying to AUTORUN job %s",
|
|
||||||
- pj->ji_qs.ji_jobid);
|
|
||||||
+ snprintf(log_buffer, sizeof(log_buffer),
|
|
||||||
+ "Trying to AUTORUN job %s",
|
|
||||||
+ pj->ji_qs.ji_jobid);
|
|
||||||
+
|
|
||||||
+
|
|
||||||
log_record(
|
|
||||||
PBSEVENT_JOB,
|
|
||||||
PBS_EVENTCLASS_JOB,
|
|
16
torque.spec
16
torque.spec
@ -1,9 +1,9 @@
|
|||||||
|
|
||||||
# comment out snap if building a real release
|
# comment out snap if building a real release
|
||||||
%define name torque
|
%define name torque
|
||||||
%define version 2.3.13
|
%define version 2.5.7
|
||||||
#%%define snap 200604251602
|
#%%define snap 200604251602
|
||||||
%define release 2
|
%define release 1
|
||||||
|
|
||||||
# The following options are supported:
|
# The following options are supported:
|
||||||
# --with server_name=hostname
|
# --with server_name=hostname
|
||||||
@ -92,9 +92,7 @@ Source4: xpbs.png
|
|||||||
Source5: xpbsmon.png
|
Source5: xpbsmon.png
|
||||||
Source6: README-localhost
|
Source6: README-localhost
|
||||||
Source7: pbs-config-multilib
|
Source7: pbs-config-multilib
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=711463
|
License: OpenPBS and TORQUEv1.1
|
||||||
Patch0: torque-buffer-overrun-2.3.13.patch
|
|
||||||
License: OpenPBS
|
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
URL: http://www.clusterresources.com/products/torque/
|
URL: http://www.clusterresources.com/products/torque/
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -124,7 +122,6 @@ This package holds just a few shared files and directories.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n torque-%{version}%{?snap:-snap.%snap}
|
%setup -q -n torque-%{version}%{?snap:-snap.%snap}
|
||||||
%patch0 -p1
|
|
||||||
%__install -pm 644 %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7} .
|
%__install -pm 644 %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7} .
|
||||||
|
|
||||||
|
|
||||||
@ -212,7 +209,8 @@ fi
|
|||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-, root, root)
|
%defattr(-, root, root)
|
||||||
%doc README.torque torque.setup Release_Notes CHANGELOG PBS_License.txt README-localhost
|
%doc README.torque torque.setup Release_Notes
|
||||||
|
%doc CHANGELOG PBS_License_2.5.txt contrib/PBS_License_2.3.txt
|
||||||
%config(noreplace) %{torquehomedir}/pbs_environment
|
%config(noreplace) %{torquehomedir}/pbs_environment
|
||||||
%config(noreplace) %{torquehomedir}/server_name
|
%config(noreplace) %{torquehomedir}/server_name
|
||||||
%dir %{torquehomedir}
|
%dir %{torquehomedir}
|
||||||
@ -467,6 +465,10 @@ A simple PAM module to authorize users on PBS MOM nodes with a running job.
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jul 26 2011 Steve Traylen <steve.traylen@cern.ch> - 2.5.7-1
|
||||||
|
- Big update to 2.5.7-1, drop torque-buffer-overrun-2.3.13.patch,
|
||||||
|
change license from OpenPBS to OpenPBS and TORQUEv1.1
|
||||||
|
|
||||||
* Wed Jun 8 2011 Steve Traylen <steve.traylen@cern.ch> - 2.3.13-2
|
* Wed Jun 8 2011 Steve Traylen <steve.traylen@cern.ch> - 2.3.13-2
|
||||||
- Add torque-buffer-overrun.patch , rhbz#711463
|
- Add torque-buffer-overrun.patch , rhbz#711463
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user