Merge branch 'master' into el6
Conflicts: .gitignore sources torque.spec
This commit is contained in:
commit
39024ef74f
5
.gitignore
vendored
5
.gitignore
vendored
@ -1,3 +1,2 @@
|
||||
torque-2.4.8.tar.gz
|
||||
/torque-2.4.10.tar.gz
|
||||
/torque-2.4.11.tar.gz
|
||||
/torque-2.5.2.tar.gz
|
||||
/torque-2.5.3.tar.gz
|
||||
|
@ -1,103 +0,0 @@
|
||||
#! /bin/sh
|
||||
|
||||
package="pbs"
|
||||
version="2.1.8"
|
||||
|
||||
prefix="/usr"
|
||||
exec_prefix="/usr"
|
||||
bindir="/usr/bin"
|
||||
sbindir="/usr/sbin"
|
||||
libexecdir="/usr/libexec"
|
||||
datadir="/usr/share"
|
||||
sysconfdir="/etc"
|
||||
sharedstatedir="/usr/com"
|
||||
localstatedir="/var"
|
||||
infodir="/usr/share/info"
|
||||
mandir="/usr/share/man"
|
||||
includedir="/usr/include/torque"
|
||||
libs="-ltorque"
|
||||
|
||||
if test "$#" -eq 0; then
|
||||
cat <<EOF
|
||||
Usage: $package-config OPTIONS
|
||||
Options:
|
||||
--prefix=DIR) : \$prefix
|
||||
--package) : \$package
|
||||
--version) : \$version
|
||||
--cflags) : -I\$includedir
|
||||
--libs) : \$libs
|
||||
--help) print all the options (not just these)
|
||||
EOF
|
||||
fi
|
||||
|
||||
o=""
|
||||
h=""
|
||||
for i in "$@"; do
|
||||
case $i in
|
||||
--prefix=*) prefix=`echo $i | sed -e "s/--prefix=//"` ;;
|
||||
--prefix) o="$o $prefix" ;;
|
||||
--package) o="$o $package" ;;
|
||||
--version) o="$o $version" ;;
|
||||
--cflags) if test "_$includedir" != "_/usr/include"
|
||||
then o="$o -I$includedir" ; fi
|
||||
;;
|
||||
--libs) o="$o $libs" ;;
|
||||
--exec_prefix|--eprefix) o="$o $exec_prefix" ;;
|
||||
--bindir) o="$o $bindir" ;;
|
||||
--sbindir) o="$o $sbindir" ;;
|
||||
--libexecdir) o="$o $libexecdir" ;;
|
||||
--datadir) o="$o $datadir" ;;
|
||||
--datainc) o="$o -I$datadir" ;;
|
||||
--datalib) o="$o -L$datadir" ;;
|
||||
--sysconfdir) o="$o $sysconfdir" ;;
|
||||
--sharedstatedir) o="$o $sharedstatedir" ;;
|
||||
--localstatedir) o="$o $localstatedir" ;;
|
||||
--infodir) o="$o $infodir" ;;
|
||||
--mandir) o="$o $mandir" ;;
|
||||
--includedir) o="$o $includedir" ;;
|
||||
--data) o="$o -I$datadir/$package" ;;
|
||||
--pkgdatadir) o="$o $datadir/$package" ;;
|
||||
--pkgdatainc) o="$o -I$datadir/$package" ;;
|
||||
--pkgdatalib) o="$o -L$datadir/$package" ;;
|
||||
--pkglibinc) o="$o -I$libinc/$package" ;;
|
||||
--pkglibadd) o="$o -L$libadd/$package" ;;
|
||||
--pkgincludedir) o="$o $includedir/$package" ;;
|
||||
--help) h="1" ;;
|
||||
-?//*|-?/*//*|-?./*//*|//*|/*//*|./*//*)
|
||||
v=`echo $i | sed -e s://:\$:g`
|
||||
v=`eval "echo $v"`
|
||||
o="$o $v" ;;
|
||||
esac
|
||||
done
|
||||
|
||||
o=`eval "echo $o"`
|
||||
o=`eval "echo $o"`
|
||||
eval "echo $o"
|
||||
|
||||
if test ! -z "$h" ; then
|
||||
cat <<EOF
|
||||
--prefix=xxx) (what is that for anyway?)
|
||||
--prefix) \$prefix $prefix
|
||||
--package) \$package $package
|
||||
--version) \$version $version
|
||||
--cflags) -I\$includedir unless it is /usr/include
|
||||
--libs) -l\$PACKAGE \$LIBS
|
||||
--exec_prefix) or...
|
||||
--eprefix) \$exec_prefix $exec_prefix
|
||||
--bindir) \$bindir $bindir
|
||||
--sbindir) \$sbindir $sbindir
|
||||
--libexecdir) \$libexecdir $libexecdir
|
||||
--datadir) \$datadir $datadir
|
||||
--sysconfdir) \$sysconfdir $sysconfdir
|
||||
--sharedstatedir) \$sharedstatedir$sharedstatedir
|
||||
--localstatedir) \$localstatedir $localstatedir
|
||||
--infodir) \$infodir $infodir
|
||||
--mandir) \$mandir $mandir
|
||||
--data) -I\$datadir/\$package
|
||||
--pkgdatadir) \$datadir/\$package
|
||||
--pkgincludedir) \$includedir/\$package
|
||||
--help) generated by ac_create_generic_config.m4
|
||||
-I//varname and other inc-targets like --pkgdatainc supported
|
||||
-L//varname and other lib-targets, e.g. --pkgdatalib or --libadd
|
||||
EOF
|
||||
fi
|
2
sources
2
sources
@ -1 +1 @@
|
||||
797eb4a80b75fb76ec99c75efd76e781 torque-2.4.11.tar.gz
|
||||
b7868cf95582e20f2725651f97266947 torque-2.5.3.tar.gz
|
||||
|
45
torque-cond-touch.patch
Normal file
45
torque-cond-touch.patch
Normal file
@ -0,0 +1,45 @@
|
||||
diff -uNr torque-2.5.2.ORIG/contrib/init.d/pbs_mom torque-2.5.2/contrib/init.d/pbs_mom
|
||||
--- torque-2.5.2.ORIG/contrib/init.d/pbs_mom 2010-10-14 21:47:05.035383236 +0200
|
||||
+++ torque-2.5.2/contrib/init.d/pbs_mom 2010-10-14 21:49:38.433427973 +0200
|
||||
@@ -54,7 +54,7 @@
|
||||
# ulimit -c unlimited # Uncomment this to preserve core files
|
||||
daemon $PBS_DAEMON $args -d $PBS_HOME
|
||||
RET=$?
|
||||
- touch /var/lock/subsys/pbs_mom
|
||||
+ [ $RET -eq 0 ] && touch /var/lock/subsys/pbs_mom
|
||||
echo
|
||||
;;
|
||||
purge)
|
||||
@@ -62,7 +62,7 @@
|
||||
echo -n "Starting TORQUE Mom with purge: "
|
||||
daemon $PBS_DAEMON -r
|
||||
RET=$?
|
||||
- touch /var/lock/subsys/pbs_mom
|
||||
+ [ $RET -eq 0 ] && touch /var/lock/subsys/pbs_mom
|
||||
echo
|
||||
;;
|
||||
stop)
|
||||
diff -uNr torque-2.5.2.ORIG/contrib/init.d/pbs_sched torque-2.5.2/contrib/init.d/pbs_sched
|
||||
--- torque-2.5.2.ORIG/contrib/init.d/pbs_sched 2010-10-14 21:47:05.034384022 +0200
|
||||
+++ torque-2.5.2/contrib/init.d/pbs_sched 2010-10-14 21:50:32.826542794 +0200
|
||||
@@ -22,7 +22,7 @@
|
||||
echo -n "Starting TORQUE Scheduler: "
|
||||
daemon $PBS_DAEMON -d $PBS_HOME
|
||||
RET=$?
|
||||
- touch /var/lock/subsys/pbs_sched
|
||||
+ [ $RET -eq 0 ] && touch /var/lock/subsys/pbs_sched
|
||||
echo
|
||||
;;
|
||||
stop)
|
||||
diff -uNr torque-2.5.2.ORIG/contrib/init.d/pbs_server torque-2.5.2/contrib/init.d/pbs_server
|
||||
--- torque-2.5.2.ORIG/contrib/init.d/pbs_server 2010-10-14 21:47:05.034384022 +0200
|
||||
+++ torque-2.5.2/contrib/init.d/pbs_server 2010-10-14 21:50:09.310577353 +0200
|
||||
@@ -28,7 +28,7 @@
|
||||
daemon $PBS_DAEMON -t create -d $PBS_HOME
|
||||
fi
|
||||
RET=$?
|
||||
- touch /var/lock/subsys/pbs_server
|
||||
+ [ $RET -eq 0 ] && touch /var/lock/subsys/pbs_server
|
||||
echo
|
||||
;;
|
||||
stop)
|
42
torque-create-request.patch
Normal file
42
torque-create-request.patch
Normal file
@ -0,0 +1,42 @@
|
||||
diff -uNr torque-2.5.2.ORIG/contrib/init.d/pbs_server torque-2.5.2/contrib/init.d/pbs_server
|
||||
--- torque-2.5.2.ORIG/contrib/init.d/pbs_server 2010-10-14 22:16:32.978386147 +0200
|
||||
+++ torque-2.5.2/contrib/init.d/pbs_server 2010-10-14 23:01:59.911917744 +0200
|
||||
@@ -25,11 +25,29 @@
|
||||
then
|
||||
daemon $PBS_DAEMON -d $PBS_HOME
|
||||
else
|
||||
+ echo -n "use \"service pbs_server create\"" && failure && echo && exit 5
|
||||
+ fi
|
||||
+ RET=$?
|
||||
+ [ $RET -eq 0 ] && touch /var/lock/subsys/pbs_server
|
||||
+ echo
|
||||
+ ;;
|
||||
+ create)
|
||||
+ echo -n "Creating Torque Server Database:... "
|
||||
+ if [ -r $PBS_HOME/server_priv/serverdb ]
|
||||
+ then
|
||||
+ echo -n "serverdb file allready exists?" && failure && echo && exit 5
|
||||
+ else
|
||||
daemon $PBS_DAEMON -t create -d $PBS_HOME
|
||||
fi
|
||||
RET=$?
|
||||
[ $RET -eq 0 ] && touch /var/lock/subsys/pbs_server
|
||||
echo
|
||||
+ sleep 3
|
||||
+ echo -n "Shutting down TORQUE Server: "
|
||||
+ killproc pbs_server
|
||||
+ RET=$?
|
||||
+ rm -f /var/lock/subsys/pbs_server
|
||||
+ echo
|
||||
;;
|
||||
stop)
|
||||
echo -n "Shutting down TORQUE Server: "
|
||||
@@ -53,7 +71,7 @@
|
||||
echo
|
||||
;;
|
||||
*)
|
||||
- echo "Usage: pbs_server {start|stop|restart|status|reload}"
|
||||
+ echo "Usage: pbs_server {start|stop|restart|status|reload|create}"
|
||||
exit 1
|
||||
esac
|
||||
exit $RET
|
71
torque-start-start.patch
Normal file
71
torque-start-start.patch
Normal file
@ -0,0 +1,71 @@
|
||||
diff -uNr torque-2.5.2.ORIG/contrib/init.d/pbs_mom torque-2.5.2/contrib/init.d/pbs_mom
|
||||
--- torque-2.5.2.ORIG/contrib/init.d/pbs_mom 2010-10-14 23:20:58.500633494 +0200
|
||||
+++ torque-2.5.2/contrib/init.d/pbs_mom 2010-10-14 23:36:00.369403267 +0200
|
||||
@@ -51,6 +51,9 @@
|
||||
case "$1" in
|
||||
start)
|
||||
echo -n "Starting TORQUE Mom: "
|
||||
+ status pbs_mom 2>&1 > /dev/null
|
||||
+ RET=$?
|
||||
+ [ $RET -eq 0 ] && echo -n "pbs_mom already running" && success && echo && exit 0
|
||||
# ulimit -c unlimited # Uncomment this to preserve core files
|
||||
daemon $PBS_DAEMON $args -d $PBS_HOME
|
||||
RET=$?
|
||||
@@ -67,6 +70,9 @@
|
||||
;;
|
||||
stop)
|
||||
echo -n "Shutting down TORQUE Mom: "
|
||||
+ status pbs_mom 2>&1 > /dev/null
|
||||
+ RET=$?
|
||||
+ [ ! $RET -eq 0 ] && echo -n "pbs_mom already stopped" && success && echo && exit 0
|
||||
kill_pbs_mom
|
||||
RET=$?
|
||||
[ $RET -eq 0 ] && success "shutdown" || failure "shutdown"
|
||||
diff -uNr torque-2.5.2.ORIG/contrib/init.d/pbs_sched torque-2.5.2/contrib/init.d/pbs_sched
|
||||
--- torque-2.5.2.ORIG/contrib/init.d/pbs_sched 2010-10-14 23:20:58.500633494 +0200
|
||||
+++ torque-2.5.2/contrib/init.d/pbs_sched 2010-10-14 23:38:04.275381652 +0200
|
||||
@@ -20,6 +20,10 @@
|
||||
case "$1" in
|
||||
start)
|
||||
echo -n "Starting TORQUE Scheduler: "
|
||||
+ status pbs_sched 2>&1 > /dev/null
|
||||
+ RET=$?
|
||||
+ [ $RET -eq 0 ] && echo -n "pbs_sched already running" && success && echo && exit 0
|
||||
+
|
||||
daemon $PBS_DAEMON -d $PBS_HOME
|
||||
RET=$?
|
||||
[ $RET -eq 0 ] && touch /var/lock/subsys/pbs_sched
|
||||
@@ -27,6 +31,9 @@
|
||||
;;
|
||||
stop)
|
||||
echo -n "Shutting down TORQUE Scheduler: "
|
||||
+ status pbs_sched 2>&1 > /dev/null
|
||||
+ RET=$?
|
||||
+ [ ! $RET -eq 0 ] && echo -n "pbs_sched already stopped" && success && echo && exit 0
|
||||
killproc pbs_sched
|
||||
RET=$?
|
||||
rm -f /var/lock/subsys/pbs_sched
|
||||
diff -uNr torque-2.5.2.ORIG/contrib/init.d/pbs_server torque-2.5.2/contrib/init.d/pbs_server
|
||||
--- torque-2.5.2.ORIG/contrib/init.d/pbs_server 2010-10-14 23:20:58.499634001 +0200
|
||||
+++ torque-2.5.2/contrib/init.d/pbs_server 2010-10-14 23:37:06.460197422 +0200
|
||||
@@ -20,6 +20,10 @@
|
||||
case "$1" in
|
||||
start)
|
||||
echo -n "Starting TORQUE Server: "
|
||||
+ status pbs_server 2>&1 > /dev/null
|
||||
+ RET=$?
|
||||
+ [ $RET -eq 0 ] && echo -n "pbs_server already running" && success && echo && exit 0
|
||||
+
|
||||
# ulimit -c unlimited # Uncomment this to preserve core files
|
||||
if [ -r $PBS_HOME/server_priv/serverdb ]
|
||||
then
|
||||
@@ -51,6 +55,9 @@
|
||||
;;
|
||||
stop)
|
||||
echo -n "Shutting down TORQUE Server: "
|
||||
+ status pbs_server 2>&1 > /dev/null
|
||||
+ RET=$?
|
||||
+ [ ! $RET -eq 0 ] && echo -n "pbs_server already stopped" && success && echo && exit 0
|
||||
killproc pbs_server
|
||||
RET=$?
|
||||
rm -f /var/lock/subsys/pbs_server
|
316
torque.spec
316
torque.spec
@ -67,8 +67,8 @@
|
||||
%global server_nameflags --with-default-server=%{server_name}
|
||||
|
||||
Name: torque
|
||||
Version: 2.4.11
|
||||
Release: 2%{?dist}
|
||||
Version: 2.5.3
|
||||
Release: 3%{?dist}
|
||||
Summary: Tera-scale Open-source Resource and QUEue manager
|
||||
Source0: http://www.clusterresources.com/downloads/%{name}/%{name}-%{version}.tar.gz
|
||||
Source2: xpbs.desktop
|
||||
@ -76,11 +76,19 @@ Source3: xpbsmon.desktop
|
||||
Source4: xpbs.png
|
||||
Source5: xpbsmon.png
|
||||
Source6: README.Fedora
|
||||
Source7: pbs-config-multilib
|
||||
Source8: config
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=528060
|
||||
Patch0: torque-cond-touch.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=631256
|
||||
Patch1: torque-create-request.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=643194
|
||||
Patch2: torque-start-start.patch
|
||||
License: OpenPBS
|
||||
Group: System Environment/Daemons
|
||||
URL: http://www.clusterresources.com/products/torque/
|
||||
%if 0%{?el4}%{?el5}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
%endif
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: pam-devel
|
||||
BuildRequires: xauth
|
||||
@ -93,6 +101,30 @@ BuildRequires: tcl-devel
|
||||
BuildRequires: tk-devel
|
||||
%endif
|
||||
|
||||
#doxygen appears to be broken in rawhide at the moment
|
||||
#Dec 9th 2010 so don't build the drmaa documentation
|
||||
#for now.
|
||||
%if ! 0%{?fc15}
|
||||
%global doxydoc 1
|
||||
%endif
|
||||
|
||||
%if 0%{?doxydoc}
|
||||
BuildRequires: graphviz
|
||||
BuildRequires: doxygen
|
||||
%if "%{?rhel}" == "5"
|
||||
BuildRequires: graphviz-gd
|
||||
%endif
|
||||
%if %{?fedora}%{!?fedora:0} >= 9
|
||||
BuildRequires: tex(latex)
|
||||
%else
|
||||
%if %{?rhel}%{!?rhel:0} >= 6
|
||||
BuildRequires: tex(latex)
|
||||
%else
|
||||
BuildRequires: tetex-latex
|
||||
%endif
|
||||
%endif
|
||||
%endif
|
||||
|
||||
%description
|
||||
TORQUE (Tera-scale Open-source Resource and QUEue manager) is a resource
|
||||
manager providing control over batch jobs and distributed compute nodes.
|
||||
@ -264,10 +296,48 @@ other leading edge HPC organizations.
|
||||
|
||||
This package holds the server.
|
||||
|
||||
%package drmaa
|
||||
Group: System Environment/Daemons
|
||||
Summary: Run time files for the drmaa interface
|
||||
Requires: torque-libs = %{version}-%{release}
|
||||
|
||||
%description drmaa
|
||||
TORQUE (Tera-scale Open-source Resource and QUEue manager) is a resource
|
||||
manager providing control over batch jobs and distributed compute nodes.
|
||||
TORQUE is based on OpenPBS version 2.3.12 and incorporates scalability,
|
||||
fault tolerance, and feature extension patches provided by USC, NCSA, OSC,
|
||||
the U.S. Dept of Energy, Sandia, PNNL, U of Buffalo, TeraGrid, and many
|
||||
other leading edge HPC organizations.
|
||||
|
||||
Run time files for working the DRMAA interface to torque.
|
||||
DRMAA is "Distributed Resource Management Application API"
|
||||
|
||||
|
||||
%package drmaa-devel
|
||||
Group: System Environment/Daemons
|
||||
Summary: Development files for the drmaa interface.
|
||||
Requires: torque-drmaa = %{version}-%{release}
|
||||
Requires: torque-devel = %{version}-%{release}
|
||||
|
||||
%description drmaa-devel
|
||||
TORQUE (Tera-scale Open-source Resource and QUEue manager) is a resource
|
||||
manager providing control over batch jobs and distributed compute nodes.
|
||||
TORQUE is based on OpenPBS version 2.3.12 and incorporates scalability,
|
||||
fault tolerance, and feature extension patches provided by USC, NCSA, OSC,
|
||||
the U.S. Dept of Energy, Sandia, PNNL, U of Buffalo, TeraGrid, and many
|
||||
other leading edge HPC organizations.
|
||||
|
||||
Developement files for working the DRMAA interface to torque.
|
||||
DRMAA is "Distributed Resource Management Application API"
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
install -pm 644 %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} \
|
||||
%{SOURCE6} %{SOURCE7} %{SOURCE8} .
|
||||
%{SOURCE6} %{SOURCE8} .
|
||||
# rm x bit on some documentation.
|
||||
chmod 644 torque.setup
|
||||
|
||||
@ -276,10 +346,10 @@ CFLAGS="%{optflags} -Wno-overlength-strings"
|
||||
%configure --includedir=%{_includedir}/torque \
|
||||
--with-server-home=%{torquehomedir} --with-pam=/%{_lib}/security \
|
||||
--with-sendmail=%{_sbindir}/sendmail --disable-static \
|
||||
--enable-drmaa \
|
||||
%{server_nameflags} %{guiflags} %{tclflags} %{rcpflags}
|
||||
|
||||
|
||||
cp -vf pbs-config-multilib pbs-config
|
||||
make %{?_smp_mflags}
|
||||
|
||||
for daemon in pbs_mom pbs_sched pbs_server
|
||||
@ -298,7 +368,6 @@ rm -f %{buildroot}%{_libdir}/*.la
|
||||
rm -f %{buildroot}%{_libdir}/*/buildindex
|
||||
rm -f %{buildroot}/%{_lib}/security/pam_pbssimpleauth.{a,la}
|
||||
mkdir -p %{buildroot}%{_bindir}
|
||||
touch -r pbs-config-multilib %{buildroot}%{_bindir}/pbs-config
|
||||
|
||||
# install initscripts
|
||||
mkdir -p %{buildroot}%{_initrddir}
|
||||
@ -369,6 +438,20 @@ ln -s %{_var}/log/torque/server_logs .
|
||||
popd
|
||||
|
||||
|
||||
# Move drmaa man pages to correct place
|
||||
# and delete the three copies of the same documentation.
|
||||
|
||||
%if 0%{?doxydoc}
|
||||
mv %{buildroot}%{_defaultdocdir}/torque-drmaa/man/man3/* %{buildroot}%{_mandir}/man3/.
|
||||
rm -rf %{buildroot}%{_defaultdocdir}/torque-drmaa/html/*
|
||||
rm -rf %{buildroot}%{_defaultdocdir}/torque-drmaa/latex/*
|
||||
# Include drmaa.pdf later from the src tree.
|
||||
rm %{buildroot}%{_defaultdocdir}/torque-drmaa/drmaa.pdf
|
||||
%endif
|
||||
|
||||
#Remove man page for binary that is not included.
|
||||
rm %{buildroot}%{_mandir}/man1/basl2c.1
|
||||
|
||||
%clean
|
||||
rm -rf %{buildroot}
|
||||
|
||||
@ -419,6 +502,9 @@ fi
|
||||
|
||||
%post libs -p /sbin/ldconfig
|
||||
%postun libs -p /sbin/ldconfig
|
||||
%post drmaa -p /sbin/ldconfig
|
||||
%postun drmaa -p /sbin/ldconfig
|
||||
|
||||
|
||||
%post mom
|
||||
/sbin/chkconfig --add pbs_mom
|
||||
@ -459,7 +545,7 @@ fi
|
||||
%{torquehomedir}/server_name
|
||||
%config(noreplace) %{_sysconfdir}/torque/pbs_environment
|
||||
%config(noreplace) %{_sysconfdir}/torque/server_name
|
||||
|
||||
%{_mandir}/man1/pbs.1.*
|
||||
|
||||
%files client
|
||||
%defattr(-, root, root, -)
|
||||
@ -479,6 +565,47 @@ fi
|
||||
%if %{use_tcl}
|
||||
%{_bindir}/pbs_tclsh
|
||||
%endif
|
||||
%{_mandir}/man1/nqs2pbs.1.*
|
||||
%{_mandir}/man1/pbsdsh.1.*
|
||||
%{_mandir}/man1/qchkpt.1.*
|
||||
%{_mandir}/man1/qmgr.1.*
|
||||
%{_mandir}/man1/qmove.1.*
|
||||
%{_mandir}/man1/qmsg.1.*
|
||||
%{_mandir}/man1/qorder.1.*
|
||||
%{_mandir}/man1/qrerun.1.*
|
||||
%{_mandir}/man1/qsig.1.*
|
||||
%{_mandir}/man8/pbsnodes.8.*
|
||||
%{_mandir}/man8/qdisable.8.*
|
||||
%{_mandir}/man8/qenable.8.*
|
||||
%{_mandir}/man8/qrun.8.*
|
||||
%{_mandir}/man8/qstart.8.*
|
||||
%{_mandir}/man8/qstop.8.*
|
||||
%{_mandir}/man8/qterm.8.*
|
||||
%{_mandir}/man7/pbs_job_attributes.7.*
|
||||
%{_mandir}/man7/pbs_queue_attributes.7.*
|
||||
%{_mandir}/man7/pbs_resources.7.*
|
||||
%{_mandir}/man7/pbs_resources_aix4.7.*
|
||||
%{_mandir}/man7/pbs_resources_aix5.7.*
|
||||
%{_mandir}/man7/pbs_resources_darwin.7.*
|
||||
%{_mandir}/man7/pbs_resources_digitalunix.7.*
|
||||
%{_mandir}/man7/pbs_resources_freebsd.7.*
|
||||
%{_mandir}/man7/pbs_resources_fujitsu.7.*
|
||||
%{_mandir}/man7/pbs_resources_hpux10.7.*
|
||||
%{_mandir}/man7/pbs_resources_hpux11.7.*
|
||||
%{_mandir}/man7/pbs_resources_irix5.7.*
|
||||
%{_mandir}/man7/pbs_resources_irix6.7.*
|
||||
%{_mandir}/man7/pbs_resources_irix6array.7.*
|
||||
%{_mandir}/man7/pbs_resources_linux.7.*
|
||||
%{_mandir}/man7/pbs_resources_netbsd.7.*
|
||||
%{_mandir}/man7/pbs_resources_solaris5.7.*
|
||||
%{_mandir}/man7/pbs_resources_solaris7.7.*
|
||||
%{_mandir}/man7/pbs_resources_sp2.7.*
|
||||
%{_mandir}/man7/pbs_resources_sunos4.7.*
|
||||
%{_mandir}/man7/pbs_resources_unicos8.7.*
|
||||
%{_mandir}/man7/pbs_resources_unicosmk2.7.*
|
||||
%{_mandir}/man7/pbs_server_attributes.7.*
|
||||
|
||||
# And the following are alternative managed ones.
|
||||
%{_mandir}/man1/qsub-torque.1.*
|
||||
%{_mandir}/man1/qalter-torque.1.*
|
||||
%{_mandir}/man1/qdel-torque.1.*
|
||||
@ -491,19 +618,39 @@ fi
|
||||
%files docs
|
||||
%defattr(-, root, root, -)
|
||||
%doc doc/admin_guide.ps
|
||||
%{_mandir}/man1/basl2c.1.*
|
||||
%{_mandir}/man1/nqs2pbs.1.*
|
||||
%{_mandir}/man1/pbs.1.*
|
||||
%{_mandir}/man1/pbsdsh.1.*
|
||||
%{_mandir}/man1/qchkpt.1.*
|
||||
%{_mandir}/man1/qmgr.1.*
|
||||
%{_mandir}/man1/qmove.1.*
|
||||
%{_mandir}/man1/qmsg.1.*
|
||||
%{_mandir}/man1/qorder.1.*
|
||||
%{_mandir}/man1/qrerun.1.*
|
||||
%{_mandir}/man1/qsig.1.*
|
||||
%if 0%{?doxydoc}
|
||||
%doc src/drmaa/drmaa.pdf
|
||||
%endif
|
||||
|
||||
%if %{build_gui}
|
||||
%files gui
|
||||
%defattr(-, root, root, -)
|
||||
%{_bindir}/pbs_wish
|
||||
%{_bindir}/xpbs
|
||||
%{_bindir}/xpbsmon
|
||||
%{_libdir}/xpbs
|
||||
%{_libdir}/xpbsmon
|
||||
%{_datadir}/applications/*.desktop
|
||||
%{_datadir}/pixmaps/*.png
|
||||
%{_mandir}/man1/xpbs.1.*
|
||||
%{_mandir}/man1/xpbsmon.1.*
|
||||
%endif
|
||||
|
||||
%files libs
|
||||
%defattr(-, root, root, -)
|
||||
%{_libdir}/libtorque.so.*
|
||||
|
||||
%files devel
|
||||
%defattr(-, root, root, -)
|
||||
%{_libdir}/libtorque.so
|
||||
%{_includedir}/torque/pbs_error.h
|
||||
%{_includedir}/torque/pbs_error_db.h
|
||||
%{_includedir}/torque/pbs_ifl.h
|
||||
%{_includedir}/torque/rm.h
|
||||
%{_includedir}/torque/rpp.h
|
||||
%{_includedir}/torque/tm.h
|
||||
%{_includedir}/torque/tm_.h
|
||||
%{_bindir}/pbs-config
|
||||
%{_mandir}/man3/pbs_alterjob.3.*
|
||||
%{_mandir}/man3/pbs_connect.3.*
|
||||
%{_mandir}/man3/pbs_default.3.*
|
||||
@ -531,71 +678,13 @@ fi
|
||||
%{_mandir}/man3/pbs_statserver.3.*
|
||||
%{_mandir}/man3/pbs_submit.3.*
|
||||
%{_mandir}/man3/pbs_terminate.3.*
|
||||
%{_mandir}/man3/rpp.3.*
|
||||
%{_mandir}/man3/tm.3.*
|
||||
%{_mandir}/man3/pbs_checkpointjob.3.gz
|
||||
%{_mandir}/man3/pbs_fbserver.3.gz
|
||||
%{_mandir}/man3/pbs_get_server_list.3.gz
|
||||
%{_mandir}/man7/pbs_job_attributes.7.*
|
||||
%{_mandir}/man7/pbs_queue_attributes.7.*
|
||||
%{_mandir}/man7/pbs_resources.7.*
|
||||
%{_mandir}/man7/pbs_resources_aix4.7.*
|
||||
%{_mandir}/man7/pbs_resources_aix5.7.*
|
||||
%{_mandir}/man7/pbs_resources_darwin.7.*
|
||||
%{_mandir}/man7/pbs_resources_digitalunix.7.*
|
||||
%{_mandir}/man7/pbs_resources_freebsd.7.*
|
||||
%{_mandir}/man7/pbs_resources_fujitsu.7.*
|
||||
%{_mandir}/man7/pbs_resources_hpux10.7.*
|
||||
%{_mandir}/man7/pbs_resources_hpux11.7.*
|
||||
%{_mandir}/man7/pbs_resources_irix5.7.*
|
||||
%{_mandir}/man7/pbs_resources_irix6.7.*
|
||||
%{_mandir}/man7/pbs_resources_irix6array.7.*
|
||||
%{_mandir}/man7/pbs_resources_linux.7.*
|
||||
%{_mandir}/man7/pbs_resources_netbsd.7.*
|
||||
%{_mandir}/man7/pbs_resources_solaris5.7.*
|
||||
%{_mandir}/man7/pbs_resources_solaris7.7.*
|
||||
%{_mandir}/man7/pbs_resources_sp2.7.*
|
||||
%{_mandir}/man7/pbs_resources_sunos4.7.*
|
||||
%{_mandir}/man7/pbs_resources_unicos8.7.*
|
||||
%{_mandir}/man7/pbs_resources_unicosmk2.7.*
|
||||
%{_mandir}/man7/pbs_server_attributes.7.*
|
||||
%{_mandir}/man8/pbs_mom.8.*
|
||||
%{_mandir}/man8/pbs_sched.8.*
|
||||
%{_mandir}/man8/pbs_sched_basl.8.*
|
||||
%{_mandir}/man8/pbs_sched_cc.8.*
|
||||
%{_mandir}/man8/pbs_sched_tcl.8.*
|
||||
%{_mandir}/man8/pbs_server.8.*
|
||||
%{_mandir}/man8/pbsnodes.8.*
|
||||
%{_mandir}/man8/qdisable.8.*
|
||||
%{_mandir}/man8/qenable.8.*
|
||||
%{_mandir}/man8/qrun.8.*
|
||||
%{_mandir}/man8/qstart.8.*
|
||||
%{_mandir}/man8/qstop.8.*
|
||||
%{_mandir}/man8/qterm.8.*
|
||||
%{_mandir}/man3/rpp.3.*
|
||||
%{_mandir}/man3/tm.3.*
|
||||
|
||||
|
||||
%if %{build_gui}
|
||||
%files gui
|
||||
%defattr(-, root, root, -)
|
||||
%{_bindir}/pbs_wish
|
||||
%{_bindir}/xpbs
|
||||
%{_bindir}/xpbsmon
|
||||
%{_libdir}/xpbs
|
||||
%{_libdir}/xpbsmon
|
||||
%{_datadir}/applications/*.desktop
|
||||
%{_datadir}/pixmaps/*.png
|
||||
%endif
|
||||
|
||||
%files libs
|
||||
%defattr(-, root, root, -)
|
||||
%{_libdir}/*.so.*
|
||||
|
||||
%files devel
|
||||
%defattr(-, root, root, -)
|
||||
%{_libdir}/*.so
|
||||
%{_includedir}/torque
|
||||
%{_bindir}/pbs-config
|
||||
|
||||
%files mom
|
||||
%defattr(-, root, root, -)
|
||||
%{_sbindir}/pbs_mom
|
||||
@ -613,6 +702,7 @@ fi
|
||||
%dir %{_var}/log/torque
|
||||
%dir %{_var}/log/torque/mom_logs
|
||||
%dir %{_sysconfdir}/torque/mom
|
||||
%{_mandir}/man8/pbs_mom.8.*
|
||||
%config(noreplace) %{_sysconfdir}/torque/mom/config
|
||||
|
||||
%files pam
|
||||
@ -630,6 +720,10 @@ fi
|
||||
%{torquehomedir}/sched_logs
|
||||
%dir %{_var}/log/torque/sched_logs
|
||||
%dir %{_sysconfdir}/torque/sched
|
||||
%{_mandir}/man8/pbs_sched.8.*
|
||||
%{_mandir}/man8/pbs_sched_basl.8.*
|
||||
%{_mandir}/man8/pbs_sched_cc.8.*
|
||||
%{_mandir}/man8/pbs_sched_tcl.8.*
|
||||
%config(noreplace) %{_sysconfdir}/torque/sched/dedicated_time
|
||||
%config(noreplace) %{_sysconfdir}/torque/sched/holidays
|
||||
%config(noreplace) %{_sysconfdir}/torque/sched/resource_group
|
||||
@ -644,18 +738,70 @@ fi
|
||||
%dir %{_var}/log/torque/server_logs
|
||||
%{torquehomedir}/server_logs
|
||||
%{torquehomedir}/server_priv
|
||||
%{_mandir}/man8/pbs_server.8.*
|
||||
|
||||
%files drmaa
|
||||
%defattr(-, root, root, -)
|
||||
%{_libdir}/libdrmaa.so.*
|
||||
|
||||
%files drmaa-devel
|
||||
%defattr(-, root, root, -)
|
||||
%{_libdir}/libdrmaa.so
|
||||
%{_includedir}/torque/drmaa.h
|
||||
%if 0%{?doxydoc}
|
||||
%{_mandir}/man3/compat.h.3.*
|
||||
%{_mandir}/man3/drmaa.3.*
|
||||
%{_mandir}/man3/drmaa.h.3.*
|
||||
%{_mandir}/man3/drmaa_attr_names_s.3.*
|
||||
%{_mandir}/man3/drmaa_attr_values_s.3.*
|
||||
%{_mandir}/man3/drmaa_attrib.3.*
|
||||
%{_mandir}/man3/drmaa_attrib_info_s.3.*
|
||||
%{_mandir}/man3/drmaa_def_attr_s.3.*
|
||||
%{_mandir}/man3/drmaa_job_ids_s.3.*
|
||||
%{_mandir}/man3/drmaa_job_iter_s.3.*
|
||||
%{_mandir}/man3/drmaa_job_s.3.*
|
||||
%{_mandir}/man3/drmaa_job_template_s.3.*
|
||||
%{_mandir}/man3/drmaa_jobt.3.*
|
||||
%{_mandir}/man3/drmaa_session.3.*
|
||||
%{_mandir}/man3/drmaa_session_s.3.*
|
||||
%{_mandir}/man3/drmaa_submission_context_s.3.*
|
||||
%{_mandir}/man3/drmaa_viter.3.*
|
||||
%{_mandir}/man3/error.h.3.*
|
||||
%{_mandir}/man3/jobs.3.*
|
||||
%{_mandir}/man3/jobs.h.3.*
|
||||
%{_mandir}/man3/lookup3.h.3.*
|
||||
%{_mandir}/man3/pbs_attrib.3.*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Dec 8 2010 Steve Traylen <steve.traylen@cern.ch> - 2.4.11-2
|
||||
- Only build a noarch doc package for EPEL6 or more. #659723
|
||||
* Wed Dec 8 2010 Steve Traylen <steve.traylen@cern.ch> - 2.5.3-3
|
||||
- Remove own copy of pbs-config. #657027
|
||||
- Move man pages from doc subpackage to relavent sub package.
|
||||
- Enable drmaa support and add drmaa sub packages.
|
||||
|
||||
* Thu Nov 18 2010 Steve Traylen <steve.traylen@cern.ch> - 2.4.11-1
|
||||
- New upstream 2.4.11.
|
||||
* Wed Dec 8 2010 Steve Traylen <steve.traylen@cern.ch> - 2.5.3-2
|
||||
- Only build noarch doc package on RHEL6 or Fedora10. #659723
|
||||
|
||||
* Tue Sep 7 2010 Steve Traylen <steve.traylen@cern.ch> - 2.4.10-1
|
||||
- New upstream 2.4.10.
|
||||
- Add 3 new man pages to file listing.
|
||||
* Thu Nov 18 2010 Steve Traylen <steve.traylen@cern.ch> - 2.5.3-1
|
||||
- Upstream to 2.5.3.
|
||||
|
||||
* Thu Oct 14 2010 Steve Traylen <steve.traylen@cern.ch> - 2.5.2-4
|
||||
- rhbz#643194, stop a stoped service, start a start service
|
||||
return codes now fixed.
|
||||
|
||||
* Thu Oct 14 2010 Steve Traylen <steve.traylen@cern.ch> - 2.5.2-3
|
||||
- rhbz#631256 Only create db if asked to.
|
||||
|
||||
* Thu Oct 14 2010 Steve Traylen <steve.traylen@cern.ch> - 2.5.2-2
|
||||
- rhbz#58060, add torque-cond-touch.spec to only touch files
|
||||
when service actually starts.
|
||||
|
||||
* Tue Sep 7 2010 Steve Traylen <steve.traylen@cern.ch> - 2.5.2-1
|
||||
- New upstream 2.5.2
|
||||
- Three new man pages added to file listing.
|
||||
|
||||
* Tue Aug 10 2010 Steve Traylen <steve.traylen@cern.ch> - 2.5.1-1
|
||||
- New upstream 2.5.1
|
||||
|
||||
* Wed Jul 14 2010 Steve Traylen <steve.traylen@cern.ch> - 2.4.8-3
|
||||
- Rebuild for cvs mistake.
|
||||
|
Loading…
Reference in New Issue
Block a user