Update to 3.0.2.
Remove torque-buffer-overrun since upstream now.
This commit is contained in:
parent
e3aa6e0cf9
commit
189f58021f
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@
|
|||||||
/torque-3.0.0.tar.gz
|
/torque-3.0.0.tar.gz
|
||||||
/torque-3.0.0-snap.201102011355.tar.gz
|
/torque-3.0.0-snap.201102011355.tar.gz
|
||||||
/torque-3.0.1.tar.gz
|
/torque-3.0.1.tar.gz
|
||||||
|
/torque-3.0.2.tar.gz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
d65463f823fdcd864c09ffd16841507b torque-3.0.1.tar.gz
|
a2f008c7eeffcb3a0721fbb252397936 torque-3.0.2.tar.gz
|
||||||
|
@ -1,119 +0,0 @@
|
|||||||
Index: src/server/req_quejob.c
|
|
||||||
===================================================================
|
|
||||||
--- src/server/req_quejob.c (revision 4680)
|
|
||||||
+++ src/server/req_quejob.c (revision 4681)
|
|
||||||
@@ -1307,17 +1307,19 @@
|
|
||||||
{
|
|
||||||
if (errno == 0)
|
|
||||||
{
|
|
||||||
- sprintf(log_buffer, "job %s in unexpected state '%s'",
|
|
||||||
- pj->ji_qs.ji_jobid,
|
|
||||||
- PJobSubState[pj->ji_qs.ji_substate]);
|
|
||||||
+ snprintf(log_buffer, sizeof(log_buffer),
|
|
||||||
+ "job %s in unexpected state '%s'",
|
|
||||||
+ pj->ji_qs.ji_jobid,
|
|
||||||
+ PJobSubState[pj->ji_qs.ji_substate]);
|
|
||||||
}
|
|
||||||
else
|
|
||||||
{
|
|
||||||
- sprintf(log_buffer, "job %s in unexpected state '%s' (errno=%d - %s)",
|
|
||||||
- pj->ji_qs.ji_jobid,
|
|
||||||
- PJobSubState[pj->ji_qs.ji_substate],
|
|
||||||
- errno,
|
|
||||||
- strerror(errno));
|
|
||||||
+ snprintf(log_buffer, sizeof(log_buffer),
|
|
||||||
+ "job %s in unexpected state '%s' (errno=%d - %s)",
|
|
||||||
+ pj->ji_qs.ji_jobid,
|
|
||||||
+ PJobSubState[pj->ji_qs.ji_substate],
|
|
||||||
+ errno,
|
|
||||||
+ strerror(errno));
|
|
||||||
}
|
|
||||||
|
|
||||||
log_err(errno, id, log_buffer);
|
|
||||||
@@ -1555,9 +1557,10 @@
|
|
||||||
|
|
||||||
if (LOGLEVEL >= 6)
|
|
||||||
{
|
|
||||||
- sprintf(log_buffer, "successfully moved file '%s' for job '%s'",
|
|
||||||
- namebuf,
|
|
||||||
- preq->rq_ind.rq_jobfile.rq_jobid);
|
|
||||||
+ snprintf(log_buffer, sizeof(log_buffer),
|
|
||||||
+ "successfully moved file '%s' for job '%s'",
|
|
||||||
+ namebuf,
|
|
||||||
+ preq->rq_ind.rq_jobfile.rq_jobid);
|
|
||||||
|
|
||||||
log_record(
|
|
||||||
PBSEVENT_JOB,
|
|
||||||
@@ -1684,9 +1687,10 @@
|
|
||||||
{
|
|
||||||
char tmpLine[1024];
|
|
||||||
|
|
||||||
- sprintf(tmpLine, "cannot save job - errno=%d - %s",
|
|
||||||
- errno,
|
|
||||||
- strerror(errno));
|
|
||||||
+ snprintf(tmpLine, sizeof(tmpLine),
|
|
||||||
+ "cannot save job - errno=%d - %s",
|
|
||||||
+ errno,
|
|
||||||
+ strerror(errno));
|
|
||||||
|
|
||||||
log_err(errno, id, tmpLine);
|
|
||||||
|
|
||||||
@@ -1719,9 +1723,10 @@
|
|
||||||
{
|
|
||||||
/* reply failed, purge the job and close the connection */
|
|
||||||
|
|
||||||
- sprintf(log_buffer, "cannot report jobid - errno=%d - %s",
|
|
||||||
- errno,
|
|
||||||
- strerror(errno));
|
|
||||||
+ snprintf(log_buffer, sizeof(log_buffer),
|
|
||||||
+ "cannot report jobid - errno=%d - %s",
|
|
||||||
+ errno,
|
|
||||||
+ strerror(errno));
|
|
||||||
|
|
||||||
log_err(errno, id, log_buffer);
|
|
||||||
|
|
||||||
@@ -2026,11 +2031,12 @@
|
|
||||||
|
|
||||||
/* need to format message first, before request goes away */
|
|
||||||
|
|
||||||
- sprintf(log_buffer, msg_jobnew,
|
|
||||||
- preq->rq_user, preq->rq_host,
|
|
||||||
- pj->ji_wattr[JOB_ATR_job_owner].at_val.at_str,
|
|
||||||
- pj->ji_wattr[JOB_ATR_jobname].at_val.at_str,
|
|
||||||
- pj->ji_qhdr->qu_qs.qu_name);
|
|
||||||
+ snprintf(log_buffer, sizeof(log_buffer),
|
|
||||||
+ msg_jobnew,
|
|
||||||
+ preq->rq_user, preq->rq_host,
|
|
||||||
+ pj->ji_wattr[JOB_ATR_job_owner].at_val.at_str,
|
|
||||||
+ pj->ji_wattr[JOB_ATR_jobname].at_val.at_str,
|
|
||||||
+ pj->ji_qhdr->qu_qs.qu_name);
|
|
||||||
|
|
||||||
/* acknowledge the request with the job id */
|
|
||||||
|
|
||||||
@@ -2069,8 +2075,10 @@
|
|
||||||
{
|
|
||||||
if (LOGLEVEL >= 7)
|
|
||||||
{
|
|
||||||
- sprintf(log_buffer, "Trying to AUTORUN job %s",
|
|
||||||
- pj->ji_qs.ji_jobid);
|
|
||||||
+ snprintf(log_buffer, sizeof(log_buffer),
|
|
||||||
+ "Trying to AUTORUN job %s",
|
|
||||||
+ pj->ji_qs.ji_jobid);
|
|
||||||
+
|
|
||||||
log_record(
|
|
||||||
PBSEVENT_JOB,
|
|
||||||
PBS_EVENTCLASS_JOB,
|
|
||||||
Index: src/lib/Libnet/get_hostaddr.c
|
|
||||||
===================================================================
|
|
||||||
--- src/lib/Libnet/get_hostaddr.c (revision 4680)
|
|
||||||
+++ src/lib/Libnet/get_hostaddr.c (revision 4681)
|
|
||||||
@@ -183,7 +183,8 @@
|
|
||||||
|
|
||||||
if (hp == NULL)
|
|
||||||
{
|
|
||||||
- sprintf(log_buffer,"cannot resolve IP address for host '%s' herror=%d: %s",
|
|
||||||
+ snprintf(log_buffer, sizeof(log_buffer),
|
|
||||||
+ "cannot resolve IP address for host '%s' herror=%d: %s",
|
|
||||||
hostname,
|
|
||||||
h_errno,
|
|
||||||
hstrerror(h_errno));
|
|
16
torque.spec
16
torque.spec
@ -70,8 +70,8 @@
|
|||||||
%global server_nameflags --with-default-server=%{server_name}
|
%global server_nameflags --with-default-server=%{server_name}
|
||||||
|
|
||||||
Name: torque
|
Name: torque
|
||||||
Version: 3.0.1
|
Version: 3.0.2
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Tera-scale Open-source Resource and QUEue manager
|
Summary: Tera-scale Open-source Resource and QUEue manager
|
||||||
Source0: http://www.clusterresources.com/downloads/%{name}/%{name}-%{version}.tar.gz
|
Source0: http://www.clusterresources.com/downloads/%{name}/%{name}-%{version}.tar.gz
|
||||||
Source2: xpbs.desktop
|
Source2: xpbs.desktop
|
||||||
@ -86,9 +86,6 @@ Source8: config
|
|||||||
# Fedora approval of TORQUEv1.1
|
# Fedora approval of TORQUEv1.1
|
||||||
# http://lists.fedoraproject.org/pipermail/legal/2011-February/001530.html
|
# http://lists.fedoraproject.org/pipermail/legal/2011-February/001530.html
|
||||||
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=711463
|
|
||||||
Patch0: torque-buffer-overrun.patch
|
|
||||||
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=713996
|
# https://bugzilla.redhat.com/show_bug.cgi?id=713996
|
||||||
Patch1: torque-munge-size.patch
|
Patch1: torque-munge-size.patch
|
||||||
|
|
||||||
@ -341,7 +338,6 @@ DRMAA is "Distributed Resource Management Application API"
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n torque-%{version}
|
%setup -q -n torque-%{version}
|
||||||
%patch0
|
|
||||||
%patch1 -p 1
|
%patch1 -p 1
|
||||||
install -pm 644 %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} \
|
install -pm 644 %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} \
|
||||||
%{SOURCE6} %{SOURCE8} .
|
%{SOURCE6} %{SOURCE8} .
|
||||||
@ -585,6 +581,8 @@ fi
|
|||||||
%{_mandir}/man1/qorder.1.*
|
%{_mandir}/man1/qorder.1.*
|
||||||
%{_mandir}/man1/qrerun.1.*
|
%{_mandir}/man1/qrerun.1.*
|
||||||
%{_mandir}/man1/qsig.1.*
|
%{_mandir}/man1/qsig.1.*
|
||||||
|
%{_mandir}/man1/qgpumode.1.gz
|
||||||
|
%{_mandir}/man1/qgpureset.1.gz
|
||||||
%{_mandir}/man8/pbsnodes.8.*
|
%{_mandir}/man8/pbsnodes.8.*
|
||||||
%{_mandir}/man8/qdisable.8.*
|
%{_mandir}/man8/qdisable.8.*
|
||||||
%{_mandir}/man8/qenable.8.*
|
%{_mandir}/man8/qenable.8.*
|
||||||
@ -692,6 +690,8 @@ fi
|
|||||||
%{_mandir}/man3/pbs_checkpointjob.3.gz
|
%{_mandir}/man3/pbs_checkpointjob.3.gz
|
||||||
%{_mandir}/man3/pbs_fbserver.3.gz
|
%{_mandir}/man3/pbs_fbserver.3.gz
|
||||||
%{_mandir}/man3/pbs_get_server_list.3.gz
|
%{_mandir}/man3/pbs_get_server_list.3.gz
|
||||||
|
%{_mandir}/man3/pbs_gpumode.3.gz
|
||||||
|
%{_mandir}/man3/pbs_gpureset.3.gz
|
||||||
%{_mandir}/man3/rpp.3.*
|
%{_mandir}/man3/rpp.3.*
|
||||||
%{_mandir}/man3/tm.3.*
|
%{_mandir}/man3/tm.3.*
|
||||||
|
|
||||||
@ -785,6 +785,10 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 27 2011 Steve Traylen <steve.traylen@cern.ch> - 3.0.2-1
|
||||||
|
- Update to 3.0.2.
|
||||||
|
- Remove torque-buffer-overrun since upstream now.
|
||||||
|
|
||||||
* Sun Jun 26 2011 Steve Traylen <steve.traylen@cern.ch> - 3.0.1-4
|
* Sun Jun 26 2011 Steve Traylen <steve.traylen@cern.ch> - 3.0.1-4
|
||||||
- Removes nodes database file from package rhbz#716659
|
- Removes nodes database file from package rhbz#716659
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user