Builds at least.
This commit is contained in:
parent
dae2fbbef2
commit
0c45f71993
@ -1 +1 @@
|
||||
torque-2.1.8.tar.gz
|
||||
torque-2.4.2.tar.gz
|
||||
|
103
pbs-config-multilib
Normal file
103
pbs-config-multilib
Normal file
@ -0,0 +1,103 @@
|
||||
#! /bin/sh
|
||||
|
||||
package="pbs"
|
||||
version="2.1.8"
|
||||
|
||||
prefix="/usr"
|
||||
exec_prefix="/usr"
|
||||
bindir="/usr/bin"
|
||||
sbindir="/usr/sbin"
|
||||
libexecdir="/usr/libexec"
|
||||
datadir="/usr/share"
|
||||
sysconfdir="/etc"
|
||||
sharedstatedir="/usr/com"
|
||||
localstatedir="/var"
|
||||
infodir="/usr/share/info"
|
||||
mandir="/usr/share/man"
|
||||
includedir="/usr/include/torque"
|
||||
libs="-ltorque"
|
||||
|
||||
if test "$#" -eq 0; then
|
||||
cat <<EOF
|
||||
Usage: $package-config OPTIONS
|
||||
Options:
|
||||
--prefix=DIR) : \$prefix
|
||||
--package) : \$package
|
||||
--version) : \$version
|
||||
--cflags) : -I\$includedir
|
||||
--libs) : \$libs
|
||||
--help) print all the options (not just these)
|
||||
EOF
|
||||
fi
|
||||
|
||||
o=""
|
||||
h=""
|
||||
for i in "$@"; do
|
||||
case $i in
|
||||
--prefix=*) prefix=`echo $i | sed -e "s/--prefix=//"` ;;
|
||||
--prefix) o="$o $prefix" ;;
|
||||
--package) o="$o $package" ;;
|
||||
--version) o="$o $version" ;;
|
||||
--cflags) if test "_$includedir" != "_/usr/include"
|
||||
then o="$o -I$includedir" ; fi
|
||||
;;
|
||||
--libs) o="$o $libs" ;;
|
||||
--exec_prefix|--eprefix) o="$o $exec_prefix" ;;
|
||||
--bindir) o="$o $bindir" ;;
|
||||
--sbindir) o="$o $sbindir" ;;
|
||||
--libexecdir) o="$o $libexecdir" ;;
|
||||
--datadir) o="$o $datadir" ;;
|
||||
--datainc) o="$o -I$datadir" ;;
|
||||
--datalib) o="$o -L$datadir" ;;
|
||||
--sysconfdir) o="$o $sysconfdir" ;;
|
||||
--sharedstatedir) o="$o $sharedstatedir" ;;
|
||||
--localstatedir) o="$o $localstatedir" ;;
|
||||
--infodir) o="$o $infodir" ;;
|
||||
--mandir) o="$o $mandir" ;;
|
||||
--includedir) o="$o $includedir" ;;
|
||||
--data) o="$o -I$datadir/$package" ;;
|
||||
--pkgdatadir) o="$o $datadir/$package" ;;
|
||||
--pkgdatainc) o="$o -I$datadir/$package" ;;
|
||||
--pkgdatalib) o="$o -L$datadir/$package" ;;
|
||||
--pkglibinc) o="$o -I$libinc/$package" ;;
|
||||
--pkglibadd) o="$o -L$libadd/$package" ;;
|
||||
--pkgincludedir) o="$o $includedir/$package" ;;
|
||||
--help) h="1" ;;
|
||||
-?//*|-?/*//*|-?./*//*|//*|/*//*|./*//*)
|
||||
v=`echo $i | sed -e s://:\$:g`
|
||||
v=`eval "echo $v"`
|
||||
o="$o $v" ;;
|
||||
esac
|
||||
done
|
||||
|
||||
o=`eval "echo $o"`
|
||||
o=`eval "echo $o"`
|
||||
eval "echo $o"
|
||||
|
||||
if test ! -z "$h" ; then
|
||||
cat <<EOF
|
||||
--prefix=xxx) (what is that for anyway?)
|
||||
--prefix) \$prefix $prefix
|
||||
--package) \$package $package
|
||||
--version) \$version $version
|
||||
--cflags) -I\$includedir unless it is /usr/include
|
||||
--libs) -l\$PACKAGE \$LIBS
|
||||
--exec_prefix) or...
|
||||
--eprefix) \$exec_prefix $exec_prefix
|
||||
--bindir) \$bindir $bindir
|
||||
--sbindir) \$sbindir $sbindir
|
||||
--libexecdir) \$libexecdir $libexecdir
|
||||
--datadir) \$datadir $datadir
|
||||
--sysconfdir) \$sysconfdir $sysconfdir
|
||||
--sharedstatedir) \$sharedstatedir$sharedstatedir
|
||||
--localstatedir) \$localstatedir $localstatedir
|
||||
--infodir) \$infodir $infodir
|
||||
--mandir) \$mandir $mandir
|
||||
--data) -I\$datadir/\$package
|
||||
--pkgdatadir) \$datadir/\$package
|
||||
--pkgincludedir) \$includedir/\$package
|
||||
--help) generated by ac_create_generic_config.m4
|
||||
-I//varname and other inc-targets like --pkgdatainc supported
|
||||
-L//varname and other lib-targets, e.g. --pkgdatalib or --libadd
|
||||
EOF
|
||||
fi
|
2
sources
2
sources
@ -1 +1 @@
|
||||
484cdbd5693ac12268405ca1fb6b549d torque-2.1.8.tar.gz
|
||||
cd1b0e63d9c54d49232f89c3dbd29272 torque-2.4.2.tar.gz
|
||||
|
14
torque-2.1.10-NI_MAXSERV.patch
Normal file
14
torque-2.1.10-NI_MAXSERV.patch
Normal file
@ -0,0 +1,14 @@
|
||||
diff -pruN torque-2.1.10_orig/src/include/port_forwarding.h torque-2.1.10/src/include/port_forwarding.h
|
||||
--- torque-2.1.10_orig/src/include/port_forwarding.h 2006-10-13 11:25:37.000000000 -0700
|
||||
+++ torque-2.1.10/src/include/port_forwarding.h 2008-02-14 13:08:05.000000000 -0800
|
||||
@@ -16,6 +16,10 @@
|
||||
# endif
|
||||
#endif /* X_UNIX_PATH */
|
||||
|
||||
+#ifndef NI_MAXSERV
|
||||
+# define NI_MAXSERV 32
|
||||
+#endif /* !NI_MAXSERV */
|
||||
+
|
||||
|
||||
struct pfwdsock {
|
||||
int sock;
|
120
torque.spec
120
torque.spec
@ -1,7 +1,7 @@
|
||||
|
||||
# comment out snap if building a real release
|
||||
%define name torque
|
||||
%define version 2.1.8
|
||||
%define version 2.4.2
|
||||
#%%define snap 200604251602
|
||||
%define release 1
|
||||
|
||||
@ -91,15 +91,20 @@ Source3: xpbsmon.desktop
|
||||
Source4: xpbs.png
|
||||
Source5: xpbsmon.png
|
||||
Source6: README-localhost
|
||||
License: Freely redistributable (See PBS_License.txt)
|
||||
Source7: pbs-config-multilib
|
||||
License: OpenPBS
|
||||
Group: System Environment/Daemons
|
||||
URL: http://www.clusterresources.com/products/torque/
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Provides: pbs
|
||||
BuildRequires: desktop-file-utils, pam-devel, xauth, readline-devel, ncurses-devel
|
||||
Requires(posttrans): /usr/sbin/alternatives
|
||||
Requires(preun): /usr/sbin/alternatives
|
||||
Conflicts: pbspro, openpbs, openpbs-oscar
|
||||
Obsoletes: torque-localhost
|
||||
|
||||
Patch0: torque-2.1.10-NI_MAXSERV.patch
|
||||
|
||||
%if %use_tcl
|
||||
BuildRequires: tcl-devel
|
||||
%endif
|
||||
@ -119,28 +124,32 @@ This package holds just a few shared files and directories.
|
||||
|
||||
%prep
|
||||
%setup -q -n torque-%{version}%{?snap:-snap.%snap}
|
||||
%patch0 -p1
|
||||
|
||||
%__install -pm 644 %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} .
|
||||
%__install -pm 644 %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7} .
|
||||
|
||||
|
||||
%build
|
||||
%configure --includedir=%{_includedir}/torque \
|
||||
%configure --disable-gcc-warnings \
|
||||
--includedir=%{_includedir}/torque \
|
||||
--with-server-home=%{torquehomedir} --with-pam=/%{_lib}/security \
|
||||
--with-sendmail=/usr/sbin/sendmail \
|
||||
%{server_nameflags} %{guiflags} %{tclflags} %{rcpflags}
|
||||
|
||||
%__cp -vf pbs-config-multilib pbs-config
|
||||
%__make %{?_smp_mflags}
|
||||
|
||||
|
||||
|
||||
%install
|
||||
%__rm -rf "$RPM_BUILD_ROOT"
|
||||
%__make DESTDIR=$RPM_BUILD_ROOT install
|
||||
%__make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -p"
|
||||
|
||||
# remove files we don't need
|
||||
%__rm -f $RPM_BUILD_ROOT/%_libdir/*.la
|
||||
%__rm -f $RPM_BUILD_ROOT/%_libdir/*/buildindex
|
||||
%{__rm} -f $RPM_BUILD_ROOT/%{_lib}/security/pam_pbssimpleauth.{a,la}
|
||||
%__rm -f $RPM_BUILD_ROOT/%{_lib}/security/pam_pbssimpleauth.{a,la}
|
||||
touch -r pbs-config-multilib $RPM_BUILD_ROOT/%{_bindir}/pbs-config
|
||||
|
||||
# install initscripts
|
||||
%__mkdir_p $RPM_BUILD_ROOT%{_initrddir}
|
||||
@ -171,6 +180,15 @@ desktop-file-install --vendor fedora \
|
||||
%endif
|
||||
|
||||
|
||||
# alternatives stuff
|
||||
for bin in qalter qdel qhold qrls qselect qstat qsub
|
||||
do
|
||||
mv $RPM_BUILD_ROOT%{_bindir}/$bin $RPM_BUILD_ROOT%{_bindir}/${bin}-torque
|
||||
mv $RPM_BUILD_ROOT%{_mandir}/man1/${bin}.1 \
|
||||
$RPM_BUILD_ROOT%{_mandir}/man1/${bin}-torque.1
|
||||
done
|
||||
|
||||
|
||||
%clean
|
||||
%__rm -rf "$RPM_BUILD_ROOT"
|
||||
|
||||
@ -216,6 +234,13 @@ This package holds the documentation files.
|
||||
%defattr(-, root, root)
|
||||
%doc doc/admin_guide.ps
|
||||
%{_mandir}/man*/*
|
||||
%exclude %{_mandir}/man1/qsub-torque.1.gz
|
||||
%exclude %{_mandir}/man1/qalter-torque.1.gz
|
||||
%exclude %{_mandir}/man1/qdel-torque.1.gz
|
||||
%exclude %{_mandir}/man1/qhold-torque.1.gz
|
||||
%exclude %{_mandir}/man1/qrls-torque.1.gz
|
||||
%exclude %{_mandir}/man1/qselect-torque.1.gz
|
||||
%exclude %{_mandir}/man1/qstat-torque.1.gz
|
||||
|
||||
|
||||
%package scheduler
|
||||
@ -230,6 +255,7 @@ This package holds the fifo C scheduler.
|
||||
%files scheduler
|
||||
%defattr(-, root, root)
|
||||
%attr(0755, root, root) %{_sbindir}/pbs_sched
|
||||
%attr(0755, root, root) %{_sbindir}/qschedd
|
||||
%{_initrddir}/pbs_sched
|
||||
%dir %{torquehomedir}/sched_priv
|
||||
%config(noreplace) %{torquehomedir}/sched_priv/*
|
||||
@ -257,6 +283,7 @@ This package holds the server.
|
||||
%files server
|
||||
%defattr(-, root, root)
|
||||
%attr(0755, root, root) %{_sbindir}/pbs_server
|
||||
%attr(0755, root, root) %{_sbindir}/qserverd
|
||||
%attr(0755, root, root) %{_sbindir}/momctl
|
||||
%{_initrddir}/pbs_server
|
||||
%{torquehomedir}/server_logs
|
||||
@ -284,6 +311,8 @@ This package holds the execute daemon required on every node.
|
||||
%files mom
|
||||
%defattr(-, root, root)
|
||||
%attr(0755, root, root) %{_sbindir}/pbs_mom
|
||||
%attr(0755, root, root) %{_sbindir}/qnoded
|
||||
%attr(0755, root, root) %{_bindir}/pbs_track
|
||||
%{_initrddir}/pbs_mom
|
||||
%if %{use_rcp}
|
||||
%attr(4755 root root) %{_sbindir}/pbs_rcp
|
||||
@ -312,6 +341,34 @@ Provides: pbs-client
|
||||
%shared_description
|
||||
This package holds the command-line client programs.
|
||||
|
||||
%posttrans client
|
||||
/usr/sbin/alternatives --install %{_bindir}/qsub qsub %{_bindir}/qsub-torque 10 \
|
||||
--slave %{_mandir}/man1/qsub.1.gz qsub-man \
|
||||
%{_mandir}/man1/qsub-torque.1.gz \
|
||||
--slave %{_bindir}/qalter qalter %{_bindir}/qalter-torque \
|
||||
--slave %{_mandir}/man1/qalter.1.gz qalter-man \
|
||||
%{_mandir}/man1/qalter-torque.1.gz \
|
||||
--slave %{_bindir}/qdel qdel %{_bindir}/qdel-torque \
|
||||
--slave %{_mandir}/man1/qdel.1.gz qdel-man \
|
||||
%{_mandir}/man1/qdel-torque.1.gz \
|
||||
--slave %{_bindir}/qhold qhold %{_bindir}/qhold-torque \
|
||||
--slave %{_mandir}/man1/qhold.1.gz qhold-man \
|
||||
%{_mandir}/man1/qhold-torque.1.gz \
|
||||
--slave %{_bindir}/qrls qrls %{_bindir}/qrls-torque \
|
||||
--slave %{_mandir}/man1/qrls.1.gz qrls-man \
|
||||
%{_mandir}/man1/qrls-torque.1.gz \
|
||||
--slave %{_bindir}/qselect qselect %{_bindir}/qselect-torque \
|
||||
--slave %{_mandir}/man1/qselect.1.gz qselect-man \
|
||||
%{_mandir}/man1/qselect-torque.1.gz \
|
||||
--slave %{_bindir}/qstat qstat %{_bindir}/qstat-torque \
|
||||
--slave %{_mandir}/man1/qstat.1.gz qstat-man \
|
||||
%{_mandir}/man1/qstat-torque.1.gz
|
||||
|
||||
%preun client
|
||||
if [ $1 -eq 0 ]; then
|
||||
/usr/sbin/alternatives --remove qsub %{_bindir}/qsub-torque
|
||||
fi
|
||||
|
||||
%files client
|
||||
%defattr(-, root, root)
|
||||
%{_bindir}/q*
|
||||
@ -322,12 +379,21 @@ This package holds the command-line client programs.
|
||||
%{_bindir}/pbsnodes
|
||||
%{_bindir}/printjob
|
||||
%{_bindir}/printtracking
|
||||
%{_bindir}/printserverdb
|
||||
%{_bindir}/tracejob
|
||||
%attr(4755 root root) %{_sbindir}/pbs_iff
|
||||
%{_sbindir}/pbs_demux
|
||||
%if %use_tcl
|
||||
%{_bindir}/pbs_tclsh
|
||||
%endif
|
||||
%{_mandir}/man1/qsub-torque.1.gz
|
||||
%{_mandir}/man1/qalter-torque.1.gz
|
||||
%{_mandir}/man1/qdel-torque.1.gz
|
||||
%{_mandir}/man1/qhold-torque.1.gz
|
||||
%{_mandir}/man1/qrls-torque.1.gz
|
||||
%{_mandir}/man1/qselect-torque.1.gz
|
||||
%{_mandir}/man1/qstat-torque.1.gz
|
||||
|
||||
|
||||
%package gui
|
||||
Group: Applications/System
|
||||
@ -402,6 +468,48 @@ A simple PAM module to authorize users on PBS MOM nodes with a running job.
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Dec 3 2009 Steve Traylen <steve.traylen@cern.ch> - 2.4.2-1
|
||||
- Updated to upstream 2.4.2
|
||||
- First EPEL build.
|
||||
- Add new commands to package.
|
||||
/usr/bin/pbs_track
|
||||
/usr/bin/printserverdb
|
||||
/usr/sbin/qnoded
|
||||
/usr/sbin/qschedd
|
||||
/usr/sbin/qserverd
|
||||
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.10-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.10-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Mon Apr 16 2008 Garrick Staples <garrick@usc.edu> 2.1.10-6
|
||||
- add alternatives system
|
||||
|
||||
* Thu Feb 14 2008 Garrick Staples <garrick@usc.edu> 2.1.10-5
|
||||
- fix missing NI_MAXSERV on fedora9
|
||||
|
||||
* Thu Jan 3 2008 Garrick Staples <garrick@usc.edu> 2.1.10-4
|
||||
- correct pbs-config build typo
|
||||
|
||||
* Thu Jan 3 2008 Garrick Staples <garrick@usc.edu> 2.1.10-3
|
||||
- rebuild because tcl was bumped
|
||||
|
||||
* Thu Dec 13 2007 Garrick Staples <garrick@usc.edu> 2.1.10-2
|
||||
- fix multilib conflicts
|
||||
|
||||
* Wed Dec 12 2007 Garrick Staples <garrick@usc.edu> 2.1.10-1
|
||||
- bump to 2.1.10
|
||||
|
||||
* Wed Oct 3 2007 Garrick Staples <garrick@usc.edu> 2.1.9-1
|
||||
- bump to 2.1.9
|
||||
|
||||
* Fri Aug 31 2007 Garrick Staples <garrick@usc.edu> 2.1.8-3
|
||||
- correct License tag
|
||||
|
||||
* Wed Aug 15 2007 Garrick Staples <garrick@usc.edu> 2.1.8-2
|
||||
- correct errors in desktop entry files
|
||||
|
||||
* Tue Mar 13 2007 Garrick Staples <garrick@usc.edu> 2.1.8-1
|
||||
- bump to 2.1.8
|
||||
- ensure daemons have the correct path to sendmail
|
||||
|
Loading…
Reference in New Issue
Block a user