parent
79167d70c4
commit
95d6ea8689
1
.gitignore
vendored
1
.gitignore
vendored
@ -29,3 +29,4 @@
|
||||
/toolbox-0.0.99.2^3.git075b9a8d2779.tar.xz
|
||||
/toolbox-0.0.99.3.tar.xz
|
||||
/toolbox-0.0.99.3-vendor.tar.xz
|
||||
/toolbox-0.0.99.4-vendored.tar.xz
|
||||
|
@ -1,27 +0,0 @@
|
||||
#!/bin/sh
|
||||
|
||||
# Process a toolbox tarball to get vendored dependencies for the RHEL build.
|
||||
#
|
||||
# Yaakov Selkowitz <yselkowi@redhat.com> - 2022
|
||||
|
||||
SOURCE="$1"
|
||||
DIRECTORY=`echo $SOURCE | sed 's/\.tar\.xz//'`
|
||||
VENDOR_SOURCE="${DIRECTORY}-vendor.tar.xz"
|
||||
|
||||
error()
|
||||
{
|
||||
MESSAGE=$1
|
||||
echo $MESSAGE
|
||||
exit 1
|
||||
}
|
||||
|
||||
rm -rf $DIRECTORY
|
||||
tar xJf $SOURCE || error "Cannot unpack $SOURCE"
|
||||
pushd $DIRECTORY/src > /dev/null || error "Cannot open directory \"$DIRECTORY\""
|
||||
|
||||
echo "Vendoring dependencies"
|
||||
go mod vendor || error "Vendoring failed"
|
||||
popd > /dev/null
|
||||
|
||||
tar cJf $VENDOR_SOURCE -C $DIRECTORY src/vendor || error "Unable to create $VENDOR_SOURCE"
|
||||
echo "$VENDOR_SOURCE is ready to use"
|
3
sources
3
sources
@ -1,2 +1 @@
|
||||
SHA512 (toolbox-0.0.99.3.tar.xz) = d9e4bd1cc7667b6ecdcf25a2c3ad7d7d67cc997168a41e668c936d2de24db774331a78a1b4a06b63e7cef8e0dc4ac5651591b6d9cec0d8e81be2b2dd64854dca
|
||||
SHA512 (toolbox-0.0.99.3-vendor.tar.xz) = 51ce5a16276ccc75d2b6fb9cae1c4371ad028f6a820cd176a4a0ee85fab447a6b37b5ec2e969b882c4f04cfe58bd78f92975606297a0db22e72457f012102ec2
|
||||
SHA512 (toolbox-0.0.99.4-vendored.tar.xz) = 882cd6ec1c1a193af8774dfdfd0aff72d376c4fec3e0cc702e2d524353c051e408eab2ac3fb43ec00fe622b46ac89fdbe97aca2f7cfbe3822e5d3ff1743f2fd0
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 32aa30a17358598f568991a5375f6182e4135648 Mon Sep 17 00:00:00 2001
|
||||
From 17a0e519fd9b1e721b35a823bd244a28e3f87a4a Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <rishi@fedoraproject.org>
|
||||
Date: Mon, 29 Jun 2020 17:57:47 +0200
|
||||
Subject: [PATCH] build: Make the build flags match Fedora's %{gobuild} for
|
||||
@ -24,22 +24,22 @@ and should be kept updated to match Fedora's Go guidelines. Use
|
||||
1 file changed, 9 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/src/go-build-wrapper b/src/go-build-wrapper
|
||||
index ef4aafc8b024..f8ea8370792c 100755
|
||||
index c572d6dfb02b..cae2de426a96 100755
|
||||
--- a/src/go-build-wrapper
|
||||
+++ b/src/go-build-wrapper
|
||||
@@ -32,9 +32,9 @@ if ! cd "$1"; then
|
||||
@@ -33,9 +33,9 @@ if ! cd "$1"; then
|
||||
exit 1
|
||||
fi
|
||||
|
||||
-tags=""
|
||||
+tags="-tags rpm_crashtraceback,${BUILDTAGS:-}"
|
||||
if $6; then
|
||||
if $7; then
|
||||
- tags="-tags migration_path_for_coreos_toolbox"
|
||||
+ tags="$tags,migration_path_for_coreos_toolbox"
|
||||
fi
|
||||
|
||||
if ! libc_dir=$("$4" --print-file-name=libc.so); then
|
||||
@@ -69,11 +69,16 @@ fi
|
||||
if ! libc_dir=$("$5" --print-file-name=libc.so); then
|
||||
@@ -70,11 +70,16 @@ fi
|
||||
|
||||
dynamic_linker="/run/host$dynamic_linker_canonical_dirname/$dynamic_linker_basename"
|
||||
|
||||
@ -50,14 +50,14 @@ index ef4aafc8b024..f8ea8370792c 100755
|
||||
+ -compiler gc \
|
||||
$tags \
|
||||
- -trimpath \
|
||||
- -ldflags "-extldflags '-Wl,-dynamic-linker,$dynamic_linker -Wl,-rpath,/run/host$libc_dir_canonical_dirname' -linkmode external -X github.com/containers/toolbox/pkg/version.currentVersion=$3" \
|
||||
+ -ldflags "${LDFLAGS:-} -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \n') -compressdwarf=false -extldflags '-Wl,-z,relro -Wl,--as-needed -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -Wl,-dynamic-linker,$dynamic_linker -Wl,-rpath,/run/host$libc_dir_canonical_dirname' -linkmode external -X github.com/containers/toolbox/pkg/version.currentVersion=$3" \
|
||||
- -ldflags "-extldflags '-Wl,-dynamic-linker,$dynamic_linker -Wl,-rpath,/run/host$libc_dir_canonical_dirname' -linkmode external -X github.com/containers/toolbox/pkg/version.currentVersion=$4" \
|
||||
+ -ldflags "${LDFLAGS:-} -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \n') -compressdwarf=false -extldflags '-Wl,-z,relro -Wl,--as-needed -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -Wl,--build-id=sha1 -Wl,-dynamic-linker,$dynamic_linker -Wl,-rpath,/run/host$libc_dir_canonical_dirname' -linkmode external -X github.com/containers/toolbox/pkg/version.currentVersion=$4" \
|
||||
+ -a \
|
||||
+ -v \
|
||||
+ -x \
|
||||
-o "$2/toolbox"
|
||||
-o "$2/$3"
|
||||
|
||||
exit "$?"
|
||||
--
|
||||
2.31.1
|
||||
2.39.1
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 6d913f1fbd6e609957bb01273504b2f479e1b546 Mon Sep 17 00:00:00 2001
|
||||
From fd03e31c7d789413700db84af02894d5be70b5ee Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <rishi@fedoraproject.org>
|
||||
Date: Mon, 29 Jun 2020 17:57:47 +0200
|
||||
Subject: [PATCH] build: Make the build flags match Fedora's %{gobuild}
|
||||
@ -23,22 +23,22 @@ PPC64, and should be kept updated to match Fedora's Go guidelines. Use
|
||||
1 file changed, 10 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/src/go-build-wrapper b/src/go-build-wrapper
|
||||
index ef4aafc8b024..4354beceb215 100755
|
||||
index c572d6dfb02b..0e6a2efa6853 100755
|
||||
--- a/src/go-build-wrapper
|
||||
+++ b/src/go-build-wrapper
|
||||
@@ -32,9 +32,9 @@ if ! cd "$1"; then
|
||||
@@ -33,9 +33,9 @@ if ! cd "$1"; then
|
||||
exit 1
|
||||
fi
|
||||
|
||||
-tags=""
|
||||
+tags="-tags rpm_crashtraceback,${BUILDTAGS:-}"
|
||||
if $6; then
|
||||
if $7; then
|
||||
- tags="-tags migration_path_for_coreos_toolbox"
|
||||
+ tags="$tags,migration_path_for_coreos_toolbox"
|
||||
fi
|
||||
|
||||
if ! libc_dir=$("$4" --print-file-name=libc.so); then
|
||||
@@ -69,11 +69,17 @@ fi
|
||||
if ! libc_dir=$("$5" --print-file-name=libc.so); then
|
||||
@@ -70,11 +70,17 @@ fi
|
||||
|
||||
dynamic_linker="/run/host$dynamic_linker_canonical_dirname/$dynamic_linker_basename"
|
||||
|
||||
@ -50,14 +50,14 @@ index ef4aafc8b024..4354beceb215 100755
|
||||
+ -compiler gc \
|
||||
$tags \
|
||||
- -trimpath \
|
||||
- -ldflags "-extldflags '-Wl,-dynamic-linker,$dynamic_linker -Wl,-rpath,/run/host$libc_dir_canonical_dirname' -linkmode external -X github.com/containers/toolbox/pkg/version.currentVersion=$3" \
|
||||
+ -ldflags "${LDFLAGS:-} -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \n') -compressdwarf=false -extldflags '-Wl,-z,relro -Wl,--as-needed -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -Wl,-dynamic-linker,$dynamic_linker -Wl,-rpath,/run/host$libc_dir_canonical_dirname' -linkmode external -X github.com/containers/toolbox/pkg/version.currentVersion=$3" \
|
||||
- -ldflags "-extldflags '-Wl,-dynamic-linker,$dynamic_linker -Wl,-rpath,/run/host$libc_dir_canonical_dirname' -linkmode external -X github.com/containers/toolbox/pkg/version.currentVersion=$4" \
|
||||
+ -ldflags "${LDFLAGS:-} -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \n') -compressdwarf=false -extldflags '-Wl,-z,relro -Wl,--as-needed -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -Wl,--build-id=sha1 -Wl,-dynamic-linker,$dynamic_linker -Wl,-rpath,/run/host$libc_dir_canonical_dirname' -linkmode external -X github.com/containers/toolbox/pkg/version.currentVersion=$4" \
|
||||
+ -a \
|
||||
+ -v \
|
||||
+ -x \
|
||||
-o "$2/toolbox"
|
||||
-o "$2/$3"
|
||||
|
||||
exit "$?"
|
||||
--
|
||||
2.31.1
|
||||
2.39.1
|
||||
|
||||
|
@ -1,95 +0,0 @@
|
||||
From e598e2160323b63310ad7b6def723eb1f8767f90 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Ond=C5=99ej=20M=C3=ADchal?= <harrymichal@seznam.cz>
|
||||
Date: Thu, 11 Nov 2021 18:18:52 +0200
|
||||
Subject: [PATCH 02/13] cmd/root: Work around Cobra 1.1.2's handling of usage
|
||||
functions
|
||||
|
||||
In version 1.1.2 of Cobra has been included a change[0] that changes
|
||||
how custom usage functions are handled.
|
||||
|
||||
Example of the wrong behaviour:
|
||||
$ toolbox --foo
|
||||
Error: unknown flag: --foo
|
||||
Run 'toolbox --help' for usage.Error: Run 'toolbox --help' for usage.
|
||||
|
||||
Desired behaviour:
|
||||
$ toolbox --foo
|
||||
Error: unknown flag: --foo
|
||||
Run 'toolbox --help' for usage.
|
||||
|
||||
A workaround is to define a template string for the usage instead. The
|
||||
template uses the templating language of Go[1]. See the default
|
||||
template string in version 1.2.1[2].
|
||||
|
||||
Because the template is set only once, the executableBase needs to be
|
||||
set before the template is applied. That required the move of
|
||||
setUpGlobals() into init() of the cmd package. This is a better place
|
||||
for the function call as init() is called earlier than Execute()[3].
|
||||
|
||||
Upstream issue: https://github.com/spf13/cobra/issues/1532
|
||||
|
||||
[0] https://github.com/spf13/cobra/pull/1044
|
||||
[1] https://pkg.go.dev/text/template
|
||||
[2] https://github.com/spf13/cobra/blob/v1.2.1/command.go#L491
|
||||
[3] https://golang.org/doc/effective_go#init
|
||||
|
||||
https://github.com/containers/toolbox/pull/917
|
||||
---
|
||||
src/cmd/root.go | 20 ++++++++------------
|
||||
1 file changed, 8 insertions(+), 12 deletions(-)
|
||||
|
||||
diff --git a/src/cmd/root.go b/src/cmd/root.go
|
||||
index eb0622f..ad0753b 100644
|
||||
--- a/src/cmd/root.go
|
||||
+++ b/src/cmd/root.go
|
||||
@@ -62,11 +62,6 @@ var (
|
||||
)
|
||||
|
||||
func Execute() {
|
||||
- if err := setUpGlobals(); err != nil {
|
||||
- fmt.Fprintf(os.Stderr, "Error: %s\n", err)
|
||||
- os.Exit(1)
|
||||
- }
|
||||
-
|
||||
if err := rootCmd.Execute(); err != nil {
|
||||
os.Exit(1)
|
||||
}
|
||||
@@ -75,6 +70,11 @@ func Execute() {
|
||||
}
|
||||
|
||||
func init() {
|
||||
+ if err := setUpGlobals(); err != nil {
|
||||
+ fmt.Fprintf(os.Stderr, "Error: %s\n", err)
|
||||
+ os.Exit(1)
|
||||
+ }
|
||||
+
|
||||
persistentFlags := rootCmd.PersistentFlags()
|
||||
|
||||
persistentFlags.BoolVarP(&rootFlags.assumeYes,
|
||||
@@ -96,7 +96,9 @@ func init() {
|
||||
persistentFlags.CountVarP(&rootFlags.verbose, "verbose", "v", "Set log-level to 'debug'")
|
||||
|
||||
rootCmd.SetHelpFunc(rootHelp)
|
||||
- rootCmd.SetUsageFunc(rootUsage)
|
||||
+
|
||||
+ usageTemplate := fmt.Sprintf("Run '%s --help' for usage.", executableBase)
|
||||
+ rootCmd.SetUsageTemplate(usageTemplate)
|
||||
}
|
||||
|
||||
func preRun(cmd *cobra.Command, args []string) error {
|
||||
@@ -188,12 +190,6 @@ func rootRun(cmd *cobra.Command, args []string) error {
|
||||
return rootRunImpl(cmd, args)
|
||||
}
|
||||
|
||||
-func rootUsage(cmd *cobra.Command) error {
|
||||
- err := fmt.Errorf("Run '%s --help' for usage.", executableBase)
|
||||
- fmt.Fprintf(os.Stderr, "%s", err)
|
||||
- return err
|
||||
-}
|
||||
-
|
||||
func migrate() error {
|
||||
logrus.Debug("Migrating to newer Podman")
|
||||
|
||||
--
|
||||
2.34.1
|
||||
|
52
toolbox.spec
52
toolbox.spec
@ -1,7 +1,7 @@
|
||||
%global __brp_check_rpaths %{nil}
|
||||
|
||||
Name: toolbox
|
||||
Version: 0.0.99.3
|
||||
Version: 0.0.99.4
|
||||
|
||||
%global goipath github.com/containers/%{name}
|
||||
|
||||
@ -11,44 +11,43 @@ Version: 0.0.99.3
|
||||
%gometa -f
|
||||
%endif
|
||||
|
||||
Release: 12%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: Tool for containerized command line environments on Linux
|
||||
|
||||
License: ASL 2.0
|
||||
URL: https://containertoolbx.org/
|
||||
Source0: https://github.com/containers/%{name}/releases/download/%{version}/%{name}-%{version}.tar.xz
|
||||
# RHEL package is built with vendored dependencies
|
||||
# created with gen-vendor-tarball.sh from SOURCE2
|
||||
Source1: %{name}-%{version}-vendor.tar.xz
|
||||
Source2: gen-vendor-tarball.sh
|
||||
Source0: https://github.com/containers/%{name}/releases/download/%{version}/%{name}-%{version}-vendored.tar.xz
|
||||
|
||||
# Fedora specific
|
||||
Patch100: toolbox-Make-the-build-flags-match-Fedora-s-gobuild.patch
|
||||
Patch101: toolbox-Make-the-build-flags-match-Fedora-s-gobuild-for-PPC64.patch
|
||||
Patch102: toolbox-cmd-root-Work-around-Cobra-1.1.2-s-handling-of-usage.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: go-md2man
|
||||
BuildRequires: golang >= 1.19.4
|
||||
%if ! 0%{?rhel}
|
||||
BuildRequires: golang(github.com/HarryMichal/go-version)
|
||||
BuildRequires: golang(github.com/acobaugh/osrelease)
|
||||
BuildRequires: golang(github.com/briandowns/spinner) >= 1.10.0
|
||||
BuildRequires: golang(github.com/HarryMichal/go-version) >= 1.0.1
|
||||
BuildRequires: golang(github.com/acobaugh/osrelease) >= 0.1.0
|
||||
BuildRequires: golang(github.com/briandowns/spinner) >= 1.17.0
|
||||
BuildRequires: golang(github.com/docker/go-units) >= 0.4.0
|
||||
BuildRequires: golang(github.com/fsnotify/fsnotify) >= 1.4.7
|
||||
BuildRequires: golang(github.com/godbus/dbus) >= 5.0.3
|
||||
BuildRequires: golang(github.com/mattn/go-isatty) >= 0.0.12
|
||||
BuildRequires: golang(github.com/sirupsen/logrus) >= 1.4.2
|
||||
BuildRequires: golang(github.com/spf13/cobra) >= 0.0.5
|
||||
BuildRequires: golang(github.com/spf13/viper) >= 1.3.2
|
||||
BuildRequires: golang(golang.org/x/crypto/ssh/terminal)
|
||||
BuildRequires: golang(github.com/fsnotify/fsnotify) >= 1.5.1
|
||||
BuildRequires: golang(github.com/godbus/dbus) >= 5.0.6
|
||||
BuildRequires: golang(github.com/sirupsen/logrus) >= 1.8.1
|
||||
BuildRequires: golang(github.com/spf13/cobra) >= 1.3.0
|
||||
BuildRequires: golang(github.com/spf13/viper) >= 1.10.1
|
||||
BuildRequires: golang(golang.org/x/sys/unix)
|
||||
BuildRequires: golang(golang.org/x/term)
|
||||
# for tests
|
||||
# BuildRequires: codespell
|
||||
# BuildRequires: golang(github.com/stretchr/testify) >= 1.7.0
|
||||
# BuildRequires: ShellCheck
|
||||
%endif
|
||||
BuildRequires: meson >= 0.58.0
|
||||
BuildRequires: pkgconfig(bash-completion)
|
||||
BuildRequires: pkgconfig(fish)
|
||||
BuildRequires: podman
|
||||
BuildRequires: shadow-utils-subid-devel
|
||||
BuildRequires: systemd
|
||||
BuildRequires: systemd-rpm-macros
|
||||
|
||||
Requires: containers-common
|
||||
@ -153,7 +152,7 @@ The %{name}-tests package contains system tests for %{name}.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q %{?rhel:-a 1}
|
||||
%setup -q
|
||||
|
||||
%ifnarch ppc64
|
||||
%patch100 -p1
|
||||
@ -161,10 +160,6 @@ The %{name}-tests package contains system tests for %{name}.
|
||||
%patch101 -p1
|
||||
%endif
|
||||
|
||||
%if ! 0%{?rhel}
|
||||
%patch102 -p1
|
||||
%endif
|
||||
|
||||
%gomkdir -s %{_builddir}/%{extractdir}/src %{?rhel:-k}
|
||||
|
||||
|
||||
@ -173,7 +168,10 @@ export %{gomodulesmode}
|
||||
export GOPATH=%{gobuilddir}:%{gopath}
|
||||
export CGO_CFLAGS="%{optflags} -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64"
|
||||
|
||||
%meson -Dprofile_dir=%{_sysconfdir}/profile.d -Dtmpfiles_dir=%{_tmpfilesdir}
|
||||
%meson \
|
||||
-Dprofile_dir=%{_sysconfdir}/profile.d \
|
||||
-Dtmpfiles_dir=%{_tmpfilesdir} \
|
||||
-Dzsh_completions_dir=%{_datadir}/zsh/site-functions
|
||||
%meson_build
|
||||
|
||||
|
||||
@ -190,8 +188,11 @@ export CGO_CFLAGS="%{optflags} -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_LARGEFILE64_
|
||||
%license COPYING %{?rhel:src/vendor/modules.txt}
|
||||
%{_bindir}/%{name}
|
||||
%{_datadir}/bash-completion
|
||||
%{_datadir}/fish
|
||||
%{_datadir}/zsh
|
||||
%{_mandir}/man1/%{name}.1*
|
||||
%{_mandir}/man1/%{name}-*.1*
|
||||
%{_mandir}/man5/%{name}.conf.5*
|
||||
%config(noreplace) %{_sysconfdir}/containers/%{name}.conf
|
||||
%{_sysconfdir}/profile.d/%{name}.sh
|
||||
%{_tmpfilesdir}/%{name}.conf
|
||||
@ -209,6 +210,9 @@ export CGO_CFLAGS="%{optflags} -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_LARGEFILE64_
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Feb 22 2023 Debarshi Ray <rishi@fedoraproject.org> - 0.0.99.4-1
|
||||
- Update to 0.0.99.4
|
||||
|
||||
* Wed Feb 22 2023 Martin Jackson <mhjacks@swbell.net> - 0.0.99.3-12
|
||||
- Fix the ExclusiveArch
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user