Remove a patch specific to Fedora that doesn't seem necessary anymore
There's no need to do a build just for this.
This commit is contained in:
parent
cbcdb7a21c
commit
79167d70c4
@ -1,72 +0,0 @@
|
||||
From 40fbd377ed0b94060ae5fb2a60289500b66486dc Mon Sep 17 00:00:00 2001
|
||||
From: Oliver Gutierrez <ogutsua@gmail.com>
|
||||
Date: Thu, 29 Jul 2021 14:12:41 +0100
|
||||
Subject: [PATCH] Don't use Go's semantic import versioning
|
||||
|
||||
Fedora doesn't support Go modules when building Go programs. This
|
||||
means that source code using semantic import versioning can't be built.
|
||||
|
||||
---
|
||||
src/cmd/create.go | 2 +-
|
||||
src/go.mod | 2 +-
|
||||
src/go.sum | 4 ++--
|
||||
src/pkg/utils/utils.go | 2 +-
|
||||
4 files changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/src/cmd/create.go b/src/cmd/create.go
|
||||
index 8b31365..502f691 100644
|
||||
--- a/src/cmd/create.go
|
||||
+++ b/src/cmd/create.go
|
||||
@@ -28,7 +28,7 @@ import (
|
||||
"github.com/containers/toolbox/pkg/podman"
|
||||
"github.com/containers/toolbox/pkg/shell"
|
||||
"github.com/containers/toolbox/pkg/utils"
|
||||
- "github.com/godbus/dbus/v5"
|
||||
+ "github.com/godbus/dbus"
|
||||
"github.com/sirupsen/logrus"
|
||||
"github.com/spf13/cobra"
|
||||
"golang.org/x/crypto/ssh/terminal"
|
||||
diff --git a/src/go.mod b/src/go.mod
|
||||
index cce3e5a..eb7f70c 100644
|
||||
--- a/src/go.mod
|
||||
+++ b/src/go.mod
|
||||
@@ -8,7 +8,7 @@ require (
|
||||
github.com/briandowns/spinner v1.10.0
|
||||
github.com/docker/go-units v0.4.0
|
||||
github.com/fsnotify/fsnotify v1.4.7
|
||||
- github.com/godbus/dbus/v5 v5.0.3
|
||||
+ github.com/godbus/dbus v4.1.0+incompatible
|
||||
github.com/mattn/go-isatty v0.0.8
|
||||
github.com/sirupsen/logrus v1.4.2
|
||||
github.com/spf13/cobra v0.0.5
|
||||
diff --git a/src/go.sum b/src/go.sum
|
||||
index fbad155..737f058 100644
|
||||
--- a/src/go.sum
|
||||
+++ b/src/go.sum
|
||||
@@ -20,8 +20,8 @@ github.com/fatih/color v1.7.0 h1:DkWD4oS2D8LGGgTQ6IvwJJXSL5Vp2ffcQg58nFV38Ys=
|
||||
github.com/fatih/color v1.7.0/go.mod h1:Zm6kSWBoL9eyXnKyktHP6abPY2pDugNf5KwzbycvMj4=
|
||||
github.com/fsnotify/fsnotify v1.4.7 h1:IXs+QLmnXW2CcXuY+8Mzv/fWEsPGWxqefPtCP5CnV9I=
|
||||
github.com/fsnotify/fsnotify v1.4.7/go.mod h1:jwhsz4b93w/PPRr/qN1Yymfu8t87LnFCMoQvtojpjFo=
|
||||
-github.com/godbus/dbus/v5 v5.0.3 h1:ZqHaoEF7TBzh4jzPmqVhE/5A1z9of6orkAe5uHoAeME=
|
||||
-github.com/godbus/dbus/v5 v5.0.3/go.mod h1:xhWf0FNVPg57R7Z0UbKHbJfkEywrmjJnf7w5xrFpKfA=
|
||||
+github.com/godbus/dbus v4.1.0+incompatible h1:WqqLRTsQic3apZUK9qC5sGNfXthmPXzUZ7nQPrNITa4=
|
||||
+github.com/godbus/dbus v4.1.0+incompatible/go.mod h1:/YcGZj5zSblfDWMMoOzV4fas9FZnQYTkDnsGvmh2Grw=
|
||||
github.com/hashicorp/hcl v1.0.0 h1:0Anlzjpi4vEasTeNFn2mLJgTSwt0+6sfsiTG8qcWGx4=
|
||||
github.com/hashicorp/hcl v1.0.0/go.mod h1:E5yfLk+7swimpb2L/Alb/PJmXilQ/rhwaUYs4T20WEQ=
|
||||
github.com/inconshreveable/mousetrap v1.0.0 h1:Z8tu5sraLXCXIcARxBp/8cbvlwVa7Z1NHg9XEKhtSvM=
|
||||
diff --git a/src/pkg/utils/utils.go b/src/pkg/utils/utils.go
|
||||
index ae7c596..4d1556a 100644
|
||||
--- a/src/pkg/utils/utils.go
|
||||
+++ b/src/pkg/utils/utils.go
|
||||
@@ -33,7 +33,7 @@ import (
|
||||
"github.com/acobaugh/osrelease"
|
||||
"github.com/containers/toolbox/pkg/shell"
|
||||
"github.com/docker/go-units"
|
||||
- "github.com/godbus/dbus/v5"
|
||||
+ "github.com/godbus/dbus"
|
||||
"github.com/sirupsen/logrus"
|
||||
"github.com/spf13/viper"
|
||||
"golang.org/x/sys/unix"
|
||||
--
|
||||
2.31.1
|
||||
|
16
toolbox.spec
16
toolbox.spec
@ -23,10 +23,9 @@ Source1: %{name}-%{version}-vendor.tar.xz
|
||||
Source2: gen-vendor-tarball.sh
|
||||
|
||||
# Fedora specific
|
||||
Patch100: toolbox-Don-t-use-Go-s-semantic-import-versioning.patch
|
||||
Patch101: toolbox-Make-the-build-flags-match-Fedora-s-gobuild.patch
|
||||
Patch102: toolbox-Make-the-build-flags-match-Fedora-s-gobuild-for-PPC64.patch
|
||||
Patch103: toolbox-cmd-root-Work-around-Cobra-1.1.2-s-handling-of-usage.patch
|
||||
Patch100: toolbox-Make-the-build-flags-match-Fedora-s-gobuild.patch
|
||||
Patch101: toolbox-Make-the-build-flags-match-Fedora-s-gobuild-for-PPC64.patch
|
||||
Patch102: toolbox-cmd-root-Work-around-Cobra-1.1.2-s-handling-of-usage.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: go-md2man
|
||||
@ -155,18 +154,15 @@ The %{name}-tests package contains system tests for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q %{?rhel:-a 1}
|
||||
%if ! 0%{?rhel}
|
||||
%patch100 -p1
|
||||
%endif
|
||||
|
||||
%ifnarch ppc64
|
||||
%patch101 -p1
|
||||
%patch100 -p1
|
||||
%else
|
||||
%patch102 -p1
|
||||
%patch101 -p1
|
||||
%endif
|
||||
|
||||
%if ! 0%{?rhel}
|
||||
%patch103 -p1
|
||||
%patch102 -p1
|
||||
%endif
|
||||
|
||||
%gomkdir -s %{_builddir}/%{extractdir}/src %{?rhel:-k}
|
||||
|
Loading…
Reference in New Issue
Block a user