Change directory layout to conform to Red Hat conventions; Implement use of

lib64 for 64-bit compiled libraries; Allow building when tog-pegasus
    packages are installed on build machine; Fix buffer overflow bugs
    167164 167165.
This commit is contained in:
jvdias 2005-10-03 21:36:16 +00:00
parent 609401d66b
commit 4582f8b6be

View File

@ -1,5 +1,5 @@
--- pegasus-2.5/Makefile.ReleaseTest.redhat 2005-05-27 13:29:01.000000000 -0400 --- pegasus-2.5/Makefile.ReleaseTest.redhat 2005-05-27 13:29:01.000000000 -0400
+++ pegasus-2.5/Makefile.ReleaseTest 2005-10-03 14:49:56.000000000 -0400 +++ pegasus-2.5/Makefile.ReleaseTest 2005-10-03 17:12:17.000000000 -0400
@@ -54,7 +54,7 @@ @@ -54,7 +54,7 @@
endif endif
@ -62,7 +62,7 @@
"%attr($(Pr_xr_xr_x),$(INSTALL_USR),$(INSTALL_GRP)) $(PEGASUS_TEST_DIR)/bin/$(i)" >> $(PEGASUS_RPM_SPEC_FILE_PATH);) "%attr($(Pr_xr_xr_x),$(INSTALL_USR),$(INSTALL_GRP)) $(PEGASUS_TEST_DIR)/bin/$(i)" >> $(PEGASUS_RPM_SPEC_FILE_PATH);)
@$(foreach i, $(POSTSTARTTEST_FILES), $(ECHO-E) \ @$(foreach i, $(POSTSTARTTEST_FILES), $(ECHO-E) \
--- pegasus-2.5/Makefile.Release.redhat 2005-08-17 17:00:43.000000000 -0400 --- pegasus-2.5/Makefile.Release.redhat 2005-08-17 17:00:43.000000000 -0400
+++ pegasus-2.5/Makefile.Release 2005-10-03 14:49:56.000000000 -0400 +++ pegasus-2.5/Makefile.Release 2005-10-03 17:12:17.000000000 -0400
@@ -481,13 +481,13 @@ @@ -481,13 +481,13 @@
$(MAKE) -f $(ROOT)/Makefile.Release setpermissions PERMISSIONS="$(Prwxr_xr_x)" OWNER="$(INSTALL_USR)" GROUP="$(INSTALL_GRP)" OBJECT=$(PEGASUS_STAGING_DIR)$(PEGASUS_LOCAL_AUTH_DIR) $(MAKE) -f $(ROOT)/Makefile.Release setpermissions PERMISSIONS="$(Prwxr_xr_x)" OWNER="$(INSTALL_USR)" GROUP="$(INSTALL_GRP)" OBJECT=$(PEGASUS_STAGING_DIR)$(PEGASUS_LOCAL_AUTH_DIR)
@ -80,7 +80,7 @@
setpermissions_PegasusProviderLibraryDirectoryFiles: FORCE setpermissions_PegasusProviderLibraryDirectoryFiles: FORCE
--- pegasus-2.5/env_var_Linux.status.redhat 2005-09-02 14:40:58.000000000 -0400 --- pegasus-2.5/env_var_Linux.status.redhat 2005-09-02 14:40:58.000000000 -0400
+++ pegasus-2.5/env_var_Linux.status 2005-10-03 14:49:56.000000000 -0400 +++ pegasus-2.5/env_var_Linux.status 2005-10-03 17:12:17.000000000 -0400
@@ -9,6 +9,7 @@ @@ -9,6 +9,7 @@
PEGASUS_OVERRIDE_PRODUCT_ID=yes PEGASUS_OVERRIDE_PRODUCT_ID=yes
PEGASUS_PRODUCT_NAME="OpenPegasus" PEGASUS_PRODUCT_NAME="OpenPegasus"
@ -149,7 +149,7 @@
PEGASUS_TEST_REPOSITORY_NAME = testrepository PEGASUS_TEST_REPOSITORY_NAME = testrepository
--- pegasus-2.5/mak/objects-unix.mak.redhat 2005-05-12 11:27:28.000000000 -0400 --- pegasus-2.5/mak/objects-unix.mak.redhat 2005-05-12 11:27:28.000000000 -0400
+++ pegasus-2.5/mak/objects-unix.mak 2005-10-03 14:51:10.000000000 -0400 +++ pegasus-2.5/mak/objects-unix.mak 2005-10-03 17:12:17.000000000 -0400
@@ -50,12 +50,12 @@ @@ -50,12 +50,12 @@
ifeq ($(_NO_TMP_O), yes) ifeq ($(_NO_TMP_O), yes)
@ -181,7 +181,7 @@
@ $(RM) $(_TMP_O) @ $(RM) $(_TMP_O)
@ $(TOUCH) $@ @ $(TOUCH) $@
--- pegasus-2.5/mak/config-linux.mak.redhat 2005-05-12 11:27:28.000000000 -0400 --- pegasus-2.5/mak/config-linux.mak.redhat 2005-05-12 11:27:28.000000000 -0400
+++ pegasus-2.5/mak/config-linux.mak 2005-10-03 14:49:56.000000000 -0400 +++ pegasus-2.5/mak/config-linux.mak 2005-10-03 17:12:17.000000000 -0400
@@ -76,10 +76,12 @@ @@ -76,10 +76,12 @@
SYS_LIBS = -ldl -lpthread SYS_LIBS = -ldl -lpthread
@ -215,7 +215,7 @@
endif endif
--- pegasus-2.5/mak/SDKMakefile.redhat 2005-07-15 15:46:17.000000000 -0400 --- pegasus-2.5/mak/SDKMakefile.redhat 2005-07-15 15:46:17.000000000 -0400
+++ pegasus-2.5/mak/SDKMakefile 2005-10-03 14:49:56.000000000 -0400 +++ pegasus-2.5/mak/SDKMakefile 2005-10-03 17:12:17.000000000 -0400
@@ -382,10 +382,10 @@ @@ -382,10 +382,10 @@
@$(MAKE) --directory=$(PEGASUS_ROOT)/mak -f SDKMakefile -i deregisterproviders @$(MAKE) --directory=$(PEGASUS_ROOT)/mak -f SDKMakefile -i deregisterproviders
@$(MAKE) --directory=$(PEGASUS_STAGING_DIR)$(PEGASUS_SAMPLES_DIR) -f Makefile clean \ @$(MAKE) --directory=$(PEGASUS_STAGING_DIR)$(PEGASUS_SAMPLES_DIR) -f Makefile clean \
@ -231,7 +231,7 @@
@$(MAKE) --directory=$(PEGASUS_STAGING_DIR)$(PEGASUS_SAMPLES_DIR)/Providers/Load -f Makefile createrepository \ @$(MAKE) --directory=$(PEGASUS_STAGING_DIR)$(PEGASUS_SAMPLES_DIR)/Providers/Load -f Makefile createrepository \
PEGASUS_MOF_DIR=$(PEGASUS_ROOT)/Schemas PEGASUS_BIN_DIR=$(PEGASUS_HOME)bin PEGASUS_MOF_DIR=$(PEGASUS_ROOT)/Schemas PEGASUS_BIN_DIR=$(PEGASUS_HOME)bin
--- pegasus-2.5/mak/config.mak.redhat 2005-08-12 13:52:31.000000000 -0400 --- pegasus-2.5/mak/config.mak.redhat 2005-08-12 13:52:31.000000000 -0400
+++ pegasus-2.5/mak/config.mak 2005-10-03 14:49:56.000000000 -0400 +++ pegasus-2.5/mak/config.mak 2005-10-03 17:12:17.000000000 -0400
@@ -85,7 +85,7 @@ @@ -85,7 +85,7 @@
OBJ_DIR = $(HOME_DIR)/obj/$(DIR) OBJ_DIR = $(HOME_DIR)/obj/$(DIR)
@ -251,7 +251,7 @@
ifeq ($(OS),VMS) ifeq ($(OS),VMS)
--- pegasus-2.5/mak/program-unix.mak.redhat 2005-05-12 11:27:28.000000000 -0400 --- pegasus-2.5/mak/program-unix.mak.redhat 2005-05-12 11:27:28.000000000 -0400
+++ pegasus-2.5/mak/program-unix.mak 2005-10-03 14:49:56.000000000 -0400 +++ pegasus-2.5/mak/program-unix.mak 2005-10-03 17:14:17.000000000 -0400
@@ -28,6 +28,12 @@ @@ -28,6 +28,12 @@
#//============================================================================== #//==============================================================================
INCLUDES = -I$(ROOT)/src $(EXTRA_INCLUDES) INCLUDES = -I$(ROOT)/src $(EXTRA_INCLUDES)
@ -274,7 +274,7 @@
endif endif
endif endif
endif endif
@@ -90,9 +96,9 @@ @@ -90,17 +96,17 @@
ifdef ICU_ROOT ifdef ICU_ROOT
ifdef ICU_INSTALL ifdef ICU_INSTALL
ifdef PEGASUS_USE_RELEASE_DIRS ifdef PEGASUS_USE_RELEASE_DIRS
@ -286,6 +286,16 @@
endif endif
endif endif
endif endif
else
ifdef PEGASUS_USE_RELEASE_DIRS
- $(LINK_WRAPPER) $(CXX) $(FLAGS) $(EXTRA_LINK_FLAGS) -Xlinker -rpath -Xlinker $(PEGASUS_DEST_LIB_DIR) -Xlinker -rpath-link -Xlinker $(LIB_DIR) -L$(LIB_DIR) $(EXE_OUTPUT) $(OBJECTS) $(DYNAMIC_LIBRARIES) $(SYS_LIBS)
+ $(LINK_WRAPPER) $(CXX) $(FLAGS) $(EXTRA_LINK_FLAGS) -L$(PEGASUS_HOME)/$(PEGASUS_ARCH_LIB_DIR) -Xlinker -rpath-link -Xlinker $(PEGASUS_HOME)/$(PEGASUS_ARCH_LIB_DIR) $(EXE_OUTPUT) $(OBJECTS) $(DYNAMIC_LIBRARIES) $(SYS_LIBS)
else
- $(LINK_WRAPPER) $(CXX) $(FLAGS) $(EXTRA_LINK_FLAGS) -Xlinker -rpath -Xlinker $(LIB_DIR) -L$(LIB_DIR) $(EXE_OUTPUT) $(OBJECTS) $(DYNAMIC_LIBRARIES) $(SYS_LIBS)
+ $(LINK_WRAPPER) $(CXX) $(FLAGS) $(EXTRA_LINK_FLAGS) -L$(PEGASUS_HOME)/$(PEGASUS_ARCH_LIB_DIR) -Xlinker -rpath-link -Xlinker $(PEGASUS_HOME)/$(PEGASUS_ARCH_LIB_DIR) $(EXE_OUTPUT) $(OBJECTS) $(DYNAMIC_LIBRARIES) $(SYS_LIBS)
endif
endif
else
@@ -109,11 +115,11 @@ @@ -109,11 +115,11 @@
ifdef PEGASUS_HAS_MESSAGES ifdef PEGASUS_HAS_MESSAGES
ifdef ICU_ROOT ifdef ICU_ROOT
@ -307,7 +317,7 @@
+ +
+include $(ROOT)/mak/install-program-unix.mak +include $(ROOT)/mak/install-program-unix.mak
--- pegasus-2.5/mak/library-unix.mak.redhat 2005-05-12 11:27:28.000000000 -0400 --- pegasus-2.5/mak/library-unix.mak.redhat 2005-05-12 11:27:28.000000000 -0400
+++ pegasus-2.5/mak/library-unix.mak 2005-10-03 14:49:56.000000000 -0400 +++ pegasus-2.5/mak/library-unix.mak 2005-10-03 17:14:54.000000000 -0400
@@ -32,11 +32,11 @@ @@ -32,11 +32,11 @@
ifdef PEGASUS_HAS_MESSAGES ifdef PEGASUS_HAS_MESSAGES
ifdef ICU_ROOT ifdef ICU_ROOT
@ -338,6 +348,19 @@
endif endif
endif endif
LINK_COMMAND += -Wl,+s LINK_COMMAND += -Wl,+s
@@ -79,10 +79,10 @@
ifneq ($(PEGASUS_PLATFORM),DARWIN_PPC_GNU)
ifdef PEGASUS_USE_RELEASE_DIRS
LINK_COMMAND = $(CXX) -shared
- LINK_ARGUMENTS = -Wl,-hlib$(LIBRARY)$(LIB_SUFFIX) -Xlinker -rpath -Xlinker $(PEGASUS_DEST_LIB_DIR)
+ LINK_ARGUMENTS = -Wl,-hlib$(LIBRARY)$(LIB_SUFFIX) -L$(PEGASUS_HOME)/$(PEGASUS_ARCH_LIB_DIR) -Xlinker -rpath-link -Xlinker $(PEGASUS_HOME)/$(PEGASUS_ARCH_LIB_DIR) $(EXTRA_LINK_ARGUMENTS)
else
LINK_COMMAND = $(CXX) -shared
- LINK_ARGUMENTS = -Wl,-hlib$(LIBRARY)$(LIB_SUFFIX) -Xlinker -rpath -Xlinker $(LIB_DIR) $(EXTRA_LINK_ARGUMENTS)
+ LINK_ARGUMENTS = -Wl,-hlib$(LIBRARY)$(LIB_SUFFIX) -L$(PEGASUS_HOME)/$(PEGASUS_ARCH_LIB_DIR) -Xlinker -rpath-link -Xlinker $(PEGASUS_HOME)/$(PEGASUS_ARCH_LIB_DIR) $(EXTRA_LINK_ARGUMENTS)
endif
else
LINK_COMMAND = $(CXX) -dynamiclib
@@ -164,3 +164,5 @@ @@ -164,3 +164,5 @@
ln -f -s $(LIBRARY)$(SUFFIX) $(LIBRARY).$(PLATFORM_SUFFIX) ln -f -s $(LIBRARY)$(SUFFIX) $(LIBRARY).$(PLATFORM_SUFFIX)
@ -345,7 +368,7 @@
+ +
+include $(ROOT)/mak/install-library-unix.mak +include $(ROOT)/mak/install-library-unix.mak
--- pegasus-2.5/rpm/wbem.redhat 2003-03-13 12:25:15.000000000 -0500 --- pegasus-2.5/rpm/wbem.redhat 2003-03-13 12:25:15.000000000 -0500
+++ pegasus-2.5/rpm/wbem 2005-10-03 14:49:56.000000000 -0400 +++ pegasus-2.5/rpm/wbem 2005-10-03 17:12:17.000000000 -0400
@@ -1,13 +1,7 @@ @@ -1,13 +1,7 @@
#%PAM-1.0 #%PAM-1.0
-auth required /lib/security/pam_env.so -auth required /lib/security/pam_env.so
@ -367,7 +390,7 @@
+session required pam_stack.so service=system-auth +session required pam_stack.so service=system-auth
+session required pam_loginuid.so +session required pam_loginuid.so
--- pegasus-2.5/rpm/tog-pegasus.rc.redhat 2005-05-29 02:43:30.000000000 -0400 --- pegasus-2.5/rpm/tog-pegasus.rc.redhat 2005-05-29 02:43:30.000000000 -0400
+++ pegasus-2.5/rpm/tog-pegasus.rc 2005-10-03 14:49:56.000000000 -0400 +++ pegasus-2.5/rpm/tog-pegasus.rc 2005-10-03 17:12:17.000000000 -0400
@@ -1,34 +1,28 @@ @@ -1,34 +1,28 @@
#! /bin/sh #! /bin/sh
-#//%2005//////////////////////////////////////////////////////////////////////// -#//%2005////////////////////////////////////////////////////////////////////////
@ -466,7 +489,7 @@
status) status)
pid=`pidofproc $CIMSERVER_BIN` pid=`pidofproc $CIMSERVER_BIN`
--- pegasus-2.5/src/Pegasus/ProviderManager2/tests/ProviderManagerModule/ProviderManagerModule.cpp.redhat 2005-04-18 17:18:24.000000000 -0400 --- pegasus-2.5/src/Pegasus/ProviderManager2/tests/ProviderManagerModule/ProviderManagerModule.cpp.redhat 2005-04-18 17:18:24.000000000 -0400
+++ pegasus-2.5/src/Pegasus/ProviderManager2/tests/ProviderManagerModule/ProviderManagerModule.cpp 2005-10-03 14:49:56.000000000 -0400 +++ pegasus-2.5/src/Pegasus/ProviderManager2/tests/ProviderManagerModule/ProviderManagerModule.cpp 2005-10-03 17:12:17.000000000 -0400
@@ -134,7 +134,7 @@ @@ -134,7 +134,7 @@
int main(int argc, char** argv) int main(int argc, char** argv)
@ -490,7 +513,7 @@
Test1(); Test1();
--- pegasus-2.5/src/Pegasus/ProviderManager2/CMPI/samples/ProcessIndication/Makefile.redhat 2005-05-12 11:30:52.000000000 -0400 --- pegasus-2.5/src/Pegasus/ProviderManager2/CMPI/samples/ProcessIndication/Makefile.redhat 2005-05-12 11:30:52.000000000 -0400
+++ pegasus-2.5/src/Pegasus/ProviderManager2/CMPI/samples/ProcessIndication/Makefile 2005-10-03 14:49:56.000000000 -0400 +++ pegasus-2.5/src/Pegasus/ProviderManager2/CMPI/samples/ProcessIndication/Makefile 2005-10-03 17:12:17.000000000 -0400
@@ -29,7 +29,7 @@ @@ -29,7 +29,7 @@
# Makefile for CMPIRT_SampleClass library # Makefile for CMPIRT_SampleClass library
@ -501,7 +524,7 @@
# Changes shouldn't be necessary below this line # Changes shouldn't be necessary below this line
CFLAGS=-Wall -D_COMPILE_UNIX -g -I. -I../.. CFLAGS=-Wall -D_COMPILE_UNIX -g -I. -I../..
--- pegasus-2.5/src/Pegasus/Config/FixedPropertyTableLinux.h.redhat 2005-07-15 19:02:21.000000000 -0400 --- pegasus-2.5/src/Pegasus/Config/FixedPropertyTableLinux.h.redhat 2005-07-15 19:02:21.000000000 -0400
+++ pegasus-2.5/src/Pegasus/Config/FixedPropertyTableLinux.h 2005-10-03 14:49:56.000000000 -0400 +++ pegasus-2.5/src/Pegasus/Config/FixedPropertyTableLinux.h 2005-10-03 17:12:17.000000000 -0400
@@ -45,19 +45,19 @@ @@ -45,19 +45,19 @@
{"enableBinaryRepository", "false"}, {"enableBinaryRepository", "false"},
#endif #endif
@ -534,7 +557,7 @@
#if defined(PEGASUS_USE_RELEASE_DIRS) && defined(PEGASUS_OS_LSB) #if defined(PEGASUS_USE_RELEASE_DIRS) && defined(PEGASUS_OS_LSB)
{"traceFilePath", "/var/opt/lsb-pegasus/cache/cimserver.trc"}, {"traceFilePath", "/var/opt/lsb-pegasus/cache/cimserver.trc"},
--- pegasus-2.5/src/Pegasus/Config/ConfigFileDirLinux.h.redhat 2005-02-05 18:00:07.000000000 -0500 --- pegasus-2.5/src/Pegasus/Config/ConfigFileDirLinux.h.redhat 2005-02-05 18:00:07.000000000 -0500
+++ pegasus-2.5/src/Pegasus/Config/ConfigFileDirLinux.h 2005-10-03 14:49:56.000000000 -0400 +++ pegasus-2.5/src/Pegasus/Config/ConfigFileDirLinux.h 2005-10-03 17:12:17.000000000 -0400
@@ -37,12 +37,12 @@ @@ -37,12 +37,12 @@
/** /**
Default file name for the current configuration. Default file name for the current configuration.
@ -551,7 +574,7 @@
/** /**
Default file name for the cimserver startup file containing the PID. Default file name for the cimserver startup file containing the PID.
--- pegasus-2.5/src/Pegasus/ControlProviders/CertificateProvider/Makefile.redhat 2005-05-12 11:29:46.000000000 -0400 --- pegasus-2.5/src/Pegasus/ControlProviders/CertificateProvider/Makefile.redhat 2005-05-12 11:29:46.000000000 -0400
+++ pegasus-2.5/src/Pegasus/ControlProviders/CertificateProvider/Makefile 2005-10-03 14:49:56.000000000 -0400 +++ pegasus-2.5/src/Pegasus/ControlProviders/CertificateProvider/Makefile 2005-10-03 17:12:17.000000000 -0400
@@ -56,8 +56,8 @@ @@ -56,8 +56,8 @@
ifeq ($(OS),linux) ifeq ($(OS),linux)
EXTRA_LIBRARIES += -lcrypt EXTRA_LIBRARIES += -lcrypt
@ -564,7 +587,7 @@
endif endif
--- pegasus-2.5/src/Pegasus/Common/tests/DynLoad/Makefile.redhat 2005-05-12 11:28:46.000000000 -0400 --- pegasus-2.5/src/Pegasus/Common/tests/DynLoad/Makefile.redhat 2005-05-12 11:28:46.000000000 -0400
+++ pegasus-2.5/src/Pegasus/Common/tests/DynLoad/Makefile 2005-10-03 14:49:56.000000000 -0400 +++ pegasus-2.5/src/Pegasus/Common/tests/DynLoad/Makefile 2005-10-03 17:12:17.000000000 -0400
@@ -45,7 +45,7 @@ @@ -45,7 +45,7 @@
ifeq ($(PEGASUS_OS_TYPE),VMS) ifeq ($(PEGASUS_OS_TYPE),VMS)
$(PROGRAM) libTestDynLib $(PROGRAM) libTestDynLib
@ -575,7 +598,7 @@
endif endif
--- pegasus-2.5/src/Pegasus/Common/MessageQueueService.cpp.redhat 2005-08-16 18:46:53.000000000 -0400 --- pegasus-2.5/src/Pegasus/Common/MessageQueueService.cpp.redhat 2005-08-16 18:46:53.000000000 -0400
+++ pegasus-2.5/src/Pegasus/Common/MessageQueueService.cpp 2005-10-03 14:49:56.000000000 -0400 +++ pegasus-2.5/src/Pegasus/Common/MessageQueueService.cpp 2005-10-03 17:12:17.000000000 -0400
@@ -68,7 +68,9 @@ @@ -68,7 +68,9 @@
#define MAX_THREADS_PER_SVC_QUEUE_LIMIT 5000 #define MAX_THREADS_PER_SVC_QUEUE_LIMIT 5000
@ -588,7 +611,7 @@
PEGASUS_THREAD_RETURN PEGASUS_THREAD_CDECL PEGASUS_THREAD_RETURN PEGASUS_THREAD_CDECL
--- pegasus-2.5/src/Pegasus/Common/Makefile.redhat 2005-06-12 18:31:19.000000000 -0400 --- pegasus-2.5/src/Pegasus/Common/Makefile.redhat 2005-06-12 18:31:19.000000000 -0400
+++ pegasus-2.5/src/Pegasus/Common/Makefile 2005-10-03 14:49:56.000000000 -0400 +++ pegasus-2.5/src/Pegasus/Common/Makefile 2005-10-03 17:12:17.000000000 -0400
@@ -165,8 +165,8 @@ @@ -165,8 +165,8 @@
ifeq ($(OS),linux) ifeq ($(OS),linux)
EXTRA_LIBRARIES += -lcrypt EXTRA_LIBRARIES += -lcrypt
@ -615,7 +638,7 @@
ifneq ($(CL_MAJOR_VERSION), 12) ifneq ($(CL_MAJOR_VERSION), 12)
SYS_LIBS += secur32.lib SYS_LIBS += secur32.lib
--- pegasus-2.5/src/Pegasus/Common/Constants.h.redhat 2005-07-27 17:02:36.000000000 -0400 --- pegasus-2.5/src/Pegasus/Common/Constants.h.redhat 2005-07-27 17:02:36.000000000 -0400
+++ pegasus-2.5/src/Pegasus/Common/Constants.h 2005-10-03 14:49:56.000000000 -0400 +++ pegasus-2.5/src/Pegasus/Common/Constants.h 2005-10-03 17:12:17.000000000 -0400
@@ -380,21 +380,21 @@ @@ -380,21 +380,21 @@
# define PEGASUS_PAM_STANDALONE_PROC_NAME "/opt/freeware/cimom/pegasus/bin/cimservera" # define PEGASUS_PAM_STANDALONE_PROC_NAME "/opt/freeware/cimom/pegasus/bin/cimservera"
# elif defined(PEGASUS_OS_LINUX) && !defined(PEGASUS_OS_LSB) # elif defined(PEGASUS_OS_LINUX) && !defined(PEGASUS_OS_LSB)
@ -647,7 +670,7 @@
# define PEGASUS_SSLCLIENT_CERTIFICATEFILE "/etc/opt/lsb-pegasus/client.pem" # define PEGASUS_SSLCLIENT_CERTIFICATEFILE "/etc/opt/lsb-pegasus/client.pem"
# undef PEGASUS_SSLCLIENT_RANDOMFILE # undef PEGASUS_SSLCLIENT_RANDOMFILE
--- pegasus-2.5/src/Pegasus/Common/System.cpp.redhat 2005-06-06 10:27:55.000000000 -0400 --- pegasus-2.5/src/Pegasus/Common/System.cpp.redhat 2005-06-06 10:27:55.000000000 -0400
+++ pegasus-2.5/src/Pegasus/Common/System.cpp 2005-10-03 14:49:56.000000000 -0400 +++ pegasus-2.5/src/Pegasus/Common/System.cpp 2005-10-03 17:12:17.000000000 -0400
@@ -144,13 +144,13 @@ @@ -144,13 +144,13 @@
char *System::extract_file_path(const char *fullpath, char *dirname) char *System::extract_file_path(const char *fullpath, char *dirname)
{ {
@ -665,7 +688,7 @@
{ {
if (*p == '\\' || *p == '/') if (*p == '\\' || *p == '/')
--- pegasus-2.5/src/Pegasus/Common/Platform_LINUX_IX86_GNU.h.redhat 2005-02-26 00:22:13.000000000 -0500 --- pegasus-2.5/src/Pegasus/Common/Platform_LINUX_IX86_GNU.h.redhat 2005-02-26 00:22:13.000000000 -0500
+++ pegasus-2.5/src/Pegasus/Common/Platform_LINUX_IX86_GNU.h 2005-10-03 14:49:56.000000000 -0400 +++ pegasus-2.5/src/Pegasus/Common/Platform_LINUX_IX86_GNU.h 2005-10-03 17:12:17.000000000 -0400
@@ -72,9 +72,12 @@ @@ -72,9 +72,12 @@
#include <stdio.h> #include <stdio.h>
#include <stdlib.h> #include <stdlib.h>
@ -683,7 +706,7 @@
- -
#endif /* Pegasus_Platform_LINUX_IX86_GNU_h */ #endif /* Pegasus_Platform_LINUX_IX86_GNU_h */
--- pegasus-2.5/src/Pegasus/Common/SystemUnix.cpp.redhat 2005-07-19 15:31:26.000000000 -0400 --- pegasus-2.5/src/Pegasus/Common/SystemUnix.cpp.redhat 2005-07-19 15:31:26.000000000 -0400
+++ pegasus-2.5/src/Pegasus/Common/SystemUnix.cpp 2005-10-03 14:49:56.000000000 -0400 +++ pegasus-2.5/src/Pegasus/Common/SystemUnix.cpp 2005-10-03 17:12:17.000000000 -0400
@@ -566,7 +566,7 @@ @@ -566,7 +566,7 @@
if ((he = gethostbyname (hostName))) if ((he = gethostbyname (hostName)))
@ -694,7 +717,7 @@
#if defined(PEGASUS_OS_OS400) #if defined(PEGASUS_OS_OS400)
--- pegasus-2.5/src/Pegasus/Common/Config.h.redhat 2005-05-05 14:18:42.000000000 -0400 --- pegasus-2.5/src/Pegasus/Common/Config.h.redhat 2005-05-05 14:18:42.000000000 -0400
+++ pegasus-2.5/src/Pegasus/Common/Config.h 2005-10-03 14:49:56.000000000 -0400 +++ pegasus-2.5/src/Pegasus/Common/Config.h 2005-10-03 17:12:17.000000000 -0400
@@ -182,6 +182,13 @@ @@ -182,6 +182,13 @@
#define PEGASUS_MAXHOSTNAMELEN MAXHOSTNAMELEN #define PEGASUS_MAXHOSTNAMELEN MAXHOSTNAMELEN
#endif #endif
@ -710,7 +733,7 @@
#ifdef __cplusplus #ifdef __cplusplus
PEGASUS_NAMESPACE_BEGIN PEGASUS_NAMESPACE_BEGIN
--- pegasus-2.5/src/Providers/ManagedSystem/ComputerSystem/ComputerSystem_Linux.cpp.redhat 2005-03-02 13:17:32.000000000 -0500 --- pegasus-2.5/src/Providers/ManagedSystem/ComputerSystem/ComputerSystem_Linux.cpp.redhat 2005-03-02 13:17:32.000000000 -0500
+++ pegasus-2.5/src/Providers/ManagedSystem/ComputerSystem/ComputerSystem_Linux.cpp 2005-10-03 14:49:56.000000000 -0400 +++ pegasus-2.5/src/Providers/ManagedSystem/ComputerSystem/ComputerSystem_Linux.cpp 2005-10-03 17:12:17.000000000 -0400
@@ -310,7 +310,7 @@ @@ -310,7 +310,7 @@
he=gethostbyname(hostName); he=gethostbyname(hostName);
if (he) if (he)
@ -721,7 +744,7 @@
_hostName.assign(hostName); _hostName.assign(hostName);
--- pegasus-2.5/src/Providers/ManagedSystem/OperatingSystem/OperatingSystem_Linux.cpp.redhat 2005-02-05 18:01:03.000000000 -0500 --- pegasus-2.5/src/Providers/ManagedSystem/OperatingSystem/OperatingSystem_Linux.cpp.redhat 2005-02-05 18:01:03.000000000 -0500
+++ pegasus-2.5/src/Providers/ManagedSystem/OperatingSystem/OperatingSystem_Linux.cpp 2005-10-03 14:49:56.000000000 -0400 +++ pegasus-2.5/src/Providers/ManagedSystem/OperatingSystem/OperatingSystem_Linux.cpp 2005-10-03 17:12:17.000000000 -0400
@@ -172,7 +172,7 @@ @@ -172,7 +172,7 @@
he=gethostbyname(hostName); he=gethostbyname(hostName);
if (he) if (he)
@ -732,7 +755,7 @@
csName.assign(hostName); csName.assign(hostName);
--- pegasus-2.5/src/Providers/ManagedSystem/Process/Process_Linux.cpp.redhat 2005-07-15 16:46:54.000000000 -0400 --- pegasus-2.5/src/Providers/ManagedSystem/Process/Process_Linux.cpp.redhat 2005-07-15 16:46:54.000000000 -0400
+++ pegasus-2.5/src/Providers/ManagedSystem/Process/Process_Linux.cpp 2005-10-03 14:49:56.000000000 -0400 +++ pegasus-2.5/src/Providers/ManagedSystem/Process/Process_Linux.cpp 2005-10-03 17:12:17.000000000 -0400
@@ -782,7 +782,7 @@ @@ -782,7 +782,7 @@
he=gethostbyname(hostName); he=gethostbyname(hostName);
if (he) if (he)
@ -743,7 +766,7 @@
csName.assign(hostName); csName.assign(hostName);
--- pegasus-2.5/src/Clients/repupgrade/RepositoryUpgrade.cpp.redhat 2005-06-03 16:04:34.000000000 -0400 --- pegasus-2.5/src/Clients/repupgrade/RepositoryUpgrade.cpp.redhat 2005-06-03 16:04:34.000000000 -0400
+++ pegasus-2.5/src/Clients/repupgrade/RepositoryUpgrade.cpp 2005-10-03 14:49:57.000000000 -0400 +++ pegasus-2.5/src/Clients/repupgrade/RepositoryUpgrade.cpp 2005-10-03 17:12:17.000000000 -0400
@@ -2075,7 +2075,7 @@ @@ -2075,7 +2075,7 @@
fileName = _pegasusHome + "/bin/" + fileName = _pegasusHome + "/bin/" +
FileSystem::buildLibraryFileName(moduleName); FileSystem::buildLibraryFileName(moduleName);