*** empty log message ***

This commit is contained in:
jvdias 2005-10-03 18:55:04 +00:00
parent 2ff3d1074a
commit 609401d66b

View File

@ -1,5 +1,5 @@
--- pegasus-2.5/Makefile.ReleaseTest.redhat 2005-05-27 13:29:01.000000000 -0400
+++ pegasus-2.5/Makefile.ReleaseTest 2005-10-03 12:29:48.000000000 -0400
+++ pegasus-2.5/Makefile.ReleaseTest 2005-10-03 14:49:56.000000000 -0400
@@ -54,7 +54,7 @@
endif
@ -62,7 +62,7 @@
"%attr($(Pr_xr_xr_x),$(INSTALL_USR),$(INSTALL_GRP)) $(PEGASUS_TEST_DIR)/bin/$(i)" >> $(PEGASUS_RPM_SPEC_FILE_PATH);)
@$(foreach i, $(POSTSTARTTEST_FILES), $(ECHO-E) \
--- pegasus-2.5/Makefile.Release.redhat 2005-08-17 17:00:43.000000000 -0400
+++ pegasus-2.5/Makefile.Release 2005-10-03 12:29:48.000000000 -0400
+++ pegasus-2.5/Makefile.Release 2005-10-03 14:49:56.000000000 -0400
@@ -481,13 +481,13 @@
$(MAKE) -f $(ROOT)/Makefile.Release setpermissions PERMISSIONS="$(Prwxr_xr_x)" OWNER="$(INSTALL_USR)" GROUP="$(INSTALL_GRP)" OBJECT=$(PEGASUS_STAGING_DIR)$(PEGASUS_LOCAL_AUTH_DIR)
@ -80,7 +80,7 @@
setpermissions_PegasusProviderLibraryDirectoryFiles: FORCE
--- pegasus-2.5/env_var_Linux.status.redhat 2005-09-02 14:40:58.000000000 -0400
+++ pegasus-2.5/env_var_Linux.status 2005-10-03 12:29:48.000000000 -0400
+++ pegasus-2.5/env_var_Linux.status 2005-10-03 14:49:56.000000000 -0400
@@ -9,6 +9,7 @@
PEGASUS_OVERRIDE_PRODUCT_ID=yes
PEGASUS_PRODUCT_NAME="OpenPegasus"
@ -148,8 +148,40 @@
PEGASUS_TEST_REPOSITORY_DIR = $(PEGASUS_VARDATA_DIR)
PEGASUS_TEST_REPOSITORY_NAME = testrepository
--- pegasus-2.5/mak/objects-unix.mak.redhat 2005-05-12 11:27:28.000000000 -0400
+++ pegasus-2.5/mak/objects-unix.mak 2005-10-03 14:51:10.000000000 -0400
@@ -50,12 +50,12 @@
ifeq ($(_NO_TMP_O), yes)
$(OBJ_DIR)/%.o: %.cpp $(ERROR)
- $(CXX) -c -o $@ $(FLAGS) $(EXTRA_CXX_FLAGS) $(LOCAL_DEFINES) $(DEFINES) $(SYS_INCLUDES) $(INCLUDES) $*.cpp
+ $(CXX) -c -o $@ $(FLAGS) $(EXTRA_CXX_FLAGS) $(LOCAL_DEFINES) $(DEFINES) $(INCLUDES) $(SYS_INCLUDES) $*.cpp
@ $(TOUCH) $@
@ $(ECHO)
else
$(OBJ_DIR)/%.o: %.cpp $(ERROR)
- $(CXX) -c -o $(_TMP_O) $(FLAGS) $(EXTRA_CXX_FLAGS) $(LOCAL_DEFINES) $(DEFINES) $(SYS_INCLUDES) $(INCLUDES) $*.cpp
+ $(CXX) -c -o $(_TMP_O) $(FLAGS) $(EXTRA_CXX_FLAGS) $(LOCAL_DEFINES) $(DEFINES) $(INCLUDES) $(SYS_INCLUDES) $*.cpp
@ $(COPY) $(_TMP_O) $@
@ $(RM) $(_TMP_O)
@ $(TOUCH) $@
@@ -64,12 +64,12 @@
ifeq ($(_NO_TMP_O), yes)
$(OBJ_DIR)/%.o: %.c $(ERROR)
- $(CC) -c -o $@ $(FLAGS) $(EXTRA_C_FLAGS) $(LOCAL_DEFINES) $(DEFINES) $(SYS_INCLUDES) $(INCLUDES) $*.c
+ $(CC) -c -o $@ $(FLAGS) $(EXTRA_C_FLAGS) $(LOCAL_DEFINES) $(DEFINES) $(INCLUDES) $(SYS_INCLUDES) $*.c
@ $(TOUCH) $@
@ $(ECHO)
else
$(OBJ_DIR)/%.o: %.c $(ERROR)
- $(CC) -c -o $(_TMP_O) $(FLAGS) $(EXTRA_C_FLAGS) $(LOCAL_DEFINES) $(DEFINES) $(SYS_INCLUDES) $(INCLUDES) $*.c
+ $(CC) -c -o $(_TMP_O) $(FLAGS) $(EXTRA_C_FLAGS) $(LOCAL_DEFINES) $(DEFINES) $(INCLUDES) $(SYS_INCLUDES) $*.c
@ $(COPY) $(_TMP_O) $@
@ $(RM) $(_TMP_O)
@ $(TOUCH) $@
--- pegasus-2.5/mak/config-linux.mak.redhat 2005-05-12 11:27:28.000000000 -0400
+++ pegasus-2.5/mak/config-linux.mak 2005-10-03 12:29:59.000000000 -0400
+++ pegasus-2.5/mak/config-linux.mak 2005-10-03 14:49:56.000000000 -0400
@@ -76,10 +76,12 @@
SYS_LIBS = -ldl -lpthread
@ -183,7 +215,7 @@
endif
--- pegasus-2.5/mak/SDKMakefile.redhat 2005-07-15 15:46:17.000000000 -0400
+++ pegasus-2.5/mak/SDKMakefile 2005-10-03 12:29:48.000000000 -0400
+++ pegasus-2.5/mak/SDKMakefile 2005-10-03 14:49:56.000000000 -0400
@@ -382,10 +382,10 @@
@$(MAKE) --directory=$(PEGASUS_ROOT)/mak -f SDKMakefile -i deregisterproviders
@$(MAKE) --directory=$(PEGASUS_STAGING_DIR)$(PEGASUS_SAMPLES_DIR) -f Makefile clean \
@ -199,7 +231,7 @@
@$(MAKE) --directory=$(PEGASUS_STAGING_DIR)$(PEGASUS_SAMPLES_DIR)/Providers/Load -f Makefile createrepository \
PEGASUS_MOF_DIR=$(PEGASUS_ROOT)/Schemas PEGASUS_BIN_DIR=$(PEGASUS_HOME)bin
--- pegasus-2.5/mak/config.mak.redhat 2005-08-12 13:52:31.000000000 -0400
+++ pegasus-2.5/mak/config.mak 2005-10-03 12:29:48.000000000 -0400
+++ pegasus-2.5/mak/config.mak 2005-10-03 14:49:56.000000000 -0400
@@ -85,7 +85,7 @@
OBJ_DIR = $(HOME_DIR)/obj/$(DIR)
@ -219,7 +251,7 @@
ifeq ($(OS),VMS)
--- pegasus-2.5/mak/program-unix.mak.redhat 2005-05-12 11:27:28.000000000 -0400
+++ pegasus-2.5/mak/program-unix.mak 2005-10-03 12:29:48.000000000 -0400
+++ pegasus-2.5/mak/program-unix.mak 2005-10-03 14:49:56.000000000 -0400
@@ -28,6 +28,12 @@
#//==============================================================================
INCLUDES = -I$(ROOT)/src $(EXTRA_INCLUDES)
@ -275,7 +307,7 @@
+
+include $(ROOT)/mak/install-program-unix.mak
--- pegasus-2.5/mak/library-unix.mak.redhat 2005-05-12 11:27:28.000000000 -0400
+++ pegasus-2.5/mak/library-unix.mak 2005-10-03 12:29:48.000000000 -0400
+++ pegasus-2.5/mak/library-unix.mak 2005-10-03 14:49:56.000000000 -0400
@@ -32,11 +32,11 @@
ifdef PEGASUS_HAS_MESSAGES
ifdef ICU_ROOT
@ -313,7 +345,7 @@
+
+include $(ROOT)/mak/install-library-unix.mak
--- pegasus-2.5/rpm/wbem.redhat 2003-03-13 12:25:15.000000000 -0500
+++ pegasus-2.5/rpm/wbem 2005-10-03 12:29:48.000000000 -0400
+++ pegasus-2.5/rpm/wbem 2005-10-03 14:49:56.000000000 -0400
@@ -1,13 +1,7 @@
#%PAM-1.0
-auth required /lib/security/pam_env.so
@ -335,7 +367,7 @@
+session required pam_stack.so service=system-auth
+session required pam_loginuid.so
--- pegasus-2.5/rpm/tog-pegasus.rc.redhat 2005-05-29 02:43:30.000000000 -0400
+++ pegasus-2.5/rpm/tog-pegasus.rc 2005-10-03 12:29:48.000000000 -0400
+++ pegasus-2.5/rpm/tog-pegasus.rc 2005-10-03 14:49:56.000000000 -0400
@@ -1,34 +1,28 @@
#! /bin/sh
-#//%2005////////////////////////////////////////////////////////////////////////
@ -434,7 +466,7 @@
status)
pid=`pidofproc $CIMSERVER_BIN`
--- pegasus-2.5/src/Pegasus/ProviderManager2/tests/ProviderManagerModule/ProviderManagerModule.cpp.redhat 2005-04-18 17:18:24.000000000 -0400
+++ pegasus-2.5/src/Pegasus/ProviderManager2/tests/ProviderManagerModule/ProviderManagerModule.cpp 2005-10-03 12:29:48.000000000 -0400
+++ pegasus-2.5/src/Pegasus/ProviderManager2/tests/ProviderManagerModule/ProviderManagerModule.cpp 2005-10-03 14:49:56.000000000 -0400
@@ -134,7 +134,7 @@
int main(int argc, char** argv)
@ -458,7 +490,7 @@
Test1();
--- pegasus-2.5/src/Pegasus/ProviderManager2/CMPI/samples/ProcessIndication/Makefile.redhat 2005-05-12 11:30:52.000000000 -0400
+++ pegasus-2.5/src/Pegasus/ProviderManager2/CMPI/samples/ProcessIndication/Makefile 2005-10-03 12:29:48.000000000 -0400
+++ pegasus-2.5/src/Pegasus/ProviderManager2/CMPI/samples/ProcessIndication/Makefile 2005-10-03 14:49:56.000000000 -0400
@@ -29,7 +29,7 @@
# Makefile for CMPIRT_SampleClass library
@ -469,7 +501,7 @@
# Changes shouldn't be necessary below this line
CFLAGS=-Wall -D_COMPILE_UNIX -g -I. -I../..
--- pegasus-2.5/src/Pegasus/Config/FixedPropertyTableLinux.h.redhat 2005-07-15 19:02:21.000000000 -0400
+++ pegasus-2.5/src/Pegasus/Config/FixedPropertyTableLinux.h 2005-10-03 12:30:39.000000000 -0400
+++ pegasus-2.5/src/Pegasus/Config/FixedPropertyTableLinux.h 2005-10-03 14:49:56.000000000 -0400
@@ -45,19 +45,19 @@
{"enableBinaryRepository", "false"},
#endif
@ -502,7 +534,7 @@
#if defined(PEGASUS_USE_RELEASE_DIRS) && defined(PEGASUS_OS_LSB)
{"traceFilePath", "/var/opt/lsb-pegasus/cache/cimserver.trc"},
--- pegasus-2.5/src/Pegasus/Config/ConfigFileDirLinux.h.redhat 2005-02-05 18:00:07.000000000 -0500
+++ pegasus-2.5/src/Pegasus/Config/ConfigFileDirLinux.h 2005-10-03 12:29:48.000000000 -0400
+++ pegasus-2.5/src/Pegasus/Config/ConfigFileDirLinux.h 2005-10-03 14:49:56.000000000 -0400
@@ -37,12 +37,12 @@
/**
Default file name for the current configuration.
@ -519,7 +551,7 @@
/**
Default file name for the cimserver startup file containing the PID.
--- pegasus-2.5/src/Pegasus/ControlProviders/CertificateProvider/Makefile.redhat 2005-05-12 11:29:46.000000000 -0400
+++ pegasus-2.5/src/Pegasus/ControlProviders/CertificateProvider/Makefile 2005-10-03 12:29:48.000000000 -0400
+++ pegasus-2.5/src/Pegasus/ControlProviders/CertificateProvider/Makefile 2005-10-03 14:49:56.000000000 -0400
@@ -56,8 +56,8 @@
ifeq ($(OS),linux)
EXTRA_LIBRARIES += -lcrypt
@ -532,7 +564,7 @@
endif
--- pegasus-2.5/src/Pegasus/Common/tests/DynLoad/Makefile.redhat 2005-05-12 11:28:46.000000000 -0400
+++ pegasus-2.5/src/Pegasus/Common/tests/DynLoad/Makefile 2005-10-03 12:29:48.000000000 -0400
+++ pegasus-2.5/src/Pegasus/Common/tests/DynLoad/Makefile 2005-10-03 14:49:56.000000000 -0400
@@ -45,7 +45,7 @@
ifeq ($(PEGASUS_OS_TYPE),VMS)
$(PROGRAM) libTestDynLib
@ -543,7 +575,7 @@
endif
--- pegasus-2.5/src/Pegasus/Common/MessageQueueService.cpp.redhat 2005-08-16 18:46:53.000000000 -0400
+++ pegasus-2.5/src/Pegasus/Common/MessageQueueService.cpp 2005-10-03 12:29:48.000000000 -0400
+++ pegasus-2.5/src/Pegasus/Common/MessageQueueService.cpp 2005-10-03 14:49:56.000000000 -0400
@@ -68,7 +68,9 @@
#define MAX_THREADS_PER_SVC_QUEUE_LIMIT 5000
@ -556,7 +588,7 @@
PEGASUS_THREAD_RETURN PEGASUS_THREAD_CDECL
--- pegasus-2.5/src/Pegasus/Common/Makefile.redhat 2005-06-12 18:31:19.000000000 -0400
+++ pegasus-2.5/src/Pegasus/Common/Makefile 2005-10-03 12:29:48.000000000 -0400
+++ pegasus-2.5/src/Pegasus/Common/Makefile 2005-10-03 14:49:56.000000000 -0400
@@ -165,8 +165,8 @@
ifeq ($(OS),linux)
EXTRA_LIBRARIES += -lcrypt
@ -583,7 +615,7 @@
ifneq ($(CL_MAJOR_VERSION), 12)
SYS_LIBS += secur32.lib
--- pegasus-2.5/src/Pegasus/Common/Constants.h.redhat 2005-07-27 17:02:36.000000000 -0400
+++ pegasus-2.5/src/Pegasus/Common/Constants.h 2005-10-03 12:29:48.000000000 -0400
+++ pegasus-2.5/src/Pegasus/Common/Constants.h 2005-10-03 14:49:56.000000000 -0400
@@ -380,21 +380,21 @@
# define PEGASUS_PAM_STANDALONE_PROC_NAME "/opt/freeware/cimom/pegasus/bin/cimservera"
# elif defined(PEGASUS_OS_LINUX) && !defined(PEGASUS_OS_LSB)
@ -615,7 +647,7 @@
# define PEGASUS_SSLCLIENT_CERTIFICATEFILE "/etc/opt/lsb-pegasus/client.pem"
# undef PEGASUS_SSLCLIENT_RANDOMFILE
--- pegasus-2.5/src/Pegasus/Common/System.cpp.redhat 2005-06-06 10:27:55.000000000 -0400
+++ pegasus-2.5/src/Pegasus/Common/System.cpp 2005-10-03 12:29:48.000000000 -0400
+++ pegasus-2.5/src/Pegasus/Common/System.cpp 2005-10-03 14:49:56.000000000 -0400
@@ -144,13 +144,13 @@
char *System::extract_file_path(const char *fullpath, char *dirname)
{
@ -633,7 +665,7 @@
{
if (*p == '\\' || *p == '/')
--- pegasus-2.5/src/Pegasus/Common/Platform_LINUX_IX86_GNU.h.redhat 2005-02-26 00:22:13.000000000 -0500
+++ pegasus-2.5/src/Pegasus/Common/Platform_LINUX_IX86_GNU.h 2005-10-03 12:29:48.000000000 -0400
+++ pegasus-2.5/src/Pegasus/Common/Platform_LINUX_IX86_GNU.h 2005-10-03 14:49:56.000000000 -0400
@@ -72,9 +72,12 @@
#include <stdio.h>
#include <stdlib.h>
@ -651,7 +683,7 @@
-
#endif /* Pegasus_Platform_LINUX_IX86_GNU_h */
--- pegasus-2.5/src/Pegasus/Common/SystemUnix.cpp.redhat 2005-07-19 15:31:26.000000000 -0400
+++ pegasus-2.5/src/Pegasus/Common/SystemUnix.cpp 2005-10-03 12:29:48.000000000 -0400
+++ pegasus-2.5/src/Pegasus/Common/SystemUnix.cpp 2005-10-03 14:49:56.000000000 -0400
@@ -566,7 +566,7 @@
if ((he = gethostbyname (hostName)))
@ -662,7 +694,7 @@
#if defined(PEGASUS_OS_OS400)
--- pegasus-2.5/src/Pegasus/Common/Config.h.redhat 2005-05-05 14:18:42.000000000 -0400
+++ pegasus-2.5/src/Pegasus/Common/Config.h 2005-10-03 12:29:48.000000000 -0400
+++ pegasus-2.5/src/Pegasus/Common/Config.h 2005-10-03 14:49:56.000000000 -0400
@@ -182,6 +182,13 @@
#define PEGASUS_MAXHOSTNAMELEN MAXHOSTNAMELEN
#endif
@ -678,7 +710,7 @@
#ifdef __cplusplus
PEGASUS_NAMESPACE_BEGIN
--- pegasus-2.5/src/Providers/ManagedSystem/ComputerSystem/ComputerSystem_Linux.cpp.redhat 2005-03-02 13:17:32.000000000 -0500
+++ pegasus-2.5/src/Providers/ManagedSystem/ComputerSystem/ComputerSystem_Linux.cpp 2005-10-03 12:29:48.000000000 -0400
+++ pegasus-2.5/src/Providers/ManagedSystem/ComputerSystem/ComputerSystem_Linux.cpp 2005-10-03 14:49:56.000000000 -0400
@@ -310,7 +310,7 @@
he=gethostbyname(hostName);
if (he)
@ -689,7 +721,7 @@
_hostName.assign(hostName);
--- pegasus-2.5/src/Providers/ManagedSystem/OperatingSystem/OperatingSystem_Linux.cpp.redhat 2005-02-05 18:01:03.000000000 -0500
+++ pegasus-2.5/src/Providers/ManagedSystem/OperatingSystem/OperatingSystem_Linux.cpp 2005-10-03 12:29:48.000000000 -0400
+++ pegasus-2.5/src/Providers/ManagedSystem/OperatingSystem/OperatingSystem_Linux.cpp 2005-10-03 14:49:56.000000000 -0400
@@ -172,7 +172,7 @@
he=gethostbyname(hostName);
if (he)
@ -700,7 +732,7 @@
csName.assign(hostName);
--- pegasus-2.5/src/Providers/ManagedSystem/Process/Process_Linux.cpp.redhat 2005-07-15 16:46:54.000000000 -0400
+++ pegasus-2.5/src/Providers/ManagedSystem/Process/Process_Linux.cpp 2005-10-03 12:29:48.000000000 -0400
+++ pegasus-2.5/src/Providers/ManagedSystem/Process/Process_Linux.cpp 2005-10-03 14:49:56.000000000 -0400
@@ -782,7 +782,7 @@
he=gethostbyname(hostName);
if (he)
@ -711,7 +743,7 @@
csName.assign(hostName);
--- pegasus-2.5/src/Clients/repupgrade/RepositoryUpgrade.cpp.redhat 2005-06-03 16:04:34.000000000 -0400
+++ pegasus-2.5/src/Clients/repupgrade/RepositoryUpgrade.cpp 2005-10-03 12:29:48.000000000 -0400
+++ pegasus-2.5/src/Clients/repupgrade/RepositoryUpgrade.cpp 2005-10-03 14:49:57.000000000 -0400
@@ -2075,7 +2075,7 @@
fileName = _pegasusHome + "/bin/" +
FileSystem::buildLibraryFileName(moduleName);