59 lines
2.3 KiB
Diff
59 lines
2.3 KiB
Diff
# HG changeset patch
|
|
# User Rob Lemley <rob@thunderbird.net>
|
|
# Date 1663866047 14400
|
|
# Thu Sep 22 13:00:47 2022 -0400
|
|
# Node ID 8c718243f4e83fc18dfc88bf5d817c5c18f13937
|
|
# Parent 17dc6bb322b5d40299bba0a90d59c0593137d4f6
|
|
Bug 1790116 - update_rnp.sh changes for RNP v0.16.2. r=kaie
|
|
|
|
The changes in bug_1768424.patch are now included upstream in
|
|
https://github.com/rnpgp/rnp/commit/ac6f58ef7ccea270b735b53f87da2c3ca5b34290.
|
|
|
|
bug_1763641.patch removed per bug 1790116 comment 26.
|
|
|
|
disable_obsolete_ciphers.patch no longer needed, use security rules instead.
|
|
|
|
Differential Revision: https://phabricator.services.mozilla.com/D157010
|
|
|
|
diff --git a/comm/third_party/update_rnp.sh b/comm/third_party/update_rnp.sh
|
|
--- a/comm/third_party/update_rnp.sh
|
|
+++ b/comm/third_party/update_rnp.sh
|
|
@@ -43,11 +43,11 @@ TAGLIST=$(git -C "${RNPgit}" tag --list
|
|
LATEST_VERSION=$($THIRDROC latest_version $TAGLIST)
|
|
REVISION=$(git -C "${RNPgit}" rev-parse --verify HEAD)
|
|
TIMESTAMP=$(git -C "${RNPgit}" show -s --format=%ct)
|
|
|
|
# Cleanup rnp checkout
|
|
-rm -rf ${RNPgit}/{.git,.github,.cirrus.yml,.clang-format,.gitignore}
|
|
+rm -rf ${RNPgit}/{.git,.github,.cirrus.yml,.clang-format,.gitignore,.codespellrc}
|
|
rm -rf ${RNPgit}/{_config.yml,docker.sh,ci,cmake,git-hooks,travis.sh,vcpkg.txt}
|
|
rm -rf ${RNPgit}/{Brewfile,CMakeLists.txt,CMakeSettings.json}
|
|
|
|
# Do the switch
|
|
rm -rf rnp
|
|
@@ -60,17 +60,17 @@ mv "${RNPgit}" rnp
|
|
|
|
# Restore moz.build
|
|
hg revert rnp/moz.build rnp/module.ver rnp/rnp.symbols rnp/src/lib/rnp/rnp_export.h \
|
|
rnp/src/rnp/moz.build rnp/src/rnpkeys/moz.build
|
|
|
|
-# Reapply Thunderbird patch to disable obsolete ciphers
|
|
-PATCH_FILES=("patches/rnp/disable_obsolete_ciphers.patch" \
|
|
- "patches/rnp/bug_1763641.patch" \
|
|
- "patches/rnp/bug_1768424.patch")
|
|
-for PATCH_FILE in "${PATCH_FILES[@]}"; do
|
|
- patch -p2 -i "${PATCH_FILE}" -N -r "${MY_TEMP_DIR}/${PATCH_FILE}.rej"
|
|
-done
|
|
+# Patch librnp - currently not needed
|
|
+#PATCH_FILES=("patches/rnp/disable_obsolete_ciphers.patch")
|
|
+#for PATCH_FILE in "${PATCH_FILES[@]}"; do
|
|
+# # shellcheck disable=SC2086
|
|
+# echo "Applying patch $(basename ${PATCH_FILE})"
|
|
+# patch -p2 -i "${PATCH_FILE}" -N -r "${MY_TEMP_DIR}/${PATCH_FILE}.rej"
|
|
+#done
|
|
|
|
# Patch sometimes creates backup files that are not wanted.
|
|
find rnp -name '*.orig' -exec rm -f '{}' \;
|
|
|
|
rm -rf "${MY_TEMP_DIR}"
|