Merge branch 'master' into f15

This commit is contained in:
Jan Horak 2011-11-08 20:15:29 +01:00
commit f44eac26e4
5 changed files with 26 additions and 54 deletions

2
.gitignore vendored
View File

@ -28,3 +28,5 @@ thunderbird-langpacks-3.1.2-20100803.tar.bz2
/thunderbird-langpacks-7.0-20110927.tar.xz
/thunderbird-7.0.1.source.tar.bz2
/thunderbird-langpacks-7.0.1-20110930.tar.xz
/thunderbird-8.0.source.tar.bz2
/thunderbird-langpacks-8.0-20111108.tar.xz

View File

@ -1,2 +1,2 @@
ad177fe5202deabda44882ff5c871f1b thunderbird-7.0.1.source.tar.bz2
95ff11c17e3a3edd8a6ba7712a8f7348 thunderbird-langpacks-7.0.1-20110930.tar.xz
332f60036aebdce7dec6ee2b1af4941d thunderbird-8.0.source.tar.bz2
6bffd9152416e3ddb52afc51269cefcc thunderbird-langpacks-8.0-20111108.tar.xz

View File

@ -33,8 +33,8 @@
Summary: Mozilla Thunderbird mail/newsgroup client
Name: thunderbird
Version: 7.0.1
Release: 3%{?dist}
Version: 8.0
Release: 1%{?dist}
URL: http://www.mozilla.org/projects/thunderbird/
License: MPLv1.1 or GPLv2+ or LGPLv2+
Group: Applications/Internet
@ -45,7 +45,7 @@ Group: Applications/Internet
%endif
Source0: %{tarball}
%if %{build_langpacks}
Source1: thunderbird-langpacks-%{version}-20110930.tar.xz
Source1: thunderbird-langpacks-%{version}-20111108.tar.xz
%endif
Source10: thunderbird-mozconfig
Source11: thunderbird-mozconfig-branded
@ -63,8 +63,8 @@ Patch9: mozilla-670719.patch
Patch10: xulrunner-2.0-network-link-service.patch
Patch11: xulrunner-2.0-NetworkManager09.patch
# backport from 8.0beta
Patch100: xulrunner-7.0.1-yarr-jit.patch
# Build patches
Patch100: xulrunner-install.patch
%if %{official_branding}
# Required by Mozilla Corporation
@ -146,7 +146,7 @@ cd mozilla
%patch9 -p1 -b .moz670719
%patch10 -p1 -b .link-service
%patch11 -p1 -b .NetworkManager09
%patch100 -p2 -b .yarr-jit
%patch100 -p2 -b .install
cd ..
%if %{official_branding}
@ -328,7 +328,6 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{mozappdir}/thunderbird-bin
%{mozappdir}/thunderbird
%{mozappdir}/*.so
%{mozappdir}/README.txt
%{mozappdir}/platform.ini
%{mozappdir}/application.ini
%{mozappdir}/blocklist.xml
@ -353,7 +352,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
#===============================================================================
%changelog
* Tue Oct 18 2012 Martin Stransky <stransky@redhat.com> - 7.0.1-3
* Tue Nov 8 2011 Jan Horak <jhorak@redhat.com> - 8.0-1
- Update to 8.0
* Tue Oct 18 2011 Martin Stransky <stransky@redhat.com> - 7.0.1-3
- Added NM patches (mozbz#627672, mozbz#639959)
* Wed Oct 12 2011 Dan Horák <dan[at]danny.cz> - 7.0.1-2

View File

@ -1,44 +0,0 @@
diff -up xulrunner-7.0.1/mozilla-release/js/src/jsregexpinlines.h.yarr-jit xulrunner-7.0.1/mozilla-release/js/src/jsregexpinlines.h
--- xulrunner-7.0.1/mozilla-release/js/src/jsregexpinlines.h.yarr-jit 2011-09-28 22:24:50.000000000 +0200
+++ xulrunner-7.0.1/mozilla-release/js/src/jsregexpinlines.h 2011-10-11 17:35:10.000000000 +0200
@@ -491,7 +491,9 @@ RegExp::compileHelper(JSContext *cx, JSL
}
#endif
+#if ENABLE_YARR_JIT
codeBlock.setFallBack(true);
+#endif
byteCode = JSC::Yarr::byteCompile(yarrPattern, cx->compartment->regExpAllocator).get();
return true;
diff -up xulrunner-7.0.1/mozilla-release/js/src/yarr/wtfbridge.h.yarr-jit xulrunner-7.0.1/mozilla-release/js/src/yarr/wtfbridge.h
--- xulrunner-7.0.1/mozilla-release/js/src/yarr/wtfbridge.h.yarr-jit 2011-09-28 22:24:52.000000000 +0200
+++ xulrunner-7.0.1/mozilla-release/js/src/yarr/wtfbridge.h 2011-10-11 17:35:10.000000000 +0200
@@ -50,7 +50,9 @@
#include "jstl.h"
#include "vm/String.h"
#include "assembler/wtf/Platform.h"
+#if ENABLE_YARR_JIT
#include "assembler/jit/ExecutableAllocator.h"
+#endif
namespace JSC { namespace Yarr {
@@ -261,6 +263,8 @@ deleteAllValues(Vector<T, N> &v) {
v.deleteAllValues();
}
+#if ENABLE_YARR_JIT
+
/*
* Minimal JSGlobalData. This used by Yarr to get the allocator.
*/
@@ -272,6 +276,8 @@ class JSGlobalData {
: regexAllocator(regexAllocator) { }
};
+#endif
+
/*
* Sentinel value used in Yarr.
*/

12
xulrunner-install.patch Normal file
View File

@ -0,0 +1,12 @@
diff -up comm-release/mozilla/toolkit/mozapps/installer/packager.mk.install comm-release/mozilla/toolkit/mozapps/installer/packager.mk
--- comm-release/mozilla/toolkit/mozapps/installer/packager.mk.install 2011-11-05 10:21:10.000000000 +0100
+++ comm-release/mozilla/toolkit/mozapps/installer/packager.mk 2011-11-08 18:48:08.674042803 +0100
@@ -401,7 +401,7 @@ PRECOMPILE_GRE=$$PWD
endif
GENERATE_CACHE = \
- $(_ABS_RUN_TEST_PROGRAM) $(LIBXUL_DIST)/bin/xpcshell$(BIN_SUFFIX) -g "$(PRECOMPILE_GRE)" -a "$$PWD" -f $(MOZILLA_DIR)/toolkit/mozapps/installer/precompile_cache.js -e "populate_startupcache('$(PRECOMPILE_DIR)', 'omni.jar', 'startupCache.zip');" && \
+ $(_ABS_RUN_TEST_PROGRAM) $(LIBXUL_DIST)/bin/xpcshell$(BIN_SUFFIX) -g "$(PRECOMPILE_GRE)" -a "$$PWD" -f $(call core_abspath,$(MOZILLA_DIR)/toolkit/mozapps/installer/precompile_cache.js) -e "populate_startupcache('$(PRECOMPILE_DIR)', 'omni.jar', 'startupCache.zip');" && \
rm -rf jsloader && \
$(UNZIP) startupCache.zip && \
rm startupCache.zip && \