- Update to 2.0.0.12
- Fix up icon location and some scriptlets
This commit is contained in:
parent
769ddf610f
commit
e08965f856
@ -1,2 +1,2 @@
|
||||
thunderbird-2.0.0.9-source.tar.bz2
|
||||
thunderbird-langpacks-2.0.0.9-20071115.tar.bz2
|
||||
thunderbird-langpacks-2.0.0.12-20080226.tar.bz2
|
||||
thunderbird-2.0.0.12-source.tar.bz2
|
||||
|
@ -118,7 +118,7 @@
|
||||
|
||||
nsFontMetricsPango::nsFontMetricsPango()
|
||||
{
|
||||
@@ -169,14 +228,20 @@ nsFontMetricsPango::Init(const nsFont& a
|
||||
@@ -169,15 +228,21 @@ nsFontMetricsPango::Init(const nsFont& a
|
||||
mLangGroup = aLangGroup;
|
||||
|
||||
// Hang on to the device context
|
||||
@ -134,7 +134,8 @@
|
||||
// Make sure to clamp the pixel size to something reasonable so we
|
||||
// don't make the X server blow up.
|
||||
nscoord screenPixels = gdk_screen_height();
|
||||
mPointSize = PR_MIN(screenPixels * FONT_MAX_FONT_SCALE, mPointSize);
|
||||
mPointSize = PR_MIN((screenPixels - 1) * FONT_MAX_FONT_SCALE, mPointSize);
|
||||
mPointSize = PR_MIN(2000, mPointSize);
|
||||
+#endif
|
||||
|
||||
// enumerate over the font names passed in
|
||||
|
@ -4575,14 +4575,6 @@ Index: config/system-headers
|
||||
fribidi/fribidi.h
|
||||
FSp_fopen.h
|
||||
fstream.h
|
||||
@@ -208,6 +209,7 @@
|
||||
gdk/gdkevents.h
|
||||
gdk/gdk.h
|
||||
gdk/gdkkeysyms.h
|
||||
+gdk/gdkpango.h
|
||||
gdk/gdkprivate.h
|
||||
gdk/gdkregion.h
|
||||
gdk/gdkwindow.h
|
||||
@@ -501,6 +503,7 @@
|
||||
pango/pangofc-fontmap.h
|
||||
pango/pango-fontmap.h
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
a6dd74f87dafc7516e7970ecefee046b thunderbird-2.0.0.9-source.tar.bz2
|
||||
5abe9f6d6b292adaa4283cd001781ae8 thunderbird-langpacks-2.0.0.9-20071115.tar.bz2
|
||||
4aebeaad511dd0ba73fbabfdd6819438 thunderbird-langpacks-2.0.0.12-20080226.tar.bz2
|
||||
c23f576a8fd0ceee5135829c8ae5168b thunderbird-2.0.0.12-source.tar.bz2
|
||||
|
1614
thunderbird-2.0.0.12-gcc43.patch
Normal file
1614
thunderbird-2.0.0.12-gcc43.patch
Normal file
File diff suppressed because it is too large
Load Diff
@ -5,7 +5,7 @@ Name=Thunderbird Email
|
||||
GenericName=Email
|
||||
Comment=Send and Receive Email
|
||||
Exec=thunderbird
|
||||
Icon=thunderbird.png
|
||||
Icon=thunderbird
|
||||
Terminal=false
|
||||
Type=Application
|
||||
StartupWMClass=Thunderbird-bin
|
||||
|
@ -7,8 +7,8 @@
|
||||
|
||||
Summary: Mozilla Thunderbird mail/newsgroup client
|
||||
Name: thunderbird
|
||||
Version: 2.0.0.9
|
||||
Release: 2%{?dist}
|
||||
Version: 2.0.0.12
|
||||
Release: 1%{?dist}
|
||||
URL: http://www.mozilla.org/projects/thunderbird/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Group: Applications/Internet
|
||||
@ -18,7 +18,7 @@ Group: Applications/Internet
|
||||
%define tarball thunderbird-2.0.0.0rc1-source.tar.bz2
|
||||
%endif
|
||||
Source0: %{tarball}
|
||||
Source1: thunderbird-langpacks-%{version}-20071115.tar.bz2
|
||||
Source1: thunderbird-langpacks-%{version}-20080226.tar.bz2
|
||||
Source10: thunderbird-mozconfig
|
||||
Source11: thunderbird-mozconfig-branded
|
||||
Source12: thunderbird-redhat-default-prefs.js
|
||||
@ -31,6 +31,7 @@ Source100: find-external-requires
|
||||
# Build patches
|
||||
Patch1: firefox-2.0-link-layout.patch
|
||||
Patch2: firefox-1.0-prdtoa.patch
|
||||
Patch3: thunderbird-2.0.0.12-gcc43.patch
|
||||
|
||||
Patch10: thunderbird-0.7.3-psfonts.patch
|
||||
Patch11: thunderbird-0.7.3-gnome-uriloader.patch
|
||||
@ -102,6 +103,7 @@ Mozilla Thunderbird is a standalone mail and newsgroup client.
|
||||
%setup -q -n mozilla
|
||||
%patch1 -p1 -b .link-layout
|
||||
%patch2 -p0
|
||||
%patch3 -p0 -b .gcc43
|
||||
|
||||
%patch10 -p1 -b .psfonts
|
||||
%patch11 -p1 -b .gnome-uriloader
|
||||
@ -178,9 +180,9 @@ make -f client.mk build
|
||||
|
||||
DESTDIR=$RPM_BUILD_ROOT make install
|
||||
|
||||
%{__mkdir_p} $RPM_BUILD_ROOT{%{_libdir},%{_bindir},%{_datadir}/applications}
|
||||
%{__mkdir_p} $RPM_BUILD_ROOT{%{_libdir},%{_bindir},%{_datadir}/applications,%{_datadir}/icons/hicolor/48x48/apps}
|
||||
|
||||
%{__install} -p -D %{SOURCE22} $RPM_BUILD_ROOT%{_datadir}/pixmaps/%{name}.png
|
||||
%{__install} -p -D %{SOURCE22} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/%{name}.png
|
||||
|
||||
desktop-file-install --vendor mozilla \
|
||||
--dir $RPM_BUILD_ROOT%{_datadir}/applications \
|
||||
@ -258,17 +260,24 @@ touch $RPM_BUILD_ROOT%{mozappdir}/components/xpti.dat
|
||||
%{__rm} -rf $RPM_BUILD_ROOT
|
||||
|
||||
%post
|
||||
update-desktop-database %{_datadir}/applications
|
||||
update-desktop-database &> /dev/null || :
|
||||
touch --no-create %{_datadir}/icons/hicolor
|
||||
if [ -x %{_bindir}/gtk-update-icon-cache ]; then
|
||||
%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
|
||||
fi
|
||||
|
||||
%postun
|
||||
update-desktop-database %{_datadir}/applications
|
||||
|
||||
update-desktop-database &> /dev/null || :
|
||||
touch --no-create %{_datadir}/icons/hicolor
|
||||
if [ -x %{_bindir}/gtk-update-icon-cache ]; then
|
||||
%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
|
||||
fi
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%attr(755,root,root) %{_bindir}/thunderbird
|
||||
%attr(644,root,root) %{_datadir}/applications/mozilla-thunderbird.desktop
|
||||
%attr(644,root,root) %{_datadir}/pixmaps/thunderbird.png
|
||||
%attr(644,root,root) %{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
|
||||
%dir %{mozappdir}
|
||||
%doc %{mozappdir}/LICENSE
|
||||
%{mozappdir}/chrome
|
||||
@ -308,6 +317,10 @@ update-desktop-database %{_datadir}/applications
|
||||
#===============================================================================
|
||||
|
||||
%changelog
|
||||
* Tue Feb 26 2008 Christopher Aillon <caillon@redhat.com> 2.0.0.12-1
|
||||
- Update to 2.0.0.12
|
||||
- Fix up icon location and some scriptlets
|
||||
|
||||
* Sun Dec 9 2007 Christopher Aillon <caillon@redhat.com> 2.0.0.9-2
|
||||
- Fix some rpmlint warnings
|
||||
- Drop some old patches and obsoletes
|
||||
|
Loading…
Reference in New Issue
Block a user