Build with system hunspell
This commit is contained in:
parent
5414a7c796
commit
dc868677e3
@ -1,12 +0,0 @@
|
|||||||
diff -up thunderbird-3.0/mozilla/modules/libpr0n/build/Makefile.in.makebug thunderbird-3.0/mozilla/modules/libpr0n/build/Makefile.in
|
|
||||||
--- thunderbird-3.0/mozilla/modules/libpr0n/build/Makefile.in.makebug 2009-07-15 22:37:19.000000000 +0200
|
|
||||||
+++ thunderbird-3.0/mozilla/modules/libpr0n/build/Makefile.in 2009-07-30 16:10:37.000000000 +0200
|
|
||||||
@@ -103,7 +103,7 @@ EXTRA_DSO_LDOPTS = \
|
|
||||||
GARBAGE += _img_list nsImgBuildDefines.h
|
|
||||||
|
|
||||||
export::
|
|
||||||
- @{ \
|
|
||||||
+ @{ set \
|
|
||||||
$(foreach d,$(filter-out icon,$(MOZ_IMG_DECODERS)), \
|
|
||||||
echo "#define IMG_BUILD_DECODER_${d}";) \
|
|
||||||
$(foreach d,$(MOZ_IMG_ENCODERS), \
|
|
@ -1,38 +0,0 @@
|
|||||||
diff -up thunderbird-3.0/mozilla/modules/libpr0n/build/nsImageModule.cpp.setjmp thunderbird-3.0/mozilla/modules/libpr0n/build/nsImageModule.cpp
|
|
||||||
--- thunderbird-3.0/mozilla/modules/libpr0n/build/nsImageModule.cpp.setjmp 2009-07-31 13:22:44.000000000 +0200
|
|
||||||
+++ thunderbird-3.0/mozilla/modules/libpr0n/build/nsImageModule.cpp 2009-07-31 13:34:42.000000000 +0200
|
|
||||||
@@ -59,6 +59,16 @@
|
|
||||||
#include "imgRequestProxy.h"
|
|
||||||
#include "imgTools.h"
|
|
||||||
|
|
||||||
+#ifdef IMG_BUILD_ENCODER_png
|
|
||||||
+// png
|
|
||||||
+#include "nsPNGEncoder.h"
|
|
||||||
+#endif
|
|
||||||
+#ifdef IMG_BUILD_ENCODER_jpeg
|
|
||||||
+// jpeg
|
|
||||||
+#include "nsJPEGEncoder.h"
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
+
|
|
||||||
#ifdef IMG_BUILD_DECODER_gif
|
|
||||||
// gif
|
|
||||||
#include "nsGIFDecoder2.h"
|
|
||||||
@@ -85,17 +95,6 @@
|
|
||||||
#include "nsXBMDecoder.h"
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-
|
|
||||||
-#ifdef IMG_BUILD_ENCODER_png
|
|
||||||
-// png
|
|
||||||
-#include "nsPNGEncoder.h"
|
|
||||||
-#endif
|
|
||||||
-#ifdef IMG_BUILD_ENCODER_jpeg
|
|
||||||
-// jpeg
|
|
||||||
-#include "nsJPEGEncoder.h"
|
|
||||||
-#endif
|
|
||||||
-
|
|
||||||
-
|
|
||||||
// objects that just require generic constructors
|
|
||||||
|
|
||||||
NS_GENERIC_FACTORY_CONSTRUCTOR(imgContainer)
|
|
@ -11,7 +11,7 @@
|
|||||||
Summary: Mozilla Thunderbird mail/newsgroup client
|
Summary: Mozilla Thunderbird mail/newsgroup client
|
||||||
Name: thunderbird
|
Name: thunderbird
|
||||||
Version: 3.0
|
Version: 3.0
|
||||||
Release: 3.5.b3%{?dist}
|
Release: 3.6.b3%{?dist}
|
||||||
URL: http://www.mozilla.org/projects/thunderbird/
|
URL: http://www.mozilla.org/projects/thunderbird/
|
||||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
@ -37,8 +37,6 @@ Patch1: mozilla-jemalloc.patch
|
|||||||
Patch2: thunderbird-shared-error.patch
|
Patch2: thunderbird-shared-error.patch
|
||||||
Patch3: xulrunner-elif.patch
|
Patch3: xulrunner-elif.patch
|
||||||
Patch4: thunderbird-pango.patch
|
Patch4: thunderbird-pango.patch
|
||||||
Patch5: thunderbird-makebug.patch
|
|
||||||
Patch6: thunderbird-setjmp.patch
|
|
||||||
|
|
||||||
%if %{official_branding}
|
%if %{official_branding}
|
||||||
# Required by Mozilla Corporation
|
# Required by Mozilla Corporation
|
||||||
@ -95,8 +93,6 @@ Mozilla Thunderbird is a standalone mail and newsgroup client.
|
|||||||
%patch2 -p1 -b .shared-error
|
%patch2 -p1 -b .shared-error
|
||||||
#%patch3 -p0 -b .xulrunner-elif
|
#%patch3 -p0 -b .xulrunner-elif
|
||||||
#%patch4 -p1 -b .pango-fix
|
#%patch4 -p1 -b .pango-fix
|
||||||
%patch5 -p1 -b .makebug
|
|
||||||
%patch6 -p1 -b .setjmp
|
|
||||||
|
|
||||||
%if %{official_branding}
|
%if %{official_branding}
|
||||||
# Required by Mozilla Corporation
|
# Required by Mozilla Corporation
|
||||||
@ -298,6 +294,9 @@ fi
|
|||||||
#===============================================================================
|
#===============================================================================
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 3 2009 Jan Horak <jhorak@redhat.com> - 3.0-3.6.beta3
|
||||||
|
- Build with system hunspell
|
||||||
|
|
||||||
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0-3.5.b3
|
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0-3.5.b3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user