Merge branch 'master' into epel7

Conflicts:
	thunderbird.spec
This commit is contained in:
Jan Horak 2014-08-04 15:01:29 +02:00
commit c78a1d4d44
13 changed files with 216 additions and 9880 deletions

2
.gitignore vendored
View File

@ -93,3 +93,5 @@ thunderbird-langpacks-3.1.2-20100803.tar.bz2
/thunderbird-langpacks-24.6.0-20140609.tar.xz
/thunderbird-24.7.0.source.tar.bz2
/thunderbird-langpacks-24.7.0-20140722.tar.xz
/thunderbird-31.0.source.tar.bz2
/thunderbird-langpacks-31.0-20140729.tar.xz

View File

@ -1,34 +1,34 @@
# HG changeset patch
# Parent 36da3cb921935478b6a37936b18b5c85a33d5617
# User Chris Coulson <chris.coulson@canonical.com>
# Parent b17cad2d1e5e6bcb5a10096d51d07ea8a79b6921
# User Martin Stransky <stransky@redhat.com>
Bug 858919 - Add support for libnotify calls which was removed for new notification API. r=karlt
diff --git a/mozilla/toolkit/system/gnome/moz.build b/mozilla/toolkit/system/gnome/moz.build
--- a/mozilla/toolkit/system/gnome/moz.build
+++ b/mozilla/toolkit/system/gnome/moz.build
@@ -3,16 +3,18 @@
diff --git a/toolkit/system/gnome/moz.build b/toolkit/system/gnome/moz.build
--- a/toolkit/system/gnome/moz.build
+++ b/toolkit/system/gnome/moz.build
@@ -1,15 +1,17 @@
# -*- Mode: python; c-basic-offset: 4; indent-tabs-mode: nil; tab-width: 40 -*-
# vim: set filetype=python:
# This Source Code Form is subject to the terms of the Mozilla Public
# License, v. 2.0. If a copy of the MPL was not distributed with this
# file, You can obtain one at http://mozilla.org/MPL/2.0/.
MODULE = 'mozgnome'
CPP_SOURCES += [
SOURCES += [
+ 'nsAlertsIconListener.cpp',
+ 'nsAlertsService.cpp',
'nsGnomeModule.cpp',
+ 'nsSystemAlertsService.cpp',
+ 'nsAlertsIconListener.cpp'
]
if CONFIG['MOZ_ENABLE_GCONF']:
CPP_SOURCES += [
SOURCES += [
'nsGConfService.cpp',
]
if CONFIG['MOZ_ENABLE_GNOMEVFS']:
diff --git a/mozilla/toolkit/system/gnome/nsAlertsIconListener.h b/mozilla/toolkit/system/gnome/nsAlertsIconListener.h
diff --git a/toolkit/system/gnome/nsAlertsIconListener.h b/toolkit/system/gnome/nsAlertsIconListener.h
new file mode 100644
--- /dev/null
+++ b/mozilla/toolkit/system/gnome/nsAlertsIconListener.h
@@ -0,0 +1,88 @@
+++ b/toolkit/system/gnome/nsAlertsIconListener.h
@@ -0,0 +1,89 @@
+/* -*- Mode: C++; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
@ -59,7 +59,6 @@ new file mode 100644
+ NS_DECL_NSIOBSERVER
+
+ nsAlertsIconListener();
+ virtual ~nsAlertsIconListener();
+
+ nsresult InitAlertAsync(const nsAString & aImageUrl,
+ const nsAString & aAlertTitle,
@ -72,6 +71,8 @@ new file mode 100644
+ void SendClosed();
+
+protected:
+ virtual ~nsAlertsIconListener();
+
+ nsresult OnStopRequest(imgIRequest* aRequest);
+ nsresult OnStopFrame(imgIRequest* aRequest);
+
@ -117,10 +118,100 @@ new file mode 100644
+};
+
+#endif
diff --git a/mozilla/toolkit/system/gnome/nsGnomeModule.cpp b/mozilla/toolkit/system/gnome/nsGnomeModule.cpp
--- a/mozilla/toolkit/system/gnome/nsGnomeModule.cpp
+++ b/mozilla/toolkit/system/gnome/nsGnomeModule.cpp
@@ -17,53 +17,59 @@ NS_GENERIC_FACTORY_CONSTRUCTOR_INIT(nsGC
diff --git a/toolkit/system/gnome/nsAlertsService.cpp b/toolkit/system/gnome/nsAlertsService.cpp
new file mode 100644
--- /dev/null
+++ b/toolkit/system/gnome/nsAlertsService.cpp
@@ -0,0 +1,53 @@
+/* -*- Mode: C++; tab-width: 2; indent-tabs-mode:nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+#include "nsXULAppAPI.h"
+#include "nsAlertsService.h"
+#include "nsAlertsIconListener.h"
+#include "nsAutoPtr.h"
+
+NS_IMPL_ADDREF(nsAlertsService)
+NS_IMPL_RELEASE(nsAlertsService)
+
+NS_INTERFACE_MAP_BEGIN(nsAlertsService)
+ NS_INTERFACE_MAP_ENTRY_AMBIGUOUS(nsISupports, nsIAlertsService)
+ NS_INTERFACE_MAP_ENTRY(nsIAlertsService)
+NS_INTERFACE_MAP_END_THREADSAFE
+
+nsAlertsService::nsAlertsService()
+{
+}
+
+nsAlertsService::~nsAlertsService()
+{}
+
+nsresult
+nsAlertsService::Init()
+{
+ return NS_OK;
+}
+
+NS_IMETHODIMP nsAlertsService::ShowAlertNotification(const nsAString & aImageUrl, const nsAString & aAlertTitle,
+ const nsAString & aAlertText, bool aAlertTextClickable,
+ const nsAString & aAlertCookie,
+ nsIObserver * aAlertListener,
+ const nsAString & aAlertName,
+ const nsAString & aBidi,
+ const nsAString & aLang,
+ nsIPrincipal * aPrincipal)
+{
+ nsRefPtr<nsAlertsIconListener> alertListener = new nsAlertsIconListener();
+ if (!alertListener)
+ return NS_ERROR_OUT_OF_MEMORY;
+
+ return alertListener->InitAlertAsync(aImageUrl, aAlertTitle, aAlertText, aAlertTextClickable,
+ aAlertCookie, aAlertListener);
+}
+
+NS_IMETHODIMP nsAlertsService::CloseAlert(const nsAString& aAlertName,
+ nsIPrincipal* aPrincipal)
+{
+ return NS_ERROR_NOT_IMPLEMENTED;
+}
diff --git a/toolkit/system/gnome/nsAlertsService.h b/toolkit/system/gnome/nsAlertsService.h
new file mode 100644
--- /dev/null
+++ b/toolkit/system/gnome/nsAlertsService.h
@@ -0,0 +1,27 @@
+/* -*- Mode: C++; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+#ifndef nsAlertsService_h__
+#define nsAlertsService_h__
+
+#include "nsIAlertsService.h"
+#include "nsCOMPtr.h"
+
+class nsAlertsService : public nsIAlertsService
+{
+public:
+ NS_DECL_NSIALERTSSERVICE
+ NS_DECL_ISUPPORTS
+
+ nsAlertsService();
+
+ nsresult Init();
+
+protected:
+ virtual ~nsAlertsService();
+
+};
+
+#endif /* nsAlertsService_h__ */
diff --git a/toolkit/system/gnome/nsGnomeModule.cpp b/toolkit/system/gnome/nsGnomeModule.cpp
--- a/toolkit/system/gnome/nsGnomeModule.cpp
+++ b/toolkit/system/gnome/nsGnomeModule.cpp
@@ -17,53 +17,58 @@ NS_GENERIC_FACTORY_CONSTRUCTOR_INIT(nsGC
NS_GENERIC_FACTORY_CONSTRUCTOR_INIT(nsGnomeVFSService, Init)
#endif
#ifdef MOZ_ENABLE_GIO
@ -129,8 +220,8 @@ diff --git a/mozilla/toolkit/system/gnome/nsGnomeModule.cpp b/mozilla/toolkit/sy
NS_GENERIC_FACTORY_CONSTRUCTOR(nsGIOService)
NS_GENERIC_FACTORY_CONSTRUCTOR_INIT(nsGSettingsService, Init)
#endif
+#include "nsSystemAlertsService.h"
+NS_GENERIC_FACTORY_CONSTRUCTOR_INIT(nsSystemAlertsService, Init)
+#include "nsAlertsService.h"
+NS_GENERIC_FACTORY_CONSTRUCTOR_INIT(nsAlertsService, Init)
#ifdef MOZ_ENABLE_GCONF
NS_DEFINE_NAMED_CID(NS_GCONFSERVICE_CID);
@ -143,21 +234,20 @@ diff --git a/mozilla/toolkit/system/gnome/nsGnomeModule.cpp b/mozilla/toolkit/sy
NS_DEFINE_NAMED_CID(NS_GSETTINGSSERVICE_CID);
#endif
+NS_DEFINE_NAMED_CID(NS_SYSTEMALERTSSERVICE_CID);
+
static const mozilla::Module::CIDEntry kGnomeCIDs[] = {
#ifdef MOZ_ENABLE_GCONF
{ &kNS_GCONFSERVICE_CID, false, NULL, nsGConfServiceConstructor },
{ &kNS_GCONFSERVICE_CID, false, nullptr, nsGConfServiceConstructor },
#endif
#ifdef MOZ_ENABLE_GNOMEVFS
{ &kNS_GNOMEVFSSERVICE_CID, false, NULL, nsGnomeVFSServiceConstructor },
{ &kNS_GNOMEVFSSERVICE_CID, false, nullptr, nsGnomeVFSServiceConstructor },
#endif
#ifdef MOZ_ENABLE_GIO
{ &kNS_GIOSERVICE_CID, false, NULL, nsGIOServiceConstructor },
{ &kNS_GSETTINGSSERVICE_CID, false, NULL, nsGSettingsServiceConstructor },
{ &kNS_GIOSERVICE_CID, false, nullptr, nsGIOServiceConstructor },
{ &kNS_GSETTINGSSERVICE_CID, false, nullptr, nsGSettingsServiceConstructor },
#endif
+ { &kNS_SYSTEMALERTSSERVICE_CID, false, NULL, nsSystemAlertsServiceConstructor },
{ NULL }
+ { &kNS_SYSTEMALERTSSERVICE_CID, false, nullptr, nsAlertsServiceConstructor },
{ nullptr }
};
static const mozilla::Module::ContractIDEntry kGnomeContracts[] = {
@ -172,7 +262,7 @@ diff --git a/mozilla/toolkit/system/gnome/nsGnomeModule.cpp b/mozilla/toolkit/sy
{ NS_GSETTINGSSERVICE_CONTRACTID, &kNS_GSETTINGSSERVICE_CID },
#endif
+ { NS_SYSTEMALERTSERVICE_CONTRACTID, &kNS_SYSTEMALERTSSERVICE_CID },
{ NULL }
{ nullptr }
};
static nsresult
@ -180,94 +270,3 @@ diff --git a/mozilla/toolkit/system/gnome/nsGnomeModule.cpp b/mozilla/toolkit/sy
{
g_type_init();
return NS_OK;
diff --git a/mozilla/toolkit/system/gnome/nsSystemAlertsService.cpp b/mozilla/toolkit/system/gnome/nsSystemAlertsService.cpp
new file mode 100644
--- /dev/null
+++ b/mozilla/toolkit/system/gnome/nsSystemAlertsService.cpp
@@ -0,0 +1,54 @@
+/* -*- Mode: C++; tab-width: 2; indent-tabs-mode:nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+#include "nsSystemAlertsService.h"
+#include "nsAlertsIconListener.h"
+#include "nsAutoPtr.h"
+
+NS_IMPL_THREADSAFE_ADDREF(nsSystemAlertsService)
+NS_IMPL_THREADSAFE_RELEASE(nsSystemAlertsService)
+
+NS_INTERFACE_MAP_BEGIN(nsSystemAlertsService)
+ NS_INTERFACE_MAP_ENTRY_AMBIGUOUS(nsISupports, nsIAlertsService)
+ NS_INTERFACE_MAP_ENTRY(nsIAlertsService)
+NS_INTERFACE_MAP_END_THREADSAFE
+
+nsSystemAlertsService::nsSystemAlertsService()
+{}
+
+nsSystemAlertsService::~nsSystemAlertsService()
+{}
+
+nsresult
+nsSystemAlertsService::Init()
+{
+ return NS_OK;
+}
+
+NS_IMETHODIMP
+nsSystemAlertsService::ShowAlertNotification(const nsAString & aImageUrl,
+ const nsAString & aAlertTitle,
+ const nsAString & aAlertText,
+ bool aAlertTextClickable,
+ const nsAString & aAlertCookie,
+ nsIObserver * aAlertListener,
+ const nsAString & aAlertName,
+ const nsAString & aBidi,
+ const nsAString & aLang)
+{
+ nsRefPtr<nsAlertsIconListener> alertListener = new nsAlertsIconListener();
+ if (!alertListener)
+ return NS_ERROR_OUT_OF_MEMORY;
+
+ return alertListener->InitAlertAsync(aImageUrl, aAlertTitle, aAlertText, aAlertTextClickable,
+ aAlertCookie, aAlertListener);
+}
+
+NS_IMETHODIMP
+nsSystemAlertsService::CloseAlert(const nsAString & aAlertName)
+{
+ return NS_ERROR_NOT_IMPLEMENTED;
+}
+
diff --git a/mozilla/toolkit/system/gnome/nsSystemAlertsService.h b/mozilla/toolkit/system/gnome/nsSystemAlertsService.h
new file mode 100644
--- /dev/null
+++ b/mozilla/toolkit/system/gnome/nsSystemAlertsService.h
@@ -0,0 +1,27 @@
+/* -*- Mode: C++; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+#ifndef nsSystemAlertsService_h__
+#define nsSystemAlertsService_h__
+
+#include "nsIAlertsService.h"
+#include "nsCOMPtr.h"
+
+class nsSystemAlertsService : public nsIAlertsService
+{
+public:
+ NS_DECL_NSIALERTSSERVICE
+ NS_DECL_ISUPPORTS
+
+ nsSystemAlertsService();
+ virtual ~nsSystemAlertsService();
+
+ nsresult Init();
+
+protected:
+
+};
+
+#endif /* nsSystemAlertsService_h__ */

View File

@ -1,31 +0,0 @@
# HG changeset patch
# Parent c2172c2aaa693e00c989f76c83b83a2be97afaab
# User Ulrich Weigand <uweigand@de.ibm.com>
Bug 973977 - Mark SharedStub hidden to fix ppc64 build failure
diff --git a/xpcom/reflect/xptcall/src/md/unix/xptcstubs_asm_ppc64_linux.s b/xpcom/reflect/xptcall/src/md/unix/xptcstubs_asm_ppc64_linux.s
--- a/xpcom/reflect/xptcall/src/md/unix/xptcstubs_asm_ppc64_linux.s
+++ b/xpcom/reflect/xptcall/src/md/unix/xptcstubs_asm_ppc64_linux.s
@@ -15,16 +15,21 @@
.set f15,15; .set f16,16; .set f17,17; .set f18,18; .set f19,19
.set f20,20; .set f21,21; .set f22,22; .set f23,23; .set f24,24
.set f25,25; .set f26,26; .set f27,27; .set f28,28; .set f29,29
.set f30,30; .set f31,31
.section ".text"
.align 2
.globl SharedStub
+ # Make the symbol hidden so that the branch from the stub does
+ # not go via a PLT. This is not only better for performance,
+ # but may be necessary to avoid linker errors since there is
+ # no place to restore the TOC register in a sibling call.
+ .hidden SharedStub
.section ".opd","aw"
.align 3
SharedStub:
.quad .SharedStub,.TOC.@tocbase
.previous
.type SharedStub,@function

View File

@ -1,12 +1,12 @@
diff -up xulrunner-24.0/mozilla-release/gfx/ycbcr/moz.build.neon xulrunner-24.0/mozilla-release/gfx/ycbcr/moz.build
--- xulrunner-24.0/mozilla-release/gfx/ycbcr/moz.build.neon 2013-09-11 01:15:02.000000000 +0200
+++ xulrunner-24.0/mozilla-release/gfx/ycbcr/moz.build 2013-09-16 11:23:40.487028288 +0200
diff -up firefox-29.0/mozilla-release/gfx/ycbcr/moz.build.arm firefox-29.0/mozilla-release/gfx/ycbcr/moz.build
--- firefox-29.0/mozilla-release/gfx/ycbcr/moz.build.arm 2014-04-22 07:27:47.000000000 +0200
+++ firefox-29.0/mozilla-release/gfx/ycbcr/moz.build 2014-04-22 16:40:34.862849368 +0200
@@ -61,7 +61,7 @@ else:
'yuv_row_other.cpp',
]
-if CONFIG['OS_TEST'] == 'arm' and CONFIG['HAVE_ARM_NEON']:
-if CONFIG['CPU_ARCH'] == 'arm' and CONFIG['HAVE_ARM_NEON']:
+if CONFIG['HAVE_ARM_NEON']:
CPP_SOURCES += [
'yuv_convert_arm.cpp',
SOURCES += [
'yuv_row_arm.s',
]

File diff suppressed because it is too large Load Diff

View File

@ -1,2 +1,2 @@
7804283cb4f5c1bbec711b470afe2472 thunderbird-24.7.0.source.tar.bz2
ff00fce21aaca53bb9e0daf0910b7ba8 thunderbird-langpacks-24.7.0-20140722.tar.xz
195ea7d3887eb49402ea7b3875b7ce15 thunderbird-31.0.source.tar.bz2
c81e3f90897913440fafd965e69133dc thunderbird-langpacks-31.0-20140729.tar.xz

View File

@ -1,26 +0,0 @@
diff -up comm-release/mail/app/profile/all-thunderbird.js.addons comm-release/mail/app/profile/all-thunderbird.js
--- comm-release/mail/app/profile/all-thunderbird.js.addons 2011-11-15 10:36:03.868551158 +0100
+++ comm-release/mail/app/profile/all-thunderbird.js 2011-11-15 10:36:20.555397903 +0100
@@ -138,7 +138,7 @@ pref("extensions.update.autoUpdateDefaul
// Disable add-ons installed into the shared user and shared system areas by
// default. This does not include the application directory. See the SCOPE
// constants in AddonManager.jsm for values to use here
-pref("extensions.autoDisableScopes", 15);
+pref("extensions.autoDisableScopes", 0);
// Preferences for AMO integration
pref("extensions.getAddons.cache.enabled", true);
diff -up comm-release/mozilla/toolkit/mozapps/extensions/XPIProvider.jsm.addons comm-release/mozilla/toolkit/mozapps/extensions/XPIProvider.jsm
--- comm-release/mozilla/toolkit/mozapps/extensions/XPIProvider.jsm.addons 2011-11-15 11:15:06.518905245 +0100
+++ comm-release/mozilla/toolkit/mozapps/extensions/XPIProvider.jsm 2011-11-15 11:15:40.399934236 +0100
@@ -1591,8 +1591,8 @@ var XPIProvider = {
this.showUpgradeUI();
flushCaches = true;
}
- else if (aAppChanged === undefined) {
- // For new profiles we will never need to show the add-on selection UI
+ else {
+ // For all profiles we will never need to show the add-on selection UI
Services.prefs.setBoolPref(PREF_SHOWN_SELECTION_UI, true);
}

View File

@ -0,0 +1,26 @@
diff -up comm-esr31/mail/app/profile/all-thunderbird.js.addons comm-esr31/mail/app/profile/all-thunderbird.js
--- comm-esr31/mail/app/profile/all-thunderbird.js.addons 2014-07-18 02:04:05.000000000 +0200
+++ comm-esr31/mail/app/profile/all-thunderbird.js 2014-07-29 15:29:11.949728141 +0200
@@ -174,7 +174,7 @@ pref("extensions.update.autoUpdateDefaul
// Disable add-ons installed into the shared user and shared system areas by
// default. This does not include the application directory. See the SCOPE
// constants in AddonManager.jsm for values to use here
-pref("extensions.autoDisableScopes", 15);
+pref("extensions.autoDisableScopes", 0);
// Preferences for AMO integration
pref("extensions.getAddons.cache.enabled", true);
diff -up comm-esr31/mozilla/toolkit/mozapps/extensions/internal/XPIProvider.jsm.addons comm-esr31/mozilla/toolkit/mozapps/extensions/internal/XPIProvider.jsm
--- comm-esr31/mozilla/toolkit/mozapps/extensions/internal/XPIProvider.jsm.addons 2014-07-29 15:29:11.951728146 +0200
+++ comm-esr31/mozilla/toolkit/mozapps/extensions/internal/XPIProvider.jsm 2014-07-29 15:30:51.879030210 +0200
@@ -1894,8 +1894,8 @@ this.XPIProvider = {
this.showUpgradeUI();
flushCaches = true;
}
- else if (aAppChanged === undefined) {
- // For new profiles we will never need to show the add-on selection UI
+ else {
+ // For all profiles we will never need to show the add-on selection UI
Services.prefs.setBoolPref(PREF_SHOWN_SELECTION_UI, true);
}

View File

@ -1,8 +1,7 @@
diff -up comm-release/config/baseconfig.mk.dir comm-release/config/baseconfig.mk
--- comm-release/config/baseconfig.mk.dir 2012-11-20 10:35:27.280236537 +0100
+++ comm-release/config/baseconfig.mk 2012-11-20 10:35:45.208242562 +0100
@@ -2,7 +2,7 @@ INCLUDED_AUTOCONF_MK = 1
diff -up thunderbird-31.0/comm-esr31/config/baseconfig.mk.dir thunderbird-31.0/comm-esr31/config/baseconfig.mk
--- thunderbird-31.0/comm-esr31/config/baseconfig.mk.dir 2014-07-29 13:51:58.204106461 +0200
+++ thunderbird-31.0/comm-esr31/config/baseconfig.mk 2014-07-29 13:54:26.868555504 +0200
@@ -1,6 +1,6 @@
includedir := $(includedir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
@ -10,26 +9,15 @@ diff -up comm-release/config/baseconfig.mk.dir comm-release/config/baseconfig.mk
sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
MOZILLA_SRCDIR = $(topsrcdir)/mozilla
MOZDEPTH = $(DEPTH)/mozilla
diff -up comm-release/mozilla/config/baseconfig.mk.dir comm-release/mozilla/config/baseconfig.mk
--- comm-release/mozilla/config/baseconfig.mk.dir 2012-11-16 22:16:02.000000000 +0100
+++ comm-release/mozilla/config/baseconfig.mk 2012-11-20 10:34:30.610216973 +0100
@@ -2,7 +2,7 @@ INCLUDED_AUTOCONF_MK = 1
diff -up thunderbird-31.0/comm-esr31/mozilla/config/baseconfig.mk.dir thunderbird-31.0/comm-esr31/mozilla/config/baseconfig.mk
--- thunderbird-31.0/comm-esr31/mozilla/config/baseconfig.mk.dir 2014-07-18 02:05:10.000000000 +0200
+++ thunderbird-31.0/comm-esr31/mozilla/config/baseconfig.mk 2014-07-29 13:51:58.204106461 +0200
@@ -4,7 +4,7 @@
# whether a normal build is happening or whether the check is running.
includedir := $(includedir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
+installdir = $(libdir)/$(MOZ_APP_NAME)
sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
DIST = $(DEPTH)/dist
diff -up comm-release/mozilla/js/src/config/baseconfig.mk.dir comm-release/mozilla/js/src/config/baseconfig.mk
--- comm-release/mozilla/js/src/config/baseconfig.mk.dir 2012-11-16 22:16:14.000000000 +0100
+++ comm-release/mozilla/js/src/config/baseconfig.mk 2012-11-20 10:34:32.511217747 +0100
@@ -1,6 +1,6 @@
INCLUDED_AUTOCONF_MK = 1
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
+installdir = $(libdir)/$(MOZ_APP_NAME)
sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
ifneq (,$(filter /%,$(TOP_DIST)))
ifndef TOP_DIST
TOP_DIST = dist

View File

@ -1,6 +1,5 @@
mk_add_options MOZ_CO_PROJECT=mail
ac_add_options --enable-application=mail
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/objdir
mk_add_options AUTOCONF=autoconf-2.13
#ac_add_options --with-system-png

13
thunderbird-objdir.patch Normal file
View File

@ -0,0 +1,13 @@
diff -up thunderbird-31.0/comm-esr31/client.mk.old thunderbird-31.0/comm-esr31/client.mk
--- thunderbird-31.0/comm-esr31/client.mk.old 2014-07-18 02:04:05.000000000 +0200
+++ thunderbird-31.0/comm-esr31/client.mk 2014-07-30 10:57:01.177453550 +0200
@@ -131,7 +131,7 @@ endif
ifndef MOZ_OBJDIR
- MOZ_OBJDIR = obj-$(CONFIG_GUESS)
+ MOZ_OBJDIR = objdir
else
# On Windows Pymake builds check MOZ_OBJDIR doesn't start with "/"
ifneq (,$(findstring mingw,$(CONFIG_GUESS)))
diff -up thunderbird-31.0/comm-esr31/mozilla/media/webrtc/trunk/Makefile.old thunderbird-31.0/comm-esr31/mozilla/media/webrtc/trunk/Makefile

View File

@ -5,7 +5,7 @@
# Build as a debug package?
%define debug_build 0
%if 0%{?fedora} <= 18
%if 0%{?fedora} < 20
%define system_sqlite 0
%else
%define system_sqlite 1
@ -14,9 +14,9 @@
%define build_langpacks 1
%if %{?system_nss}
%global nspr_version 4.10.2
%global nspr_version 4.10.6
%global nspr_build_version %(pkg-config --silence-errors --modversion nspr 2>/dev/null || echo 65536)
%global nss_version 3.15.2
%global nss_version 3.16.2
%global nss_build_version %(pkg-config --silence-errors --modversion nss 2>/dev/null || echo 65536)
%endif
@ -24,13 +24,13 @@
%define freetype_version 2.1.9
%if %{?system_sqlite}
%define sqlite_version 3.7.17
%define sqlite_version 3.8.4.2
# The actual sqlite version (see #480989):
%global sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo 65536)
%endif
%define libnotify_version 0.4
%global libvpx_version 1.0.0
%global libvpx_version 1.3.0
%define _default_patch_fuzz 2
%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
@ -40,7 +40,9 @@
#
# IMPORTANT: If there is no top level directory, this should be
# set to the cwd, ie: '.'
%define tarballdir comm-esr24
%define tarballdir comm-esr31
%define objdir objdir
%define mozappdir %{_libdir}/%{name}
%define official_branding 1
# enable crash reporter only for iX86
@ -50,18 +52,17 @@
%define enable_mozilla_crashreporter 0
%endif
%define mozappdir %{_libdir}/%{name}
Summary: Mozilla Thunderbird mail/newsgroup client
Name: thunderbird
Version: 24.7.0
Release: 1%{?dist}
Version: 31.0
Release: 2%{?dist}
URL: http://www.mozilla.org/projects/thunderbird/
License: MPLv1.1 or GPLv2+ or LGPLv2+
Group: Applications/Internet
Source0: ftp://ftp.mozilla.org/pub/thunderbird/releases/%{version}%{?pre_version}/source/thunderbird-%{version}%{?pre_version}.source.tar.bz2
%if %{build_langpacks}
Source1: thunderbird-langpacks-%{version}-20140722.tar.xz
Source1: thunderbird-langpacks-%{version}-20140729.tar.xz
%endif
Source10: thunderbird-mozconfig
Source11: thunderbird-mozconfig-branded
@ -71,22 +72,20 @@ Source21: thunderbird.sh.in
# Mozilla (XULRunner) patches
Patch0: thunderbird-install-dir.patch
Patch8: xulrunner-10.0-secondary-ipc.patch
Patch9: mozilla-build-arm.patch
# Build patches
Patch100: thunderbird-objdir.patch
# Linux specific
Patch200: thunderbird-8.0-enable-addons.patch
Patch200: thunderbird-enable-addons.patch
# PPC fixes
Patch300: xulrunner-24.0-jemalloc-ppc.patch
Patch301: mozilla-ppc64le.patch
Patch304: mozilla-973977.patch
# Fedora specific patches
Patch400: rhbz-966424.patch
Patch401: revert-removal-of-native-notifications.patch
Patch401: mozilla-858919.patch
# Epel patches:
Patch500: firefox-system-nss-3.16.2.patch
@ -103,6 +102,8 @@ Patch500: firefox-system-nss-3.16.2.patch
BuildRequires: nss-static >= %{nss_version}
BuildRequires: nspr-devel >= %{nspr_version}
BuildRequires: nss-devel >= %{nss_version}
Requires: nspr >= %{nspr_build_version}
Requires: nss >= %{nss_build_version}
%endif
BuildRequires: cairo-devel >= %{cairo_version}
BuildRequires: libnotify-devel >= %{libnotify_version}
@ -121,6 +122,7 @@ BuildRequires: libXrender-devel
BuildRequires: hunspell-devel
%if %{?system_sqlite}
BuildRequires: sqlite-devel >= %{sqlite_version}
Requires: sqlite >= %{sqlite_build_version}
%endif
BuildRequires: startup-notification-devel
BuildRequires: alsa-lib-devel
@ -129,15 +131,10 @@ BuildRequires: desktop-file-utils
BuildRequires: libcurl-devel
BuildRequires: mesa-libGL-devel
BuildRequires: libvpx-devel >= %{libvpx_version}
Requires: mozilla-filesystem
%if %{?system_nss}
Requires: nspr >= %{nspr_build_version}
Requires: nss >= %{nss_build_version}
%endif
%if %{?system_sqlite}
Requires: sqlite >= %{sqlite_build_version}
%endif
Requires: libvpx >= %{libvpx_version}
BuildRequires: pulseaudio-libs-devel
BuildRequires: libicu-devel
Requires: mozilla-filesystem
%description
Mozilla Thunderbird is a standalone mail and newsgroup client.
@ -166,14 +163,15 @@ debug %{name}, you want to install %{name}-debuginfo instead.
%setup -q -c
cd %{tarballdir}
%patch0 -p1 -b .dir
%patch0 -p2 -b .dir
%patch100 -p2 -b .objdir
# Mozilla (XULRunner) patches
cd mozilla
%patch8 -p3 -b .secondary-ipc
%patch9 -p2 -b .arm
%patch9 -p2 -b .arm
%patch300 -p2 -b .852698
%patch400 -p1 -b .966424
%patch401 -p2 -b .notifications
%patch401 -p1 -b .858919
%ifarch ppc64
%patch304 -p1 -b .973977
%endif
@ -182,11 +180,7 @@ cd mozilla
%patch500 -p2 -b .nss-ver
%endif
cd ..
%patch200 -p1 -b .addons
%if 0%{?fedora} > 20
%patch301 -p1 -b .ppc64le
%endif
%if %{official_branding}
# Required by Mozilla Corporation
@ -296,13 +290,13 @@ make -f client.mk build STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
# create debuginfo for crash-stats.mozilla.com
%if %{enable_mozilla_crashreporter}
make -C objdir buildsymbols
make -C %{objdir} buildsymbols
%endif
#===============================================================================
%install
cd %{tarballdir}/objdir
cd %{tarballdir}/%{objdir}
DESTDIR=$RPM_BUILD_ROOT make install
@ -351,7 +345,7 @@ touch %{name}.lang
for langpack in `ls thunderbird-langpacks/*.xpi`; do
language=`basename $langpack .xpi`
extensionID=langpack-$language@thunderbird.mozilla.org
language=`echo $language | sed -e 's/-/_/g'`
%{__install} -m 644 ${langpack} $RPM_BUILD_ROOT%{mozappdir}/langpacks/${extensionID}.xpi
echo "%%lang($language) %{mozappdir}/langpacks/${extensionID}.xpi" >> %{name}.lang
@ -379,7 +373,7 @@ touch $RPM_BUILD_ROOT%{mozappdir}/components/xpti.dat
# Add debuginfo for crash-stats.mozilla.com
%if %{enable_mozilla_crashreporter}
%{__mkdir_p} $RPM_BUILD_ROOT/%{moz_debug_dir}
%{__cp} objdir/mozilla/dist/%{symbols_file_name} $RPM_BUILD_ROOT/%{moz_debug_dir}
%{__cp} %{objdir}/mozilla/dist/%{symbols_file_name} $RPM_BUILD_ROOT/%{moz_debug_dir}
%endif
#===============================================================================
@ -455,6 +449,12 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
#===============================================================================
%changelog
* Wed Jul 30 2014 Martin Stransky <stransky@redhat.com> - 31.0-2
- Added patch for mozbz#858919
* Tue Jul 29 2014 Martin Stransky <stransky@redhat.com> - 31.0-1
- Update to 31.0
* Tue Jul 22 2014 Jan Horak <jhorak@redhat.com> - 24.7.0-1
- Update to 24.7.0

View File

@ -1,36 +0,0 @@
diff -up thunderbird-10.0/comm-release/mozilla/ipc/chromium/src/base/data_pack.cc.secondary-ipc thunderbird-10.0/comm-release/mozilla/ipc/chromium/src/base/data_pack.cc
--- thunderbird-10.0/comm-release/mozilla/ipc/chromium/src/base/data_pack.cc.secondary-ipc 2012-01-29 15:44:23.000000000 +0100
+++ thunderbird-10.0/comm-release/mozilla/ipc/chromium/src/base/data_pack.cc 2012-01-31 10:45:57.784248018 +0100
@@ -91,14 +91,7 @@ bool DataPack::Load(const FilePath& path
bool DataPack::Get(uint32_t resource_id, StringPiece* data) {
// It won't be hard to make this endian-agnostic, but it's not worth
// bothering to do right now.
-#if defined(__BYTE_ORDER)
- // Linux check
- COMPILE_ASSERT(__BYTE_ORDER == __LITTLE_ENDIAN,
- datapack_assumes_little_endian);
-#elif defined(__BIG_ENDIAN__)
- // Mac check
- #error DataPack assumes little endian
-#endif
+#warning DoTheRightThingMakingThisEndianAgnostic!
DataPackEntry* target = reinterpret_cast<DataPackEntry*>(
bsearch(&resource_id, mmap_->data() + kHeaderLength, resource_count_,
diff -up thunderbird-10.0/comm-release/mozilla/ipc/chromium/src/build/build_config.h.secondary-ipc thunderbird-10.0/comm-release/mozilla/ipc/chromium/src/build/build_config.h
--- thunderbird-10.0/comm-release/mozilla/ipc/chromium/src/build/build_config.h.secondary-ipc 2012-01-29 15:44:23.000000000 +0100
+++ thunderbird-10.0/comm-release/mozilla/ipc/chromium/src/build/build_config.h 2012-01-31 10:53:24.409935119 +0100
@@ -65,10 +65,10 @@
#elif defined(__ppc__) || defined(__powerpc__)
#define ARCH_CPU_PPC 1
#define ARCH_CPU_32_BITS 1
-#elif defined(__sparc64__)
+#elif defined(__sparc__) && !defined(__arch64)
#define ARCH_CPU_SPARC 1
#define ARCH_CPU_64_BITS 1
-#elif defined(__sparc__)
+#elif defined(__sparc__) && defined(__arch64)
#define ARCH_CPU_SPARC 1
#define ARCH_CPU_32_BITS 1
#elif defined(__mips__)
diff -up thunderbird-10.0/comm-release/mozilla/ipc/chromium/src/chrome/common/ipc_message_utils.h.secondary-ipc thunderbird-10.0/comm-release/mozilla/ipc/chromium/src/chrome/common/ipc_message_utils.h