Update to 12.0

This commit is contained in:
Jan Horak 2012-04-24 09:57:17 +02:00
parent 7f8e036d22
commit b1a3545985
7 changed files with 63 additions and 201 deletions

2
.gitignore vendored
View File

@ -41,3 +41,5 @@ thunderbird-langpacks-3.1.2-20100803.tar.bz2
/thunderbird-langpacks-11.0-20120313.tar.xz
/thunderbird-11.0.1.source.tar.bz2
/thunderbird-langpacks-11.0.1-20120329.tar.xz
/thunderbird-12.0.source.tar.bz2
/thunderbird-langpacks-12.0-20120424.tar.xz

View File

@ -1,74 +0,0 @@
diff -up xulrunner-11.0/mozilla-beta/configure.in.vpx1.0.0 xulrunner-11.0/mozilla-beta/configure.in
--- xulrunner-11.0/mozilla-beta/configure.in.vpx1.0.0 2012-03-09 01:39:31.000000000 +0100
+++ xulrunner-11.0/mozilla-beta/configure.in 2012-03-09 15:03:51.246031329 +0100
@@ -5710,20 +5710,20 @@ if test -n "$MOZ_WEBM"; then
[MOZ_NATIVE_LIBVPX_DEC_TEST=1],
([--with-system-libvpx requested but symbol vpx_codec_dec_init_ver not found]))
if test -n "$MOZ_NATIVE_LIBVPX_DEC_TEST" ; then
- AC_MSG_CHECKING([for libvpx version >= v0.9.7])
- dnl We need at least v0.9.7 to fix several crash bugs (for which we
- dnl had local patches prior to v0.9.7).
+ AC_MSG_CHECKING([for libvpx version >= v1.0.0])
+ dnl We need at least v1.0.0 to fix several crash bugs (for which we
+ dnl had local patches prior to v1.0.0).
dnl
dnl This is a terrible test for the library version, but we don't
dnl have a good one. There is no version number in a public header,
dnl and testing the headers still doesn't guarantee we link against
dnl the right version. While we could call vpx_codec_version() at
dnl run-time, that would break cross-compiling. There are no
- dnl additional exported symbols between the v0.9.7 release and the
- dnl v0.9.6 one to check for.
+ dnl additional exported decoder symbols between the v1.0.0 release
+ dnl and the v0.9.7 one to check for.
AC_TRY_COMPILE([
#include <vpx/vpx_decoder.h>
- #if !defined(VPX_CODEC_USE_INPUT_PARTITION)
+ #if !defined(VPX_CODEC_USE_INPUT_FRAGMENTS)
#error "test failed."
#endif
],
@@ -5734,7 +5734,7 @@ if test -n "$MOZ_WEBM"; then
MOZ_LIBVPX_INCLUDES="-I${LIBVPX_DIR}/include"
MOZ_LIBVPX_LIBS="-L${LIBVPX_DIR}/lib -lvpx"],
[AC_MSG_RESULT([no])
- AC_MSG_ERROR([--with-system-libvpx requested but it is not v0.9.7 or later])])
+ AC_MSG_ERROR([--with-system-libvpx requested but it is not v1.0.0 or later])])
fi
CFLAGS=$_SAVE_CFLAGS
LDFLAGS=$_SAVE_LDFLAGS
diff -up xulrunner-11.0/mozilla-beta/configure.vpx1.0.0 xulrunner-11.0/mozilla-beta/configure
--- xulrunner-11.0/mozilla-beta/configure.vpx1.0.0 2012-03-09 01:58:50.000000000 +0100
+++ xulrunner-11.0/mozilla-beta/configure 2012-03-09 15:15:42.537585632 +0100
@@ -17761,14 +17761,14 @@ else
fi
if test -n "$MOZ_NATIVE_LIBVPX_DEC_TEST" ; then
- echo $ac_n "checking for libvpx version >= v0.9.7""... $ac_c" 1>&6
-echo "configure:17766: checking for libvpx version >= v0.9.7" >&5
+ echo $ac_n "checking for libvpx version >= v1.0.0""... $ac_c" 1>&6
+echo "configure:17766: checking for libvpx version >= v1.0.0" >&5
cat > conftest.$ac_ext <<EOF
#line 17768 "configure"
#include "confdefs.h"
#include <vpx/vpx_decoder.h>
- #if !defined(VPX_CODEC_USE_INPUT_PARTITION)
+ #if !defined(VPX_CODEC_USE_INPUT_FRAGMENTS)
#error "test failed."
#endif
@@ -17791,7 +17791,7 @@ else
cat conftest.$ac_ext >&5
rm -rf conftest*
echo "$ac_t""no" 1>&6
- { echo "configure: error: --with-system-libvpx requested but it is not v0.9.7 or later" 1>&2; exit 1; }
+ { echo "configure: error: --with-system-libvpx requested but it is not v1.0.0 or later" 1>&2; exit 1; }
fi
rm -f conftest*
fi
@@ -25794,4 +25794,3 @@ if cmp -s config/autoconf.mk config/auto
else
rm -f config/autoconf.mk.orig 2> /dev/null
fi
-

View File

@ -1,6 +1,6 @@
diff -up thunderbird-11.0/comm-release/mailnews/base/search/src/nsMsgSearchAdapter.cpp.733867 thunderbird-11.0/comm-release/mailnews/base/search/src/nsMsgSearchAdapter.cpp
--- thunderbird-11.0/comm-release/mailnews/base/search/src/nsMsgSearchAdapter.cpp.733867 2012-03-13 03:37:12.000000000 +0100
+++ thunderbird-11.0/comm-release/mailnews/base/search/src/nsMsgSearchAdapter.cpp 2012-03-16 07:20:29.299342799 +0100
diff -up comm-release/mailnews/base/search/src/nsMsgSearchAdapter.cpp.733867 comm-release/mailnews/base/search/src/nsMsgSearchAdapter.cpp
--- comm-release/mailnews/base/search/src/nsMsgSearchAdapter.cpp.733867 2012-04-21 00:32:39.000000000 +0200
+++ comm-release/mailnews/base/search/src/nsMsgSearchAdapter.cpp 2012-04-24 09:02:03.295311592 +0200
@@ -688,7 +688,7 @@ nsresult nsMsgSearchAdapter::EncodeImapV
PL_strcat(encoding, "{");
lengthStr.AppendInt((PRInt32) strlen(value));
@ -10,10 +10,10 @@ diff -up thunderbird-11.0/comm-release/mailnews/base/search/src/nsMsgSearchAdapt
PL_strcat(encoding, value);
return NS_OK;
}
diff -up thunderbird-11.0/comm-release/mailnews/base/src/nsMsgFolderCompactor.cpp.733867 thunderbird-11.0/comm-release/mailnews/base/src/nsMsgFolderCompactor.cpp
--- thunderbird-11.0/comm-release/mailnews/base/src/nsMsgFolderCompactor.cpp.733867 2012-03-13 03:37:13.000000000 +0100
+++ thunderbird-11.0/comm-release/mailnews/base/src/nsMsgFolderCompactor.cpp 2012-03-16 07:20:29.300342735 +0100
@@ -753,7 +753,7 @@ nsFolderCompactState::OnDataAvailable(ns
diff -up comm-release/mailnews/base/src/nsMsgFolderCompactor.cpp.733867 comm-release/mailnews/base/src/nsMsgFolderCompactor.cpp
--- comm-release/mailnews/base/src/nsMsgFolderCompactor.cpp.733867 2012-04-21 00:32:39.000000000 +0200
+++ comm-release/mailnews/base/src/nsMsgFolderCompactor.cpp 2012-04-24 09:02:03.295311592 +0200
@@ -758,7 +758,7 @@ nsFolderCompactState::OnDataAvailable(ns
}
}
}
@ -22,7 +22,7 @@ diff -up thunderbird-11.0/comm-release/mailnews/base/src/nsMsgFolderCompactor.cp
// if status offset isn't in the first block, this code won't work. There's no good reason
// for the status offset not to be at the beginning of the message anyway.
@@ -1203,7 +1203,7 @@ nsOfflineStoreCompactState::OnDataAvaila
@@ -1216,7 +1216,7 @@ nsOfflineStoreCompactState::OnDataAvaila
// check if there's an envelope header; if not, write one.
if (strncmp(m_dataBuffer, "From ", 5))
{
@ -31,19 +31,19 @@ diff -up thunderbird-11.0/comm-release/mailnews/base/src/nsMsgFolderCompactor.cp
m_offlineMsgSize += bytesWritten;
}
}
diff -up thunderbird-11.0/comm-release/mailnews/compose/src/nsSmtpProtocol.cpp.733867 thunderbird-11.0/comm-release/mailnews/compose/src/nsSmtpProtocol.cpp
--- thunderbird-11.0/comm-release/mailnews/compose/src/nsSmtpProtocol.cpp.733867 2012-03-13 03:37:13.000000000 +0100
+++ thunderbird-11.0/comm-release/mailnews/compose/src/nsSmtpProtocol.cpp 2012-03-16 07:23:01.225877457 +0100
diff -up comm-release/mailnews/compose/src/nsSmtpProtocol.cpp.733867 comm-release/mailnews/compose/src/nsSmtpProtocol.cpp
--- comm-release/mailnews/compose/src/nsSmtpProtocol.cpp.733867 2012-04-21 00:32:39.000000000 +0200
+++ comm-release/mailnews/compose/src/nsSmtpProtocol.cpp 2012-04-24 09:02:03.873310511 +0200
@@ -1722,7 +1722,7 @@ PRInt32 nsSmtpProtocol::SendQuit()
{
m_sendDone = PR_TRUE;
m_sendDone = true;
nsCOMPtr<nsIURI> url = do_QueryInterface(m_runningURL);
- SendData(url, "QUIT"CRLF); // send a quit command to close the connection with the server.
+ SendData(url, "QUIT" CRLF); // send a quit command to close the connection with the server.
m_nextState = SMTP_RESPONSE;
m_nextStateAfterResponse = SMTP_DONE;
return(0);
@@ -1969,7 +1969,7 @@ nsresult nsSmtpProtocol::LoadUrl(nsIURI
@@ -1969,7 +1969,7 @@ nsresult nsSmtpProtocol::LoadUrl(nsIURI
{
nsCOMPtr<nsIURI> url = do_QueryInterface(m_runningURL);
// send a quit command to close the connection with the server.
@ -57,10 +57,10 @@ diff -up thunderbird-11.0/comm-release/mailnews/compose/src/nsSmtpProtocol.cpp.7
return rv;
}
-
diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapMailFolder.cpp.733867 thunderbird-11.0/comm-release/mailnews/imap/src/nsImapMailFolder.cpp
--- thunderbird-11.0/comm-release/mailnews/imap/src/nsImapMailFolder.cpp.733867 2012-03-13 03:37:13.000000000 +0100
+++ thunderbird-11.0/comm-release/mailnews/imap/src/nsImapMailFolder.cpp 2012-03-16 07:20:29.309342162 +0100
@@ -8298,7 +8298,7 @@ nsImapMailFolder::CopyFileToOfflineStore
diff -up comm-release/mailnews/imap/src/nsImapMailFolder.cpp.733867 comm-release/mailnews/imap/src/nsImapMailFolder.cpp
--- comm-release/mailnews/imap/src/nsImapMailFolder.cpp.733867 2012-04-21 00:32:39.000000000 +0200
+++ comm-release/mailnews/imap/src/nsImapMailFolder.cpp 2012-04-24 09:02:03.878310501 +0200
@@ -8309,7 +8309,7 @@ nsImapMailFolder::CopyFileToOfflineStore
bool needMoreData = false;
char * newLine = nsnull;
PRUint32 numBytesInLine = 0;
@ -69,10 +69,10 @@ diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapMailFolder.cpp.73
offlineStore->Write(envelope, strlen(envelope), &bytesWritten);
fileSize += bytesWritten;
do
diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp.733867 thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp
--- thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp.733867 2012-03-13 03:37:13.000000000 +0100
+++ thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp 2012-03-16 07:20:29.314341844 +0100
@@ -1410,7 +1410,7 @@ void nsImapProtocol::HandleIdleResponses
diff -up comm-release/mailnews/imap/src/nsImapProtocol.cpp.733867 comm-release/mailnews/imap/src/nsImapProtocol.cpp
--- comm-release/mailnews/imap/src/nsImapProtocol.cpp.733867 2012-04-21 00:32:39.000000000 +0200
+++ comm-release/mailnews/imap/src/nsImapProtocol.cpp 2012-04-24 09:07:04.801246261 +0200
@@ -1409,7 +1409,7 @@ void nsImapProtocol::HandleIdleResponses
{
// PRInt32 oldRecent = GetServerStateParser().NumberOfRecentMessages();
nsCAutoString commandBuffer(GetServerCommandTag());
@ -81,7 +81,7 @@ diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp.7338
do
{
@@ -3290,7 +3290,7 @@ void nsImapProtocol::FetchMsgAttribute(c
@@ -3287,7 +3287,7 @@ void nsImapProtocol::FetchMsgAttribute(c
commandString.Append(messageIds);
commandString.Append(" (");
commandString.Append(attribute);
@ -114,10 +114,10 @@ diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp.7338
command.Append(correctedPassword);
- command.Append("\""CRLF);
+ command.Append("\"" CRLF);
rv = SendData(command.get(), PR_TRUE /* suppress logging */);
rv = SendData(command.get(), true /* suppress logging */);
NS_ENSURE_SUCCESS(rv, rv);
ParseIMAPandCheckForNewMail();
@@ -7446,7 +7446,7 @@ void nsImapProtocol::CreateMailbox(const
@@ -7447,7 +7447,7 @@ void nsImapProtocol::CreateMailbox(const
nsCString command(GetServerCommandTag());
command += " create \"";
command += escapedName;
@ -126,7 +126,7 @@ diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp.7338
nsresult rv = SendData(command.get());
if(NS_SUCCEEDED(rv))
@@ -7549,7 +7549,7 @@ void nsImapProtocol::Lsub(const char *ma
@@ -7550,7 +7550,7 @@ void nsImapProtocol::Lsub(const char *ma
nsCString command (GetServerCommandTag());
command += " lsub \"\" \"";
command += escapedPattern;
@ -135,7 +135,7 @@ diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp.7338
PR_Free(boxnameWithOnlineDirectory);
@@ -7578,7 +7578,7 @@ void nsImapProtocol::List(const char *ma
@@ -7579,7 +7579,7 @@ void nsImapProtocol::List(const char *ma
command += useXLIST ?
" xlist \"\" \"" : " list \"\" \"";
command += escapedPattern;
@ -144,7 +144,7 @@ diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp.7338
PR_Free(boxnameWithOnlineDirectory);
@@ -7599,7 +7599,7 @@ void nsImapProtocol::Subscribe(const cha
@@ -7600,7 +7600,7 @@ void nsImapProtocol::Subscribe(const cha
nsCString command (GetServerCommandTag());
command += " subscribe \"";
command += escapedName;
@ -153,7 +153,7 @@ diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp.7338
nsresult rv = SendData(command.get());
if (NS_SUCCEEDED(rv))
@@ -7617,7 +7617,7 @@ void nsImapProtocol::Unsubscribe(const c
@@ -7618,7 +7618,7 @@ void nsImapProtocol::Unsubscribe(const c
nsCString command (GetServerCommandTag());
command += " unsubscribe \"";
command += escapedName;
@ -162,7 +162,7 @@ diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp.7338
nsresult rv = SendData(command.get());
if (NS_SUCCEEDED(rv))
@@ -7631,7 +7631,7 @@ void nsImapProtocol::Idle()
@@ -7632,7 +7632,7 @@ void nsImapProtocol::Idle()
if (m_urlInProgress)
return;
nsCAutoString command (GetServerCommandTag());
@ -171,7 +171,7 @@ diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp.7338
nsresult rv = SendData(command.get());
if (NS_SUCCEEDED(rv))
{
@@ -7658,7 +7658,7 @@ void nsImapProtocol::EndIdle(bool waitFo
@@ -7659,7 +7659,7 @@ void nsImapProtocol::EndIdle(bool waitFo
nsCOMPtr <nsIAsyncInputStream> asyncInputStream = do_QueryInterface(m_inputStream);
if (asyncInputStream)
asyncInputStream->AsyncWait(nsnull, 0, 0, nsnull);
@ -180,7 +180,7 @@ diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp.7338
// set a short timeout if we don't want to wait for a response
if (m_transport && !waitForResponse)
m_transport->SetTimeout(nsISocketTransport::TIMEOUT_READ_WRITE, 5);
@@ -7727,8 +7727,8 @@ void nsImapProtocol::Copy(const char * m
@@ -7728,8 +7728,8 @@ void nsImapProtocol::Copy(const char * m
PRUint32 msgsHandled = 0;
const char *formatString;
formatString = (idsAreUid)
@ -191,9 +191,9 @@ diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp.7338
do
{
diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapServerResponseParser.cpp.733867 thunderbird-11.0/comm-release/mailnews/imap/src/nsImapServerResponseParser.cpp
--- thunderbird-11.0/comm-release/mailnews/imap/src/nsImapServerResponseParser.cpp.733867 2012-03-13 03:37:13.000000000 +0100
+++ thunderbird-11.0/comm-release/mailnews/imap/src/nsImapServerResponseParser.cpp 2012-03-16 07:20:29.316341717 +0100
diff -up comm-release/mailnews/imap/src/nsImapServerResponseParser.cpp.733867 comm-release/mailnews/imap/src/nsImapServerResponseParser.cpp
--- comm-release/mailnews/imap/src/nsImapServerResponseParser.cpp.733867 2012-04-21 00:32:39.000000000 +0200
+++ comm-release/mailnews/imap/src/nsImapServerResponseParser.cpp 2012-04-24 09:02:03.884310490 +0200
@@ -185,7 +185,7 @@ void nsImapServerResponseParser::ParseIM
NS_ASSERTION(aCurrentCommand && *aCurrentCommand != '\r' &&
@ -201,11 +201,11 @@ diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapServerResponsePar
- bool sendingIdleDone = !strcmp(aCurrentCommand, "DONE"CRLF);
+ bool sendingIdleDone = !strcmp(aCurrentCommand, "DONE" CRLF);
if (sendingIdleDone)
fWaitingForMoreClientInput = PR_FALSE;
fWaitingForMoreClientInput = false;
diff -up thunderbird-11.0/comm-release/mailnews/local/src/nsPop3Protocol.cpp.733867 thunderbird-11.0/comm-release/mailnews/local/src/nsPop3Protocol.cpp
--- thunderbird-11.0/comm-release/mailnews/local/src/nsPop3Protocol.cpp.733867 2012-03-13 03:37:13.000000000 +0100
+++ thunderbird-11.0/comm-release/mailnews/local/src/nsPop3Protocol.cpp 2012-03-16 07:23:38.980300990 +0100
diff -up comm-release/mailnews/local/src/nsPop3Protocol.cpp.733867 comm-release/mailnews/local/src/nsPop3Protocol.cpp
--- comm-release/mailnews/local/src/nsPop3Protocol.cpp.733867 2012-04-21 00:32:40.000000000 +0200
+++ comm-release/mailnews/local/src/nsPop3Protocol.cpp 2012-04-24 09:02:03.885310488 +0200
@@ -2483,7 +2483,7 @@ PRInt32 nsPop3Protocol::SendList()
return(MK_OUT_OF_MEMORY);
m_pop3ConData->next_state_after_response = POP3_GET_LIST;
@ -215,9 +215,9 @@ diff -up thunderbird-11.0/comm-release/mailnews/local/src/nsPop3Protocol.cpp.733
}
diff -up thunderbird-11.0/comm-release/mailnews/mime/src/mimedrft.cpp.733867 thunderbird-11.0/comm-release/mailnews/mime/src/mimedrft.cpp
--- thunderbird-11.0/comm-release/mailnews/mime/src/mimedrft.cpp.733867 2012-03-13 03:37:13.000000000 +0100
+++ thunderbird-11.0/comm-release/mailnews/mime/src/mimedrft.cpp 2012-03-16 07:20:29.320341461 +0100
diff -up comm-release/mailnews/mime/src/mimedrft.cpp.733867 comm-release/mailnews/mime/src/mimedrft.cpp
--- comm-release/mailnews/mime/src/mimedrft.cpp.733867 2012-04-21 00:32:40.000000000 +0200
+++ comm-release/mailnews/mime/src/mimedrft.cpp 2012-04-24 09:02:03.886310486 +0200
@@ -1473,7 +1473,7 @@ mime_parse_stream_complete (nsMIMESessio
*newbody = 0;
PL_strcatn(newbody, newbodylen, "<PRE>");
@ -227,9 +227,9 @@ diff -up thunderbird-11.0/comm-release/mailnews/mime/src/mimedrft.cpp.733867 thu
PR_Free(body);
body = newbody;
}
diff -up thunderbird-11.0/comm-release/mailnews/mime/src/mimemult.cpp.733867 thunderbird-11.0/comm-release/mailnews/mime/src/mimemult.cpp
--- thunderbird-11.0/comm-release/mailnews/mime/src/mimemult.cpp.733867 2012-03-13 03:37:13.000000000 +0100
+++ thunderbird-11.0/comm-release/mailnews/mime/src/mimemult.cpp 2012-03-16 07:20:29.321341397 +0100
diff -up comm-release/mailnews/mime/src/mimemult.cpp.733867 comm-release/mailnews/mime/src/mimemult.cpp
--- comm-release/mailnews/mime/src/mimemult.cpp.733867 2012-04-21 00:32:40.000000000 +0200
+++ comm-release/mailnews/mime/src/mimemult.cpp 2012-04-24 09:05:56.522197836 +0200
@@ -280,7 +280,7 @@ MimeMultipart_parse_line (const char *li
MimeWriteAString(obj, NS_LITERAL_CSTRING(MSG_LINEBREAK));
MimeWriteAString(obj, NS_LITERAL_CSTRING("Content-Disposition: attachment; filename=\""));
@ -252,14 +252,12 @@ diff -up thunderbird-11.0/comm-release/mailnews/mime/src/mimemult.cpp.733867 thu
}
nsCString result;
char timeBuffer[128];
@@ -306,8 +306,8 @@ MimeMultipart_parse_line (const char *li
"%a %b %d %H:%M:%S %Y",
@@ -307,7 +307,7 @@ MimeMultipart_parse_line (const char *li
&now);
MimeWriteAString(obj, nsDependentCString(timeBuffer));
- MimeWriteAString(obj, NS_LITERAL_CSTRING("\""MSG_LINEBREAK));
MimeWriteAString(obj, NS_LITERAL_CSTRING("\""MSG_LINEBREAK));
- MimeWriteAString(obj, NS_LITERAL_CSTRING(MSG_LINEBREAK"You deleted an attachment from this message. The original MIME headers for the attachment were:"MSG_LINEBREAK));
+ MimeWriteAString(obj, NS_LITERAL_CSTRING("\"" MSG_LINEBREAK));
+ MimeWriteAString(obj, NS_LITERAL_CSTRING(MSG_LINEBREAK "You deleted an attachment from this message. The original MIME headers for the attachment were:" MSG_LINEBREAK));
MimeHeaders_write_raw_headers(mult->hdrs, obj->options, PR_FALSE);
+ MimeWriteAString(obj, NS_LITERAL_CSTRING(MSG_LINEBREAK "You deleted an attachment from this message. The original MIME headers for the attachment were:"MSG_LINEBREAK));
MimeHeaders_write_raw_headers(mult->hdrs, obj->options, false);
}
PRInt32 old_nchildren = container->nchildren;

View File

@ -1,2 +1,2 @@
b500560a006cb10194281263c78841f2 thunderbird-11.0.1.source.tar.bz2
049e1abc49faaa34b7edc682c2fd2863 thunderbird-langpacks-11.0.1-20120329.tar.xz
7b30b72472a65bce74ba0ae60e4d4e6c thunderbird-12.0.source.tar.bz2
20672911c33375dbbd0677cf72654777 thunderbird-langpacks-12.0-20120424.tar.xz

View File

@ -21,7 +21,8 @@ ac_add_options --disable-xprint
ac_add_options --disable-strip
ac_add_options --disable-install-strip
ac_add_options --enable-pango
ac_add_options --enable-system-cairo
# temporary disable system cairo, because compilation fails
#ac_add_options --enable-system-cairo
ac_add_options --enable-svg
ac_add_options --enable-canvas
ac_add_options --enable-system-hunspell

View File

@ -1,7 +1,7 @@
# Build as a debug package?
%define debug_build 0
%if 0%{?fedora} <= 15
%if 0%{?fedora} <= 16
%define system_sqlite 0
%else
%define system_sqlite 1
@ -13,7 +13,7 @@
%define nss_version 3.13.3
%define cairo_version 1.8.8
%define freetype_version 2.1.9
%define sqlite_version 3.7.7.1
%define sqlite_version 3.7.10
%define libnotify_version 0.4
%global libvpx_version 1.0.0
@ -38,14 +38,14 @@
Summary: Mozilla Thunderbird mail/newsgroup client
Name: thunderbird
Version: 11.0.1
Version: 12.0
Release: 1%{?dist}
URL: http://www.mozilla.org/projects/thunderbird/
License: MPLv1.1 or GPLv2+ or LGPLv2+
Group: Applications/Internet
Source0: ftp://ftp.mozilla.org/pub/thunderbird/releases/%{version}%{?pre_version}/source/thunderbird-%{version}%{?pre_version}.source.tar.bz2
%if %{build_langpacks}
Source1: thunderbird-langpacks-%{version}-20120329.tar.xz
Source1: thunderbird-langpacks-%{version}-20120424.tar.xz
%endif
Source10: thunderbird-mozconfig
Source11: thunderbird-mozconfig-branded
@ -61,8 +61,6 @@ Patch7: crashreporter-remove-static.patch
Patch8: xulrunner-10.0-secondary-ipc.patch
# Build patches
Patch100: xulrunner-10.0-gcc47.patch
Patch101: mozilla-722127.patch
Patch102: mozilla-733867-x.patch
# Linux specific
@ -150,12 +148,8 @@ cd %{tarballdir}
cd mozilla
%patch7 -p2 -b .static
%patch8 -p3 -b .secondary-ipc
%if 0%{?fedora} >= 17
%patch100 -p1 -b .gcc47
%endif
%patch101 -p2 -b .722127
cd ..
%patch102 -p2 -b .733867
%patch102 -p1 -b .733867
%patch200 -p1 -b .addons
@ -385,10 +379,14 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%exclude %{_libdir}/%{name}-devel-%{version}
%{mozappdir}/chrome.manifest
%{mozappdir}/searchplugins
%{mozappdir}/distribution/extensions
#===============================================================================
%changelog
* Tue Apr 24 2012 Jan Horak <jhorak@redhat.com> - 12.0-1
- Update to 12.0
* Thu Mar 29 2012 Jan Horak <jhorak@redhat.com> - 11.0.1-1
- Update to 11.0.1

View File

@ -1,63 +0,0 @@
diff -up mozilla-beta/ipc/chromium/src/base/time_posix.cc.gcc47 mozilla-beta/ipc/chromium/src/base/time_posix.cc
--- mozilla-beta/ipc/chromium/src/base/time_posix.cc.gcc47 2012-01-24 03:00:00.000000000 -0500
+++ mozilla-beta/ipc/chromium/src/base/time_posix.cc 2012-01-30 14:12:49.198472212 -0500
@@ -14,6 +14,8 @@
#include <time.h>
#endif
+#include <unistd.h>
+
#include <limits>
#include "base/basictypes.h"
diff -up mozilla-beta/toolkit/crashreporter/client/Makefile.in.gcc47 mozilla-beta/toolkit/crashreporter/client/Makefile.in
--- mozilla-beta/toolkit/crashreporter/client/Makefile.in.gcc47 2012-01-30 14:41:14.475441039 -0500
+++ mozilla-beta/toolkit/crashreporter/client/Makefile.in 2012-01-30 14:43:03.587646656 -0500
@@ -69,6 +69,9 @@ CPPSRCS = \
$(STDCXX_COMPAT) \
$(NULL)
+# Needed for moz_free
+LIBS += -L$(LIBXUL_DIST)/lib -lmozalloc
+
ifeq ($(OS_ARCH),WINNT)
CPPSRCS += crashreporter_win.cpp
LIBS += \
diff -up mozilla-beta/ipc/chromium/src/base/file_util_linux.cc.file mozilla-beta/ipc/chromium/src/base/file_util_linux.cc
--- mozilla-beta/ipc/chromium/src/base/file_util_linux.cc.file 2012-01-24 09:00:00.000000000 +0100
+++ mozilla-beta/ipc/chromium/src/base/file_util_linux.cc 2012-01-25 15:30:43.707796295 +0100
@@ -5,6 +5,9 @@
#include "base/file_util.h"
#include <fcntl.h>
+#if defined(ANDROID) || defined(OS_POSIX)
+#include <unistd.h>
+#endif
#include <string>
#include <vector>
diff -up mozilla-beta/ipc/chromium/src/base/message_pump_libevent.cc.file mozilla-beta/ipc/chromium/src/base/message_pump_libevent.cc
--- mozilla-beta/ipc/chromium/src/base/message_pump_libevent.cc.file 2012-01-24 09:00:00.000000000 +0100
+++ mozilla-beta/ipc/chromium/src/base/message_pump_libevent.cc 2012-01-25 15:13:11.947771212 +0100
@@ -6,6 +6,9 @@
#include <errno.h>
#include <fcntl.h>
+#if defined(ANDROID) || defined(OS_POSIX)
+#include <unistd.h>
+#endif
#include "eintr_wrapper.h"
#include "base/logging.h"
diff -up mozilla-beta/ipc/chromium/src/base/file_util.cc.old mozilla-beta/ipc/chromium/src/base/file_util.cc
--- mozilla-beta/ipc/chromium/src/base/file_util.cc.old 2012-01-25 13:48:11.000000000 +0100
+++ mozilla-beta/ipc/chromium/src/base/file_util.cc 2012-01-25 13:52:25.096659244 +0100
@@ -8,7 +8,7 @@
#include <io.h>
#endif
#include <stdio.h>
-#if defined(ANDROID)
+#if defined(ANDROID) || defined(OS_POSIX)
#include <unistd.h>
#endif