Added fix for gcc47
This commit is contained in:
parent
7bace115d1
commit
8424ae658d
@ -62,6 +62,7 @@ Patch8: xulrunner-10.0-secondary-ipc.patch
|
|||||||
Patch13: xulrunner-9.0-secondary-build-fix.patch
|
Patch13: xulrunner-9.0-secondary-build-fix.patch
|
||||||
|
|
||||||
# Build patches
|
# Build patches
|
||||||
|
Patch100: xulrunner-10.0-gcc47.patch
|
||||||
|
|
||||||
# Linux specific
|
# Linux specific
|
||||||
Patch200: thunderbird-8.0-enable-addons.patch
|
Patch200: thunderbird-8.0-enable-addons.patch
|
||||||
@ -148,6 +149,9 @@ cd mozilla
|
|||||||
%patch7 -p2 -b .static
|
%patch7 -p2 -b .static
|
||||||
%patch8 -p3 -b .secondary-ipc
|
%patch8 -p3 -b .secondary-ipc
|
||||||
%patch13 -p2 -b .secondary-build
|
%patch13 -p2 -b .secondary-build
|
||||||
|
%if 0%{?fedora} >= 17
|
||||||
|
%patch100 -p1 -b .gcc47
|
||||||
|
%endif
|
||||||
cd ..
|
cd ..
|
||||||
|
|
||||||
%patch200 -p1 -b .addons
|
%patch200 -p1 -b .addons
|
||||||
|
25
xulrunner-10.0-gcc47.patch
Normal file
25
xulrunner-10.0-gcc47.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
diff -up mozilla-beta/ipc/chromium/src/base/time_posix.cc.gcc47 mozilla-beta/ipc/chromium/src/base/time_posix.cc
|
||||||
|
--- mozilla-beta/ipc/chromium/src/base/time_posix.cc.gcc47 2012-01-24 03:00:00.000000000 -0500
|
||||||
|
+++ mozilla-beta/ipc/chromium/src/base/time_posix.cc 2012-01-30 14:12:49.198472212 -0500
|
||||||
|
@@ -14,6 +14,8 @@
|
||||||
|
#include <time.h>
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+#include <unistd.h>
|
||||||
|
+
|
||||||
|
#include <limits>
|
||||||
|
|
||||||
|
#include "base/basictypes.h"
|
||||||
|
diff -up mozilla-beta/toolkit/crashreporter/client/Makefile.in.gcc47 mozilla-beta/toolkit/crashreporter/client/Makefile.in
|
||||||
|
--- mozilla-beta/toolkit/crashreporter/client/Makefile.in.gcc47 2012-01-30 14:41:14.475441039 -0500
|
||||||
|
+++ mozilla-beta/toolkit/crashreporter/client/Makefile.in 2012-01-30 14:43:03.587646656 -0500
|
||||||
|
@@ -69,6 +69,9 @@ CPPSRCS = \
|
||||||
|
$(STDCXX_COMPAT) \
|
||||||
|
$(NULL)
|
||||||
|
|
||||||
|
+# Needed for moz_free
|
||||||
|
+LIBS += -L$(LIBXUL_DIST)/lib -lmozalloc
|
||||||
|
+
|
||||||
|
ifeq ($(OS_ARCH),WINNT)
|
||||||
|
CPPSRCS += crashreporter_win.cpp
|
||||||
|
LIBS += \
|
Loading…
Reference in New Issue
Block a user