Added fix for gcc47

This commit is contained in:
Jan Horak 2012-01-31 13:37:20 +01:00
parent 7bace115d1
commit 8424ae658d
2 changed files with 29 additions and 0 deletions

View File

@ -62,6 +62,7 @@ Patch8: xulrunner-10.0-secondary-ipc.patch
Patch13: xulrunner-9.0-secondary-build-fix.patch
# Build patches
Patch100: xulrunner-10.0-gcc47.patch
# Linux specific
Patch200: thunderbird-8.0-enable-addons.patch
@ -148,6 +149,9 @@ cd mozilla
%patch7 -p2 -b .static
%patch8 -p3 -b .secondary-ipc
%patch13 -p2 -b .secondary-build
%if 0%{?fedora} >= 17
%patch100 -p1 -b .gcc47
%endif
cd ..
%patch200 -p1 -b .addons

View File

@ -0,0 +1,25 @@
diff -up mozilla-beta/ipc/chromium/src/base/time_posix.cc.gcc47 mozilla-beta/ipc/chromium/src/base/time_posix.cc
--- mozilla-beta/ipc/chromium/src/base/time_posix.cc.gcc47 2012-01-24 03:00:00.000000000 -0500
+++ mozilla-beta/ipc/chromium/src/base/time_posix.cc 2012-01-30 14:12:49.198472212 -0500
@@ -14,6 +14,8 @@
#include <time.h>
#endif
+#include <unistd.h>
+
#include <limits>
#include "base/basictypes.h"
diff -up mozilla-beta/toolkit/crashreporter/client/Makefile.in.gcc47 mozilla-beta/toolkit/crashreporter/client/Makefile.in
--- mozilla-beta/toolkit/crashreporter/client/Makefile.in.gcc47 2012-01-30 14:41:14.475441039 -0500
+++ mozilla-beta/toolkit/crashreporter/client/Makefile.in 2012-01-30 14:43:03.587646656 -0500
@@ -69,6 +69,9 @@ CPPSRCS = \
$(STDCXX_COMPAT) \
$(NULL)
+# Needed for moz_free
+LIBS += -L$(LIBXUL_DIST)/lib -lmozalloc
+
ifeq ($(OS_ARCH),WINNT)
CPPSRCS += crashreporter_win.cpp
LIBS += \