Adding missing patches
This commit is contained in:
parent
f31a5b0805
commit
823ae07c2b
24
mozilla-jemalloc.patch
Normal file
24
mozilla-jemalloc.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -r f1af606531f5 memory/jemalloc/jemalloc.h
|
||||
--- mozilla/memory/jemalloc/jemalloc.h Sat Nov 22 20:22:22 2008 +0100
|
||||
+++ mozilla/memory/jemalloc/jemalloc.h Mon Dec 01 16:53:06 2008 -0500
|
||||
@@ -45,14 +45,14 @@
|
||||
} jemalloc_stats_t;
|
||||
|
||||
#ifndef MOZ_MEMORY_DARWIN
|
||||
-void *malloc(size_t size);
|
||||
-void *valloc(size_t size);
|
||||
-void *calloc(size_t num, size_t size);
|
||||
-void *realloc(void *ptr, size_t size);
|
||||
-void free(void *ptr);
|
||||
+void *malloc(size_t size) __THROW __attribute_malloc__ __wur;
|
||||
+void *valloc(size_t size) __THROW __attribute_malloc__ __wur;
|
||||
+void *calloc(size_t num, size_t size) __THROW __attribute_malloc__ __wur;
|
||||
+void *realloc(void *ptr, size_t size) __THROW __attribute_malloc__ __wur;
|
||||
+void free(void *ptr) __THROW __attribute_malloc__ __wur;
|
||||
#endif
|
||||
|
||||
-int posix_memalign(void **memptr, size_t alignment, size_t size);
|
||||
+int posix_memalign(void **memptr, size_t alignment, size_t size) __THROW __attribute_malloc__ __wur;
|
||||
void *memalign(size_t alignment, size_t size);
|
||||
size_t malloc_usable_size(const void *ptr);
|
||||
void jemalloc_stats(jemalloc_stats_t *stats);
|
39
thunderbird-shared-error.patch
Normal file
39
thunderbird-shared-error.patch
Normal file
@ -0,0 +1,39 @@
|
||||
diff -upU8 thunderbird-3.0/mail/installer/Makefile.in.shared-error thunderbird-3.0/mail/installer/Makefile.in
|
||||
--- thunderbird-3.0/mail/installer/Makefile.in.shared-error 2009-02-24 03:16:03.000000000 +0100
|
||||
+++ thunderbird-3.0/mail/installer/Makefile.in 2009-02-27 16:02:31.000000000 +0100
|
||||
@@ -56,16 +56,17 @@ NO_PKG_FILES = \
|
||||
PalmSyncInstall.exe \
|
||||
$(NULL)
|
||||
|
||||
include $(topsrcdir)/config/rules.mk
|
||||
|
||||
MOZ_PKG_REMOVALS = $(srcdir)/removed-files.in
|
||||
|
||||
ifdef BUILD_STATIC_LIBS
|
||||
+ifeq (BUILD_STATIC_LIBS, 1)
|
||||
ifeq (WINNT,$(OS_ARCH))
|
||||
MOZ_PKG_MANIFEST_P = $(srcdir)/windows/packages-static
|
||||
endif
|
||||
else
|
||||
$(error you need a "--enable-static --disable-shared" build to create an installer)
|
||||
endif
|
||||
|
||||
MOZ_NONLOCALIZED_PKG_LIST = \
|
||||
@@ -80,16 +81,17 @@ MOZ_LOCALIZED_PKG_LIST = $(AB_CD)
|
||||
DEFINES += -DAB_CD=$(AB_CD)
|
||||
|
||||
ifdef MOZ_PKG_MANIFEST_P
|
||||
MOZ_PKG_MANIFEST = packages-static
|
||||
|
||||
$(MOZ_PKG_MANIFEST): $(MOZ_PKG_MANIFEST_P)
|
||||
$(PERL) $(MOZILLA_SRCDIR)/config/preprocessor.pl $(DEFINES) $(ACDEFINES) $< > $@
|
||||
endif
|
||||
+endif
|
||||
|
||||
ifneq (,$(filter mac cocoa,$(MOZ_WIDGET_TOOLKIT)))
|
||||
MOZ_PKG_MAC_DSSTORE=branding/dsstore
|
||||
MOZ_PKG_MAC_BACKGROUND=branding/background.png
|
||||
MOZ_PKG_MAC_ICON=branding/disk.icns
|
||||
MOZ_PKG_MAC_EXTRA=--symlink "/Applications:/ "
|
||||
endif
|
||||
|
Loading…
Reference in New Issue
Block a user