Update to 13.0

This commit is contained in:
Jan Horak 2012-06-05 13:22:22 +02:00
parent 912d6895fa
commit 48cb964e6e
8 changed files with 29 additions and 331 deletions

2
.gitignore vendored
View File

@ -45,3 +45,5 @@ thunderbird-langpacks-3.1.2-20100803.tar.bz2
/thunderbird-langpacks-12.0-20120424.tar.xz
/thunderbird-12.0.1.source.tar.bz2
/thunderbird-langpacks-12.0.1-20120430.tar.xz
/thunderbird-13.0.source.tar.bz2
/thunderbird-langpacks-13.0-20120605.tar.xz

View File

@ -1,24 +0,0 @@
# HG changeset patch
# Parent 6292e55419d1730a2e88a56fd30b2440ce0b393a
# User Raúl Porcel <armin76@gentoo.org>
Bug XXXXXX - Fix TARGET_CPU usage on ARM
diff --git a/xpcom/glue/objs.mk b/xpcom/glue/objs.mk
--- a/mozilla/xpcom/glue/objs.mk
+++ b/mozilla/xpcom/glue/objs.mk
@@ -71,13 +71,13 @@ XPCOM_GLUENS_SRC_LCPPSRCS = \
SSE.cpp \
unused.cpp \
nsProxyRelease.cpp \
nsTextFormatter.cpp \
GenericFactory.cpp \
FileUtils.cpp \
$(NULL)
-ifeq (arm,$(TARGET_CPU))
+ifneq (,$(filter arm%,$(TARGET_CPU)))
XPCOM_GLUENS_SRC_LCPPSRCS += arm.cpp
endif
XPCOM_GLUENS_SRC_CPPSRCS = $(addprefix $(topsrcdir)/xpcom/glue/,$(XPCOM_GLUENS_SRC_LCPPSRCS))

View File

@ -1,265 +0,0 @@
diff -up comm-release/mailnews/base/search/src/nsMsgSearchAdapter.cpp.733867 comm-release/mailnews/base/search/src/nsMsgSearchAdapter.cpp
--- comm-release/mailnews/base/search/src/nsMsgSearchAdapter.cpp.733867 2012-04-21 00:32:39.000000000 +0200
+++ comm-release/mailnews/base/search/src/nsMsgSearchAdapter.cpp 2012-04-25 10:51:32.343536178 +0200
@@ -688,7 +688,7 @@ nsresult nsMsgSearchAdapter::EncodeImapV
PL_strcat(encoding, "{");
lengthStr.AppendInt((PRInt32) strlen(value));
PL_strcat(encoding, lengthStr.get());
- PL_strcat(encoding, "}"CRLF);
+ PL_strcat(encoding, "}" CRLF);
PL_strcat(encoding, value);
return NS_OK;
}
diff -up comm-release/mailnews/base/src/nsMsgFolderCompactor.cpp.733867 comm-release/mailnews/base/src/nsMsgFolderCompactor.cpp
--- comm-release/mailnews/base/src/nsMsgFolderCompactor.cpp.733867 2012-04-21 00:32:39.000000000 +0200
+++ comm-release/mailnews/base/src/nsMsgFolderCompactor.cpp 2012-04-25 10:51:33.208535909 +0200
@@ -758,7 +758,7 @@ nsFolderCompactState::OnDataAvailable(ns
}
}
}
-#define EXTRA_KEYWORD_HDR " "MSG_LINEBREAK
+#define EXTRA_KEYWORD_HDR " " MSG_LINEBREAK
// if status offset isn't in the first block, this code won't work. There's no good reason
// for the status offset not to be at the beginning of the message anyway.
@@ -1216,7 +1216,7 @@ nsOfflineStoreCompactState::OnDataAvaila
// check if there's an envelope header; if not, write one.
if (strncmp(m_dataBuffer, "From ", 5))
{
- m_fileStream->Write("From "CRLF, 7, &bytesWritten);
+ m_fileStream->Write("From " CRLF, 7, &bytesWritten);
m_offlineMsgSize += bytesWritten;
}
}
diff -up comm-release/mailnews/compose/src/nsSmtpProtocol.cpp.733867 comm-release/mailnews/compose/src/nsSmtpProtocol.cpp
--- comm-release/mailnews/compose/src/nsSmtpProtocol.cpp.733867 2012-04-21 00:32:39.000000000 +0200
+++ comm-release/mailnews/compose/src/nsSmtpProtocol.cpp 2012-04-25 10:51:33.365535861 +0200
@@ -1722,7 +1722,7 @@ PRInt32 nsSmtpProtocol::SendQuit()
{
m_sendDone = true;
nsCOMPtr<nsIURI> url = do_QueryInterface(m_runningURL);
- SendData(url, "QUIT"CRLF); // send a quit command to close the connection with the server.
+ SendData(url, "QUIT" CRLF); // send a quit command to close the connection with the server.
m_nextState = SMTP_RESPONSE;
m_nextStateAfterResponse = SMTP_DONE;
return(0);
@@ -1969,7 +1969,7 @@ nsresult nsSmtpProtocol::LoadUrl(nsIURI
{
nsCOMPtr<nsIURI> url = do_QueryInterface(m_runningURL);
// send a quit command to close the connection with the server.
- if (SendData(url, "QUIT"CRLF) == NS_OK)
+ if (SendData(url, "QUIT" CRLF) == NS_OK)
{
m_nextState = SMTP_RESPONSE;
m_nextStateAfterResponse = SMTP_ERROR_DONE;
@@ -2118,4 +2118,3 @@ nsSmtpProtocol::GetUsernamePassword(nsAC
NS_ENSURE_SUCCESS(rv,rv);
return rv;
}
-
diff -up comm-release/mailnews/imap/src/nsImapMailFolder.cpp.733867 comm-release/mailnews/imap/src/nsImapMailFolder.cpp
--- comm-release/mailnews/imap/src/nsImapMailFolder.cpp.733867 2012-04-21 00:32:39.000000000 +0200
+++ comm-release/mailnews/imap/src/nsImapMailFolder.cpp 2012-04-25 10:51:33.367535861 +0200
@@ -8309,7 +8309,7 @@ nsImapMailFolder::CopyFileToOfflineStore
bool needMoreData = false;
char * newLine = nsnull;
PRUint32 numBytesInLine = 0;
- const char *envelope = "From "CRLF;
+ const char *envelope = "From " CRLF;
offlineStore->Write(envelope, strlen(envelope), &bytesWritten);
fileSize += bytesWritten;
do
diff -up comm-release/mailnews/imap/src/nsImapProtocol.cpp.733867 comm-release/mailnews/imap/src/nsImapProtocol.cpp
--- comm-release/mailnews/imap/src/nsImapProtocol.cpp.733867 2012-04-21 00:32:39.000000000 +0200
+++ comm-release/mailnews/imap/src/nsImapProtocol.cpp 2012-04-25 10:51:33.370535858 +0200
@@ -1409,7 +1409,7 @@ void nsImapProtocol::HandleIdleResponses
{
// PRInt32 oldRecent = GetServerStateParser().NumberOfRecentMessages();
nsCAutoString commandBuffer(GetServerCommandTag());
- commandBuffer.Append(" IDLE"CRLF);
+ commandBuffer.Append(" IDLE" CRLF);
do
{
@@ -3287,7 +3287,7 @@ void nsImapProtocol::FetchMsgAttribute(c
commandString.Append(messageIds);
commandString.Append(" (");
commandString.Append(attribute);
- commandString.Append(")"CRLF);
+ commandString.Append(")" CRLF);
nsresult rv = SendData(commandString.get());
if (NS_SUCCEEDED(rv))
@@ -5283,7 +5283,7 @@ nsImapProtocol::Expunge()
IncrementCommandTagNumber();
nsCAutoString command(GetServerCommandTag());
- command.Append(" expunge"CRLF);
+ command.Append(" expunge" CRLF);
nsresult rv = SendData(command.get());
if (NS_SUCCEEDED(rv))
@@ -5359,7 +5359,7 @@ void nsImapProtocol::ID()
command.Append(gAppName);
command.Append("\" \"version\" \"");
command.Append(gAppVersion);
- command.Append("\")"CRLF);
+ command.Append("\")" CRLF);
nsresult rv = SendData(command.get());
if (NS_SUCCEEDED(rv))
@@ -5816,7 +5816,7 @@ nsresult nsImapProtocol::AuthLogin(const
nsCAutoString correctedPassword;
EscapeUserNamePasswordString(password.get(), &correctedPassword);
command.Append(correctedPassword);
- command.Append("\""CRLF);
+ command.Append("\"" CRLF);
rv = SendData(command.get(), true /* suppress logging */);
NS_ENSURE_SUCCESS(rv, rv);
ParseIMAPandCheckForNewMail();
@@ -7447,7 +7447,7 @@ void nsImapProtocol::CreateMailbox(const
nsCString command(GetServerCommandTag());
command += " create \"";
command += escapedName;
- command += "\""CRLF;
+ command += "\"" CRLF;
nsresult rv = SendData(command.get());
if(NS_SUCCEEDED(rv))
@@ -7550,7 +7550,7 @@ void nsImapProtocol::Lsub(const char *ma
nsCString command (GetServerCommandTag());
command += " lsub \"\" \"";
command += escapedPattern;
- command += "\""CRLF;
+ command += "\"" CRLF;
PR_Free(boxnameWithOnlineDirectory);
@@ -7579,7 +7579,7 @@ void nsImapProtocol::List(const char *ma
command += useXLIST ?
" xlist \"\" \"" : " list \"\" \"";
command += escapedPattern;
- command += "\""CRLF;
+ command += "\"" CRLF;
PR_Free(boxnameWithOnlineDirectory);
@@ -7600,7 +7600,7 @@ void nsImapProtocol::Subscribe(const cha
nsCString command (GetServerCommandTag());
command += " subscribe \"";
command += escapedName;
- command += "\""CRLF;
+ command += "\"" CRLF;
nsresult rv = SendData(command.get());
if (NS_SUCCEEDED(rv))
@@ -7618,7 +7618,7 @@ void nsImapProtocol::Unsubscribe(const c
nsCString command (GetServerCommandTag());
command += " unsubscribe \"";
command += escapedName;
- command += "\""CRLF;
+ command += "\"" CRLF;
nsresult rv = SendData(command.get());
if (NS_SUCCEEDED(rv))
@@ -7632,7 +7632,7 @@ void nsImapProtocol::Idle()
if (m_urlInProgress)
return;
nsCAutoString command (GetServerCommandTag());
- command += " IDLE"CRLF;
+ command += " IDLE" CRLF;
nsresult rv = SendData(command.get());
if (NS_SUCCEEDED(rv))
{
@@ -7659,7 +7659,7 @@ void nsImapProtocol::EndIdle(bool waitFo
nsCOMPtr <nsIAsyncInputStream> asyncInputStream = do_QueryInterface(m_inputStream);
if (asyncInputStream)
asyncInputStream->AsyncWait(nsnull, 0, 0, nsnull);
- nsresult rv = SendData("DONE"CRLF);
+ nsresult rv = SendData("DONE" CRLF);
// set a short timeout if we don't want to wait for a response
if (m_transport && !waitForResponse)
m_transport->SetTimeout(nsISocketTransport::TIMEOUT_READ_WRITE, 5);
@@ -7728,8 +7728,8 @@ void nsImapProtocol::Copy(const char * m
PRUint32 msgsHandled = 0;
const char *formatString;
formatString = (idsAreUid)
- ? "%s uid store %s %s"CRLF
- : "%s store %s %s"CRLF;
+ ? "%s uid store %s %s" CRLF
+ : "%s store %s %s" CRLF;
do
{
diff -up comm-release/mailnews/imap/src/nsImapServerResponseParser.cpp.733867 comm-release/mailnews/imap/src/nsImapServerResponseParser.cpp
--- comm-release/mailnews/imap/src/nsImapServerResponseParser.cpp.733867 2012-04-21 00:32:39.000000000 +0200
+++ comm-release/mailnews/imap/src/nsImapServerResponseParser.cpp 2012-04-25 10:51:33.374535858 +0200
@@ -185,7 +185,7 @@ void nsImapServerResponseParser::ParseIM
NS_ASSERTION(aCurrentCommand && *aCurrentCommand != '\r' &&
*aCurrentCommand != '\n' && *aCurrentCommand != ' ', "Invailid command string");
- bool sendingIdleDone = !strcmp(aCurrentCommand, "DONE"CRLF);
+ bool sendingIdleDone = !strcmp(aCurrentCommand, "DONE" CRLF);
if (sendingIdleDone)
fWaitingForMoreClientInput = false;
diff -up comm-release/mailnews/local/src/nsPop3Protocol.cpp.733867 comm-release/mailnews/local/src/nsPop3Protocol.cpp
--- comm-release/mailnews/local/src/nsPop3Protocol.cpp.733867 2012-04-21 00:32:40.000000000 +0200
+++ comm-release/mailnews/local/src/nsPop3Protocol.cpp 2012-04-25 10:51:33.375535858 +0200
@@ -2483,7 +2483,7 @@ PRInt32 nsPop3Protocol::SendList()
return(MK_OUT_OF_MEMORY);
m_pop3ConData->next_state_after_response = POP3_GET_LIST;
m_listpos = 0;
- return SendData(m_url, "LIST"CRLF);
+ return SendData(m_url, "LIST" CRLF);
}
diff -up comm-release/mailnews/mime/src/mimedrft.cpp.733867 comm-release/mailnews/mime/src/mimedrft.cpp
--- comm-release/mailnews/mime/src/mimedrft.cpp.733867 2012-04-21 00:32:40.000000000 +0200
+++ comm-release/mailnews/mime/src/mimedrft.cpp 2012-04-25 10:51:33.376535858 +0200
@@ -1473,7 +1473,7 @@ mime_parse_stream_complete (nsMIMESessio
*newbody = 0;
PL_strcatn(newbody, newbodylen, "<PRE>");
PL_strcatn(newbody, newbodylen, body);
- PL_strcatn(newbody, newbodylen, "</PRE>"CRLF);
+ PL_strcatn(newbody, newbodylen, "</PRE>" CRLF);
PR_Free(body);
body = newbody;
}
diff -up comm-release/mailnews/mime/src/mimemult.cpp.733867 comm-release/mailnews/mime/src/mimemult.cpp
--- comm-release/mailnews/mime/src/mimemult.cpp.733867 2012-04-21 00:32:40.000000000 +0200
+++ comm-release/mailnews/mime/src/mimemult.cpp 2012-04-25 10:52:45.835512632 +0200
@@ -280,7 +280,7 @@ MimeMultipart_parse_line (const char *li
MimeWriteAString(obj, NS_LITERAL_CSTRING(MSG_LINEBREAK));
MimeWriteAString(obj, NS_LITERAL_CSTRING("Content-Disposition: attachment; filename=\""));
MimeWriteAString(obj, fileName);
- MimeWriteAString(obj, NS_LITERAL_CSTRING("\""MSG_LINEBREAK));
+ MimeWriteAString(obj, NS_LITERAL_CSTRING("\"" MSG_LINEBREAK));
MimeWriteAString(obj, NS_LITERAL_CSTRING("X-Mozilla-External-Attachment-URL: "));
MimeWriteAString(obj, obj->options->state->detachedFilePath);
MimeWriteAString(obj, NS_LITERAL_CSTRING(MSG_LINEBREAK));
@@ -293,10 +293,10 @@ MimeMultipart_parse_line (const char *li
status = MimeWriteAString(obj, header);
if (status < 0)
return status;
- status = MimeWriteAString(obj, NS_LITERAL_CSTRING("\""MSG_LINEBREAK"Content-Transfer-Encoding: 8bit"MSG_LINEBREAK));
+ status = MimeWriteAString(obj, NS_LITERAL_CSTRING("\"" MSG_LINEBREAK "Content-Transfer-Encoding: 8bit" MSG_LINEBREAK));
MimeWriteAString(obj, NS_LITERAL_CSTRING("Content-Disposition: inline; filename=\"Deleted: "));
MimeWriteAString(obj, fileName);
- MimeWriteAString(obj, NS_LITERAL_CSTRING("\""MSG_LINEBREAK"X-Mozilla-Altered: AttachmentDeleted; date=\""));
+ MimeWriteAString(obj, NS_LITERAL_CSTRING("\"" MSG_LINEBREAK "X-Mozilla-Altered: AttachmentDeleted; date=\""));
}
nsCString result;
char timeBuffer[128];
@@ -306,8 +306,8 @@ MimeMultipart_parse_line (const char *li
"%a %b %d %H:%M:%S %Y",
&now);
MimeWriteAString(obj, nsDependentCString(timeBuffer));
- MimeWriteAString(obj, NS_LITERAL_CSTRING("\""MSG_LINEBREAK));
- MimeWriteAString(obj, NS_LITERAL_CSTRING(MSG_LINEBREAK"You deleted an attachment from this message. The original MIME headers for the attachment were:"MSG_LINEBREAK));
+ MimeWriteAString(obj, NS_LITERAL_CSTRING("\"" MSG_LINEBREAK));
+ MimeWriteAString(obj, NS_LITERAL_CSTRING(MSG_LINEBREAK "You deleted an attachment from this message. The original MIME headers for the attachment were:" MSG_LINEBREAK));
MimeHeaders_write_raw_headers(mult->hdrs, obj->options, false);
}
PRInt32 old_nchildren = container->nchildren;

View File

@ -1,26 +0,0 @@
diff -up mozilla-beta/ipc/chromium/src/base/file_util_linux.cc.file mozilla-beta/ipc/chromium/src/base/file_util_linux.cc
--- mozilla-beta/ipc/chromium/src/base/file_util_linux.cc.file 2012-01-24 09:00:00.000000000 +0100
+++ mozilla-beta/ipc/chromium/src/base/file_util_linux.cc 2012-01-25 15:30:43.707796295 +0100
@@ -5,6 +5,9 @@
#include "base/file_util.h"
#include <fcntl.h>
+#if defined(ANDROID) || defined(OS_POSIX)
+#include <unistd.h>
+#endif
#include <string>
#include <vector>
diff -up mozilla-beta/ipc/chromium/src/base/message_pump_libevent.cc.file mozilla-beta/ipc/chromium/src/base/message_pump_libevent.cc
--- mozilla-beta/ipc/chromium/src/base/message_pump_libevent.cc.file 2012-01-24 09:00:00.000000000 +0100
+++ mozilla-beta/ipc/chromium/src/base/message_pump_libevent.cc 2012-01-25 15:13:11.947771212 +0100
@@ -6,6 +6,9 @@
#include <errno.h>
#include <fcntl.h>
+#if defined(ANDROID) || defined(OS_POSIX)
+#include <unistd.h>
+#endif
#include "eintr_wrapper.h"
#include "base/logging.h"

View File

@ -1,2 +1,2 @@
64cacde4cb2b1e8736f1c3a0ea6a02db thunderbird-12.0.1.source.tar.bz2
ba8beb1d1d2902a7d2fea6cc3f39ebfe thunderbird-langpacks-12.0.1-20120430.tar.xz
0134c67c30e8598f2a64ea004d5bc4bc thunderbird-13.0.source.tar.bz2
e1961f65a693da079387a385c869d144 thunderbird-langpacks-13.0-20120605.tar.xz

View File

@ -1,6 +1,6 @@
mk_add_options MOZ_CO_PROJECT=mail
ac_add_options --enable-application=mail
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/objdir
mk_add_options AUTOCONF=autoconf-2.13
#ac_add_options --with-system-png

View File

@ -38,14 +38,14 @@
Summary: Mozilla Thunderbird mail/newsgroup client
Name: thunderbird
Version: 12.0.1
Release: 2%{?dist}
Version: 13.0
Release: 1%{?dist}
URL: http://www.mozilla.org/projects/thunderbird/
License: MPLv1.1 or GPLv2+ or LGPLv2+
Group: Applications/Internet
Source0: ftp://ftp.mozilla.org/pub/thunderbird/releases/%{version}%{?pre_version}/source/thunderbird-%{version}%{?pre_version}.source.tar.bz2
%if %{build_langpacks}
Source1: thunderbird-langpacks-%{version}-20120430.tar.xz
Source1: thunderbird-langpacks-%{version}-20120605.tar.xz
%endif
Source10: thunderbird-mozconfig
Source11: thunderbird-mozconfig-branded
@ -61,14 +61,12 @@ Patch7: crashreporter-remove-static.patch
Patch8: xulrunner-10.0-secondary-ipc.patch
# Build patches
Patch102: mozilla-733867-x.patch
Patch103: mozilla-file.patch
Patch104: xulrunner-10.0-gcc47.patch
Patch105: xulrunner-prtime.patch
# Linux specific
Patch200: thunderbird-8.0-enable-addons.patch
# ARM Specific
Patch210: mozilla-724615.patch
%if %{official_branding}
# Required by Mozilla Corporation
@ -152,13 +150,11 @@ cd %{tarballdir}
cd mozilla
%patch7 -p2 -b .static
%patch8 -p3 -b .secondary-ipc
%patch103 -p1 -b .mozilla-file
%patch104 -p1 -b .gcc47
%patch105 -p1 -b .prtime
cd ..
%patch102 -p1 -b .733867
%patch200 -p1 -b .addons
%patch210 -p1 -b .724615
%if %{official_branding}
# Required by Mozilla Corporation
@ -238,16 +234,18 @@ make -f client.mk build STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
# create debuginfo for crash-stats.mozilla.com
%if %{enable_mozilla_crashreporter}
make buildsymbols
make -C objdir buildsymbols
%endif
#===============================================================================
%install
cd %{tarballdir}
cd %{tarballdir}/objdir
DESTDIR=$RPM_BUILD_ROOT make install
cd ..
# install icons
for s in 16 22 24 32 48 256; do
%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/${s}x${s}/apps
@ -316,7 +314,7 @@ touch $RPM_BUILD_ROOT%{mozappdir}/components/xpti.dat
# Add debuginfo for crash-stats.mozilla.com
%if %{enable_mozilla_crashreporter}
%{__mkdir_p} $RPM_BUILD_ROOT/%{moz_debug_dir}
%{__cp} mozilla/dist/%{symbols_file_name} $RPM_BUILD_ROOT/%{moz_debug_dir}
%{__cp} objdir/mozilla/dist/%{symbols_file_name} $RPM_BUILD_ROOT/%{moz_debug_dir}
%endif
#===============================================================================
@ -391,6 +389,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
#===============================================================================
%changelog
* Tue Jun 5 2012 Jan Horak <jhorak@redhat.com> - 13.0-1
- Update to 13.0
* Mon May 7 2012 Martin Stransky <stransky@redhat.com> - 12.0.1-2
- Fixed #717245 - adhere Static Library Packaging Guidelines

10
xulrunner-prtime.patch Normal file
View File

@ -0,0 +1,10 @@
diff -up mozilla-release/hal/sandbox/PHal.ipdl.old mozilla-release/hal/sandbox/PHal.ipdl
--- mozilla-release/hal/sandbox/PHal.ipdl.old 2012-06-01 14:04:00.000000000 +0200
+++ mozilla-release/hal/sandbox/PHal.ipdl 2012-06-05 09:15:02.524408100 +0200
@@ -39,7 +39,7 @@
include protocol PContent;
include protocol PBrowser;
-include "nspr/prtime.h";
+include "prtime.h";
include "mozilla/HalSensor.h";
include "mozilla/HalTypes.h";