Merge branch 'master' into f15

This commit is contained in:
Jan Horak 2011-09-27 21:44:59 +02:00
commit 39644fdd9a
5 changed files with 59 additions and 31 deletions

2
.gitignore vendored
View File

@ -24,3 +24,5 @@ thunderbird-langpacks-3.1.2-20100803.tar.bz2
/thunderbird-langpacks-6.0-20110816.tar.xz /thunderbird-langpacks-6.0-20110816.tar.xz
/thunderbird-6.0.2.source.tar.bz2 /thunderbird-6.0.2.source.tar.bz2
/thunderbird-langpacks-6.0.2-20110906.tar.xz /thunderbird-langpacks-6.0.2-20110906.tar.xz
/thunderbird-7.0.source.tar.bz2
/thunderbird-langpacks-7.0-20110927.tar.xz

View File

@ -1,2 +1,2 @@
917a667fe21cfd103092dbc23a112192 thunderbird-6.0.2.source.tar.bz2 6a4b2dbdc2324f52c019a3a8dee6dad4 thunderbird-7.0.source.tar.bz2
b33f0aef987a8e10ff6ab3a22d0a3865 thunderbird-langpacks-6.0.2-20110906.tar.xz a7005466350abeebea533b2589e58955 thunderbird-langpacks-7.0-20110927.tar.xz

View File

@ -0,0 +1,36 @@
diff -up thunderbird-7.0/comm-beta/config/autoconf.mk.in.old thunderbird-7.0/comm-beta/config/autoconf.mk.in
--- thunderbird-7.0/comm-beta/config/autoconf.mk.in.old 2011-09-05 12:24:29.000000000 +0200
+++ thunderbird-7.0/comm-beta/config/autoconf.mk.in 2011-09-12 12:21:09.304918326 +0200
@@ -65,7 +65,7 @@ datadir = @datadir@
mandir = @mandir@
idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
+installdir = $(libdir)/$(MOZ_APP_NAME)
sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
MOZDEPTH = $(DEPTH)/mozilla
diff -up thunderbird-7.0/comm-beta/mozilla/config/autoconf.mk.in.old thunderbird-7.0/comm-beta/mozilla/config/autoconf.mk.in
--- thunderbird-7.0/comm-beta/mozilla/config/autoconf.mk.in.old 2011-09-05 12:38:22.000000000 +0200
+++ thunderbird-7.0/comm-beta/mozilla/config/autoconf.mk.in 2011-09-12 12:21:24.192991555 +0200
@@ -68,7 +68,7 @@ datadir = @datadir@
mandir = @mandir@
idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
+installdir = $(libdir)/$(MOZ_APP_NAME)
sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
DIST = $(DEPTH)/dist
diff -up thunderbird-7.0/comm-beta/mozilla/js/src/config/autoconf.mk.in.old thunderbird-7.0/comm-beta/mozilla/js/src/config/autoconf.mk.in
--- thunderbird-7.0/comm-beta/mozilla/js/src/config/autoconf.mk.in.old 2011-09-05 12:38:30.000000000 +0200
+++ thunderbird-7.0/comm-beta/mozilla/js/src/config/autoconf.mk.in 2011-09-12 12:21:37.409056596 +0200
@@ -61,7 +61,7 @@ libdir = @libdir@
datadir = @datadir@
mandir = @mandir@
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
+installdir = $(libdir)/$(MOZ_APP_NAME)
sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
TOP_DIST = @TOP_DIST@

View File

@ -19,18 +19,18 @@ case $MOZ_ARCH in
;; ;;
esac esac
if [ ! -x $MOZ_LIB_DIR/thunderbird-TBIRD_VERSION/thunderbird ]; then if [ ! -x $MOZ_LIB_DIR/thunderbird/thunderbird ]; then
if [ ! -x $SECONDARY_LIB_DIR/thunderbird-TBIRD_VERSION/thunderbird ]; then if [ ! -x $SECONDARY_LIB_DIR/thunderbird/thunderbird ]; then
echo "Error: $MOZ_LIB_DIR/thunderbird-TBIRD_VERSION/thunderbird not found" echo "Error: $MOZ_LIB_DIR/thunderbird/thunderbird not found"
if [ -d $SECONDARY_LIB_DIR ]; then if [ -d $SECONDARY_LIB_DIR ]; then
echo " $SECONDARY_LIB_DIR/thunderbird-TBIRD_VERSION/thunderbird not found" echo " $SECONDARY_LIB_DIR/thunderbird/thunderbird not found"
fi fi
exit 1 exit 1
fi fi
MOZ_LIB_DIR="$SECONDARY_LIB_DIR" MOZ_LIB_DIR="$SECONDARY_LIB_DIR"
fi fi
MOZ_DIST_BIN="$MOZ_LIB_DIR/thunderbird-TBIRD_VERSION" MOZ_DIST_BIN="$MOZ_LIB_DIR/thunderbird"
MOZ_PROGRAM="$MOZ_DIST_BIN/thunderbird" MOZ_PROGRAM="$MOZ_DIST_BIN/thunderbird"
MOZ_LANGPACKS_DIR="$MOZ_DIST_BIN/langpacks" MOZ_LANGPACKS_DIR="$MOZ_DIST_BIN/langpacks"
MOZ_EXTENSIONS_PROFILE_DIR="$HOME/.mozilla/extensions/{3550f703-e582-4d05-9a08-453d09bdfdc6}" MOZ_EXTENSIONS_PROFILE_DIR="$HOME/.mozilla/extensions/{3550f703-e582-4d05-9a08-453d09bdfdc6}"

View File

@ -12,7 +12,6 @@
# #
# IMPORTANT: If there is no top level directory, this should be # IMPORTANT: If there is no top level directory, this should be
# set to the cwd, ie: '.' # set to the cwd, ie: '.'
#%define tarballdir .
%define tarballdir comm-release %define tarballdir comm-release
%define official_branding 1 %define official_branding 1
@ -30,12 +29,11 @@
%define enable_mozilla_crashreporter 0 %define enable_mozilla_crashreporter 0
%endif %endif
%define version_internal 6.0 %define mozappdir %{_libdir}/%{name}
%define mozappdir %{_libdir}/%{name}-%{version_internal}
Summary: Mozilla Thunderbird mail/newsgroup client Summary: Mozilla Thunderbird mail/newsgroup client
Name: thunderbird Name: thunderbird
Version: 6.0.2 Version: 7.0
Release: 1%{?dist} Release: 1%{?dist}
URL: http://www.mozilla.org/projects/thunderbird/ URL: http://www.mozilla.org/projects/thunderbird/
License: MPLv1.1 or GPLv2+ or LGPLv2+ License: MPLv1.1 or GPLv2+ or LGPLv2+
@ -47,7 +45,7 @@ Group: Applications/Internet
%endif %endif
Source0: %{tarball} Source0: %{tarball}
%if %{build_langpacks} %if %{build_langpacks}
Source1: thunderbird-langpacks-%{version}-20110906.tar.xz Source1: thunderbird-langpacks-%{version}-20110927.tar.xz
%endif %endif
Source10: thunderbird-mozconfig Source10: thunderbird-mozconfig
Source11: thunderbird-mozconfig-branded Source11: thunderbird-mozconfig-branded
@ -58,7 +56,7 @@ Source21: thunderbird.sh.in
Source100: find-external-requires Source100: find-external-requires
# Mozilla (XULRunner) patches # Mozilla (XULRunner) patches
Patch0: thunderbird-version.patch Patch0: thunderbird-install-dir.patch
Patch7: crashreporter-remove-static.patch Patch7: crashreporter-remove-static.patch
Patch8: xulrunner-6.0-secondary-ipc.patch Patch8: xulrunner-6.0-secondary-ipc.patch
@ -134,10 +132,7 @@ debug %{name}, you want to install %{name}-debuginfo instead.
%setup -q -c %setup -q -c
cd %{tarballdir} cd %{tarballdir}
sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \ %patch0 -p2 -b .dir
> version.patch
%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
# Mozilla (XULRunner) patches # Mozilla (XULRunner) patches
cd mozilla cd mozilla
%patch7 -p2 -b .static %patch7 -p2 -b .static
@ -148,7 +143,7 @@ cd ..
# Required by Mozilla Corporation # Required by Mozilla Corporation
%else %else
# Not yet approved by Mozillla Corporation # Not yet approved by Mozilla Corporation
%endif %endif
@ -166,9 +161,6 @@ cd ..
%build %build
cd %{tarballdir} cd %{tarballdir}
INTERNAL_GECKO=%{version_internal}
MOZ_APP_DIR=%{mozappdir}
# -fpermissive is needed to build with gcc 4.6+ which has become stricter # -fpermissive is needed to build with gcc 4.6+ which has become stricter
# #
# Mozilla builds with -Wall with exception of a few warnings which show up # Mozilla builds with -Wall with exception of a few warnings which show up
@ -205,11 +197,6 @@ make buildsymbols
%install %install
cd %{tarballdir} cd %{tarballdir}
INTERNAL_GECKO=%{version_internal}
INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
DESTDIR=$RPM_BUILD_ROOT make install DESTDIR=$RPM_BUILD_ROOT make install
# install icons # install icons
@ -227,8 +214,7 @@ desktop-file-install --vendor mozilla \
# set up the thunderbird start script # set up the thunderbird start script
rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
%{__cat} %{SOURCE21} | %{__sed} -e 's,TBIRD_VERSION,%{version_internal},g' > \ %{__cat} %{SOURCE21} > $RPM_BUILD_ROOT%{_bindir}/thunderbird
$RPM_BUILD_ROOT%{_bindir}/thunderbird
%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird %{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
# set up our default preferences # set up our default preferences
@ -342,19 +328,23 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png %{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png %{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png %{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
%{mozappdir}/hyphenation
%if %{enable_mozilla_crashreporter} %if %{enable_mozilla_crashreporter}
%{mozappdir}/crashreporter %{mozappdir}/crashreporter
%{mozappdir}/crashreporter.ini %{mozappdir}/crashreporter.ini
%{mozappdir}/Throbber-small.gif %{mozappdir}/Throbber-small.gif
%endif %endif
%exclude %{_datadir}/idl/%{name}-%{version_internal} %exclude %{_datadir}/idl/%{name}-%{version}
%exclude %{_includedir}/%{name}-%{version_internal} %exclude %{_includedir}/%{name}-%{version}
%exclude %{_libdir}/%{name}-devel-%{version_internal} %exclude %{_libdir}/%{name}-devel-%{version}
%{mozappdir}/chrome.manifest %{mozappdir}/chrome.manifest
#=============================================================================== #===============================================================================
%changelog %changelog
* Tue Sep 27 2011 Jan Horak <jhorak@redhat.com> - 7.0-1
- Update to 7.0
* Tue Sep 6 2011 Jan Horak <jhorak@redhat.com> - 6.0.2-1 * Tue Sep 6 2011 Jan Horak <jhorak@redhat.com> - 6.0.2-1
- Update to 6.0.2 - Update to 6.0.2