Update to 6.0
This commit is contained in:
parent
1ad8b8a434
commit
203d662932
2
.gitignore
vendored
2
.gitignore
vendored
@ -20,3 +20,5 @@ thunderbird-langpacks-3.1.2-20100803.tar.bz2
|
|||||||
/thunderbird-langpacks-3.1.11-20110621.tar.xz
|
/thunderbird-langpacks-3.1.11-20110621.tar.xz
|
||||||
/thunderbird-langpacks-5.0-20110628.tar.xz
|
/thunderbird-langpacks-5.0-20110628.tar.xz
|
||||||
/thunderbird-5.0.source.tar.bz2
|
/thunderbird-5.0.source.tar.bz2
|
||||||
|
/thunderbird-6.0.source.tar.bz2
|
||||||
|
/thunderbird-langpacks-6.0-20110816.tar.xz
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
dcc92e621124ea15dc8f6474ee1f357d thunderbird-langpacks-5.0-20110628.tar.xz
|
9ac741d238e95790cdeb5222e9b23ae8 thunderbird-6.0.source.tar.bz2
|
||||||
0bbacea54b4b8fc4ff20e73b3278c1ba thunderbird-5.0.source.tar.bz2
|
d245c7967fdeb839ee5fd48e7bafaf80 thunderbird-langpacks-6.0-20110816.tar.xz
|
||||||
|
@ -101,8 +101,8 @@ if [ $MOZILLA_DOWN -ne 0 ]; then
|
|||||||
|
|
||||||
function create_langpack_link() {
|
function create_langpack_link() {
|
||||||
local language=$*
|
local language=$*
|
||||||
local langpack=langpack-${language}@thunderbird.mozilla.org
|
local langpack=langpack-${language}@thunderbird.mozilla.org.xpi
|
||||||
if [ -f $MOZ_LANGPACKS_DIR/$langpack/chrome.manifest ]; then
|
if [ -f $MOZ_LANGPACKS_DIR/$langpack ]; then
|
||||||
rm -rf $MOZ_EXTENSIONS_PROFILE_DIR/$langpack
|
rm -rf $MOZ_EXTENSIONS_PROFILE_DIR/$langpack
|
||||||
ln -s $MOZ_LANGPACKS_DIR/$langpack \
|
ln -s $MOZ_LANGPACKS_DIR/$langpack \
|
||||||
$MOZ_EXTENSIONS_PROFILE_DIR/$langpack
|
$MOZ_EXTENSIONS_PROFILE_DIR/$langpack
|
||||||
|
@ -13,7 +13,7 @@
|
|||||||
# IMPORTANT: If there is no top level directory, this should be
|
# IMPORTANT: If there is no top level directory, this should be
|
||||||
# set to the cwd, ie: '.'
|
# set to the cwd, ie: '.'
|
||||||
#%define tarballdir .
|
#%define tarballdir .
|
||||||
%define tarballdir comm-miramar
|
%define tarballdir comm-release
|
||||||
|
|
||||||
%define official_branding 1
|
%define official_branding 1
|
||||||
# enable crash reporter only for iX86
|
# enable crash reporter only for iX86
|
||||||
@ -35,8 +35,8 @@
|
|||||||
|
|
||||||
Summary: Mozilla Thunderbird mail/newsgroup client
|
Summary: Mozilla Thunderbird mail/newsgroup client
|
||||||
Name: thunderbird
|
Name: thunderbird
|
||||||
Version: 5.0
|
Version: 6.0
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
URL: http://www.mozilla.org/projects/thunderbird/
|
URL: http://www.mozilla.org/projects/thunderbird/
|
||||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
@ -47,7 +47,7 @@ Group: Applications/Internet
|
|||||||
%endif
|
%endif
|
||||||
Source0: %{tarball}
|
Source0: %{tarball}
|
||||||
%if %{build_langpacks}
|
%if %{build_langpacks}
|
||||||
Source1: thunderbird-langpacks-%{version}-20110628.tar.xz
|
Source1: thunderbird-langpacks-%{version}-20110816.tar.xz
|
||||||
%endif
|
%endif
|
||||||
Source10: thunderbird-mozconfig
|
Source10: thunderbird-mozconfig
|
||||||
Source11: thunderbird-mozconfig-branded
|
Source11: thunderbird-mozconfig-branded
|
||||||
@ -60,9 +60,6 @@ Source100: find-external-requires
|
|||||||
# Mozilla (XULRunner) patches
|
# Mozilla (XULRunner) patches
|
||||||
Patch0: thunderbird-version.patch
|
Patch0: thunderbird-version.patch
|
||||||
Patch7: crashreporter-remove-static.patch
|
Patch7: crashreporter-remove-static.patch
|
||||||
# secondary arch patches inherited from xulrunner
|
|
||||||
Patch8: xulrunner-2.0-secondary-jit.patch
|
|
||||||
Patch9: xulrunner-5.0-secondary-ipc.patch
|
|
||||||
|
|
||||||
%if %{official_branding}
|
%if %{official_branding}
|
||||||
# Required by Mozilla Corporation
|
# Required by Mozilla Corporation
|
||||||
@ -143,8 +140,6 @@ sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
|
|||||||
# Mozilla (XULRunner) patches
|
# Mozilla (XULRunner) patches
|
||||||
cd mozilla
|
cd mozilla
|
||||||
%patch7 -p2 -b .static
|
%patch7 -p2 -b .static
|
||||||
%patch8 -p2 -b .secondary-jit
|
|
||||||
%patch9 -p2 -b .secondary-ipc
|
|
||||||
cd ..
|
cd ..
|
||||||
|
|
||||||
%if %{official_branding}
|
%if %{official_branding}
|
||||||
@ -258,14 +253,11 @@ touch %{name}.lang
|
|||||||
%{__tar} xf %{SOURCE1}
|
%{__tar} xf %{SOURCE1}
|
||||||
for langpack in `ls thunderbird-langpacks/*.xpi`; do
|
for langpack in `ls thunderbird-langpacks/*.xpi`; do
|
||||||
language=`basename $langpack .xpi`
|
language=`basename $langpack .xpi`
|
||||||
extensiondir=$RPM_BUILD_ROOT%{mozappdir}/langpacks/langpack-$language@thunderbird.mozilla.org
|
extensionID=langpack-$language@thunderbird.mozilla.org
|
||||||
%{__mkdir_p} $extensiondir
|
|
||||||
unzip $langpack -d $extensiondir
|
|
||||||
find $extensiondir -type f | xargs chmod 644
|
|
||||||
|
|
||||||
language=`echo $language | sed -e 's/-/_/g'`
|
language=`echo $language | sed -e 's/-/_/g'`
|
||||||
extensiondir=`echo $extensiondir | sed -e "s,^$RPM_BUILD_ROOT,,"`
|
%{__install} -m 644 ${langpack} $RPM_BUILD_ROOT%{mozappdir}/langpacks/${extensionID}.xpi
|
||||||
echo "%%lang($language) $extensiondir" >> %{name}.lang
|
echo "%%lang($language) %{mozappdir}/langpacks/${extensionID}.xpi" >> %{name}.lang
|
||||||
done
|
done
|
||||||
%{__rm} -rf thunderbird-langpacks
|
%{__rm} -rf thunderbird-langpacks
|
||||||
%endif # build_langpacks
|
%endif # build_langpacks
|
||||||
@ -361,6 +353,12 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
#===============================================================================
|
#===============================================================================
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Aug 16 2011 Jan Horak <jhorak@redhat.com> - 6.0-1
|
||||||
|
- Update to 6.0
|
||||||
|
|
||||||
|
* Sun Aug 16 2011 Remi Collet <remi@fedoraproject.org> 5.0-4
|
||||||
|
- Don't unzip the langpacks
|
||||||
|
|
||||||
* Mon Aug 15 2011 Jan Horak <jhorak@redhat.com> - 5.0-3
|
* Mon Aug 15 2011 Jan Horak <jhorak@redhat.com> - 5.0-3
|
||||||
- Rebuild due to rhbz#728707
|
- Rebuild due to rhbz#728707
|
||||||
|
|
||||||
|
@ -1,14 +0,0 @@
|
|||||||
https://bugzilla.mozilla.org/show_bug.cgi?id=627668
|
|
||||||
|
|
||||||
diff -up xulrunner-2.0/mozilla/js/src/Makefile.in.big-endian-jit xulrunner-2.0/mozilla/js/src/Makefile.in
|
|
||||||
--- xulrunner-2.0/mozilla/js/src/Makefile.in.big-endian-jit 2010-11-04 21:05:48.000000000 +0100
|
|
||||||
+++ xulrunner-2.0/mozilla/js/src/Makefile.in 2010-11-15 14:17:39.000000000 +0100
|
|
||||||
@@ -371,7 +371,7 @@ CPPSRCS += checks.cc \
|
|
||||||
# END enclude sources for V8 dtoa
|
|
||||||
#############################################
|
|
||||||
|
|
||||||
-ifeq (,$(filter-out powerpc sparc,$(TARGET_CPU)))
|
|
||||||
+ifeq (,$(filter-out powerpc powerpc64 sparc sparc64 s390 s390x,$(TARGET_CPU)))
|
|
||||||
|
|
||||||
VPATH += $(srcdir)/assembler \
|
|
||||||
$(srcdir)/assembler/wtf \
|
|
@ -1,63 +0,0 @@
|
|||||||
Bug 668460 - Adds IPC build config for s390(x) and powerpc(64)
|
|
||||||
|
|
||||||
diff -up xulrunner-5.0/mozilla/ipc/chromium/src/base/data_pack.cc.secondary-ipc xulrunner-5.0/mozilla/ipc/chromium/src/base/data_pack.cc
|
|
||||||
--- xulrunner-5.0/mozilla/ipc/chromium/src/base/data_pack.cc.secondary-ipc 2011-06-15 23:57:27.000000000 +0200
|
|
||||||
+++ xulrunner-5.0/mozilla/ipc/chromium/src/base/data_pack.cc 2011-06-30 09:08:26.777844341 +0200
|
|
||||||
@@ -91,14 +91,7 @@ bool DataPack::Load(const FilePath& path
|
|
||||||
bool DataPack::Get(uint32_t resource_id, StringPiece* data) {
|
|
||||||
// It won't be hard to make this endian-agnostic, but it's not worth
|
|
||||||
// bothering to do right now.
|
|
||||||
-#if defined(__BYTE_ORDER)
|
|
||||||
- // Linux check
|
|
||||||
- COMPILE_ASSERT(__BYTE_ORDER == __LITTLE_ENDIAN,
|
|
||||||
- datapack_assumes_little_endian);
|
|
||||||
-#elif defined(__BIG_ENDIAN__)
|
|
||||||
- // Mac check
|
|
||||||
- #error DataPack assumes little endian
|
|
||||||
-#endif
|
|
||||||
+#warning DoTheRightThingMakingThisEndianAgnostic!
|
|
||||||
|
|
||||||
DataPackEntry* target = reinterpret_cast<DataPackEntry*>(
|
|
||||||
bsearch(&resource_id, mmap_->data() + kHeaderLength, resource_count_,
|
|
||||||
diff -up xulrunner-5.0/mozilla/ipc/chromium/src/build/build_config.h.secondary-ipc xulrunner-5.0/mozilla/ipc/chromium/src/build/build_config.h
|
|
||||||
--- xulrunner-5.0/mozilla/ipc/chromium/src/build/build_config.h.secondary-ipc 2011-06-15 23:57:27.000000000 +0200
|
|
||||||
+++ xulrunner-5.0/mozilla/ipc/chromium/src/build/build_config.h 2011-06-30 09:08:26.777844341 +0200
|
|
||||||
@@ -57,9 +57,24 @@
|
|
||||||
#define ARCH_CPU_ARMEL 1
|
|
||||||
#define ARCH_CPU_32_BITS 1
|
|
||||||
#define WCHAR_T_IS_UNSIGNED 1
|
|
||||||
-#elif defined(__ppc__)
|
|
||||||
+#elif defined(__powerpc64__)
|
|
||||||
+#define ARCH_CPU_PPC64 1
|
|
||||||
+#define ARCH_CPU_64_BITS 1
|
|
||||||
+#elif defined(__powerpc__)
|
|
||||||
#define ARCH_CPU_PPC 1
|
|
||||||
#define ARCH_CPU_32_BITS 1
|
|
||||||
+#elif defined(__s390x__)
|
|
||||||
+#define ARCH_CPU_S390X 1
|
|
||||||
+#define ARCH_CPU_64_BITS 1
|
|
||||||
+#elif defined(__s390__)
|
|
||||||
+#define ARCH_CPU_S390 1
|
|
||||||
+#define ARCH_CPU_32_BITS 1
|
|
||||||
+#elif defined(__sparc__) && !defined(__arch64)
|
|
||||||
+#define ARCH_CPU_SPARC 1
|
|
||||||
+#define ARCH_CPU_32_BITS 1
|
|
||||||
+#elif defined(__sparc__) && defined(__arch64)
|
|
||||||
+#define ARCH_CPU_SPARC64 1
|
|
||||||
+#define ARCH_CPU_64_BITS 1
|
|
||||||
#else
|
|
||||||
#error Please add support for your architecture in build/build_config.h
|
|
||||||
#endif
|
|
||||||
diff -up xulrunner-5.0/mozilla/ipc/chromium/src/chrome/common/ipc_message_utils.h.secondary-ipc xulrunner-5.0/mozilla/ipc/chromium/src/chrome/common/ipc_message_utils.h
|
|
||||||
--- xulrunner-5.0/mozilla/ipc/chromium/src/chrome/common/ipc_message_utils.h.secondary-ipc 2011-06-15 23:57:27.000000000 +0200
|
|
||||||
+++ xulrunner-5.0/mozilla/ipc/chromium/src/chrome/common/ipc_message_utils.h 2011-06-30 09:47:16.629029528 +0200
|
|
||||||
@@ -219,7 +219,8 @@ struct ParamTraits<unsigned long> {
|
|
||||||
}
|
|
||||||
};
|
|
||||||
|
|
||||||
-#if !(defined(OS_MACOSX) || defined(OS_WIN) || (defined(CHROMIUM_MOZILLA_BUILD) && defined(OS_LINUX) && defined(ARCH_CPU_64_BITS)))
|
|
||||||
+// Although s390 is a 32-bit system it defines size_t as unsigned long
|
|
||||||
+#if !(defined(OS_MACOSX) || defined(OS_WIN) || (defined(CHROMIUM_MOZILLA_BUILD) && defined(OS_LINUX) && (defined(ARCH_CPU_64_BITS) || defined(ARCH_CPU_S390))))
|
|
||||||
// There size_t is a synonym for |unsigned long| ...
|
|
||||||
template <>
|
|
||||||
struct ParamTraits<size_t> {
|
|
Loading…
Reference in New Issue
Block a user