Update to 52.4.0
This commit is contained in:
parent
f986115b20
commit
1f55323196
3
.gitignore
vendored
3
.gitignore
vendored
@ -185,3 +185,6 @@ thunderbird-langpacks-3.1.2-20100803.tar.bz2
|
||||
/thunderbird-52.3.0.source.tar.xz
|
||||
/thunderbird-langpacks-52.3.0-20170821.tar.xz
|
||||
/l10n-lightning-52.3.0.tar.xz
|
||||
/thunderbird-52.4.0.source.tar.xz
|
||||
/thunderbird-langpacks-52.4.0-20171003.tar.xz
|
||||
/l10n-lightning-52.4.0.tar.xz
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up thunderbird-52.3.0/mozilla/media/libstagefright/binding/mp4parse_capi/Cargo.toml.toml-fix thunderbird-52.3.0/mozilla/media/libstagefright/binding/mp4parse_capi/Cargo.toml
|
||||
--- thunderbird-52.3.0/mozilla/media/libstagefright/binding/mp4parse_capi/Cargo.toml.toml-fix 2017-08-21 10:51:01.408785691 +0200
|
||||
+++ thunderbird-52.3.0/mozilla/media/libstagefright/binding/mp4parse_capi/Cargo.toml 2017-08-21 10:51:05.904787854 +0200
|
||||
@@ -20,8 +20,6 @@ exclude = [
|
||||
|
||||
build = false
|
||||
|
||||
-build = false
|
||||
-
|
||||
[dependencies]
|
||||
"mp4parse" = {version = "0.6.0", path = "../mp4parse"}
|
||||
|
@ -9,7 +9,7 @@ tbver=`rpmspec -P thunderbird.spec |awk '/^Version:/ { print $2; exit }'`
|
||||
tag=THUNDERBIRD_${tbver//./_}_RELEASE
|
||||
branch=`rpmspec -P thunderbird.spec | awk '/^%define *tarballdir/ { print $3; exit }'`
|
||||
#locales=$PWD/thunderbird-${tbver}/${branch}/calendar/locales/shipped-locales
|
||||
locales=$PWD/thunderbird-${tbver}/thunderbird-${tbver}/calendar/locales/shipped-locales
|
||||
locales=$PWD/thunderbird-${tbver}/calendar/locales/shipped-locales
|
||||
#locales=$PWD/shipped-locales
|
||||
if [ ! -f $locales ]
|
||||
then
|
||||
@ -42,7 +42,7 @@ rm -rf l10n-merged
|
||||
cp -R l10n l10n-merged
|
||||
for lang in $(<$locales)
|
||||
do
|
||||
compare-locales --merge l10n-merged/$lang $PWD/thunderbird-${tbver}/thunderbird-${tbver}/calendar/locales/l10n.ini l10n $lang
|
||||
compare-locales --merge l10n-merged/$lang $PWD/thunderbird-${tbver}/calendar/locales/l10n.ini l10n $lang
|
||||
done
|
||||
|
||||
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (thunderbird-52.3.0.source.tar.xz) = 10e6495d207328aae325a797be1de5e535b5d967df929b0af9d7554d0473b5a7931c8f9cb1793e843b1913f441f790169dd4ac1ad9e0e53e66bc8e1c1dd60e66
|
||||
SHA512 (thunderbird-langpacks-52.3.0-20170821.tar.xz) = b55de6bd7502278f073bce6f58d8a765d8c877310c6668affd8b303fbb02afc0909d8a65263ea3e07e86dd96c91a47b56865e8fdef2b5775f13448889d376b38
|
||||
SHA512 (l10n-lightning-52.3.0.tar.xz) = 17d1f60c156a7d035c01286af445677372c5d43dcbd38e995c3f94bc9bb272ae354e92f41f7dcb8f87b2d2c2631f20fc87a1c2f5b51c29e7f272e5591c517d6c
|
||||
SHA512 (thunderbird-52.4.0.source.tar.xz) = ea371ea657c7c10abef9785131030035e541999d62f079e10c60f961190eda06d7bb56e3b1192b77df23e765542c0b61899776a076443f4ca7ad40a81612a93b
|
||||
SHA512 (thunderbird-langpacks-52.4.0-20171003.tar.xz) = 3c5ec61f2976cc12fe58580305b0b6d60f60fb83f8d4b3c32bb93ac05c6e704e831fbb30ae7d697342c955366b73a7088be4aeca948a9d489afbc0e55565800c
|
||||
SHA512 (l10n-lightning-52.4.0.tar.xz) = 8a8d19d6a84d3fb447ca8874cb857f327967a74008784a8011dc3bc13ef50d17b22bb254a65d3cb9198623d8928a4aaa6cb0f4145d3716d36931082c5d187664
|
||||
|
@ -72,7 +72,7 @@
|
||||
# Bump one with each minor lightning release
|
||||
%define gdata_version 3.3
|
||||
# BUMP VERSION THERE:
|
||||
%define gdata_version_internal 0.6
|
||||
%define gdata_version_internal 0.7
|
||||
%global gdata_extname %{_libdir}/mozilla/extensions/{3550f703-e582-4d05-9a08-453d09bdfdc6}/{a62ef8ec-5fdc-40c2-873c-223b8a6925cc}
|
||||
|
||||
# The tarball is pretty inconsistent with directory structure.
|
||||
@ -95,14 +95,14 @@
|
||||
|
||||
Summary: Mozilla Thunderbird mail/newsgroup client
|
||||
Name: thunderbird
|
||||
Version: 52.3.0
|
||||
Version: 52.4.0
|
||||
Release: 1%{?dist}
|
||||
URL: http://www.mozilla.org/projects/thunderbird/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Group: Applications/Internet
|
||||
Source0: ftp://ftp.mozilla.org/pub/thunderbird/releases/%{version}%{?pre_version}/source/thunderbird-%{version}%{?pre_version}.source.tar.xz
|
||||
%if %{build_langpacks}
|
||||
Source1: thunderbird-langpacks-%{version}-20170821.tar.xz
|
||||
Source1: thunderbird-langpacks-%{version}-20171003.tar.xz
|
||||
%endif
|
||||
# Locales for lightning
|
||||
Source2: l10n-lightning-%{version}.tar.xz
|
||||
@ -139,7 +139,6 @@ Patch302: mozilla-1228540.patch
|
||||
Patch303: mozilla-1253216.patch
|
||||
Patch304: mozilla-1245783.patch
|
||||
Patch305: build-fix-dupes.patch
|
||||
Patch306: build-toml-fix.patch
|
||||
Patch307: build-missing-xlocale-h.patch
|
||||
|
||||
# Fedora specific patches
|
||||
@ -282,7 +281,6 @@ cd mozilla
|
||||
cd ..
|
||||
|
||||
%patch305 -p1 -b .fix-dupes
|
||||
%patch306 -p1 -b .build-toml-fix
|
||||
%patch105 -p1 -b .bad-langs
|
||||
%patch200 -p1 -b .addons
|
||||
|
||||
@ -734,6 +732,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
#===============================================================================
|
||||
|
||||
%changelog
|
||||
* Tue Oct 3 2017 Jan Horak <jhorak@redhat.com> - 52.4.0-1
|
||||
- Update to 52.4.0
|
||||
|
||||
* Mon Aug 21 2017 Jan Horak <jhorak@redhat.com> - 52.3.0-1
|
||||
- Update to 52.3.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user