- added enable-static to mozconfig
- removed thunderbird-shared-error.patch - update to 3.1.8
This commit is contained in:
parent
c7ccebccb4
commit
0826909596
2
.gitignore
vendored
2
.gitignore
vendored
@ -10,3 +10,5 @@ thunderbird-langpacks-3.1.2-20100803.tar.bz2
|
|||||||
/thunderbird-langpacks-3.1.6-20101027.tar.bz2
|
/thunderbird-langpacks-3.1.6-20101027.tar.bz2
|
||||||
/thunderbird-3.1.7.source.tar.bz2
|
/thunderbird-3.1.7.source.tar.bz2
|
||||||
/thunderbird-langpacks-3.1.7-20101209.tar.bz2
|
/thunderbird-langpacks-3.1.7-20101209.tar.bz2
|
||||||
|
/thunderbird-3.1.8.source.tar.bz2
|
||||||
|
/thunderbird-langpacks-3.1.8-20110301.tar.bz2
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
be64630152a2d5a824a76752594e7596 thunderbird-3.1.7.source.tar.bz2
|
bb4564eba437adceb22292249d186e11 thunderbird-3.1.8.source.tar.bz2
|
||||||
8dbaa17d293d3ebdbc9c6d082a1d539d thunderbird-langpacks-3.1.7-20101209.tar.bz2
|
d9c56e04e9269c2995061010e7c7b842 thunderbird-langpacks-3.1.8-20110301.tar.bz2
|
||||||
|
@ -29,6 +29,7 @@ ac_add_options --enable-system-hunspell
|
|||||||
ac_add_options --disable-crashreporter
|
ac_add_options --disable-crashreporter
|
||||||
ac_add_options --disable-necko-wifi
|
ac_add_options --disable-necko-wifi
|
||||||
ac_add_options --disable-updater
|
ac_add_options --disable-updater
|
||||||
|
ac_add_options --enable-static
|
||||||
|
|
||||||
export BUILD_OFFICIAL=1
|
export BUILD_OFFICIAL=1
|
||||||
export MOZILLA_OFFICIAL=1
|
export MOZILLA_OFFICIAL=1
|
||||||
|
@ -1,18 +0,0 @@
|
|||||||
Our build ends up in this path and fails otherwise...
|
|
||||||
|
|
||||||
diff -up comm-central/mail/installer/Makefile.in.shared-error comm-central/mail/installer/Makefile.in
|
|
||||||
--- comm-central/mail/installer/Makefile.in.shared-error 2009-09-16 13:47:43.000000000 +0200
|
|
||||||
+++ comm-central/mail/installer/Makefile.in 2009-09-16 13:48:25.000000000 +0200
|
|
||||||
@@ -95,9 +95,11 @@ endif
|
|
||||||
# mozconfig instead.
|
|
||||||
ifndef MAIL_PKG_SHARED
|
|
||||||
ifndef BUILD_STATIC_LIBS
|
|
||||||
+ifeq (BUILD_STATIC_LIBS, 1)
|
|
||||||
$(error you need an "--enable-static" build to package a build)
|
|
||||||
endif
|
|
||||||
endif
|
|
||||||
+endif
|
|
||||||
|
|
||||||
include $(MOZILLA_SRCDIR)/toolkit/mozapps/installer/packager.mk
|
|
||||||
|
|
||||||
|
|
@ -5,7 +5,7 @@
|
|||||||
%define sqlite_version 3.6.14
|
%define sqlite_version 3.6.14
|
||||||
%define libnotify_version 0.4
|
%define libnotify_version 0.4
|
||||||
%define build_langpacks 1
|
%define build_langpacks 1
|
||||||
%define thunderbird_version 3.1.7
|
%define thunderbird_version 3.1.8
|
||||||
%define moz_objdir objdir-tb
|
%define moz_objdir objdir-tb
|
||||||
%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
|
%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
|
||||||
|
|
||||||
@ -31,7 +31,7 @@
|
|||||||
Summary: Mozilla Thunderbird mail/newsgroup client
|
Summary: Mozilla Thunderbird mail/newsgroup client
|
||||||
Name: thunderbird
|
Name: thunderbird
|
||||||
Version: %{thunderbird_version}
|
Version: %{thunderbird_version}
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
URL: http://www.mozilla.org/projects/thunderbird/
|
URL: http://www.mozilla.org/projects/thunderbird/
|
||||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
@ -42,7 +42,7 @@ Group: Applications/Internet
|
|||||||
%endif
|
%endif
|
||||||
Source0: %{tarball}
|
Source0: %{tarball}
|
||||||
%if %{build_langpacks}
|
%if %{build_langpacks}
|
||||||
Source1: thunderbird-langpacks-%{version}-20101209.tar.bz2
|
Source1: thunderbird-langpacks-%{version}-20110301.tar.bz2
|
||||||
%endif
|
%endif
|
||||||
Source10: thunderbird-mozconfig
|
Source10: thunderbird-mozconfig
|
||||||
Source11: thunderbird-mozconfig-branded
|
Source11: thunderbird-mozconfig-branded
|
||||||
@ -65,9 +65,6 @@ Patch7: crashreporter-remove-static.patch
|
|||||||
Patch8: mozilla-notify.patch
|
Patch8: mozilla-notify.patch
|
||||||
Patch9: xulrunner-2.0-os2cc.patch
|
Patch9: xulrunner-2.0-os2cc.patch
|
||||||
|
|
||||||
# Thunderbird patches
|
|
||||||
Patch50: thunderbird-shared-error.patch
|
|
||||||
|
|
||||||
%if %{official_branding}
|
%if %{official_branding}
|
||||||
# Required by Mozilla Corporation
|
# Required by Mozilla Corporation
|
||||||
|
|
||||||
@ -138,9 +135,6 @@ cd mozilla
|
|||||||
%patch9 -p1 -b .os2cc
|
%patch9 -p1 -b .os2cc
|
||||||
cd ..
|
cd ..
|
||||||
|
|
||||||
# Thunderbird patches
|
|
||||||
%patch50 -p1 -b .shared-error
|
|
||||||
|
|
||||||
%if %{official_branding}
|
%if %{official_branding}
|
||||||
# Required by Mozilla Corporation
|
# Required by Mozilla Corporation
|
||||||
|
|
||||||
@ -397,6 +391,9 @@ fi
|
|||||||
#===============================================================================
|
#===============================================================================
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 1 2011 Jan Horak <jhorak@redhat.com> - 3.1.8-1
|
||||||
|
- Update to 3.1.8
|
||||||
|
|
||||||
* Wed Feb 9 2011 Christopher Aillon <caillon@redhat.com> - 3.1.7-6
|
* Wed Feb 9 2011 Christopher Aillon <caillon@redhat.com> - 3.1.7-6
|
||||||
- Drop the -lightning subpackage, it needs to be in its own SRPM
|
- Drop the -lightning subpackage, it needs to be in its own SRPM
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user