143 lines
4.5 KiB
Diff
143 lines
4.5 KiB
Diff
src/compare.c | 1 -
|
|
src/extract.c | 2 +-
|
|
src/list.c | 7 ++-----
|
|
tests/Makefile.am | 1 +
|
|
tests/exclude06.at | 47 +++++++++++++++++++++++++++++++++++++++++++++++
|
|
tests/testsuite.at | 1 +
|
|
6 files changed, 52 insertions(+), 7 deletions(-)
|
|
|
|
diff --git a/src/compare.c b/src/compare.c
|
|
index f4e92da..437ffb3 100644
|
|
--- a/src/compare.c
|
|
+++ b/src/compare.c
|
|
@@ -452,7 +452,6 @@ diff_archive (void)
|
|
{
|
|
|
|
set_next_block_after (current_header);
|
|
- decode_header (current_header, ¤t_stat_info, ¤t_format, 1);
|
|
|
|
/* Print the block from current_header and current_stat_info. */
|
|
|
|
diff --git a/src/extract.c b/src/extract.c
|
|
index 947e3ed..71f4e4f 100644
|
|
--- a/src/extract.c
|
|
+++ b/src/extract.c
|
|
@@ -1349,7 +1349,7 @@ extract_archive (void)
|
|
priv_set_remove_linkdir ();
|
|
|
|
set_next_block_after (current_header);
|
|
- decode_header (current_header, ¤t_stat_info, ¤t_format, 1);
|
|
+
|
|
if (!current_stat_info.file_name[0]
|
|
|| (interactive_option
|
|
&& !confirm ("extract", current_stat_info.file_name)))
|
|
diff --git a/src/list.c b/src/list.c
|
|
index 6e1971f..1edd504 100644
|
|
--- a/src/list.c
|
|
+++ b/src/list.c
|
|
@@ -90,7 +90,8 @@ read_and (void (*do_something) (void))
|
|
|
|
/* Valid header. We should decode next field (mode) first.
|
|
Ensure incoming names are null terminated. */
|
|
-
|
|
+ decode_header (current_header, ¤t_stat_info,
|
|
+ ¤t_format, 1);
|
|
if (! name_match (current_stat_info.file_name)
|
|
|| (NEWER_OPTION_INITIALIZED (newer_mtime_option)
|
|
/* FIXME: We get mtime now, and again later; this causes
|
|
@@ -116,8 +117,6 @@ read_and (void (*do_something) (void))
|
|
quotearg_colon (current_stat_info.file_name)));
|
|
/* Fall through. */
|
|
default:
|
|
- decode_header (current_header,
|
|
- ¤t_stat_info, ¤t_format, 0);
|
|
skip_member ();
|
|
continue;
|
|
}
|
|
@@ -221,8 +220,6 @@ list_archive (void)
|
|
off_t block_ordinal = current_block_ordinal ();
|
|
|
|
/* Print the header block. */
|
|
-
|
|
- decode_header (current_header, ¤t_stat_info, ¤t_format, 0);
|
|
if (verbose_option)
|
|
print_header (¤t_stat_info, current_header, block_ordinal);
|
|
|
|
diff --git a/tests/Makefile.am b/tests/Makefile.am
|
|
index e9b753c..fe2535a 100644
|
|
--- a/tests/Makefile.am
|
|
+++ b/tests/Makefile.am
|
|
@@ -66,6 +66,7 @@ TESTSUITE_AT = \
|
|
exclude03.at\
|
|
exclude04.at\
|
|
exclude05.at\
|
|
+ exclude06.at\
|
|
extrac01.at\
|
|
extrac02.at\
|
|
extrac03.at\
|
|
diff --git a/tests/exclude06.at b/tests/exclude06.at
|
|
new file mode 100644
|
|
index 0000000..f7ab141
|
|
--- /dev/null
|
|
+++ b/tests/exclude06.at
|
|
@@ -0,0 +1,47 @@
|
|
+# Process this file with autom4te to create testsuite. -*- Autotest -*-
|
|
+# Copyright (C) 2010 Free Software Foundation, Inc.
|
|
+
|
|
+# This program is free software; you can redistribute it and/or modify
|
|
+# it under the terms of the GNU General Public License as published by
|
|
+# the Free Software Foundation; either version 3, or (at your option)
|
|
+# any later version.
|
|
+
|
|
+# This program is distributed in the hope that it will be useful,
|
|
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
+# GNU General Public License for more details.
|
|
+
|
|
+# You should have received a copy of the GNU General Public License
|
|
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
|
|
+
|
|
+# Tar 1.23 would fail to exclude names longer that 100 characters from
|
|
+# pax format archives.
|
|
+#
|
|
+# Reported-by: Matthew Peterson <mrpeterson2@gmail.com>
|
|
+# References: <AANLkTin0teb1dcl0HCNquHxvN4HQnJmP6aK7CJCqy0sd@mail.gmail.com>
|
|
+# http://lists.gnu.org/archive/html/help-tar/2010-06/msg00000.html
|
|
+
|
|
+AT_SETUP([exclude: long files in pax archives])
|
|
+AT_KEYWORDS([exclude exclude06])
|
|
+
|
|
+m4_define([test_base_dir],[one/two/three/four/five/six/seven/eight/nine/ten/eleven/twelve/thirteen/fourteen/fifteen/sixteen/seventeen])
|
|
+
|
|
+AT_TAR_CHECK([
|
|
+AT_TAR_MKHIER(test_base_dir)
|
|
+genfile --length 20 -f test_base_dir[/1.txt]
|
|
+genfile --length 20 -f test_base_dir[/1.c]
|
|
+
|
|
+tar cf archive.tar test_base_dir
|
|
+mkdir out
|
|
+tar -C out -xf archive.tar --exclude='*.txt'
|
|
+find out -type f
|
|
+],
|
|
+[0],
|
|
+[[out/]test_base_dir[/1.c]
|
|
+],
|
|
+[],
|
|
+[],
|
|
+[],
|
|
+[pax])
|
|
+
|
|
+AT_CLEANUP
|
|
diff --git a/tests/testsuite.at b/tests/testsuite.at
|
|
index f581071..ef70b99 100644
|
|
--- a/tests/testsuite.at
|
|
+++ b/tests/testsuite.at
|
|
@@ -130,6 +130,7 @@ m4_include([exclude02.at])
|
|
m4_include([exclude03.at])
|
|
m4_include([exclude04.at])
|
|
m4_include([exclude05.at])
|
|
+m4_include([exclude06.at])
|
|
|
|
m4_include([delete01.at])
|
|
m4_include([delete02.at])
|