132f2c7962
Resolves: rhbz#1230762 Version: 1.28-6
158 lines
3.9 KiB
Diff
158 lines
3.9 KiB
Diff
From: rpm-build <rpm-build>
|
|
Date: Fri, 26 Jun 2015 14:10:30 +0200
|
|
Subject: [PATCH 11/11] tests: better test --{,no-}recursion options
|
|
|
|
Downstream patch, proposed:
|
|
http://www.mail-archive.com/bug-tar@gnu.org/msg04803.html
|
|
|
|
Related: #1230762
|
|
diff --git a/tests/Makefile.am b/tests/Makefile.am
|
|
index fc06c3b..670291b 100644
|
|
--- a/tests/Makefile.am
|
|
+++ b/tests/Makefile.am
|
|
@@ -48,6 +48,7 @@ TESTSUITE_AT = \
|
|
T-empty.at\
|
|
T-null.at\
|
|
T-rec.at\
|
|
+ T-recurse.at\
|
|
T-zfile.at\
|
|
T-nonl.at\
|
|
T-mult.at\
|
|
diff --git a/tests/T-recurse.at b/tests/T-recurse.at
|
|
new file mode 100644
|
|
index 0000000..7d5efe8
|
|
--- /dev/null
|
|
+++ b/tests/T-recurse.at
|
|
@@ -0,0 +1,96 @@
|
|
+# Process this file with autom4te to create testsuite. -*- Autotest -*-
|
|
+
|
|
+# Test suite for GNU tar.
|
|
+# Copyright 2015 Free Software Foundation, Inc.
|
|
+
|
|
+# This file is part of GNU tar.
|
|
+
|
|
+# GNU tar is free software; you can redistribute it and/or modify
|
|
+# it under the terms of the GNU General Public License as published by
|
|
+# the Free Software Foundation; either version 3 of the License, or
|
|
+# (at your option) any later version.
|
|
+
|
|
+# GNU tar is distributed in the hope that it will be useful,
|
|
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
+# GNU General Public License for more details.
|
|
+
|
|
+# You should have received a copy of the GNU General Public License
|
|
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
|
|
+
|
|
+# Description: Test interaction of --recursion and --no-recursion options
|
|
+# together with --files-from option. This is complementary to recurs02.at test
|
|
+# case. References:
|
|
+# <alpine.LSU.2.11.1502201029580.29773@nerf60.vanv.qr>
|
|
+# http://lists.gnu.org/archive/html/bug-tar/2015-06/msg00006.html
|
|
+
|
|
+AT_SETUP([files-from & recurse: toggle])
|
|
+AT_KEYWORDS([recurse T-recurse files-from])
|
|
+
|
|
+AT_TAR_CHECK([
|
|
+mkdir directory1 directory2
|
|
+touch directory1/file directory2/file
|
|
+
|
|
+AT_DATA([F1],[--no-recursion
|
|
+directory1/
|
|
+--recursion
|
|
+directory2/
|
|
+])
|
|
+
|
|
+AT_DATA([F2A],[directory1/
|
|
+])
|
|
+
|
|
+AT_DATA([F2B],[directory2/
|
|
+])
|
|
+
|
|
+a=archive
|
|
+tar cf "$a" --files-from F1
|
|
+tar tf "$a"
|
|
+
|
|
+a=archive2
|
|
+tar cf "$a" --no-recursion -T F2A --recursion -T F2B
|
|
+tar tf "$a"
|
|
+],
|
|
+[0],
|
|
+[directory1/
|
|
+directory2/
|
|
+directory2/file
|
|
+directory1/
|
|
+directory2/
|
|
+directory2/file
|
|
+])
|
|
+
|
|
+AT_CLEANUP
|
|
+
|
|
+# Tar is not yet ready to properly handle --{,no-}recursion options if those are
|
|
+# set both as program arguments and from within --files-from file. The problem
|
|
+# is that content of -T argument is parsed too late; solution to this would
|
|
+# require additional NELT_* type implemented to allow handling of --recursion
|
|
+# option similarly to how the -C option is processed now.
|
|
+
|
|
+AT_SETUP([toggle --recursion (not) from -T])
|
|
+AT_KEYWORDS([recurse T-recurse T-recurse2 files-from])
|
|
+
|
|
+AT_TAR_CHECK([
|
|
+mkdir directory1 directory2
|
|
+touch directory1/file directory2/file
|
|
+
|
|
+AT_DATA([F1],[--no-recursion
|
|
+directory1/
|
|
+])
|
|
+
|
|
+AT_DATA([F2],[directory2/
|
|
+])
|
|
+
|
|
+tar cf archive -T F1 --recursion -T F2
|
|
+tar tf archive
|
|
+
|
|
+AT_XFAIL_IF([true])
|
|
+],
|
|
+[0],
|
|
+[directory1/
|
|
+directory2/
|
|
+directory2/file
|
|
+])
|
|
+
|
|
+AT_CLEANUP
|
|
diff --git a/tests/recurs02.at b/tests/recurs02.at
|
|
index 93aa2c1..00e1d66 100644
|
|
--- a/tests/recurs02.at
|
|
+++ b/tests/recurs02.at
|
|
@@ -37,11 +37,18 @@ tar --create --file archive \
|
|
--no-recursion directory1 \
|
|
--recursion directory2 || exit 1
|
|
tar tf archive
|
|
+tar cf archive directory1 directory2
|
|
+tar tf archive \
|
|
+ --no-recursion directory1 \
|
|
+ --recursion directory2 || exit 1
|
|
],
|
|
[0],
|
|
[directory1/
|
|
directory2/
|
|
directory2/file
|
|
+directory1/
|
|
+directory2/
|
|
+directory2/file
|
|
])
|
|
|
|
AT_CLEANUP
|
|
diff --git a/tests/testsuite.at b/tests/testsuite.at
|
|
index 789f16c..e3da356 100644
|
|
--- a/tests/testsuite.at
|
|
+++ b/tests/testsuite.at
|
|
@@ -200,6 +200,7 @@ AT_BANNER([The -T option])
|
|
m4_include([T-mult.at])
|
|
m4_include([T-nest.at])
|
|
m4_include([T-rec.at])
|
|
+m4_include([T-recurse.at])
|
|
m4_include([T-cd.at])
|
|
m4_include([T-empty.at])
|
|
m4_include([T-null.at])
|