fix for GCC 4.3
This commit is contained in:
parent
e3aa03d6a5
commit
fd8db9579f
32
tar-1.19-gcc43.patch
Normal file
32
tar-1.19-gcc43.patch
Normal file
@ -0,0 +1,32 @@
|
|||||||
|
diff -up tar-1.19/lib/argp-fmtstream.h.gcc43 tar-1.19/lib/argp-fmtstream.h
|
||||||
|
--- tar-1.19/lib/argp-fmtstream.h.gcc43 2007-09-28 15:11:36.000000000 +0200
|
||||||
|
+++ tar-1.19/lib/argp-fmtstream.h 2008-02-13 16:56:58.000000000 +0100
|
||||||
|
@@ -198,7 +198,11 @@ extern int __argp_fmtstream_ensure (argp
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#ifndef ARGP_FS_EI
|
||||||
|
-#define ARGP_FS_EI extern inline
|
||||||
|
+# ifdef __GNUC_STDC_INLINE__
|
||||||
|
+# define ARGP_FS_EI extern inline __attribute__((__gnu_inline__))
|
||||||
|
+# else
|
||||||
|
+# define ARGP_FS_EI extern inline
|
||||||
|
+# endif
|
||||||
|
#endif
|
||||||
|
|
||||||
|
ARGP_FS_EI size_t
|
||||||
|
diff -up tar-1.19/lib/argp.h.gcc43 tar-1.19/lib/argp.h
|
||||||
|
--- tar-1.19/lib/argp.h.gcc43 2007-09-28 15:11:36.000000000 +0200
|
||||||
|
+++ tar-1.19/lib/argp.h 2008-02-13 16:55:36.000000000 +0100
|
||||||
|
@@ -580,7 +580,11 @@ extern void *__argp_input (const struct
|
||||||
|
# endif
|
||||||
|
|
||||||
|
# ifndef ARGP_EI
|
||||||
|
-# define ARGP_EI extern __inline__
|
||||||
|
+# if defined __GNUC_STDC_INLINE__
|
||||||
|
+# define ARGP_EI extern __inline__ __attribute__((__gnu_inline__))
|
||||||
|
+# else
|
||||||
|
+# define ARGP_EI extern __inline__
|
||||||
|
+# endif
|
||||||
|
# endif
|
||||||
|
|
||||||
|
ARGP_EI void
|
@ -231,7 +231,7 @@ diff -up /dev/null tar-1.17/src/xattrs.c
|
|||||||
+{ /* "system.posix_acl_access" */
|
+{ /* "system.posix_acl_access" */
|
||||||
+#ifdef HAVE_LIBACL
|
+#ifdef HAVE_LIBACL
|
||||||
+ char *val = NULL;
|
+ char *val = NULL;
|
||||||
+ size_t len;
|
+ ssize_t len;
|
||||||
+ acl_t acl;
|
+ acl_t acl;
|
||||||
+
|
+
|
||||||
+ if (fd != -1)
|
+ if (fd != -1)
|
||||||
@ -260,7 +260,7 @@ diff -up /dev/null tar-1.17/src/xattrs.c
|
|||||||
+ return;
|
+ return;
|
||||||
+ }
|
+ }
|
||||||
+
|
+
|
||||||
+ *ret_ptr = xstrndup (val, len);
|
+ *ret_ptr = xstrdup (val);
|
||||||
+ *ret_len = len;
|
+ *ret_len = len;
|
||||||
+
|
+
|
||||||
+ acl_free (val);
|
+ acl_free (val);
|
||||||
@ -273,7 +273,7 @@ diff -up /dev/null tar-1.17/src/xattrs.c
|
|||||||
+{ /* "system.posix_acl_default" */
|
+{ /* "system.posix_acl_default" */
|
||||||
+#ifdef HAVE_LIBACL
|
+#ifdef HAVE_LIBACL
|
||||||
+ char *val = NULL;
|
+ char *val = NULL;
|
||||||
+ size_t len;
|
+ ssize_t len;
|
||||||
+ acl_t acl;
|
+ acl_t acl;
|
||||||
+
|
+
|
||||||
+ if ((acl = acl_get_file (file_name, ACL_TYPE_DEFAULT)) == (acl_t)NULL)
|
+ if ((acl = acl_get_file (file_name, ACL_TYPE_DEFAULT)) == (acl_t)NULL)
|
||||||
@ -292,7 +292,7 @@ diff -up /dev/null tar-1.17/src/xattrs.c
|
|||||||
+ return;
|
+ return;
|
||||||
+ }
|
+ }
|
||||||
+
|
+
|
||||||
+ *ret_ptr = xstrndup (val, len);
|
+ *ret_ptr = xstrdup (val);
|
||||||
+ *ret_len = len;
|
+ *ret_len = len;
|
||||||
+
|
+
|
||||||
+ acl_free (val);
|
+ acl_free (val);
|
||||||
|
4
tar.spec
4
tar.spec
@ -14,7 +14,7 @@ Patch2: tar-1.15.1-vfatTruncate.patch
|
|||||||
Patch3: tar-1.19-xattrs.patch
|
Patch3: tar-1.19-xattrs.patch
|
||||||
Patch4: tar-1.19-xattrs-conf.patch
|
Patch4: tar-1.19-xattrs-conf.patch
|
||||||
Patch5: tar-1.17-wildcards.patch
|
Patch5: tar-1.17-wildcards.patch
|
||||||
|
Patch6: tar-1.19-gcc43.patch
|
||||||
Prereq: info
|
Prereq: info
|
||||||
BuildRequires: autoconf automake gzip texinfo gettext libacl-devel libselinux-devel gawk
|
BuildRequires: autoconf automake gzip texinfo gettext libacl-devel libselinux-devel gawk
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -40,6 +40,7 @@ the rmt package.
|
|||||||
%patch3 -p1 -b .xattrs
|
%patch3 -p1 -b .xattrs
|
||||||
%patch4 -p1 -b .xattrs-conf
|
%patch4 -p1 -b .xattrs-conf
|
||||||
%patch5 -p1 -b .wildcards
|
%patch5 -p1 -b .wildcards
|
||||||
|
%patch6 -p1 -b .gcc43
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --bindir=/bin --libexecdir=/sbin
|
%configure --bindir=/bin --libexecdir=/sbin
|
||||||
@ -93,6 +94,7 @@ fi
|
|||||||
* Tue Feb 12 2008 Radek Brich <rbrich@redhat.com> 2:1.19-3
|
* Tue Feb 12 2008 Radek Brich <rbrich@redhat.com> 2:1.19-3
|
||||||
- do not print getfilecon/setfilecon warnings when SELinux is disabled
|
- do not print getfilecon/setfilecon warnings when SELinux is disabled
|
||||||
or SELinux data are not available (bz#431879)
|
or SELinux data are not available (bz#431879)
|
||||||
|
- fix for GCC 4.3
|
||||||
|
|
||||||
* Mon Jan 21 2008 Radek Brich <rbrich@redhat.com> 2:1.19-2
|
* Mon Jan 21 2008 Radek Brich <rbrich@redhat.com> 2:1.19-2
|
||||||
- fix errors in man page
|
- fix errors in man page
|
||||||
|
Loading…
Reference in New Issue
Block a user