New upstream release 1.22, removed applied patch
This commit is contained in:
parent
30f2f22fe9
commit
f7288fe86e
@ -1,2 +1,2 @@
|
||||
tar-1.21.tar.gz
|
||||
tar-1.21.tar.gz.sig
|
||||
tar-1.22.tar.bz2
|
||||
tar-1.22.tar.bz2.sig
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
e7ae56b3bf924d5108b57b544b247c50 tar-1.21.tar.gz
|
||||
cceab48ed4cdd0c5e2de825e59797820 tar-1.21.tar.gz.sig
|
||||
07fa517027f426bb80f5f5ff91b63585 tar-1.22.tar.bz2
|
||||
f6398627528d2a8c458cc422cccaeea1 tar-1.22.tar.bz2.sig
|
||||
|
@ -1,75 +1,3 @@
|
||||
diff -up /dev/null tar-1.19/m4/size_max.m4
|
||||
--- /dev/null 2007-12-17 10:53:34.527001576 +0100
|
||||
+++ tar-1.19/m4/size_max.m4 2007-12-17 11:46:35.000000000 +0100
|
||||
@@ -0,0 +1,68 @@
|
||||
+# size_max.m4 serial 6
|
||||
+dnl Copyright (C) 2003, 2005-2006 Free Software Foundation, Inc.
|
||||
+dnl This file is free software; the Free Software Foundation
|
||||
+dnl gives unlimited permission to copy and/or distribute it,
|
||||
+dnl with or without modifications, as long as this notice is preserved.
|
||||
+
|
||||
+dnl From Bruno Haible.
|
||||
+
|
||||
+AC_DEFUN([gl_SIZE_MAX],
|
||||
+[
|
||||
+ AC_CHECK_HEADERS(stdint.h)
|
||||
+ dnl First test whether the system already has SIZE_MAX.
|
||||
+ AC_MSG_CHECKING([for SIZE_MAX])
|
||||
+ AC_CACHE_VAL([gl_cv_size_max], [
|
||||
+ gl_cv_size_max=
|
||||
+ AC_EGREP_CPP([Found it], [
|
||||
+#include <limits.h>
|
||||
+#if HAVE_STDINT_H
|
||||
+#include <stdint.h>
|
||||
+#endif
|
||||
+#ifdef SIZE_MAX
|
||||
+Found it
|
||||
+#endif
|
||||
+], gl_cv_size_max=yes)
|
||||
+ if test -z "$gl_cv_size_max"; then
|
||||
+ dnl Define it ourselves. Here we assume that the type 'size_t' is not wider
|
||||
+ dnl than the type 'unsigned long'. Try hard to find a definition that can
|
||||
+ dnl be used in a preprocessor #if, i.e. doesn't contain a cast.
|
||||
+ AC_COMPUTE_INT([size_t_bits_minus_1], [sizeof (size_t) * CHAR_BIT - 1],
|
||||
+ [#include <stddef.h>
|
||||
+#include <limits.h>], size_t_bits_minus_1=)
|
||||
+ AC_COMPUTE_INT([fits_in_uint], [sizeof (size_t) <= sizeof (unsigned int)],
|
||||
+ [#include <stddef.h>], fits_in_uint=)
|
||||
+ if test -n "$size_t_bits_minus_1" && test -n "$fits_in_uint"; then
|
||||
+ if test $fits_in_uint = 1; then
|
||||
+ dnl Even though SIZE_MAX fits in an unsigned int, it must be of type
|
||||
+ dnl 'unsigned long' if the type 'size_t' is the same as 'unsigned long'.
|
||||
+ AC_TRY_COMPILE([#include <stddef.h>
|
||||
+ extern size_t foo;
|
||||
+ extern unsigned long foo;
|
||||
+ ], [], fits_in_uint=0)
|
||||
+ fi
|
||||
+ dnl We cannot use 'expr' to simplify this expression, because 'expr'
|
||||
+ dnl works only with 'long' integers in the host environment, while we
|
||||
+ dnl might be cross-compiling from a 32-bit platform to a 64-bit platform.
|
||||
+ if test $fits_in_uint = 1; then
|
||||
+ gl_cv_size_max="(((1U << $size_t_bits_minus_1) - 1) * 2 + 1)"
|
||||
+ else
|
||||
+ gl_cv_size_max="(((1UL << $size_t_bits_minus_1) - 1) * 2 + 1)"
|
||||
+ fi
|
||||
+ else
|
||||
+ dnl Shouldn't happen, but who knows...
|
||||
+ gl_cv_size_max='((size_t)~(size_t)0)'
|
||||
+ fi
|
||||
+ fi
|
||||
+ ])
|
||||
+ AC_MSG_RESULT([$gl_cv_size_max])
|
||||
+ if test "$gl_cv_size_max" != yes; then
|
||||
+ AC_DEFINE_UNQUOTED([SIZE_MAX], [$gl_cv_size_max],
|
||||
+ [Define as the maximum value of type 'size_t', if the system doesn't define it.])
|
||||
+ fi
|
||||
+])
|
||||
+
|
||||
+dnl Autoconf >= 2.61 has AC_COMPUTE_INT built-in.
|
||||
+dnl Remove this when we can assume autoconf >= 2.61.
|
||||
+m4_ifdef([AC_COMPUTE_INT], [], [
|
||||
+ AC_DEFUN([AC_COMPUTE_INT], [_AC_COMPUTE_INT([$2],[$1],[$3],[$4])])
|
||||
+])
|
||||
diff -up tar-1.19/config.hin.xattrs-conf tar-1.19/config.hin
|
||||
--- tar-1.19/config.hin.xattrs-conf 2007-10-10 13:01:17.000000000 +0200
|
||||
+++ tar-1.19/config.hin 2007-12-17 11:47:38.000000000 +0100
|
||||
@ -80,8 +8,8 @@ diff -up tar-1.19/config.hin.xattrs-conf tar-1.19/config.hin
|
||||
+/* Define to 1 if you have the <attr/xattr.h> header file. */
|
||||
+#undef HAVE_ATTR_XATTR_H
|
||||
+
|
||||
/* Define to 1 if you have the <bp-sym.h> header file. */
|
||||
#undef HAVE_BP_SYM_H
|
||||
/* Define to 1 if you have the `btowc' function. */
|
||||
#undef HAVE_BTOWC
|
||||
|
||||
@@ -354,12 +357,21 @@
|
||||
/* Define to 1 if you have the <features.h> header file. */
|
||||
|
13
tar.spec
13
tar.spec
@ -1,20 +1,19 @@
|
||||
Summary: A GNU file archiving program
|
||||
Name: tar
|
||||
Epoch: 2
|
||||
Version: 1.21
|
||||
Release: 2%{?dist}
|
||||
Version: 1.22
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+
|
||||
Group: Applications/Archiving
|
||||
URL: http://www.gnu.org/software/tar/
|
||||
Source0: ftp://ftp.gnu.org/pub/gnu/tar/tar-%{version}.tar.gz
|
||||
Source1: ftp://ftp.gnu.org/pub/gnu/tar/tar-%{version}.tar.gz.sig
|
||||
Source0: ftp://ftp.gnu.org/pub/gnu/tar/tar-%{version}.tar.bz2
|
||||
Source1: ftp://ftp.gnu.org/pub/gnu/tar/tar-%{version}.tar.bz2.sig
|
||||
Source2: tar.1
|
||||
Patch1: tar-1.14-loneZeroWarning.patch
|
||||
Patch2: tar-1.15.1-vfatTruncate.patch
|
||||
Patch3: tar-1.19-xattrs.patch
|
||||
Patch4: tar-1.19-xattrs-conf.patch
|
||||
Patch5: tar-1.17-wildcards.patch
|
||||
Patch6: tar-1.21-testsuite.patch
|
||||
Prereq: info
|
||||
BuildRequires: autoconf automake gzip texinfo gettext libacl-devel libselinux-devel gawk rsh
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -40,7 +39,6 @@ the rmt package.
|
||||
%patch3 -p1 -b .xattrs
|
||||
%patch4 -p1 -b .xattrs-conf
|
||||
%patch5 -p1 -b .wildcards
|
||||
%patch6 -p1 -b .testsuite
|
||||
|
||||
%build
|
||||
%configure --bindir=/bin --libexecdir=/sbin
|
||||
@ -91,6 +89,9 @@ fi
|
||||
%{_infodir}/tar.info*
|
||||
|
||||
%changelog
|
||||
* Mon Mar 02 2009 Ondrej Vasik <ovasik@redhat.com> 2:1.22-1
|
||||
- New upstream release 1.22, removed applied patch
|
||||
|
||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2:1.21-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user