tar: option --xattrs-include should imply --xattrs option
Resolves: #965969 Version: 1.26-28
This commit is contained in:
parent
2852f8c68f
commit
e72627093d
39
tar-1.26-xattrs-include-implies-xattrs.patch
Normal file
39
tar-1.26-xattrs-include-implies-xattrs.patch
Normal file
@ -0,0 +1,39 @@
|
||||
diff --git a/src/tar.c b/src/tar.c
|
||||
index e244808..18277e4 100644
|
||||
--- a/src/tar.c
|
||||
+++ b/src/tar.c
|
||||
@@ -162,6 +162,14 @@ set_archive_format (char const *name)
|
||||
archive_format = p->fmt;
|
||||
}
|
||||
|
||||
+static void
|
||||
+set_xattr_option (int value)
|
||||
+{
|
||||
+ if (value == 1)
|
||||
+ set_archive_format ("posix");
|
||||
+ xattrs_option = value;
|
||||
+}
|
||||
+
|
||||
const char *
|
||||
archive_format_string (enum archive_format fmt)
|
||||
{
|
||||
@@ -2141,16 +2149,16 @@ parse_opt (int key, char *arg, struct argp_state *state)
|
||||
break;
|
||||
|
||||
case XATTR_OPTION:
|
||||
- set_archive_format ("posix");
|
||||
- xattrs_option = 1;
|
||||
+ set_xattr_option (1);
|
||||
break;
|
||||
|
||||
case NO_XATTR_OPTION:
|
||||
- xattrs_option = -1;
|
||||
+ set_xattr_option (-1);
|
||||
break;
|
||||
|
||||
case XATTR_INCLUDE:
|
||||
case XATTR_EXCLUDE:
|
||||
+ set_xattr_option (1);
|
||||
xattrs_mask_add (arg, (key == XATTR_INCLUDE));
|
||||
break;
|
||||
|
11
tar.spec
11
tar.spec
@ -112,6 +112,13 @@ Patch16: tar-1.26-fix-symlink-eating-bug.patch
|
||||
# ~> #996753
|
||||
Patch17: tar-1.26-docu-xattrs.patch
|
||||
|
||||
# The --xattrs-include or --xattrs-exclude options should imply --xattrs.
|
||||
# ~> still downstream
|
||||
# http://lists.gnu.org/archive/html/bug-tar/2013-05/msg00020.html
|
||||
# ~> #965969
|
||||
|
||||
Patch18: tar-1.26-xattrs-include-implies-xattrs.patch
|
||||
|
||||
# Silence gcc warnings
|
||||
# ~> upstream tar: 17f99bc6f, 5bb0433
|
||||
# ~> upstream paxutils: 0b3d84a0
|
||||
@ -167,6 +174,7 @@ the rmt package on the remote box.
|
||||
%patch15 -p1 -b .print-xattrs-fix
|
||||
%patch16 -p1 -b .birthtime
|
||||
%patch17 -p1 -b .xattrs-documentation
|
||||
%patch18 -p1 -b .xattrs-if-xattrs-include
|
||||
%patch999 -p1 -b .silence-gcc
|
||||
|
||||
autoreconf -v
|
||||
@ -226,8 +234,9 @@ fi
|
||||
%{_infodir}/tar.info*
|
||||
|
||||
%changelog
|
||||
* Wed Aug 14 2013 Pavel Raiskup <praiskup@redhat.com> - 1.26-28
|
||||
* Mon Sep 09 2013 Pavel Raiskup <praiskup@redhat.com> - 1.26-28
|
||||
- add documenation for xattrs-like options (#996753)
|
||||
- the --xattrs-include implies --xattrs now (#965969)
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2:1.26-27
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
Loading…
Reference in New Issue
Block a user